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Chapter 1. Introduction

About This Handbook

This Installation and User’s Handbook provides installation and setup information for the 
SYMplicity™ Storage Management software in a networked Microsoft® Windows NT™ 
or Windows 95™ environment. Use this Installation and User’s Handbook to do the 
following:

• Determine the hardware and software required to install this software

• Install the software

• Identify features unique to the networked operating environment

• Set up software parameters

• Troubleshoot the installation and networked operation

This guide is accompanied by the SYMplicity Storage Manager User’s Handbook. The 
User’s Handbook describes how to use the storage management software after installation. 
Some parts of that book may be affected by information given in this book. 

You should use this Installation and User’s Handbook after installing the RAID Controller 
hardware. After you install and set up the software, go to the User’s Handbook for further 
information on using the software and maintaining the RAID Controllers.

Understanding the Restrictions

Table 1 "Restrictions and Notes" on page 2 details the restrictions and important notes that 
apply to using the storage management software in the Windows environment.

Note: Always check for a readme file on any installation media. This file may contain 
important information that was not available at the time this Installation and User’s 
Handbook was prepared.
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Table 1: Restrictions and Notes 

Restriction/Note Application Workaround

Do not use Microsoft’s Network 
Monitor™ service with the storage 
management software. Monitoring 
the network connections with this 
service can result in problems, such 
as blue screens.

Installation and 
Setup

Stop the Network Monitor Service if you have 
it installed before using the storage 
management software:

1 Select Control Panel → Services.

2 Highlight the Network Monitor Service.

3 Select Stop.

Do not install the RDAC driver 
before installing the storage 
management software. This driver 
is available for installation on a 
Windows NT host machine 
connected to the RAID Controllers 
with Fibre Channel connection. 

Installation and 
Setup

None. Do not install the RDAC driver 
before upgrading or installing the storage 
management software. The installation 
procedure will remove any version of the 
RDAC driver. The RDAC driver will need 
to be installed from this software’s 
installation CD. See "Installing the Driver" on 
page 46 for more information.

raidutil does not always generate 
an error message even when an 
operation fails. For example, using 
raidutil -R to reset the controller 
battery age without LUN 0 created 
causes the operation to fail. 
However, there is no error 
message. 

General

Anytime you use raidutil to perform an 
operation, it is a good idea to verify that it 
completes successfully. For example, after 
creating LUNs, you might want to use lad to 
verify your configuration. 
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The networked storage 
management software does not 
have any knowledge of the I/O data 
path; therefore, the following 
restrictions apply:

• Configuration — cannot check 
for I/Os before deleting LUNs.

• Recovery/Status — Recovery 
Guru/Health Check does not 
detect any problems with the 
data path/connection. If any Data 
Path Failure is displayed, it 
indicates that there are problems 
with the network connection or 
one of the controllers in the 
affected RAID Controller.

• Maintenance/Tuning — does 
not check for I/Os or verify 
LUNs are Optimal before 
upgrading firmware, balancing 
LUNs, or changing controller 
mode.

All 
Applications

Configuration — make sure you stop I/Os and 
no other users are on the system before 
selecting Delete LUN.

Recovery/Status — make certain there are no 
network problems before proceeding with the 
Data Path Failure recovery procedure. 
Proceeding with the recovery procedure could 
cause an operational controller to be failed 
when the problem may be with the network or 
its connection.

Maintenance/Tuning 

• Firmware Upgrade — the Online method 
for Firmware Upgrade is grayed out. Before 
selecting the Offline method of Firmware 
Upgrade, you must stop I/Os.

• LUN Balancing/Controller Mode — make 
sure you stop I/Os because they could fail. 
Also, if the host machine (connected to your 
RAID Controllers via I/O data connection) 
does not have RDAC installed, you may have 
to make changes to mounted filesystems 
(UNIX only).

• Caching Parameters — Before saving 
changes to your caching parameters, you 
must stop
I/Os.

Table 1: Restrictions and Notes  (continued)

Restriction/Note Application Workaround
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The host’s operating system could 
hang and I/Os could fail if a host 
machine (connected to your RAID 
Controllers via I/O data 
connection) is issuing I/Os to the 
modules when you use the 
software to:

• Delete or format LUNs.

• Change controller mode or LUN 
assignments between controllers.

• Upgrade controller firmware.
Configuration, 
Recovery, 
Maintenance/
Tuning 

Configuration

Make sure that you stop I/Os and that no other 
users are on the host machine’s operating 
system before deleting logical units (Delete) or 
using File → Reset Configuration.

Recovery

Make sure you stop I/Os and that no other users 
are on the host machine’s operating system 
before performing any procedure that will 
format a LUN (such as Options → Manual 
Recovery → Logical Units → Format).

Maintenance/Tuning

Make sure that you stop I/Os and that no other 
users are on the host machine’s operating 
system before performing tasks that transfer 
LUN ownership between controllers, such as 
using Controller Mode, using LUN Balancing, 
or upgrading controller firmware (Firmware 
Upgrade, Offline method).

If you have more than one station 
with this software installed, you 
should open only one 
Configuration session at a time.

Operations could fail or hang if
I/Os are occurring and LUN 
creation or deletion will fail for all 
but one station.

Configuration

You must be very careful not to use more than 
one Configuration Application at a time. Also, 
be sure to stop I/Os before deleting or 
formatting logical units.

When creating multiple LUNs that 
will use the full capacity of the 
drive group, the last LUN is not 
created.

Configuration

Do one of the following:

• Specify 10 LUNs (or less) in the Create LUN 
panel.

• Recreate the last LUN individually after the 
failure message.

• Determine what size of the remaining drive 
group capacity to allocate to each of the 
LUNs, and create the LUNs one at a time.

Table 1: Restrictions and Notes  (continued)

Restriction/Note Application Workaround
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Hardware and Software Requirements

Check to make sure you have the following components installed:

• Windows 95, or Windows NT Server 4.0, Windows NT 4.0 Enterprise Edition 
Operating System, or Windows NT Workstation 4.0 installed on each Remote 
Management Station (RMS) where you intend to install the storage management 
software.

• Microsoft Service Pack 3 for Windows NT 4.0.

• A BOOTP or DHCP server (see "Appendix A. Specifications" for further information).

• RAID Controllers with Series 4 controllers.

• The network enable bit (an NVSRAM setting) is set to on (default).

• At least an 800 x 600 resolution graphics card and mouse.

When a LUN is Dead and ALL its 
drives are Failed (for example, 2 
drive Raid 1), Recovery Guru 
reports that the first replaced drive 
is still Failed.

CAUTION If the controllers in the 
module containing the Dead LUNs 
are reset (bus reset or turning the 
module off and on again), the dead 
LUNs will be lost. In this instance, 
use the Configuration Application 
or raidutil to re-create them.

Recovery Guru

You should select OK when asked, “Are you 
certain you have replaced it and that it has 
enough capacity?” and continue the recovery 
process.

Manual Recovery → LUNs → 
Format does not work while new 
LUNs are formatting on different 
drive groups.

Recovery
Wait for LUNs on other drive group to 
complete formatting before starting manual 
recovery.

Table 1: Restrictions and Notes  (continued)

Restriction/Note Application Workaround
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Selecting the Correct Installation Procedure

The procedure you need to use to install the storage management software depends on 
whether this is an upgrade to a previously installed version or whether you are installing 
the software for the first time.

Upgrade Installation First Time Installation

Continue with "Chapter 2. Upgrading 
the Software".

Continue with "Chapter 3. Installing the 
Software for the First Time".
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Chapter 2. Upgrading the Software

This chapter gives the following procedures for installing an upgrade version of the 
storage management software. 

If you have not installed this software before, go to "Chapter 3. Installing the Software for 
the First Time".

Preparing for an Upgrade Installation

This section provides the following procedures for preparing for your upgrade installation: 

Retaining Your Previous Configuration Information

During the upgrade/installation procedure, your current rmparams and rmscript.bat files 
will be saved as rmparams.ori and rmscript.ori. You can refer to these old files after 
installation to determine if you want to customize the new files. 

Upgrading the RDAC Driver

Do not install the RDAC driver before upgrading the storage management software. The 
installation procedure will remove any version of the RDAC driver. The new version of 
the RDAC driver will need to be installed from this software’s installation CD. See 
"Installing the Driver" on page 46 for more information.

Preparing for an Upgrade Installation page 7

Installing the Software page 9

What’s Next? page 12

Retaining Your Previous Configuration Information page 7

Upgrading the RDAC Driver page 7

Downloading the NVSRAM Files page 8

Upgrading the Controller Firmware page 8

Installing the Software page 9
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Downloading the NVSRAM Files

Important: In most cases, you have to download a new NVSRAM file before 
upgrading controller firmware, especially if you are upgrading from one 
major firmware release to another. The NVSRAM file specifies certain 
default settings for the controller (it will be part of the controller 
firmware’s release media). 

1. Select Maintenance/Tuning → Firmware Upgrade.

2. Be sure to specify the NVSRAM file on the Path line because the fwcompat.def file 
does not recognize NVSRAM files and will not place them in the Compatible Files/
Versions list.

3. When finished, run nvutil -vf from the command line to ensure the controller receives 
the new settings.

4. Turn power off, then back on to the affected RAID Controllers to ensure the new 
NVSRAM settings take effect.

5. Continue with "Upgrading the Controller Firmware."

Upgrading the Controller Firmware

1. Determine if you need to upgrade to the required controller firmware version:

a. Select RAID Controller → Module Profile → Controllers.

b. Verify the boot and firmware levels meet the minimum requirement (see Table 18 
on page 85).

c. Select OK when finished viewing.

2. Upgrade your controller firmware now.

a. Select Maintenance/Tuning → Firmware Upgrade.

b. Select Offline.

c. Download the firmware files from this software’s CD-ROM. For example, at the 
path line (assuming d: is your CD-ROM drive) type: 
d:\networkd\firmware\03000105.apd + 03000103.bwd 
where the numbers match the firmware level to which you need to upgrade.
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Installing the Software

Use the following procedure to install the storage management software.

Important: You must have administrator privileges to access this software. This 
installation procedure requires you to restart the operating system. 
Therefore, make sure that other users are not on the system when 
installing this software.

Caution: Do not install the RDAC driver before upgrading the storage management 
software. The installation procedure will remove any version of the 
RDAC driver. The storage management software’s installation CD 
contains a new version of the RDAC driver, which you will need to install 
after upgrading the software.

1. Insert the Installation CD into your CD-ROM drive. 

Note: In the following examples, c:\ is designated as your boot drive and d:\ is designated 
as the CD-ROM device drive. Be sure to select the correct drives for your system. 

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs.

b. Select Install, and then browse. 

c. When you see d:\networkd\netsymsm\setup.exe, select Finish. 

3. Follow the instructions on screen to complete the installation procedure.

Important: During installation, you will be prompted to define the directory path 
where you want this software installed. If you are defining your own 
directory path, do not use special characters for the directory name (such 
as, #, $, or +). The default path is c:\Program Files\NetSYMsm. For the 
purpose of providing examples of the installation requirements, this 
Installation Guide will refer to the default directory. 

4. When the installation is completed, remove the CD and restart the system.

5. After your system restarts, continue with "Verifying the Installation" on page 9.

Verifying the Installation

Verify the storage management software is installed, and that the Disk Array Monitor 
service is running.

1. Select Start → Programs. Networked SYMplicity Storage Manager appears in the list.
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2. To verify that the Disk Array Monitor is running:

3. Continue with "Editing the RAID Controller Information" on page 10.

Editing the RAID Controller Information

Your existing RAID Controller configuration has been retained.

Use the following procedure to add or change information about your RAID Controllers:

1. Select the Recovery Application.

The Select Module main screen appears.

Figure 1.  Select Module Main Screen

2. Verify that this screen contains the correct number of RAID Controllers. You may 
want to refer to the table (similar to Table 4 on page 16) you created when you 
originally installed the software.

3. If you want to add or change information for a RAID Controller, highlight that module 
and select Edit.

Windows NT Windows 95

Select Start → Settings → Control 
Panel → Services. The Disk Array 
Monitor is running if this service’s 
status is Started.

An icon appears in the service tray in the 
lower right corner of your screen. Move 
your cursor over the icon. A status message 
pops up indicating that the Disk Array 
Monitor is Running.
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The Edit screen appears.

4. In the Edit screen, make the following changes:

• Change the module name if desired. Remember, there is a 16 character limit. The 
new name might include the host machine’s name, the module’s location, and a 
unique number for the module.

• For RAID Controllers using the independent controller configuration, click the box 
next to Independent Controllers. This indicates the RAID Controllers are using the 
independent controller configuration. (Two different Fibre hosts are each connected 
to both controllers in a RAID Controller.)

• In the Comment field, add information that might help you identify the module. 
You may want to add location details, host-RAID Controller configuration type, 
machine type, or other unique information to further clarify the module for future 
identification.

Figure 2.  The Edit Screen
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5. Select OK when done.

The Select Module main screen now reflects any changes you made.

6. Repeat Step 3. through Step 5. until you have added/changed information for each 
RAID Controller you want to change.

7. Continue with "What’s Next?" on page 12.

What’s Next?

The remainder of the book contains information that you may need to review after you 
have completed your upgrade installation. 

If you want to Continue with

Read background information relating to 
operating the storage management 
software in the Windows environment

"Chapter 4. Operating System Support"

Customize the installation to run on your 
system

"Chapter 5. Customizing the Installation"

Ensure that the storage management 
software operates properly and determine 
if the system configuration meets your 
needs

"Chapter 6. Initial Startup Procedures"
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Chapter 3. Installing the Software for the First Time

This chapter gives the procedures for installing the storage management software for the 
first time. If you have a previously installed version of the software, go to "Chapter 2. 
Upgrading the Software".

Sample Network

Figure 3 shows a sample setup of two networks. Each network contains a BOOTP server 
and at least one host machine connected to two or more RAID Controller modules. 
Remember that if the network spans multiple subnets, you may need one BOOTP server 
for each subnet that has a networked RAID Controller Unit.

Also in Figure 3, the host machines are connected to the RAID Controllers via an I/O data 
connection (Fibre Channel). This storage management software is unaware of these host 
machines, the operating system installed on them, and the I/O data connection. The 
software management station has no way to talk with the host system or to monitor the 
connection. Therefore, you need to follow the operating system’s documentation when 

Sample Network page 13

Summary of Preparation Tasks page 14

Determining the Hardware Ethernet Address page 17

Determining Names for RAID Controller Units and Controllers page 18

Obtaining IP Addresses page 19

Setting Up the BOOTP Server page 19

Verifying the TCP/IP Protocol and Setting Up the Host or DNS Table page 32

Installing the Software page 33
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using the host’s operating system with your controllers. Furthermore, you do not see 
messages displayed on the host’s console, nor does this software receive or display any 
messages from the host. They are entirely independent systems.

Figure 3.  Sample Network System and Hardware Components

Summary of Preparation Tasks

Before you install the storage management software, you must perform the tasks described 
in Table 2 to ensure the components on the network are set up and operating properly, and 
you have all the controller information needed for the software to operate correctly.
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Perform the tasks in  Step 1 through  Step 7 and use Table 4 on page 16 to record 
information such as RAID Controller and controller names, hardware ethernet and IP 
addresses, and host machine configuration type.

Table 2: Summary of Tasks for Configuring Controllers on the Network 

Task To Perform Why Perform This Task? For More Details, See: 

1 Install all hardware components 
(host machines, RAID 
Controllers, cables, etc.) that you 
want connected to the network.

NOTE You need the proper type 
of transceiver when connecting your 
RAID Controllers to the network.

To ensure the network 
hardware is present.

The Installation Guide specific 
to your hardware components.

2 Determine the hardware ethernet 
address for each controller in all 
the RAID Controllers connected 
to the network.

To configure the BOOTP 
server on the network.

"Determining the Hardware 
Ethernet Address" on page 17.

3 Establish and record a naming 
scheme for each RAID Controller 
and for each controller in the 
RAID Controllers connected to 
the network.

To help when assigning 
names and addresses to your 
controllers and host 
machines.

"Determining Names for RAID 
Controller Units and 
Controllers" on page 18.

4 Obtain IP addresses from your 
network administrator for each 
controller in all the RAID 
Controllers connected to the 
network.

To configure the BOOTP 
server on the network and to 
set up the host (or DNS) 
table.

"Obtaining IP Addresses" on 
page 19.

5 Configure the hardware and IP 
addresses on the BOOTP server 
on the network.

To set up the network address 
information for the BOOTP 
server.

"Setting Up the BOOTP 
Server" on page 19.

6 Verify the TCP/IP Protocol is 
installed and set up the host (or 
DNS) table.

To verify your Windows 
machine is configured to 
reach the controllers over the 
network.

"Verifying the TCP/IP Protocol 
and Setting Up the Host or DNS 
Table" on page 32.

7 Power up the components 
connected to the network.

To ensure all devices and 
links are operational.

The Installation Guide specific 
to your hardware components. 
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Table 3 provides samples for both a single and a dual-controller RAID Controller. 

Table 4 provides a place for you to record controller and controller information. Keeping 
this record will help you properly set up the BOOTP table for the network server and the 
host or DNS (Domain Name Server) table to use the storage management software. It will 
also help you correctly add additional RAID Controllers after initial installation. The first 
four column headings show a reference to the page where you can go for detailed 
instructions on obtaining this information.

Table 3: Sample Table for Recording Controller (Addresses and Names) and 
Controller Information 

RAID Controller Name Hardware 
Ethernet Address IP Address Controller 

Name
Host Machine 
Configuration 

Type

Example: 

(The first RAID Controller 
on host machine socrates.)
RAID Controller Name: 

socrates_ks_001

00a0b802042c 153.79.144.17 soc_7 Single-host

Example:

(The first RAID Controller 
on host machine beatrice.)
RAID Controller Name: 

beatrice_fl_001

00a0b8020420 153.79.144.13 beatr_1 Single-host

00a0b80000d8 153.79.144.14 beatr_2

Table 4:  Table for Recording Controller (Addresses and Names) and Controller 
Information 

RAID Controller 
Name

(See page 19)

Hardware Ethernet 
Address

(See page 17)

IP Address
(See page 19)

Controller 
Name

(See page 19)

Host Machine 
Configuration 

Type

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:
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Determining the Hardware Ethernet Address

Use the following procedure to record the correct hardware ethernet address for each 
controller in all RAID Controllers connected to the network.

1. Turn the power off to all the RAID Controllers on the network.

Important: Consult the manual shipped with your RAID Controller Unit for specific 
procedures on removing/replacing controllers.

2. Remove the controller (one at a time for redundant controllers) from the RAID 
Controller.

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

RAID Controller 
Name:

Table 4:  Table for Recording Controller (Addresses and Names) and Controller 
Information  (continued)

RAID Controller 
Name

(See page 19)

Hardware Ethernet 
Address

(See page 17)

IP Address
(See page 19)

Controller 
Name

(See page 19)

Host Machine 
Configuration 

Type
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3. Record the ethernet address as it appears on the label on the controller back underneath 
the canister.

The Ethernet ID (or hardware ethernet address) is shown in Figure 4. Use Table 4 on 
page 16 to record the IDs. 

Figure 4.  Location of Ethernet Address on the Back of the Controller 

4. Replace the controller in the RAID Controller Unit.

5. Repeat  Step 2 through  Step 4 for each controller in every RAID Controller Unit.

6. Continue with "Determining Names for RAID Controller Units and Controllers" on 
page 18.

Determining Names for RAID Controller Units and 
Controllers

When you open any storage management application for the first time after installation, 
you will be required to add information about the controllers in each RAID Controller 
Unit to allow the software to recognize them. You will also be able to provide a unique 
name for each RAID Controller Unit and controller. Use the information below and Table 
4 on page 16 to record the information you will need to add the RAID Controller Units.
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RAID Controller Unit Names

The RAID Controller Unit name can be anything you want; however, the software allows 
only 16 characters. You can provide a unique name for each controller (see Example 
Names in Table 3), or you can accept the default name which will be Net Module xxx 
(where xxx is a sequential number). If you choose to rename the controllers, the new name 
might include the name of the host machine, an indication of its location, and a unique 
number.

Controller Names

• The controller names can also be anything you want; however, the name should be 
meaningful to you in the first eight characters because the software only displays the 
first eight characters in its device-name display. 

• Furthermore, you need to provide a unique name for each controller in all RAID 
Controller Units (see Example Names in Table 3). Therefore, we suggest that the name 
identifies the name of the host machine (connected to your RAID Controllers via I/O 
data connection) and a number representing the controller or its host-side ID. However, 
keep in mind the eight-character display limit. Because names for host machines could 
be much longer than the character limit allows, you may need to be creative when 
creating or abbreviating them.

Obtaining IP Addresses

Each controller in every RAID Controller Unit on the network needs a unique IP address. 
Contact your network administrator to get the IP addresses you need and record them in 
Table 4 on page 16. You can also use Table 4 to provide a list for your network 
administrator.

Setting Up the BOOTP Server

Regardless of whether BOOTP is UNIX or DHCP, you have some required and optional 
settings to consider. Review Table 5, then select the correct procedure for the type of 
BOOTP Server you are using.
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.

Table 5: Required and Optional Entries for Setting Up the BOOTP Server

Entry Description Format /(Example) In 
BOOTP Server

Required Entries

subnet mask Mask used to route packets to defined subnets. dot notation 
(sm=255.255.248.0)

router IP address of machine that routes packets to other 
locations or networks.

dot notation

(gw=153.79.144.2)

controller 
name

Controller name you created for the controller (such as 
beatr_1 and soc_ks9). (Refer to Table 4 on page 16.)

controller name

(beatr_1)

IP address IP address of controller. (Refer to Table 4 on page 16.) dot notation

(ip=153.79.144.13)

ethernet 
address

Hardware ethernet address of controller. (Refer to Table 
4 on page 16.) 

hexadecimal notation

(ha=00a0b8020420)
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tag 164 The remote management station (RMS) tag; includes a 
tag and IP address for each Windows station where you 
are installing the storage management software.

IMPORTANT You may have a maximum of four remote 
management and SNMP network management stations 
(NMS); that is, the combined total of tags 164 (T164=) 
and 165 (T165=).

1 From each station, select Start → Settings → Control 
Panel → Network → Protocols → TCP/IP Protocol → 
IP Address to locate this IP address.

NOTE If the IP address information is blank and 
Obtain An IP Address From A DHCP Server is selected, 
you will need to go to either your network administrator 
or to the DHCP Server to obtain the IP address. 
Remember, this IP address must be reserved for only this 
station.

2 You must then convert the dot notation (IP address) to 
a hexadecimal notation (see example below).

NOTE Select Start → Programs → Accessories → 
Calculator. Use the Scientific view to assist with 
numerical conversion. This is not required for DHCP.

Figure 5.  Sample Conversion of Dot to Hexadecimal 
Notation

3 Enter the hexadecimal notation in the BOOTP server.

hexadecimal notation
(T164=0x994F9006)

Table 5: Required and Optional Entries for Setting Up the BOOTP Server

Entry Description Format /(Example) In 
BOOTP Server
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Select the correct procedure for setting up your BOOTP server.

Optional Entries

vm=rfc 1084 Some BOOTP servers require this vendor tag in order to 
return vendor-specific configuration information for 
controller operations.

vm=rfc 1084

tag 163 The network timeout tag sets a value on the controller 
for the amount of time (in seconds) it will wait for a 
reply from this software. The default is 30.

T163=30

tag 165 The Simple Network Management Protocol (SNMP) 
tag; includes a tag and the IP address of the Network 
Management Station (NMS).

Set this tag if you want the controller to send traps 
directly to the designated NMS. You can also enable the 
storage management software to send traps to the 
designated NMS. This procedure is explained later in 
"Enabling SNMP" on page 3-8.

1 Contact your network administrator or use the 
operating system on the NMS to locate this IP address. 
Consult your operating system documentation for 
directions.

2 You must then convert the dot notation (IP address) to 
a hexadecimal notation (see Figure 5 on page 21 for an 
example).

3 Enter the hexadecimal notation in the BOOTP table.

hexadecimal notation

(T165=0x994F8004)

UNIX DHCP

Continue with "Using a UNIX 
BOOTP Server" on page 23

Go to "Using a DHCP Server" on 
page 24.

Table 5: Required and Optional Entries for Setting Up the BOOTP Server

Entry Description Format /(Example) In 
BOOTP Server
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Using a UNIX BOOTP Server 

1. Use Table 4 on page 16 and Table 5 on page 20 to set up the BOOTP table and make 
the required entries for supporting the controllers in the RAID Controllers connected to 
the network.

A sample entry for editing the BOOTP table follows.

NOTE To set up this BOOTP server, you would use a text editor to edit the bootptab file 
in the /etc directory.

2. Turn on power, or cycle power to the RAID Controllers on the network in order for the 
parameters in the BOOTP table to take effect.

3. Continue with "Verifying the TCP/IP Protocol and Setting Up the Host or DNS Table" 
on page 32.

EXAMPLE The following sample entry for a BOOTP table assumes you are 
configuring a UNIX BOOTP server, such as a server on network 1 as 
shown in Figure 3 on page 14. The s3.default:\ entry denotes settings that 
are common to all controllers. The tc=s3.default:\ entry associates this 
common setting group to a specific controller.

s3.default:\ (common settings)

ht=ether:\

sm=255.255.248.0:\

gw=153.79.144.2:\

T164=0x994F9006:\

T165=0x994F8004:\ 

hn:

beatr_1:\

tc=s3.default:\ (refers to common settings)

ip=153.79.144.13:\

ha=00a0b8020420:
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beatr_2:\

tc=s3.default:\

ip=153.79.144.14:\

ha=00a0b80000d8:

beatr_3:\

tc=s3.default:\

ip=153.79.144.11:\

ha=00a0b80000e5:

beatr_4:\

tc=s3.default:\

ip=153.79.144.12:\

ha=00a0b802007c:

beatr_5:\

tc=s3.default:\

ip=153.79.144.15:\

ha=00a0b80200d7:

beatr_6:\

tc=s3.default:\

ip=153.79.144.16:\

ha=00a0b802008e:

Using a DHCP Server

You must have a DHCP Manager installed before you can set up the DHCP Server. If you 
have this installed, continue with "Setting Up a DHCP Server." If a DHCP Manager is not 
installed, you need to install it now.
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Note: The following steps and screen examples assume you are configuring a 
Windows NT DHCP Server using its DHCP Manager.

Installing the DHCP Manager

Use the following procedure to install the DHCP Manager.

1. Select Start → Settings → Control Panel.

2. Select the Network icon.

3. Select the Services tab.

4. Select DHCP Server Network Services → Add.

5. Re-install the service pack.

6. Continue with "Setting Up a DHCP Server" on page 25.

Setting Up a DHCP Server

Refer to Table 5 on page 20 and Table 4 on page 16 when using the following steps to set 
up your DHCP/BOOTP server:

1. Select Start → Programs → Administrative Tools → DHCP Manager. 

The DHCP Manager Screen appears. 

2. Create a scope.

A scope defines a group of controllers you want to configure using the DHCP/BOOTP 
server.

a. Double-click Local Machine.
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b. Select Scope → Create (Figure 6 displays).

Figure 6.  Create Scope Screen

c. Enter the starting and ending IP addresses of the controllers you are configuring on 
your network.

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet, your 
starting address should be set to 153.79.144.1 and your ending address should be set 
to 153.79.144.50.

NOTE If each field does not contain at least three characters, you must press the 
period key to advance to the next field. If you have only one controller, 
you still must add its address for both the starting and ending addresses.

d. Enter your subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection permanent.

f. If you wish, you can add a Scope Name and Comment.

g. Select OK.

h. When you see that the scope has been successfully completed, select Yes to 
activate.

You are returned to the DHCP Manager screen.

3. Create vendor unique option entries. 

You will need to add all controller configuration options that are vendor specific in the 
DHCP Server’s options list.

a. Select DHCP Options → Defaults. The Default Value screen displays.



Chapter 3. Installing the Software for the First Time 27

b. Select New (Figure 7 displays). 

Figure 7.  Add Option Type Screen

c. Fill in the option’s Name, Data Type, and Identifier fields. 

For example, the following options should be added:

Note: Typically, the entries listed above will be all that you need to configure the 
controllers. However, there are other configuration options available. Consult the 
Table 5 on page 20 for a list of required and optional entries for the BOOTP server. 
Remember, you may have a maximum of four remote management and SNMP 
network management stations (NMS); that is, the combined total of tags 164 and 
165.

d. Make sure the Array box is checked whenever the option you add is an IP address.

e. Select OK. You are returned to Default Value screen. 

f. Repeat  Step b through  Step e until all options are added.

g. When you have added all Vendor Unique Options, select OK at the Default Value 
screen.

You are returned to the DHCP Manager screen.

Name Data Type Identifier (Tag)

Remote Management Station IP address 164

Network Management Station IP address 165
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4. Configure global scope options. 

The scope options will allow you to configure settings that will be applicable to all 
your controllers. Refer to Table 5 on page 20 to determine what parameters you want to 
apply to the entire group.

  NOTE You can apply some options to specific controllers later using  Step 6 on page 
30.

a. Select DHCP Options → Global (Figure 8 displays).

Figure 8.  Global Options Screen

b. Highlight any entry in the Unused Options list and select Add to move it to the 
Active Options list.

Note: Each option is preceded by its tag number. A typical installation may include the 
following Global Options:

003 Router
164 Remote Management Station (RMS)
165 Network Management Station (NMS)

c. Select Value to assign a value to the active option.

The Value option greys out and the Edit Array option box appears in the lower part 
of the screen.
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d. Select Edit Array if the value you need to add is an IP address (such as for a router, 
RMS, or NMS) (Figure 9 displays).

Figure 9.  IP Address Array Editor Screen

e. Enter the unique IP address for the option you added. Figure 9 shows an example of 
adding the IP Address for an RMS.

NOTE If you do not know the IP address, but you know the Server name, you 
can use this field and the Resolve option to determine the correct IP 
address. 

f. Select Add to move it to the IP Address list.

g. Select OK. You are returned to the DHCP Options: Global screen.

h. Repeat  Step b through  Step g until all global options are added.

i. When you have added all Global Scope Options, select OK at the DHCP Options: 
Global screen. 

You are returned to the DHCP Manager screen.

5. Create a reservation for each controller. 

Use Table 4 on page 16 to make sure you include all the controllers for every RAID 
Controller in your network. This table contains your controller names and IP addresses.

a. Select Scope → Add Reservations.

b. In the IP Address field, enter the IP address for the first controller (in your table).

c. In the Unique Identifier field, enter the hardware ethernet address for the same 
controller.

d. In the Client Name field, enter the controller’s eight-character name.

e. Select Add. The screen resets and is ready for the next entry. 
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f. Repeat  Step b through  Step e for each controller in Table 3.

g. When all controllers have been entered, select Close.

You are returned to the DHCP Manager screen.

6. Configure Controller Specific Options. 

Creating a controller specific option allows you to associate a controller configuration 
entry with a specific controller added in Step 5. 

Important: If you already set an option as Global Scope, it applies to every controller 
in this group and does not need to be added again here.

a. Select Scope → Active Leases (Figure 10 displays). 

Figure 10.  Active Leases Screen
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b. Highlight any controller in the list.

c. Select Properties (Figure 11 displays).

Figure 11.  Client Properties Screen

d. Select Options. The DHCP Options: Reservations screen displays.

e. Highlight an entry in the Unused Options list and select Add to move it to the 
Active Options list.

f. Select Value to assign a value to the active option.

Important: You must add Option 012 Host Name for each controller, and enter the 
controller’s name for the value.

g. Enter the information for the value of the option.

For example, for Host Name enter the controller name from Table 3 on page 16 in 
the String box. Or, select Edit Array if the value you need to add is an IP address 
(such as for a router, RMS, or NMS).

h. Repeat  Step e through  Step g until all specific options for this controller are added.

i. Select OK. 

You are returned to the Client Properties screen.

j. Select OK. 

You are returned to the Active Leases screen.

k. Repeat Step b through  Step h until all Controller Specific Options for every 
controller are added.

l. When you selected all controllers you want and added specific options, select OK at 
the Active Leases screen. 

You are returned to the DHCP Manager screen.

7. Continue with "Verifying the TCP/IP Protocol and Setting Up the Host or DNS Table" 
on page 32.
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Verifying the TCP/IP Protocol and Setting Up the Host 
or DNS Table

Use the following procedure to verify the TCP/IP Protocol is installed and to set up the 
host or DNS (Domain Name Service) table. This is necessary to correspond your network 
controller name for the controllers with their IP addresses.

1. Verify the TCP/IP Protocol is installed and configured properly.

NOTE If the TCP/IP Protocol software is not installed, load it from your Windows NT 
or Windows 95 CD-ROM. Select Start → Settings → Control Panel → 
Network → Protocols → Add Programs.

2. You must edit either the DNS (Domain Name Service) or your host table to add the IP 
address and controller name for each controller on the network. Edit the two host tables 
found in the following directory/paths:

For example, to set up the host tables for the controllers connected to network 1 
(Figure 3 on page 14), use a text editor to create the following controller name and IP 
address entries:

3. Continue with "Installing the Software" on page 33. 

Windows NT Windows 95

c:\winnt\system32\drivers\etc\hosts c:\windows\hosts

c:\winnt\system32\drivers\etc\lmhosts c:\windows\hosts\lmhosts

127.0.0.01 localhost

153.79.144.13 beatr_1

153.79.144.14 beatr_2

153.79.144.11 beatr_3

153.79.144.12 beatr_4

153.79.144.15 beatr_5

153.79.144.16 beatr_6
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Installing the Software

Use the following procedure to install the storage management software.

Important: You must have administrator privileges to access this software. This 
installation procedure requires you to restart the operating system. 
Therefore, make sure that other users are not on the system when 
installing this software.

1. Insert the Installation CD into your CD-ROM drive. 

NOTE In the following examples, c:\ is designated as your boot drive and d:\ is 
designated as the CD-ROM device drive. Be sure to select the correct drives 
for your system. 

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs.

b. Select Install, and then browse. 

c. When you see d:\networkd\netsymsm\setup.exe, select Finish. 

3. Follow the instructions on screen to complete the installation procedure.

Important: During installation, you will be prompted to define the directory path 
where you want this software installed. If you are defining your own 
directory path, do not use special characters for the directory name (such 
as, #, $, or +). The default path is c:\Program Files\NetSYMsm. For the 
purpose of providing examples of the installation requirements, this 
Installation Guide will refer to the default directory. 

4. When the installation is completed, remove the CD and restart the system.

5. After your system restarts, continue with "Verifying the Installation" on page 34.
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Verifying the Installation

Verify that the storage management software is installed, and that the Disk Array Monitor 
service is running.

1. To verify that the software has been installed, select Start → Programs. Networked 
SYMplicity Storage Manager appears in the list.

2. To verify that the Disk Array Monitor is running:

3. Continue with "Adding RAID Controller Information" on page 34.

Adding RAID Controller Information 

Since you are installing the storage management software for the first time, there are no 
RAID Controllers defined at this point. When you first select an application, you are 
prompted to add RAID Controllers. Using the information you compiled in Table 4 on 
page 16, define the RAID Controllers on your network by performing the following 
procedure:

1. Select the Maintenance/Tuning Application.

The No RAID Controllers Are Currently Defined screen appears.

2. Select OK to add RAID Controllers.

The Add screen appears (See Figure 12).

Windows NT Windows 95

Select Start → Settings → Control 
Panel → Services. The Disk Array 
Monitor is running if this service’s 
status is Started.

An icon appears in the service tray in the 
lower right corner of your screen. Move 
your cursor over the icon. A status message 
pops up indicating that the Disk Array 
Monitor is Running.
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Figure 12.  Add Module Screen

3. Enter the controller names for the first RAID Controller you defined in Table 4 on page 
16.

NOTE Now is also a good time to add information in the Comment field for each 
RAID Controller. You may want to add location details, host-RAID 
Controller configuration, machine type, or other unique information to 
further clarify the controller for future identification.

4. Select OK when the information is complete.

The Add Name screen appears (See Figure 13). The first RAID Controller will show 
the default name, Net Module 001.
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Figure 13.  Add Module Name Screen

5. Do one of the following:

After selecting OK, the Add screen appears again.

6. Repeat  Step 3 through  Step 5 for all the RAID Controllers on your network until you 
have completed the list in Table 4 on page 16.

NOTE If you receive an error message when adding a new controller, you should 
use the symping utility to display possible reasons and suggestions for 
correcting the problem. 

7. When you have entered all controller and controller names from Table 4, select Cancel 
at the final Add screen.

To accept the default name, select OK
To define a new name for the module, enter 
the name (up to 16 characters) and select 
OK. Refer to Table 4 on page 16.
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The Select Module main screen appears (See Figure 14).

8. Verify that this screen contains the correct number of RAID Controllers (use Table 4).

9. Continue with "Upgrading the Controller Firmware" on page 37.

Upgrading the Controller Firmware

1. Determine if you need to upgrade to the required controller firmware version:

a. Select RAID Controller → Module Profile → Controllers.

b. Verify the boot and firmware levels meet the minimum requirement (see Table 18 
on page 85).

c. Select OK when finished viewing.

Figure 14.  Select Module Main Screen
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2. Do you have the minimum firmware version?

3. Upgrade your controller firmware now.

a. Select Maintenance/Tuning → Firmware Upgrade.

b. Select Offline.

c. Download the firmware files from this software CD-ROM. For example, at the path 
line (assuming d: is your CD-ROM drive) type 
d:\networkd\firmware\03000105.apd + 03000103.bwd WHERE the numbers match 
the firmware level to which you need to upgrade.

4. Continue with Chapter 4, “Operating System Support.”

Yes No

Go to  Step 4 on page 
38.

Continue with  Step 3 on 
page 38.
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Chapter 4. Operating System Support

This section contains information related to operating this software in the Windows 
operating environment.

Logical Units Supported

Understanding Logical Unit Support

The networked storage management software supports the creation of up to 32 logical 
units per RAID Controller. However, in most cases, not all of them will be visible to the 
I/O host machine (connected to the RAID Controllers with Fibre Channel connection). 
The actual number of logical units (LUNs) you can configure on a RAID Controller 
depends on two separate limits:

• Operating System — The operating system installed on the I/O host machine has a 
maximum number of logical units (LUNs) per RAID Controller that it supports. For 
example, Windows NT limits the maximum number of LUNs per RAID Controller 
Unit to eight (8) (whether the module has a single controller or redundant controllers). 
Therefore, if you have a RAID Controller Unit with two active controllers, the total 
number of LUNs between them cannot be more than eight. 

This limit is set with the System_MaxLunsPerController parameter in the rmparams 
file and is set to support 32 LUNs by default. You should NOT change this parameter 
setting unless every I/O host is limited to eight LUNs.

Caution: Remember that with the System_MaxLunsPerController parameter in the 
rmparams file set to 32, the Configuration Application (Create LUN 
option) allows you to configure up to 32 LUNs for every RAID Controller 
configured on the network whether the I/O host machine can support 32 
LUNs or not. 

Logical Units Supported page 39

Creating and Deleting Logical Units page 40

Background Monitor page 41

Terms to Know page 42

Command Line Interface page 44

What’s Next? page 44
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If you have more than one I/O host machine connected to your modules 
and any of them do not support 32 LUNs, you must be careful not to 
configure more LUNs on those modules than the host machine allows. If 
you do, the host machine cannot send or receive data from those LUNs. 

• Host Adapter — The host adapter (in the host machine) also has a maximum number 
of LUNs it can support. For example, if you have four RAID Controllers and an eight 
LUN-per-module limit, your host adapter needs to be able to support the total number 
of LUNs (32 in this example).

Supporting 32 Logical Units

You need to first determine how many logical units are supported by the operating system 
on the I/O host machines connected to your RAID Controllers. Second, you need to 
determine how many LUNs are supported by the type of host adapters in the system. 

Note: If you have another operating system on your host machine (other than Windows 
NT), consult the documentation appropriate to that operating system to determine 
the maximum number of LUNs supported.

Creating and Deleting Logical Units

After creating or before deleting logical units (LUNs) using the Configuration Application 
in the networked storage management software, the I/O host operating system needs to 
recognize the changes. For example, with Windows NT, a reboot is necessary.

Creating Logical Units

After creating LUNs you have to make them part of the I/O host operating system. See 
your I/O host documentation for details on adding a drive. Remember each logical unit 
(not a drive group) is seen by the operating system as one drive.

Caution: Remember that the Configuration Application (Create LUN option) 
allows you to configure up to 32 LUNs for every RAID Controller 
configured on the network whether the I/O host machine can support 32 
LUNs or not. If you have more than one I/O host machine connected to 
your modules and any of them do not support 32 LUNs, you must be 
careful not to configure more LUNs on those modules than the host 
machine allows. If you do, the host machine cannot send or receive data 
from those LUNs. 
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Deleting Logical Units

Before deleting LUNs with this software or using File → Reset Configuration, stop I/Os 
to the affected RAID Controller. Then, unmount any filesystems, delete any partitions, and 
deassign any drive letters associated with the LUNs on your I/O host.

Background Monitor

The storage management software has a background monitor that automatically polls all 
RAID Controllers and checks for problems/events at a specified interval. If any problems 
or events are detected, the information is written to the default log file. This becomes an 
historical record of past component failures, general status changes, and configuration 
changes.

The checking interval can be changed from the default of every five minutes. For best 
results, use the default value or smaller to ensure that you are notified about problems/
events as close as possible to when they occur.

CAUTION Setting this value (Status → Options → Log Settings) too small could 
cause the check to affect system I/O performance. However, setting this 
value too large could delay notification of serious problems.

Stopping the Disk Array Monitor Service

CAUTION You should only stop this monitoring service if you are specifically 
instructed to do so by Recovery Guru, the troubleshooting documentation, 
or your Customer Services Representative. However, doing so means that 
none of the RAID Controllers connected to the host will be checked 
during this time. Be sure to restart the monitor when instructed.

Windows NT Windows 95

1 Select Start → Settings → Control 
Panel → Services.

2 Highlight the Disk Array Monitor 
Service 

3 Select Stop. When the status changes 
to Stopped, close the Services 
Application.

1 Double-click the icon in the service tray 
in the lower right corner of your screen. 

The icon changes and will now have the 
universal no symbol indicating that the 
monitoring service has been stopped.
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Starting the Disk Array Monitor Service

This background monitor automatically starts when you run the storage management 
software. However, it will be necessary to manually start this process if you have stopped 
it for some reason. 

When you have manually stopped the background monitor, you have not been monitoring 
for some period of time. We recommend that you run Recovery Guru/Heath Check to 
make sure that no problems have occurred while you had the disk array monitor stopped.

Terms to Know

BOOTP Server

A network machine running the service that provides startup information. See "Setting Up 
the BOOTP Server" on page 19 for the required and optional entries.

Controller Name/ID

Also known as the device name, the controller name/ID is the controller name you created 
after the software installation procedure. The software uses these names to gain access to 
each controller in the RAID Controllers connected to the network. Because each controller 
name must be unique, you can record its correspondence to a specific controller in a RAID 
Controller. See "Determining Names for RAID Controller Units and Controllers" on page 
18 for specific details and examples of creating these names.

Windows NT Windows 95

1 Select Start → Settings → Control 
Panel → Services.

2 Highlight the Disk Array Monitor 
Service. 

3 Select Start. When the status changes 
to Started, close the Services 
Application.

1 Double-click the icon in the service tray 
in the lower right corner of the screen. 

When you move your cursor over the icon, 
a message will pop up indicating that the 
Disk Array Monitor Service is Running.
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Hardware Ethernet Address

The hardware identification assigned by the manufacturer, also known as the MAC 
address. This number is located on the back of the controller (see Figure 4 on page 18). 
This unique address is required for configuring the BOOTP Server on your network. See 
"Determining the Hardware Ethernet Address" on page 17 for specific details on obtaining 
this address.

IP Address

The 32-bit identification defined by the Internet Protocol. It is usually represented in 
dotted decimal notation and can be obtained from your network administrator. This unique 
address is required for configuring the BOOTP Server on your network and setting up the 
host (or DNS) table. See "Setting Up the BOOTP Server" on page 19 and "Verifying the 
TCP/IP Protocol and Setting Up the Host or DNS Table" on page 32 for more information 
on using this address.

Module Names

By default, module names are assigned in the order in which the system detects the 
module. The default name displayed is Net Module xxx, where xxx is a sequential 
number. You can choose to rename the modules; however, the software allows only 16 
characters, and each name must be unique. See "Determining Names for RAID Controller 
Units and Controllers" on page 18 for specific details and examples of creating these 
names.

NMS

Network Management Station, also known as a target. A remote network manager you can 
assign to receive SNMP traps.

RMS

Remote Management Station. The Windows NT or Windows 95 system where the storage 
management software is installed and executed for the configuring and monitoring of 
RAID devices.

SNMP

The Simple Network Management Protocol (SNMP) notification is an option you may 
enable when installing this software. It allows this software to send remote notification of 
RAID events to a designated NMS using SNMP traps.



44 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook

SNMP Traps

An SNMP message type sent to an assigned NMS.

Command Line Interface

Certain text files were copied to the default installation directory (\netsymsm) during this 
software installation. These files provide supplementary information for storage 
management and administration. Some tasks are carried out automatically by service 
processes that run from system startup to system shutdown. There are also command line 
utilities that make it possible to embed customized and/or interactive operations.

You can access these text files by typing (from the installation directory) help <filename> 
or by using any text editor to open and read them. For example, to read the file on the 
drivutil command, from the installation directory, type: help drivutil.

For a list of these files and a description of the utility or program they describe, see the 
User’s Handbook.

What’s Next?

Continue with "Chapter 5. Customizing the Installation," to make specific changes to the 
storage management software.
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Chapter 5. Customizing the Installation

This chapter describes how to customize your installation to run on your system.

Protecting Data with RDAC over the I/O Data 
Connection

It is possible to have failover protection over the I/O data connection if your host machine 
is running Windows NT, is connected to the RAID Controller Units by Fibre Channel 
connection, and has the Redundant Disk Array Controller (RDAC) Driver installed. The 
RDAC driver is available for installation from the software CD-ROM.

Important: RDAC protection is only available on host machines running 
Windows NT.

For RAID Controllers with redundant controllers, this host-based driver manages the I/O 
data path. If a component fails on the data path (interface cable/terminator, controller, host 
adapter, etc.) that causes the host to lose communication with a controller, the RDAC 
driver automatically reroutes all I/O operations to the other controller.

Caution: Do not install the RDAC driver before upgrading or installing the storage 
management software. The installation procedure will remove any 
version of the RDAC driver. The RDAC driver will need to be installed 
from this software installation CD.

Setting Up the Fibre Channel Host Adapters

If you are using a Fibre Channel connection to your RAID Controllers, you must set up the 
host adapters using the following procedure:

1. Go to the HBA directory on this software installation CD.

2. Consult any readme file in that folder.

Protecting Data with RDAC over the I/O Data Connection page 45

Setting Up Scriptable Notification Options page 47

Understanding SNMP Notification page 48

Changing the rmparams File page 50

What’s Next? page 52
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This file will give specific instructions on what you need to do to set up your Fibre 
Channel host adapter as well as the latest information on supported host adapters and 
drivers.

3. Continue with "Installing the Driver."

Installing the Driver

To provide RDAC failover protection, you need to install the RDAC driver on any Fibre 
Channel host machine (using either the single-host or multi-host RAID Controller 
configuration) that is connected to the RAID Controller. This host machine must have 
Windows NT installed.

Important: Close all other applications, and make sure that other users are not on the 
system when installing this driver.

1. Insert the installation CD into your CD-ROM drive on the host machine attached
via I/O data path connection to the RAID Controllers. (Depending on your network 
configuration, this machine may not be the same place where you installed the 
Networked storage management software.)

Note: In the following examples, c:\ is designated as the boot drive and d:\ is designated as 
the CD-ROM drive. Be sure to select the correct drive for your system.

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs

b. Type d:\networkd\rdac\SETUP.EXE

c. Select Finish.

3. Follow the screen instructions.

4. Remove the CD when you see the Restart screen and select YES.

5. Select Start → Settings → Control Panel → Devices to verify the RDAC driver is 
installed.

The RDAC driver (symarray) is installed if this driver status is Started.

Important: Before changing any NVSRAM values, it is a good idea to record the 
existing values for the offsets you are changing. Should you ever uninstall 
the RDAC driver, you may need to refer to these values.

6. Use the Networked storage management software to change several NVSRAM settings 
after you install the RDAC driver. (Remember that this station may not be the same as 
the host where you installed the RDAC driver.) Type the following from the command 
line:

a. nvutil -n rdacon.def -vf <device_name>
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WHERE

<device_name> is the name for the controller you designated when you added the 
RAID Controller to the Select Module list.

b. Make sure to issue this command to every controller in each module connected to 
the host where you installed the RDAC driver.

c. Turn off power to each RAID Controller, then turn it back on again for these 
settings to take effect.

d. Repeat this procedure for every host machine (running Windows NT) where you 
want the RDAC driver installed.

Uninstalling the Driver

Use the following procedure only if you want to remove the RDAC driver from your host 
machine.

Important: Close all other applications and make sure that other users are not on the 
system when uninstalling this driver.

1. If you do not intend to re-install this software and are not removing the RAID 
Controller from the network, you may need to restore your controller NVSRAM 
configuration. Refer to the values you recorded before installing the RDAC driver and 
download them to the controllers in your RAID Controller using fwutil.

2. To begin the uninstall program:

a. Select Start → Settings → Control Panel → Add/Remove Programs and scroll the 
list to find SYMplicity RDAC Driver.

b. With SYMplicity RDAC Driver highlighted, select Add/Remove.

c. At the Uninstall Application screen, select OK to remove the software.

You will see screens indicating the uninstall program is removing the appropriate 
service, registry information, and files.

3. At the Restart screen, select OK to shutdown and to restart the Windows NT system.

Setting Up Scriptable Notification Options 

The rmscript.bat file is accessed by the status monitor and automatic parity check 
whenever these utilities find an exception. By default, no action is taken. You can edit this 
file to specify a set of actions to take when an error is found.

For example, if you want to install third-party notification software to perform various 
events (such as faxing or paging), you would add the appropriate script for each event near 
the end of this file. Consult the third party software documentation for specific details. 
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NOTE If you installed an upgrade of the storage management software, you may want 
to refer to the rmscript.ori file to determine if you want to make additional 
customized changes to the new file. Remember, the new file contains new script 
for this version, so you must not replace it with the old file.

For more information, read the text file about rmscript.bat. From this software installation 
directory, type: help rmscript.

Understanding SNMP Notification

Enabling SNMP

This software can provide remote notification of RAID events to a designated network 
management station (NMS) using Simple Network Management Protocol (SNMP) traps.

Use the following procedure to set up the NMS, to understand the contents of an SNMP 
trap message, and to enable or disable this notification option for each host.

1. Set up the NMS.

You only need to set up your designated NMS one time. Use the following procedure to 
compile this software Management Information Base (MIB) into your NMS.

NOTE The MIB was written to standard version 1 SNMP syntax. It was designed 
specifically for the storage management software. It is not applicable to other 
vendors’ RAID products.

a. Copy the \netsymsm\rm6traps.mib file to the network management station.

b. Follow the steps required by your specific network management station to compile 
the MIB.

NOTE For details on the required steps, consult your network administrator or the 
documentation specific to the NMS product you are using.

You want to enable SNMP You do not want to enable SNMP at 
this time

Continue with Step 1. Go to "Changing the rmparams File" on 
page 50.
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2. Make sure the host system is connected to the network that has the NMS station.

3. Enable this notification on your host. You must edit three parameters in the 
\netsymsm\rmparams file so that the software will know where to direct the SNMP trap 
messages when a RAID Event has occurred. 

4. Continue with "Changing the rmparams File" on page 50. 

Contents of an SNMP Trap Message

Refer to Table 6 for a description of the contents of an SNMP trap message.

Important: If the trap type is anything other than informational, you should use the 
Status or Recovery Applications to get more information or specific 
instructions on how to remedy the problem. Do not remove the SNMP 
message until the problem has been corrected since most trap 
notifications associated with this software are not persistent.

Table 6: Contents of an SNMP Trap Message 

Item Description

Storage Management 
Software Station IP 
Address

The standard IP address dot notation for the storage management software 
station.

Host Name The text name assigned to the host.

Trap Type There are four trap types:

• Informational — No failure has occurred. Information is provided that an 
event, such as a logical unit creation, has occurred.

• Degraded Array — A subsystem component failure has occurred. The 
module is still operational but now lacks redundancy in some area. (For 
example, a drive failure resulting in a degraded logical unit, a power supply 
failure, or a failure of one controller in a controller pair.)

• Failed Array — A failure has occurred that leaves a module or logical unit 
unable to communicate. (For example, a failure of the controller in a single-
controller RAID Controller or a multiple drive failure resulting in a dead 
logical unit.)

• Critical — This is a small category of failures that may require timely 
intervention to correct. (For example, the two-minute warning from an 
uninterruptible power supply or a warning that write-back cache has been 
disabled due to a low battery.)

Affected RAID 
Controller

Indicates which RAID Controller had the event (for example, sonne_001).

Condition Description A brief description of the event that has occurred.
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Disabling SNMP 

Perform the following steps to disable this notification on your host and stop this software 
from sending SNMP traps:

1. In the \netsymsm\rmparams file, change the value of the SNMP_Action_Number line 
to 0

2. Save the rmparams file and copy it to the backup directory. It is critical that you have a 
backup copy of this file.

3. Continue with "Changing the rmparams File" on page 50. 

Changing the rmparams File 

The \netsymsm\rmparams file is used to store several configurable options available 
through this software. Review Table 7 on page 51 for a list of the parameters in the file 
that you may need to change after initial installation.

Important: Most of these options (other than the ones shown in Table 7) should not 
be changed and many of the other options should only be changed 
through the graphical user interface (GUI). For more information, read 
the help file about rmparams. From this software installation directory, 
type: help rmparams.

You must edit the rmparams file to increase logical unit support and to 
enable/disable SNMP notification.

Because of the critical nature of the rmparams file, you should make a 
backup copy of the file in a directory other than the installation directory. 
If this file becomes corrupted or missing, you should copy the backup 
rmparams file to the installation directory to resume normal operation. 
Furthermore, if you make any changes to this file directly or use the 
options in the GUI that write to this file (such as log settings), always 
copy the new version of the file to the backup directory.

1. Make any necessary changes to the \netsymsm\rmparams file using Table 7.

2. Save the rmparams file, and copy it to a backup directory.

3. Continue with "What’s Next?" on page 52.
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Table 7: Changeable Parameters in rmparams File 

Description When To Change How To Change

SNMP_Target_IP_Address=127.0.0.1 

Provides the SNMP IP Address 
for remote notification.

If you want to enable SNMP.

Edit the rmparams file and 
change this value to the dotted 
notation IP address of the 
network management system 
where the MIB has been 
compiled. On most systems, this 
IP address can also be a dotted 
notation multicast address or 
broadcast address.

SNMP_Community_Name=NONE

Provides the community name to 
be used for SNMP remote 
notification.

If you want to enable SNMP.

Edit the rmparams file and add 
the community name.

The most commonly used 
community name is public; 
however, your network 
environment may require 
another name.

SNMP_Action_Number=0

Indicates the SNMP trap 
notification option you want to 
use.

If you want to enable SNMP.

Edit the rmparams file and 
change this value to either 1 or 2.

Value 1 will send SNMP traps to 
the designated NMS station. 
Value 2 means that all the 
relevant data is written to the file 
trap.dat.

IMPORTANT Setting this 
parameter to 0 will completely 
disable the SNMP option.
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What’s Next?

Continue with "Chapter 6. Initial Startup Procedures," to ensure that the software operates 
correctly and to determine if the current configuration meets your needs.

System_DefaultModuleSelect=TRUE

Determines whether or not the 
Select Module main screen 
displays each time you open an 
application.

If you want to change the 
default so that the Select 
Module main screen does not 
display each time you open an 
application.

Edit the rmparams file and 
change TRUE to FALSE.

System_MaxControllers=200

Determines the maximum number 
of RAID Controllers supported by 
the software.

If you have more than 200 
RAID Controllers.

Edit the rmparams file and 
change the 200 to the 
appropriate number.

Table 7: Changeable Parameters in rmparams File  (continued)

Description When To Change How To Change
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Chapter 6. Initial Startup Procedures

This chapter contains the following procedures to ensure that the storage management 
software operates properly and to determine if your system configuration meets your 
needs:

Starting the Software

Important: You must have administrator privileges to access this software.

Start Windows if it is not already running. Select Start → Programs → Networked 
SYMplicity Storage Manager.

The application names appear in the Start menu. For a description of some key terms used 
in the applications, see "Terms to Know" on page 42.

Continue with "Verifying Component Status" on page 53.

Verifying Component Status

Run Recovery Guru/Health Check

Use the following steps to ensure that the RAID Controllers (connected to the network) 
are all operational.

1. In the Select Module main screen, highlight All RAID Controllers and select OK.

The main Status screen appears (see Figure 15) showing All RAID Controllers and 
Message Log selected.

Starting the Software page 53

Verifying Component Status page 53

Determining the Current Configuration page 55

Determining If Configuration Changes Are Necessary page 59

Changing Your Hardware Configuration page 62

What’s Next? page 63
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Note: With a new installation, you will be prompted to create a message log. Your default 
log file is new and no messages will appear until after an event has occurred.

Figure 15.  Main Status Screen

2. Select Recovery Guru/Health Check.

The display area (see Figure 16) shows the summary results of the Recovery Guru/
Health Check on all of the RAID Controllers.

• If all of the RAID Controllers report an Optimal status, you are finished with this 
procedure. Go to "Determining the Current Configuration" on page 55.

• If any of the RAID Controllers report a status other than Optimal, continue 
with Step 3.

3. Highlight that RAID Controller and select Show Details to determine the appropriate 
action to take. 

4. After correcting any problems, reselect Recovery Guru/Health Check until all RAID 
Controllers are Optimal. 

5. Continue with "Determining the Current Configuration" on page 55. 
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Figure 16.  Health Check Screen

Determining the Current Configuration

Now that you have successfully installed the software, you need to use it to identify each 
RAID Controller connected to the network and determine the current module 
configuration (number of drives, number of controllers, logical units, etc.).

The software has assigned a name for each RAID Controller connected to the network 
based on the information you supplied after installation. These designations are shown in 
the RAID Controller selection list near the top of each application screen (see Figure 17 on 
page 56).

Perform the following steps for each RAID Controller to identify the module and 
determine its current configuration. 

1. Use the following steps to view the current drive groups and logical units in a RAID 
Controller.

a. Select the Configuration Application.

The Select Module Main screen appears. If you have more than one RAID 
Controller connected to the network, each RAID Controller appears in the list.

b. Make sure that the first RAID Controller is highlighted and select OK.
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The main Configuration screen appears (see Figure 17 on page 56). The main 
Configuration screen is composed of the following major areas:

• Module Information Area — a directory tree structure showing RAID 
Controllers, controllers, drive groups, and LUNs. Clicking on the different items 
changes the display in the detailed information area on the right of the screen.

• Detailed Information Area — provides information about the drive groups and 
logical units in the RAID Controller. The information displayed depends on 
what is highlighted in the Module Information area.

 

Figure 17.  Main Configuration Screen
Figure 0-1

• Logical Unit (LUN) Information Area — provides a summary of the logical 
units configured on the selected RAID Controller Unit. The Device Name 
column shows the controller name you assigned after installation.

c. At the main Configuration screen, view the current drive groups and logical units.

As you highlight a drive group in the list on the left side of the main screen, the 
corresponding logical units are highlighted in the Logical Unit Information area on 
the right side of the screen. You can only highlight one drive group at a time. You 
cannot select or highlight any item in the logical unit information list (it is 
information only).

2. Use the following steps to locate and label a RAID Module.

a. Select Locate Module → Start.

The activity lights flash on the appropriate drive modules. 
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b. Physically locate the RAID Module that has its activity lights flashing. Once you 
have identified the RAID Module, place a sticker label on it for future reference.

For best results, have the module label include both the controller name (see Table 4 
on page 16) and the IP address for each controller in the module. For example, the 
RAID Controller called sonne_002 with two controllers might have the following 
label:

sonne_002
son_ks1; 153.79.144.13
son_ks2; 153.79.144.14

c. Select Stop to stop the flashing of the activity lights.

3. Use the following steps to save and print RAID Controller profile information.

a. Select the desired RAID Controller → File → Save Module Profile. 

A screen shows the different types of information you can save.

b. Make sure All is selected (all of the buttons should be depressed), and select OK to 
save all of the types of information.

A screen display prompts you to enter a filename.

Caution: When using the Save Module Profile option in Step c., save the file to the 
same disk drive where the storage management software is installed (for 
example, c:\). This is important because saving to a different disk drive 
causes that disk drive to remain “open” which can cause the application 
you are using to terminate or return error messages.

c. Enter an appropriate path and filename on the Selection line, and select OK.

d. The information is saved to the path and filename you specified.

e. Print the Module Profile information you saved in Step c. using your host system's 
printer utility.

4. Use the following steps to view a RAID Controller profile. (Optional)

a. Select the desired RAID Controller → Module Profile. 

A summary information screen appears (see Figure 18 on page 58) showing 
information about the controllers, drives, and logical units in the RAID Controller. 

b. Select Controllers, Drives, or LUNs for more detailed information on these 
components. 

c. Select OK to exit the profile information.
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5. Use the following steps to view details on specific drives in a drive group. (Optional)

a. If you want to know which specific drives comprise a particular drive group, 
highlight the drive group (in the Drive Groups area on the main screen) and select 
List/Locate Drives.

b. Use the drive location information [x,y] provided in the list to physically locate 
individual drives in the module.

Remember that [x,y] corresponds to a specific drive in the RAID Controller, and 
indicates the channel number and host-side ID for that drive, where the channel 
number is always listed first. You can also select Locate to flash the drive activity 
lights in the RAID Controller. 

c. Select OK to exit the drive information. 

Figure 18.  Main Module Profile Screen

6. Repeat Steps 1. through 3. (then 4. and 5. if desired) for each RAID Controller 
connected to the network.

7. You should have enough information to understand the current configuration for each 
RAID Controller.

8. Continue with "Determining If Configuration Changes Are Necessary" on page 59. 
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Determining If Configuration Changes Are Necessary

In the previous section (“Determining The Current Configuration”) you should have 
performed the following tasks for each RAID Controller connected to the network:

Now, you need to determine if you need to make any changes to the configuration to meet 
the requirements of your environment.

Use Table 8: and the Module Profile information you saved and printed to assist you in 
determining if any changes are necessary.

Reviewed each module’s current configuration (controllers, drives, and logical 
units/drive groups).

Step 1. on 
page 55.

Identified each RAID Controller using Locate Module, and placed a sticker 
label on it.

Step 2. on 
page 56.

Saved the Module Profile information to a file using
File → Save Module Profile, and printed the information.

Step 3. on 
page 57.

Table 8: Possible Parameters to Change 

Parameter Description Why Change? For More Details

General Parameters

Controller Mode

Maintenance/ 
Tuning 

Applicable controller 
modes are single active, 
active/passive, or active/
active.

If you have an active/
passive controller pair, 
you should consider 
changing it to active/
active for best 
performance.

• See the Maintenance/
Tuning chapter in the 
User’s Handbook.

• Use the online help for 
the Maintenance/
Tuning Application.

Auto Parity 
Check/Repair

Maintenance/ 
Tuning → 
Options

An automatic parity check/
repair process runs each 
day at a specific time, or 
once a week.

Default is auto parity 
disabled.

If you want to enable the 
check/repair or change 
the time when it runs.

• See the Maintenance/
Tuning chapter in the 
User’s Handbook.

• Use the online help for 
the Maintenance/
Tuning Application.
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Monitoring 
Interval

Status → 
Options → Log 
Settings

The array monitor checks 
the RAID Controllers 
periodically looking for 
events and failures.

The default is to check 
every 5 minutes. 

If you want to increase or 
decrease the frequency 
of the checking interval. 
If you have a lot of 
modules, you may need 
to increase this interval 
because the amount of 
time needed to check and 
return results can 
increase.

• See the Status chapter 
in the User’s 
Handbook.

• Use the online help for 
the Status Application.

Hot Spare Drives

Configuration → 
Create Hot Spare

A hot spare drive is a drive 
containing no data that acts 
as a standby in case a drive 
fails in a RAID 1, 3, or 5 
logical unit.

The hot spare adds another 
level of redundancy to 
your RAID Controller.

If you want to create new 
or additional hot spare 
drives for added 
protection.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Logical Unit Parameters

RAID Level Or 
Number Of 
Drives

Configuration → 
Modify Group/
LUN → RAID 
Level 

or

Configuration → 
Delete, then 
Create LUN

Specifies how the data is 
striped across the drives 
and how many drives 
comprise a drive group/
LUN.

If the current RAID 
Level is not appropriate 
for your environment, or 
you need to change the 
number of drives.

NOTE If you do not 
have the minimum 
controller firmware 
level, this feature will 
not be available.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Table 8: Possible Parameters to Change  (continued)

Parameter Description Why Change? For More Details
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Segment Size

Configuration → 
Modify Group/
LUN → Segment 
Size

or

Configuration → 
Delete, then 
Create LUN → 
Options

Specifies in 512-byte 
blocks how much data is 
written to one drive before 
data is written to another 
drive in the group.

If the segment size is not 
appropriate for your 
environment.

NOTE If you do not 
have the minimum 
controller firmware 
level, this feature will 
not be available.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Capacity

Configuration → 
Modify Group/
LUN → Capacity 

or

Configuration → 
Delete, then 
Create LUN → 
Options

Specifies in megabytes 
how much capacity is 
available on the logical 
unit.

If you want to increase or 
decrease the capacities.

NOTE If you do not 
have the minimum 
controller firmware 
level, this feature will 
not be available.

• See the Configuration 
chapter in the User’s 
Handbook.

• Use the online help for 
the Configuration 
Application.

Caching 
Parameters

Configuration → 
Create LUN → 
Options

Maintenance/
Tuning

Specifies the caching 
parameters for each logical 
unit.

If you want to enable or 
disable any of these 
parameters.

• See the Configuration 
chapter in the User’s 
Handbook if you are 
creating new logical 
units, or use the online 
help.

• See the Maintenance/
Tuning chapter in the 
User’s Handbook to 
change caching 
parameters on existing 
logical units, or use the 
online help.

Table 8: Possible Parameters to Change  (continued)

Parameter Description Why Change? For More Details
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Changing Your Hardware Configuration

Adding RAID Controllers

When you add a new RAID Controller to the network, you must follow many of the same 
procedures you would use when installing the software for the first time. These tasks 
include setting up the module and controller information for your BOOTP server and your 
host table, and adding this information to the storage management software module list. 
See the software online help for the procedure to follow.

Removing RAID Controllers

Be sure to remove the RAID Controllers using the storage management software before 
physically removing them from the network. Otherwise, the software will continue trying 
to contact the controllers in that module. This is especially important because missing 
modules could cause the software to have long delays or even system hangs while trying to 
contact the removed module. Also, if you are permanently removing a module from your 
network, you should edit your BOOTP server and host (or DNS) table to remove this 
module. See the software online help for the procedure to follow.

LUN Assignment 
and LUN 
Balancing

Configuration → 
Create LUN → 
Options

Maintenance/
Tuning 

Determines what controller 
owns which logical units/
drive groups.

To reassign or balance 
the logical units/drive 
groups between 
controllers in an active/
active pair.

• See the Configuration 
chapter in the User 
Guide if you are 
creating new logical 
units, or use the online 
help.

• See the Maintenance/
Tuning chapter in the 
User Guide to change 
LUN Assignments on 
existing logical units, 
or use the online help.

Reconstruction 
Rate

Maintenance/
Tuning

Determines how quickly 
reconstruction occurs on a 
logical unit when a failed 
drive is replaced.

To increase or decrease 
the reconstruction 
performance.

• See the Maintenance/
Tuning chapter in the 
User Guide.

• Use the online help for 
the Maintenance/
Tuning Application.

Table 8: Possible Parameters to Change  (continued)

Parameter Description Why Change? For More Details
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Adding Controllers

Always set up new RAID Controllers and their controllers in the BOOTP server and host 
(or DNS) table. See "Summary of Preparation Tasks" on page 14 for the procedure to 
follow. Physically connect the new module to your network system and use Select Module 
→ Add to enter the required information for the module. See the software online help for 
the procedure to follow.

Removing Controllers

Before you remove any RAID Controller Unit (and its controllers) from the network, use 
Select Module → Remove to remove the module information from the software 
configuration. If you are permanently removing this module from your network, you 
should edit your BOOTP server and host (or DNS) table to remove this module. See the 
software online help for the procedure to follow.

Replacing Controllers

If you replace a failed controller, you need to determine its unique hardware ethernet 
address and replace only this entry in the BOOTP table. You should keep the same 
controller name and IP address to ensure that the host table remains correct. See the 
software online help for the procedure to follow.

What’s Next? 

Troubleshooting

You can continue with "Chapter 7. Troubleshooting" for troubleshooting tips or common 
problems you may encounter as you use this software in the Windows operating 
environment.

User’s Handbook/Online Help

Now that you have successfully completed the installation of the software, refer to the 
User’s Handbook and the online help for detailed information on how to use each 
application, and to make any changes that you determined are necessary in the previous 
sections.
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Chapter 7. Troubleshooting

This chapter contains the following sections:

Troubleshooting 

The troubleshooting tables that follow provide probable cause and action to take for 
specific problems you may have as you use the storage management software in the 
networked operating environment. 

IMPORTANT If you cannot find the problem you are looking for, consult the Online 
Help for additional troubleshooting information. Also, see 
"Understanding the Restrictions" on page 1 for additional information.

Locating Solutions 

To quickly find the problem-solution you are looking for, use the following tables to locate 
the problem you are having. It is possible for an entry to appear in more than one table: 

• Category — organizes problems into general use or specific option groups (page 66).

• Component — organizes problems by hardware components, such as controllers, 
drives, modules, etc. (page 66).

• Application — organizes problems for each storage management application, 
including a group for options common to all applications (page 68).

• Software — organizes problems by operating system, storage management software, or 
command line options (page 70).

Troubleshooting page 65

Replacing Controllers (Networked) page 82

Uninstalling the Software page 84
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Category

Groups problems into sections for general use or specific options. 

Component Search 

Organizes individual problems by hardware components, such as controllers, drives, 
LUNs, RAID Controllers, and so on. 

Table 9: Troubleshooting Entries by Category

Category See Page

"Configuration Application" page 70

"Firmware Upgrade" page 72

"General" page 73

"Networked Troubleshooting Only" page 79

"Recovery Guru/Health Check" page 76

Table 10: Troubleshooting Entries Organized by Component 

Component Problem See Details 

Controllers

Failed during alternate replacement page 73

Firmware upgrade failed page 72

LUN creation error after deleting all LUNs or using 
Reset configuration page 71

Not visible to storage management software page 74

Passive, no LUNs owned after replacement page 78

Verify the network enable bit setting

Fans Failure detected after replacement page 76
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Drives

 

Activity lights don’t flash (Configuration → List/
Locate Drives) page 71

All drives failed in a drive group page 78

Failed status, but LUN is Optimal page 77

Fault light comes on after replacing failed drive page 77

Fault lights lit (drives continue to fail) page 77

Missing information in Manual Recovery → Drives 
screen page 78

Number of drives incomplete or wrong during LUN 
creation page 70

Removed drive; no failure reported page 76

Status other than Optimal page 77

LUNs

Error message during LUN creation after deleting all 
LUNs or using Reset Configuration page 71

Less capacity shows than selected during configuration page 71

Missing information in Manual Recovery → LUNs 
screen page 79

Not visible to storage management software page 74

Number of drives incomplete or wrong during LUN 
creation page 70

Optimal LUN status with failed drives page 77

Reconstructing status appears, but no drives replaced page 77

Status other than Optimal page 77

Status remains Reconstructing page 78

NVSRAM Settings Verify the network enable bit setting

Table 10: Troubleshooting Entries Organized by Component  (continued)

Component Problem See Details 
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Application Search

Organizes individual problems for each storage management application, including a 
group for options common to all applications. 

RAID Controllers

Failure detected after replacing fan or power supply page 76

Listed after being removed page 74

Network station cannot talk to the Module page 79

Status other than Optimal page 75

Status does not update after a recovery procedure page 79

Power Supplies Failure detected after replacement page 76

Table 11: Troubleshooting Entries Organized by Application 

Application Problem See Details On

Common To Any 
Application

Cannot select some options page 74

“Cannot secure access to LUNs” message page 75

Select Module lists a RAID Controller removed 
from the system page 74

Status does not update after a recovery procedure page 79

Configuration

Less capacity shows than selected during 
configuration page 71

List/Locate Drives does not work page 71

LUN creation error after deleting all LUNs or 
using Reset Configuration page 71

Number of drives incomplete or wrong during 
LUN creation page 70

Reset Configuration does not work page 71

Status

Reconstructing status appears, but no drives 
replaced page 77

Status remains Reconstructing page 78

Table 10: Troubleshooting Entries Organized by Component  (continued)

Component Problem See Details 
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Recovery

All drives failed in a drive group page 78

Controller mode is Passive, no LUNs owned after 
replacement page 78

Drive fault lights lit (drives continue to fail) page 77

Drive status other than Optimal page 76

Failed status, but LUN is Optimal page 77

Fault light comes on after replacing failed drive page 77

Failure detected after replacing fan or power 
supply page 76

LUN status other than Optimal page 77

Missing information in Manual Recovery → 
Drives screen page 78

Missing information in Manual Recovery → 
Logical Units screen page 79

Reconstructing status appears, but no drives 
replaced page 77

Recovery Guru takes a long time page 76

Removed drive, but Recovery Guru does not report 
a failure page 76

Status does not update after a recovery procedure page 79

Status other than Optimal page 75

Status remains Reconstructing page 78

Maintenance/Tuning

Controller mode is Passive, no LUNs owned after 
replacement page 78

Firmware upgrade failed page 72

Table 11: Troubleshooting Entries Organized by Application  (continued)

Application Problem See Details On
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Software Search 

Organizes individual problems by operating system, storage management software, and 
command line options. 

Configuration Application 

Includes problems you may have as you use options in the Configuration Application.

Table 12: Troubleshooting Entries Organized by Software 

Software Problem See Details On

Storage Management

“Cannot secure access to LUNs” message page 75

Cannot select some options page 74

Cannot start the software page 73

Controllers/LUNs not visible page 74

Failure detected after replacing fan or power 
supply page 76

Network station cannot talk to the Module page 79

“Not all files removed” message when uninstalling 
the software page 73

RAID Controller listed after being removed page 74

Command Line 
Batch file commands fail page 73

Battery age does not reset for both controllers page 75

Table 13: Configuration Changes Troubleshooting 

Number of Drives field (in the main Create LUN screen) show less than the number of drives in the 
unassigned drive group.

CAUSE There are two main reasons this number could be different than expected:

• This list shows only the maximum number allowed, which is a maximum of 30 drives in a drive group.

• There could be failed or unresponsive drives in the unassigned drive group. Failed drives are not 
available for configuration; therefore, they are not displayed in this list.
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Less capacity shows than I selected during configuration.

When using 5+ drives to create a LUN, you could see a capacity slightly less than you selected during 
configuration; for example, you see 1.97 GB instead of 2 GB on a RAID 5, 9-drive LUN. This can occur 
because the capacity you select is based on stripe size which depends on segment size times the number 
of drives.

List/Locate Drives → Locate does not work.

CAUSE It is not possible to flash the drive activity lights for a particular drive group if any of the drives 
has a status other than Optimal. For an explanation of possible drive statuses and recommended action to 
take, see the Online help.

ACTION Use Module Profile to verify that all drives are Optimal and try again. If any of the drives are 
not Optimal, select Recovery Guru/Health Check (in the Recovery Application) to correct the problem.

Reset Configuration does not work.

CAUSE If this software detects any drives as removed or unresponsive, Reset Configuration will not 
work. Also, if the selected RAID Controller has an Independent Controller configuration, this option is 
grayed out.

ACTION Use Module Profile to verify that all drives are Optimal and that the controller is not in an 
Independent Controller configuration (neither controller is marked Inaccessible). Try File → Reset 
Configuration again.

CAUTION Any time you use Reset Configuration, you will lose all data on your drives. Only select this 
option as a last resort if your configuration is inaccessible or you want to start over. You will need to use 
Create LUN to re-configure your drive groups/LUNs.

LUN Creation error message is displayed after deleting all LUNs or using File → Reset 
Configuration.

CAUSE Most likely, the controller has 256 MB cache and requires a reset after deleting all LUNs/drive 
groups before re-creating new LUNs/drive groups.

ACTION Turn off power to the affected RAID Controller. Turn power back on and try the LUN creation 
procedure again.

Table 13: Configuration Changes Troubleshooting  (continued)



72 Netfinity Networked SYMplicity Storage Manager Installation and User’s Handbook

Firmware Upgrade

Problems you may have in upgrading firmware. 

Table 14: Controller Firmware Upgrade Troubleshooting 

Firmware upgrade does not complete successfully

CAUSE This should not happen unless you try to perform some other activity on the module while 
upgrading controller firmware. If you are upgrading firmware to a redundant controller pair, the progress 
bar reaches 50% very quickly after downloading a file to the first controller. However, it may take 
another couple of minutes to reach 100% if it is downloading to a second controller in the module. Do not 
assume the controller has hung unless the firmware upgrade has not completed after ten minutes or so.

ACTION

• To avoid this problem, wait for the controller firmware upgrade to be completed before selecting any 
other option or exiting Maintenance/Tuning.

• If it occurs, turn off power to the RAID Controller and turn it back on; then, immediately try to upgrade 
the firmware again.

IMPORTANT If you are not upgrading the firmware again immediately, check the firmware version of 
the module controllers using Module Profile. The controller firmware could be in an unusable state if 
some files completed the download process before the controller hung. In this case, your module will not 
perform properly until the firmware is upgraded.
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General 

General problems you could have in all applications. 

Table 15: Troubleshooting Generally Applicable to All Applications 

jCannot start the software.

CAUSE If the software does not load when you try to start it, the rmparams file may be corrupted or 
missing from the installation directory (\program files\netsymsm).

ACTION

You may want to view the Windows NT Event Log (“Applications” log). This log might contain specific 
information about missing files and/or executables.

1 Start Windows NT and try to start the software again. (See "Starting the Software" on page 53 if you 
need more information on starting this software.) 

2 If you had previously saved a backup rmparams file, copy it to the installation directory (default is 
\program files\netsymsm – be sure to select the appropriate directory on your system) and try to start 
the software again. 

IMPORTANT The rmparams file is required for normal operation of this software applications. 
Therefore, it is strongly advised that if you make any changes to this file, you should make a backup by 
copying the edited file to another directory.

3 If you still cannot start the software, run the clean.bat -all script to delete certain files that could be 
hiding information from this software.

4 If you still cannot start the software, reinstall the software. 

Controller failed while bringing its alternate Online.

CAUSE You have a RAID Controller with two controllers, one is Offline and the other is Online 
(Optimal). When you bring the offline controller online, you could see the alternate controller Fail or go 
Offline. 

ACTION Bring the newly failed controller Online using the same procedure.

While uninstalling this software, “not all files were removed” message is displayed.

CAUSE If you see this message after performing the uninstall procedure (page 63), the auto parity check/
repair service was probably running. The software has been successfully uninstalled; however, there may 
be some files that were not removed from the installation directory.

ACTION Delete any remaining files from the installation directory, then delete the directory.

Commands run in a batch file fail unexpectedly. 

CAUSE Utility commands such as fwutil or rdacutil -u that require a controller reboot may return before 
the controller is ready to accept commands. If the next command is executed before the controller is 
ready to accept commands, the controller will return an error status.

ACTION Include a delay command in the batch file to allow enough time for the controller to finish its 
action.
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Some controllers/logical units are not visible to storage management software, but are visible to the 
host

CAUSE  It is possible that controllers or logical units might not be visible to the storage management 
software, but will remain visible to Windows NT. Any time an operation is being performed that requires 
exclusive access to the logical units (LUNs), these LUNs may not appear on the screen except in the 
application where the operation was initiated. The software uses a file (\program 
files\netsymsm\lunlocks) to hide these LUNs from the other applications, so that no other operations can 
be performed on them until the current operation is complete. 

IMPORTANT For example, if you started a format in the Recovery Application, these LUNs show a 
“Formatting” status in Recovery, but may not appear in any other application. Operations that require 
exclusive access include Delete for LUNs and Reset Configuration (Configuration); formatting a LUN 
with Options → Manual Recovery → Logical Units (Recovery); and Firmware Upgrade → Offline 
method (Maintenance/Tuning).

Should the utility/application holding the LUN lock come to an abnormal termination, these LUNs may 
remain hidden from the other applications. 

ACTION

1 Wait for the operation to be completed, or perform operations on a different RAID Controller. 
2 If you still do not see controllers or LUNs that you know exist, do the following:

a Close all your applications and exit the storage management software completely.

b Run the clean.bat script to delete certain files that could be hiding information from this software.
3 Restart the application where you had the problem and verify that the controller/LUNs are now visible. 

A RAID Controller is listed that I have removed from my system.

CAUSE The storage management software does not automatically remove modules from configuration; 
thus, a module you remove will continue to be listed in the RAID Controller Selection box and the 
Module Selection screen.

ACTION Use Select Module → Remove before physically removing the Module. See the online help 
for the specific procedure to follow.

I Cannot select some options.

CAUSE Some options are grayed out or are unavailable because:

• The selected RAID Controller does not support that option.

• The option cannot be performed for the item you selected.

• The option is not active until you select some item.
• The option is no longer applicable because a maximum has been reached.

ACTION Recheck your selection and try again.

For more specific information, see the Procedures section in the User Guide that describes the particular 
option, or consult Online Help, “Why Are Some Options Grayed Out?”

Table 15: Troubleshooting Generally Applicable to All Applications  (continued)
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Battery age did not reset for both controllers.

CAUSE When using raidutil to reset the battery age, this command affects only one controller at a time.

ACTION Perform the battery reset command (with raidutil) for each controller in a RAID Controller as 
needed.

“Cannot secure access to the LUNs” message is displayed (operations won’t run for a selected 
RAID Controller).

CAUSE Most likely a second application has requested exclusive access to the selected RAID Controller 
when some other application has already secured access. Many operations require exclusive access to the 
affected drive group/LUNs until its operation is completed (this software “locks” these components to 
secure this access). 

ACTION Wait for any operation that has secured exclusive access to the LUNs to be completed before 
performing another operation on the same RAID Controller.

Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration 
(Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and 
Firmware Upgrade → Offline method (Maintenance/Tuning). 

CAUTION If you are using more than one network management station, you must use caution when 
performing the tasks that need exclusive access to ensure that the two hosts do not send conflicting 
commands to the controllers in the RAID Controllers.

Component/module status other than Optimal.

CAUSE Statuses other than Optimal can indicate many things and usually warrant attention because the 
module is not operating in a normal condition.

The most common causes are:

• At least one drive has failed.

• A drive has been replaced and is reconstructing.

• A logical unit is formatting.

• A controller has been placed offline or has failed.

• A module component had failed, such as a power supply or fan.

ACTION For Failed or Offline drives, Dead or Degraded logical units, or Dead controllers (or Offline 
controllers that you did not place offline), select Recovery Guru/Health Check and follow the step-by-
step procedure it provides. For an explanation of the possible drive, LUN, or controller statuses and any 
recommended action to take, see the online help.

IMPORTANT Do not rely only on logical unit (LUN) status information to determine if a recovery 
procedure is necessary. For example, if you have hot spares configured for a RAID Controller and a drive 
fails, the hot spare takes over for the failed drive. Therefore, you have an Optimal LUN with a failed 
drive. Depending on how many hot spares you have configured for the module, you can have multiple 
failed drives and still have an Optimal LUN or only a Degraded LUN.

Table 15: Troubleshooting Generally Applicable to All Applications  (continued)
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Recovery Guru/Health Check

Problems you may have in running Recovery Guru/Health Check or the Manual Recovery 
Options in the Recovery Application. 

Table 16: Recovery Guru/Health Check Troubleshooting 

Recovery Guru/Health Check results take a long time to display.

CAUSE Normally you see Recovery Guru/Health Check results in a few seconds. However, if you have 
selected All RAID Controllers or there are I/O operations running, you might notice a delay. Also, there 
could be instances where an unresponsive component or other status change affects the controller’s ability 
to provide a result in Recovery Guru/Health Check, although such occurrences are rare.

ACTION If you experience long delays in performing Recovery Guru/Health Check, you might try 
checking one RAID Controller at a time or selecting Recovery Guru/Health Check at a time of low 
system I/O.

NOTE A background check occurs at regular intervals for all RAID Controllers (results are logged to 
Message Log); the default setting is five minutes. You can change the frequency of this check by using 
Options → Log Settings.

Recovery Guru/Health Check does not report a drive failure when I remove a drive.

 If there is no I/O occurring for that drive, Recovery Guru/Health Check reports an Unresponsive Drive. 
If there is I/O occurring, the controller will fail the drive (and Recovery Guru/Health Check reports 
this, too).

CAUTION You should never remove drives from a module unless the controller has marked them as 
failed. Doing so could result in data loss for the affected logical unit/drive group. If you suspect problems 
with a drive, it is best to select Recovery Guru/Health Check and follow the instructions provided. 

Software detects a failure even after I replaced a fan or power supply (recover from a Module 
Component Failure).

CAUSE The software continues to report the condition as a failure for approximately ten minutes after 
replacing a fan or power supply due to the controller polling interval. 

ACTION Wait for the controller to poll the module (default is ten minutes) after performing this 
recovery procedure before reselecting Recovery Guru.

Drive status other than Optimal.

CAUSE You have a Failed, Offline, or Replaced drive (which is reconstructing), or a logical unit is being 
formatted. For an explanation of possible drive statuses and any recommended action to take, see the 
online help.

ACTION For Failed or Offline drives, select Recovery Guru/Health Check and follow the step-by-step 
procedures provided. No action is required if the drives are Replaced or the LUN is Reconstructing or 
Formatting. However, if the drives remain Replaced and the LUN status was Dead, Recovery Guru/
Health Check may report the RAID Controller as Optimal. If this occurs, you need to manually begin the 
format process for the LUN/drive group (Options → Manual Recovery → LUNs → Format).
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Drives continue to fail (fault lights lit). 

CAUTION It is possible that a drive channel has failed. A drive channel failure is indicated when all the 
drives on the same channel are Failed and/or Unresponsive. Depending how the logical units have been 
configured across these drives, the status of the logical units may be Dead, Degraded, or Optimal (if hot 
spare drives are in use).

ACTION Select Recovery Guru/Health Check and follow the step-by-step procedure given. 

Drive fault light came on after I replaced a failed drive.

CAUSE This light may come on momentarily when a drive in a RAID 1, 3, or 5 LUN begins 
reconstruction.

ACTION Wait a few minutes for the fault light to go off and the drive activity lights to begin flashing 
steadily. This indicates that reconstruction is occurring. The drive status changes to Replaced and the 
logical unit status changes to Reconstructing.

However, if the fault remains on, select Recovery Guru/Health Check and follow the procedure provided. 

Failed Drive status appears, but logical unit status is still Optimal.

CAUSE A drive on the logical unit has failed and a hot spare has taken over for it.

NOTE To see if a hot spare is being used, use List/Locate Drives in the Configuration Application. The 
hot spare drive status is either In Use or Standby (not being used).

ACTION Select Recovery Guru/Health Check and follow the procedure provided.

Logical unit status other than Optimal.

CAUSE You have a Failed drive or a Replaced drive which is reconstructing, a logical unit is being 
formatted. For an explanation of possible logical unit statuses and any recommended action to take, see 
the online Help. 

ACTION For Dead or Degraded logical units, select Recovery Guru/Health Check and follow the step-
by-step procedures it provides for restoring the logical units. However, if the drives remain Replaced and 
the LUN status was Dead, Recovery Guru may report the RAID Controller as Optimal. If this occurs, you 
need to manually begin the format process for the LUN/drive group (Options → Manual Recovery → 
LUNs → Format).

LUN status changed to Reconstructing, but no drives have been replaced.

CAUSE A hot spare has taken over for a failed drive and the data is being reconstructed on it. The logical 
unit status returns to Optimal as soon as reconstruction is completed.

Table 16: Recovery Guru/Health Check Troubleshooting  (continued)
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LUN status does not change from Reconstructing.

CAUTION This could occur after a Manual Recovery task is completed, especially LUN 
Reconstruction, or because data was reconstructed on a hot spare (the hot spare drive becomes In Use, the 
LUN status changes to Reconstructing, but may not return to Optimal when reconstruction is completed). 

IMPORTANT If reconstruction was interrupted on a hot spare drive because another drive failed in the 
same drive group/LUN, the LUN is probably Dead (with two Failed drives) and you have lost data. You 
should select Recovery Guru/Health Check and follow the procedure provided to replace the newly
failed drive.

ACTION Wait for the background monitor to run (default is five minutes) and to update the status, or

To update immediately, do one of the following:

• Reselect the RAID Controller. 

• Exit and re-enter the application.

All Drives in a Drive Group fail.

CAUSE If all the drives in a configured drive group fail and are then physically replaced, Recovery 
Guru/Health check will still show the replaced drives as failed. Their status is not upgraded to Replaced, 
although the LUN status will show Dead LUN.

ACTION In this case, follow the Recovery Guru/Health Check procedure to reformat the LUNs in the 
drive group. 

IMPORTANT If you turn the power to the RAID Controller off and then on again, the LUNs in the drive 
group are deleted, and the replaced drives are returned to the unassigned drive group, still failed. Follow 
the procedure given in Recovery Guru/Health Check to recreate the deleted LUNs.

Controller mode is Passive and it does not own any LUNs after replacing a Failed controller.

CAUSE After using Recovery Guru/Health Check to replace the failed controller and Options → 
Manual Recovery → Controller Pairs to place it back Online, the controller is Optimal but in the Passive 
mode rather than Active. This is most likely to occur for controller B. 

ACTION With the newly replaced controller Optimal, use Controller Mode → Change To Active/
Active (Maintenance/Tuning Application) to make the controller Active. You can either redistribute 
drive groups/LUNs during this mode change, or later you can use LUN Balancing (Maintenance/Tuning 
Application) to assign specific drive group/LUNs to each active controller. 

Information is missing in the Options → Manual Recovery → Drives screen. 

CAUSE The drives for the selected RAID Controller are unassigned (that is, they are not part of a 
configured drive group). For these drives, there is no LUN, RAID Level, or logical unit status to report. 
However, you should still see information for the drives’ location and status.

ACTION Select another module, or use the Configuration Application to create logical units using those 
unassigned drives.

Table 16: Recovery Guru/Health Check Troubleshooting  (continued)
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Networked Troubleshooting Only

Problems related to working in the networked environment

No LUN information appears in the Options → Manual Recovery → Logical Units screen. 

CAUSE There are no configured logical units for the selected RAID Controller (that is, all the drives are 
unassigned). There is no LUN, drive group, RAID Level, or logical unit status to report.

ACTION Select another module, or use the Configuration Application to create logical units using those 
unassigned drives.

Component status isn’t updated after a recovery procedure has been performed.

CAUSE A configuration change may not be detected yet. For example, a drive is failed, then replaced 
and its status becomes Replaced, but does not return to Optimal after reconstruction is completed.

ACTION Try selecting a different RAID Controller, then switching back and reselecting Options → 
Manual Recovery, or exit, then reselect the Recovery Application.

Table 17: Troubleshooting Applicable to Working in the Networked Environment

The storage management software from a particular Remote Management Station (RMS) cannot 
make the connection to a RAID Controller.

CAUSE Remember that you can have a maximum of four RMS and SNMP stations. Each controller 
allows only four connections at once, and these connections last 24 hours since the last time the 
connection was used. Therefore, if a controller has already been contacted by four remote management 
stations, a fifth station requesting access within 24 hours would be rejected.

ACTION Turn off and turn on the RAID Controller. Remember, it is best to only configure a total of 
four RMS and NMS stations for any RAID Controller. 

Table 16: Recovery Guru/Health Check Troubleshooting  (continued)
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Takes a long time to start the software, and/or screens do not display any information for the 
selected RAID Controller.

CAUSE In the network environment, response time may be slower, so be patient. However, if it takes 
several minutes to load the program group or launch an application, then it is likely that some controller is 
Offline, Failed, or not configured properly in the network setup.

• If you do not see any information provided on screen, a controller in the selected module is not set up 
properly for the network.

• If you see information provided, some other module controller is not set up properly.

IMPORTANT If you ever physically remove a RAID Controller (and its controllers) from the network, 
make sure you also use Select Module → Remove to remove the module information from the software 
configuration.

ACTION Verify that both controllers are present (controller names appear in Module Profile):

• If they are not present, verify the network path, and ensure the BOOTP table and host (or DNS) tables 
are set up correctly for the network. See page 19 for detailed procedures.

• If they are present, run Recovery Guru/Health Check (Recovery Application) on All RAID Controllers 
to determine the status of the modules’ components.

A connect error message displays when trying to add a RAID Controller, such as, “Could not 
connect to the selected RAID Controller. Verify your host names and/or check your network 
connection.”

CAUSE  The remote management station is unable to connect to the specified controller.

ACTION Use symping (the network connection verification utility) to attempt to contact the RAID 
Controller or controller. The symping utility will display possible reasons for, or actions to take to resolve 
these problems.

1 From the command line, type:

symping beatr_1

WHERE

beatr_1 is the name of the controller you designated when you added the RAID Controller to the 
Select Module list.

2 If symping does not help resolve connecting the module, check the physical network connections and 
correct any associated problems.

Table 17: Troubleshooting Applicable to Working in the Networked Environment 
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The system takes a long time to complete some operations, or you receive error messages that the 
operation failed.

CAUSE In the network environment, response time may be slower, so be patient. However, if you notice 
many error messages (indicating that operations are not completing successfully), you should verify that 
a controller is not Offline or Failed, and that it is configured properly for the network (set up in the 
BOOTP table and host tables).

IMPORTANT If you ever physically remove a RAID Controller (and its controllers) from the network, 
make sure you also use Select Module → Remove to remove the module information from the software 
configuration.

ACTION

1 Allow sufficient time for operations to complete. Remember that the network response time may be 
slower, especially if you have 24 or more LUNs configured on the RAID Controller.

2 If you receive operation-failed error messages, use Message Log to verify there are no component 
problems on your modules.

3 Verify the controller is present (controller name appears in Module Profile). If it is not present, verify 
the network path, and ensure the BOOTP table and host (or DNS) tables are set up correctly for the 
network. See page 19 for detailed procedures.

4 If no other problems are indicated, try increasing the System_NetworkTimeout parameter in the 
rmparams file (this parameter determines the amount of time allowed for operations to complete 
successfully before the operation is failed):

• Edit the rmparams file to increase the amount of time allowed for operations to complete.

• Save the rmparams file and copy it to a backup directory.

NOTE If you change the System_NetworkTimeout parameter, you may want to change the network 
timeout tag (tag=163) set for the controller in the BOOTP table as well (see Table 5 on page 20).

“Another application has failed to release locked resources” message.

CAUSE If a storage management application has an abnormal termination while performing an 
operation, it is possible that the operation did not complete and resources remain locked. This means that 
drive groups/LUNs or even controllers might not be visible or might have unknown states.

ACTION If you see this message, exit all applications and restart Windows.

Table 17: Troubleshooting Applicable to Working in the Networked Environment 
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Replacing Controllers (Networked)

General Guidelines

Use Recovery Guru/Health Check (Recovery Application) to diagnose and correct 
problems with your RAID Controller components. 

If you are replacing a failed controller, you need to determine the unique hardware 
ethernet address of the new controller and replace only this entry for the BOOTP Server. 
You should keep the same controller name and IP Address to ensure that the host (or DNS) 
table remains correct.

Incompatible Firmware Detected 

You have replaced a controller and saw a message after the new controller was brought 
Online telling you that incompatible firmware has been detected and to consult this 
section. 

Controller names disappear from the Active Leases window when the Reservation becomes 
Reservation in use. 

CAUSE Normally, when an administrator has set up a reservation for a BOOTP controller on a DHCP 
server, the Active Leases list includes the IP address, controller name, and Reservation. When a BOOTP 
controller gets an IP address, the Reservation changes to Reservation in Use, and the controller name is 
removed from the list. As a result, there is no identifier in the list to differentiate which IP address 
belongs to which controller.

ACTION Call Microsoft Technical Support to obtain the fix for this problem (Article ID: Q167708). Or 
you can refer to Table 4 on page 16 where you recorded the controller name and IP address.

An operation failed.

CAUSE If you have more than one network management station trying to gain exclusive access at the 
same time to the same drive group/LUN, one operation will fail.

ACTION Wait for any operation that has secured exclusive access to the LUNs to be completed before 
performing another operation on the same RAID Controller.

To prevent the problem, before beginning an operation that requires exclusive access, make sure that you 
stop all I/Os going to the RAID Controller and that no other users are on the system.

Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration 
(Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and 
Firmware Upgrade → Offline method (Maintenance/Tuning).

Table 17: Troubleshooting Applicable to Working in the Networked Environment 
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Problem Summary

The correct procedure for upgrading the controller firmware depends on the controller 
firmware versions of both controllers and the controller slot location of the replaced 
controller. Use the following steps to determine the correct procedure.

1. Using the Recovery Application, select Module Profile → Controllers and do the 
following:

• Record the controller name/ID for both controllers. Be sure to note which is 
currently controller A and which is controller B. You will need this information to 
identify the controllers during this procedure.

• Record the firmware version of both controllers. Be sure to note which version 
applies to the old controller and which to the new, replaced controller. You will 
need this information to determine the correct procedure to follow for upgrading the 
controller firmware.

• Record the ethernet and IP addresses for both controllers. You can use Select 
Module if you have this information in the Comments field, or you can use the table 
where you recorded this information during this software installation. You may also 
want to record all other comments added for this module because this procedure 
requires you to remove and add the module. 

2. Which controller slot location is the new, replaced controller placed in? 

In Slot A In Slot B

You may want to call your 
Customer Services Representative 
for additional support on this 
procedure.

Select only the replaced controller to 
upgrade the 3.X firmware using the 
normal procedure (Maintenance/
Tuning → Firmware Upgrade → 
Offline method).

Consult the User Handbook or online 
help for further details.
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Uninstalling the Software

Use the following procedure only if you want to remove the storage management software 
from your system.

IMPORTANT Close all other applications and make sure that other users are not on the 
system when uninstalling this software.

1. To begin the uninstall program:

a. Select Start Settings Control Panel Add/Remove Programs and scroll the list to find 
Networked SYMplicity Storage Manager.

b. With Networked SYMplicity Storage Manager highlighted, select Add/Remove.

c. At the Uninstall Application screen, select OK to remove the software.

You will see screens indicating the uninstall program is removing the appropriate 
service, registry information, and files.

2. At the Uninstall Complete screen, select Yes to shutdown and restart the Windows 
system.
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Appendix A. Specifications

This appendix contains the following information: 

Hardware Specifications

This software has been tested with the following:

BOOTP Servers

• Microsoft DHCP BOOTP for Windows NT Server 4.0 with Service Pack 3 or later. See 
"Using a DHCP Server" on page 24.

• A UNIX BOOTP Server (most of the examples and terminology in this book relating 
to a BOOTP server assume the UNIX Example).

Firmware Specifications

The storage management software requires a minimum controller firmware version 
depending on your controller model.

Hardware Specifications page 85

Firmware Specifications page 85

Table 18: Controller Firmware Requirements

Controller Type Required Firmware Level

4766 3.0 or later
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Appendix B. Notices

Notices

References in this publication to IBM products, programs, or services do not imply that 
IBM intends to make these available in all countries in which IBM operates. Any 
reference to an IBM product, program, or service is not intended to state or imply that only 
that IBM product, program, or service may be used. Subject to IBM’s valid intellectual 
property or other legally protectable rights, any functionally equivalent product, program, 
or service may be used instead of the IBM product, program, or service. The evaluation 
and verification of operation in conjunction with other products, except those expressly 
designated by IBM, are the responsibility of the user.

IBM may have patents or pending patent applications covering subject matter in this 
document. The furnishing of this document does not give you any license to these patents. 
You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
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A
automatic parity check/repair, described  59

B
background monitor

starting 42
stopping 41

batch file
delay command  73
fails unexpectedly  73

battery age reset
restriction 2
troubleshooting  75

blank screen
manual recovery

drives  78
logical units  79

BOOTP server
configuring 15
defined 42

BOOTP table
pre-installation task 15
sample entry 23

C
cannot secure access to LUNs message  75
capacity

less than expected  71
changes to support this software 13
changing

caching parameters 3
configuration parameters  59
rmparams file 50

channel failure  77
checking

hardware and software 5

clean.bat script
when to use  73,  74

command line interface 44
fwutil  73
raidutil 2, 5,  75
rdacutil  73
symping  80

component failures
unexpected  76

component status
unexpected  79

components required 5
configuration

changing parameters  59
resetting  71

Configuration Application
list/locate drives

locate won’t work  71
main screen illustrated  56
reset won’t work  71
restrictions 3, 4
troubleshooting  70

connect error message  80
controller name

editing 10
pre-installation task 15

controllers
firmware mismatch  82
incompatible software  82
IP address 15
LUN limits 39
mode

passive after replacing  78
not active after replacing  78
not visible  74
replacing notes  82
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resetting battery age  75
troubleshooting  73

D
deleting logical units

restrictions 4
directory, installation naming restriction 9, 33
disk array monitor

starting 42
stopping 41
see also background monitor

DNS (Domain Name Service)
see host table

drives
failed  70
failures

all in drive group  78
keep failing  77

fault light on  77
number for drive group

unexpected  70
removing  76
status

non-optimal  76
unresponsive  70,  71,  76

E
editing module and controller names 10
exclusive access  74,  75,  82

multi-host configuration and  75

F
failed drives  70

all in drive group  78
failed to create LUN 4
failed to release locked resources message  81
fans, replacing  76
fault light, drives  77
files

batch, failed  73
clean.bat  73,  74
lunlocks  74
see rmscript.bat

firmware
mismatch detected  82
online method restricted 3

upgrading
unsuccessful  72

fwutil command
restriction  73
see also command line interface

H
hardware ethernet address

defined 43
pre-installation task 15

hardware requirements 5
Health Check

how long it takes  76
main screen illustrated  55
see also Recovery Guru

host name
labeling RAID Modules and  57

host table
pre-installation tasks 15

hot spare
described  60
in use  77
logical unit status and  77
troubleshooting  78

I
identifying module configuration 16
incompatible software detected  82
installation

before beginning 5
directory naming restriction 9, 33

IP address
defined 43
for SNMP 51
pre-installation tasks 15

L
locating solutions for problems  65
logical unit

balancing 3
cannot secure access message  75
capacity

less than expected  71
changing parameters  59
fails to create 4
limit per module/controller 39
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manual format restriction 5
not visible to software  74
parameters  70
status

non-optimal  75,  77
remains at reconstructing  78
shows reconstructing  77

lunlocks file  74

M
MAC address

see hardware ethernet address
Maintenance/Tuning Application

restrictions 3, 4
manual recovery

drives
blank screen  78

logical units
blank screen  79

manually format LUNs 5
messages

cannot secure access to LUNs  75
connect error  80
failed to release locked resources  81
not all files removed  73
see also trap messages

MIB file 48
mismatch firmware detected  82
module names

defined 43
Module Profile

main screen illustrated  58
module status

non-optimal  75
unexpected  79

N
network

slow  81
Network Monitor 2
NMS

defined 43
not all files removed message during unin-

stall  73
notification

see rmscript.bat

number of drives
limitation  70

NVSRAM
changing setting for RDAC 46

O
online firmware upgrade, restricted 3

P
parameters

changing configuration  59
changing in rmparams file 51
logical unit  59

parity check/repair, default auto setting  59
power supplies

replacing  76
preparing to install 5
problems, finding help  65

R
RAID Module

labeling  57
LUN limit per 39
removing configuration  74

raidutil
restriction 2

RDAC driver
installing 46

rdacutil command
restriction  73
see also command line interface

reboot, required when 47
reconstruction

drive fault light  77
Recovery Application

restrictions 3, 4, 5
Recovery Guru  77,  78

removing modules  74
takes a long time  76
troubleshooting  76

replacing controllers  82
firmware mismatch or incompatible soft-

ware  82
reset configuration  71

doesn’t work  71
response time, slow  81
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restrictions
batch file failed  73
can’t see controllers  74
cannot secure access to LUNs  75
LUN formatting 5
LUNs not visible  74
Save Module Profile  57
using Manual Recovery 5
with RDAC driver 46

rmparams
backup copy 50
changeable parameters 51

rmparams file
backup copy  73
missing  73

RMS
defined 43

rmscript.bat
scriptable notification 47

S
Save Module Profile restriction  57
screen displays no information  80
screen illustrations

Configuration Application  56
Health Check  55
Module Profile  58
Status Application  54

scriptable notification
see rmscript.bat

Select Module
remove module restriction  80,  81

slow response time  81
SNMP

defined 43
disabling 50
IP address 51
set up NMS and MIB 48
traps

defined 44
message contents 49

software
can’t view LUNs  74
doesn’t start  73
exclusive access required  74,  75,  82
incompatible versions detected  82
options grayed out  74

requirements 5
starting  53
support changes 13
takes a long time to start  80

solutions, locating  65
special characters, restriction 9, 33
starting

the software  53
status

non-optimal  76
unexpected  79

Status Application
main screen illustrated  54
troubleshooting

see also Health Check
see also Message Log

symping
see command line interface

System_NetworkTimeout parameter  81

T
task summary

changeable parameters in rmparams file
51

configuring controllers on network 15
determining the current configuration  59
recording module and controller infor-

mation 16
tasks for configuring controllers 15

trap messages
contents 49
defined 44
see also SNMP

troubleshooting
Configuration Application  70
failed drives  77
general for all applications  73
list/locate won’t work  71
locating solutions  65
replacing controllers  82

firmware mismatch  82
incompatible software  82

resetting battery age  75
second controller fails  73
uninstalling  73
Windows NT  65
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U
unassigned drives

failed  70
uninstalling

not all files removed message  73
unresponsive drives  70,  71,  76
User Guide, when to use  63
utilities

see command line interface

W
Windows NT

event log  73
LUN limits 39
troubleshooting  65
versions supported 5
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