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About this book

This book provides information about planning, installing, configuring, and working
with IBM® Fibre Array Storage Technology (FAStT) Storage Manager Version 8.21
in a Microsoft® Windows NT® 4.0 or Windows® 2000 operating system environment.
This Installation and Support Guide is for system administrators. Use this guide to:

v Determine the hardware and software that are required to install the
storage-management software.

v Integrate the necessary hardware components into your network.

v Install the FAStT Storage Manager software.

v Upgrade controller firmware, if necessary.

v Identify storage-management features that are unique to your installation.

How this book is organized
Chapter 1, “Introduction” on page 1 provides an overview of IBM FAStT Storage
Manager Version 8.21 and describes storage-subsystem management methods,
configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation” on page 21 discusses preparing for a network
installation, including setting up a Dynamic Host Configuration Protocol/Boot
Protocol (DHCP/BOOTP) server on Windows NT 4.0, Windows 2000, Novell
NetWare, and UNIX® platforms.

Chapter 3, “Installing software in a standard configuration” on page 41 provides
instructions for installing the software components in a standard (noncluster)
environment.

Chapter 4, “Installing software in a cluster server environment” on page 49 provides
instructions for installing the software in a cluster server environment.

Chapter 5, “Completing the installation” on page 67 discusses starting the Enterprise
Management window, performing an automatic discovery of storage
subsystems, adding devices, setting up alert notifications, downloading firmware
and NVSRAM, creating arrays and logical drives, and other storage subsystem
management tasks.

Chapter 6, “Using the storage-management software” on page 75 provides
information about adding and deleting logical drives, using the Hot Add and
SMdevices utilities, starting and stopping the host-agent software, and uninstalling
Storage Manager components.

Chapter 7, “Operating-system support” on page 83 discusses Windows NT and
Windows 2000 operating system limitations and other operating-system issues.

Appendix A, “Storage subsystem and controller information” on page 89 provides a
data sheet template that you can use to create a controller information record.

Appendix B, “Getting information, help, and service” on page 91 provides
information about how to obtain help, service, or technical assistance.

Appendix C, “Notices” on page 93 provides product notices and trademark
information.
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Notices used in this book
This book contains the following notices designed to highlight key information:

v Notes: These notices provide important tips, guidance, or advice.

v Important: These notices provide information that might help you avoid
inconvenient or problem situations.

v Attention: These notices indicate possible damage to programs, devices, or
data. An attention notice is placed just before the instruction or situation in which
damage could occur.

Related publications
The following publications are available in Adobe Acrobat Portable Document
Format (PDF) on the IBM FAStT Storage Manager CD or go to
http://www.ibm.com/pc/support/.

v IBM FAStT Storage Manager Version 8.21 Installation and Support Guide for
Microsoft Windows NT and Windows 2000 (this book)

v IBM FAStT Storage Manager Version 8.21 Installation and Support Guide for
Novell NetWare

v IBM FAStT Storage Manager Version 8.21 Installation and Support Guide for
Linux®

v IBM TotalStorage™ FAStT700 Fibre Channel Storage Server Installation Guide

v IBM TotalStorage FAStT700 Fibre Channel Storage Server User’s Guide

v IBM FAStT700 Fibre Channel Cabling Instructions

v IBM FAStT Host Adapter Installation and User’s Guide

v IBM FAStT FC-2 Host Bus Adapter Installation and User’s Guide

v IBM TotalStorage FAStT FC2-133 Host Bus Adapter Installation and User’s Guide

v IBM FAStT Remote Mirror Option Installation and User’s Guide

v IBM FAStT500 RAID Controller Enclosure Unit Installation Guide

v IBM FAStT500 RAID Controller Enclosure Unit User’s Guide

v IBM TotalStorage FAStT EXP700 Storage Expansion Unit Installation and User’s
Guide

v IBM Netfinity® Fibre Channel Cabling Instructions

v IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide

v IBM FAStT200 Fibre Channel Cabling Instructions

The following diagnostic publications might be of interest:

v IBM FAStT MSJ User’s Guide

v IBM Fibre Channel Hardware Maintenance Manual

v IBM Fibre Channel Problem Determination Guide

v IBM Fibre Channel Basic SAN Configuration Setup Guide
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In addition, the following IBM Redbooks™ might be of interest:

v Fibre Array Storage Technology: A FAStT Introduction

v Implementing Netfinity Disk Subsystems: ServeRAID SCSI, Fibre Channel, and
SSA

v Tuning Netfinity Servers for Performance: Getting the most out of Windows 2000
and Windows NT 4.0

v Netfinity Director: Integration and Tools

v Netfinity Clustering Planning Guide

You can download these books from the http://www.ibm.com/redbooks Web site.
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Chapter 1. Introduction

This installation and support guide provides information on preparing, installing,
configuring, and starting IBM FAStT Storage Manager Version 8.21 in a Windows
NT 4.0 or Windows 2000 environment. Before you begin the installation of this
product, consult the following documentation:

v README.TXT file - Read this first. The README file is located in the root
directory of the installation CD. Refer to the IBM Web site. Go to
http://www.ibm.com/pc/support for the latest installation and user information.

v IBM FAStT Storage Manager Version 7.10 Concepts Guide - Use this document
to become familiar with terminology and features of the IBM FAStT Storage
Manager software. This book can be downloaded from the
http://www.ibm.com/pc/support Web site.

When you finish the installation process, refer to the following online help systems:

v Enterprise Management window help - Use this online help system to learn more
about working with the entire management domain.

v Subsystem Management window help - Use this online help system to learn
more about managing individual storage subsystems.

You can access these help systems from within Storage Manager 8.21 Client. From
either an Enterprise Management or Subsystem Management window, click Help or
press F1.

After installing IBM FAStT Storage Manager Version 8.21, consider installing the
FAStT Management Suite Java (FAStT MSJ) diagnostic program. You can use this
program to verify the status of the Fibre Channel connections before using the
storage subsystem. The program and the IBM FAStT MSJ User’s Guide are located
on the IBM FAStT Storage Manager Version 8.21 CD.

New features
This section describes the new premium features and standard features that are
part of the IBM FAStT Storage Manager Version 8.21 software. Your storage
subsystem firmware must be at version 5.2x.xx if you want to use any of the
features listed in this section. If your controller firmware is at version 04.x or earlier,
you must purchase a firmware upgrade option.

There are two premium features that can be enabled by purchasing a premium
feature key. Descriptions of these premium features are as follows:

v Flashcopy is a premium feature that is part of the IBM FAStT Storage Manager
8.21 software and is enabled by purchasing a premium feature key. This feature
supports the creation and management of FlashCopy logical drives. A FlashCopy
logical drive is a logical point-in-time image of another logical drive, called a base
logical drive, in the storage subsystem. A FlashCopy is the logical equivalent of a
complete physical copy, but you create it much more quickly and it requires less
disk space. Because a FlashCopy is a host addressable logical drive, you can
perform backups using the FlashCopy while the base logical drive remains online
and user-accessible. In addition, you can write to the FlashCopy logical drive to
perform application testing or scenario development and analysis. The maximum
FlashCopy logical drives allowed is one half of the total logical drives supported
by your controller model.

v Remote Mirror Option - The Remote Mirror Option is a premium feature that is
part of the IBM FAStT Storage Manager 8.21 software and is enabled by

© Copyright IBM Corp. 2000, 2002 1



purchasing a premium feature key. The Remote Mirror Option is used for online,
real-time replication of data between storage subsystems over a remote distance.
In the event of a disaster or unrecoverable error on one storage subsystem, the
Remote Mirror Option enables you to promote a second storage subsystem to
take over responsibility for normal input/output (I/O) operations. When the
Remote Mirror option is enabled, the maximum number of logical drives per
storage subsystem is reduced. For more information, refer to “Number of
supported logical drives” on page 19.

In addition to the new premium features, the storage-management software
includes the following new standard features:

v Dynamic logical-drive expansion - this feature enables you to increase the
capacity of an existing logical drive. You can use the free capacity of a logical
drive on an existing array, or add unconfigured capacity (new or unassigned
drives) to that array. You can expand a logical drive dynamically without losing
access to it, or to any other logical drives.

v 2048 logical drive support - this feature enables you to increase the number of
defined logical drives up to 2048 for each storage subsystem. The number of
logical drives will depend on your controller model. For more information refer to
“Number of supported logical drives” on page 19.

v Storage Partitioning - this feature gives you support for up to 64 storage
partitions. Specifically, there is support for up to two host ports in each host and
up to eight ports in each host group (supporting a four-way host group of
dual-adapter hosts).

v Script Engine and Command Line Interface (CLI) Language - this feature
expands previous version support to include: creating and deleting a FlashCopy
logical drive, setting FlashCopy logical drive attributes, supporting dynamic logical
drive expansion for standard or repository logical drives, disabling or recreating a
FlashCopy, creating or deleting logical drive-to-LUN mappings, uploading Read
Link Status data from a storage subsystem to a comma delimited file on a
management station, and downloading a feature key file to a storage subsystem
to enable a premium feature.

v Read Link Status Diagnostic (RLS) - this feature enhances controller diagnostics
enabling you to isolate the source of link problems on a Fibre Channel loop.
During communication between devices, RLS error counts are detected within
the traffic flow of the loop. Error count information is accumulated over a period
of time for every component and device on the loop. The baseline is
automatically set by the controller; however, a new baseline is set manually
through the Read Link Status Diagnostics window.

v Redesigned user interface - this feature supports a more integrated process of
creating logical drives and then mapping them to hosts or host groups and logical
unit numbers to create storage partitions. The previous Storage Partitions window
is now a Mappings View that you can switch to from the Logical/Physical View.

In the Subsystem Management window, the Mappings View displays storage
partition topology such as the default and defined host groups, hosts, host ports
in a tree, and FlashCopy logical drives.

v Controller default IP address - Unless a static IP address is assigned to the
controller by the administrator, controllers A and B will automatically be assigned
the following IP addresses:

– Controller A (192.168.128.101)

– Controller B (192.168.128.102)

The subnet mask for the default IP address is 255.255.255.0.

v Support for the IBM TotalStorage FAStT EXP700 Storage Expansion Unit
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Supported machine types
Table 1 provides a list of machine types and supported storage-management
software.

Table 1. Machine types and supported storage-management software

Product name Machine
type

Model Firmware
version

Supported
storage-management
software version

Netfinity Fibre Channel RAID
Controller Unit

3526 1RU
1RX

4.x 7.0, 7.01, 7.02, 7.10,
8.0, 8.2, 8.21

IBM FAStT200 3542 1RU
1RX

4.x,
5.20.xx.xx

7.02, 7.10, 8.0, 8.2,
8.21

IBM FAStT200 HA 3542 2RU
2RX

4.x,
5.20.xx.xx

7.02, 7.10, 8.0, 8.2,
8.21

Netfinity FAStT500 RAID
Controller Enclosure Unit

3552 1RU
1RX

4.x,
5.00.xx.xx
5.20.xx.xx
5.21.xx.xx

7.0, 7.01, 7.02, 7.10,
8.0, 8.2, 8.21

IBM TotalStorage FAStT700 Fibre
Channel Storage Server

1742 1RU
1RX

5.00.xx.xx
5.20.xx.xx
5.21.xx.xx

8.0, 8.2, 8.21

Note: Storage subsystem firmware must be at version 04.00.02.xx or higher to be
managed with Storage Manager 8.0, 8.2, or 8.21.

Terms to know
If you are upgrading from a previous version of the storage-management software,
some of the terms you are familiar with have changed. It is important that you
familiarize yourself with the new terminology. Table 2 provides a list of some of the
changed terms.

Table 2. New terminology

Term used in previous versions New term

RAID module Storage subsystem

Drive group Array

Volume Logical drive

It is important to understand the distinction between the following two terms when
reading this document:

Management station
A management station is a system that is used to manage the storage
subsystem. It can be attached to the storage subsystem in the following
ways:

v Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

v Through a TCP/IP connection to the host-agent software that is installed
on a host computer, which in turn is directly attached to the storage
subsystem through the Fibre Channel input/output (I/O) path
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Host computer
A host computer is a system that is directly attached to the storage
subsystem through a Fibre Channel I/O path. This system is used to do the
following:

v Serve data (typically in the form of files) from the storage subsystem

v Function as a connection point to the storage subsystem for a
remote-management station

Notes:

1. The terms host and host computer are used interchangeably throughout
this book.

2. A host computer can also function as a management station.

IBM FAStT Storage Manager Version 8.21 software
Storage Manager Version 8.21 contains the following software components for
Windows NT 4.0 and Windows 2000 environments:

v Microsoft Virtual Machine (for Windows NT 4.0 only)

v Storage Manager 8.21 Client (SMclient)

v Redundant Disk Array Controller (RDAC)

v Storage Manager 8.21 Agent (SMagent)

v Storage Manager 8.21 Utility (SMutil)

Microsoft Virtual Machine
For systems running Windows NT 4.0, the Microsoft Virtual Machine is required to
support the following Storage Manager 8.21 components or options:

v Storage Manager 8.21 Agent

v Event Monitor option of the Storage Manager 8.21 Client

Storage Manager 8.21 Client
The Storage Manager 8.21 Client (SMclient) component provides the graphical user
interface (GUI) for managing storage subsystems. The SMclient contains two main
components:

v Enterprise Management. You can use the Enterprise Management component
to add, remove, and monitor storage subsystems within the management
domain.

v Subsystem Management. You can use the Subsystem Management component
to manage the components of an individual storage subsystem.

The Event Monitor is a separate program that is bundled with the SMclient. If
installed, it monitors storage subsystems whenever the Enterprise Management
window is closed. It runs continuously in the background and can send alert
notifications in the event of a critical problem.

Redundant Disk Array Controller
The Redundant Disk Array Controller (RDAC) contains the multi-path device driver
that is necessary to provide controller failover support when a component on the
Fibre Channel I/O path fails. For RDAC in Storage Manager 8 and higher, a
maximum of four end-to-end fibre channel paths from the host to the storage
subsystems supported.
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Storage Manager 8.21 Agent
The Storage Manager Agent (SM Agent) provides a management conduit for the
Storage Manager Client to configure and monitor the subsystem through the Fibre
Channel I/O path. The agent also provides local or remote access to the Storage
Manager 8.21 client depending on whether the client is installed on the host or in a
network management station over the TCP/IP network.

Storage Manager 8.21 Utility
The Storage Manager 8.21 Utility (SMutil) dynamically defines and maps new
logical drives to the operating system. This software package contains the following
components:

v Hot Add utility. The Hot Add utility enables you to register newly created logical
drives with the operating system. For information on using the Hot Add utility, see
“Using the Hot Add utility” on page 78.

v SMdevices utility. The SMdevices utility enables you to associate storage
subsystem logical drives with operating-system device names. For information on
using the SMdevices utility, see “Using the SMdevices utility” on page 78.

v SMflashcopyassist utility. The SMflashcopyassist utility enables you to do the
following:

– Flush cached data before creating a FlashCopy™ logical drive

– Resolve duplicate logical drive signatures between the base logical drives and
the FlashCopy logical drives (Windows NT only)

For more information on using the SMflashcopyassist utility, see “Using the
SMflashcopyassist utility” on page 79.

Note: FlashCopy is a premium feature that must be purchased. Contact your
IBM service representative for more information.

Storage subsystem management methods
The storage-management software provides two methods for managing storage
subsystems: the host-agent management method and the direct management
method. Depending on your specific storage-subsystem configurations, you can use
either or both methods. The management methods you select will determine where
you will need to install the software components.

Host-agent (in-band) management method
When you use the host-agent (in-band) management method, you manage the
storage subsystems through the Fibre Channel I/O path to the host. The
management information can either be processed in the host or passed to the
management station through the network connection, as shown in Figure 1 on
page 6.

Managing storage subsystems through the host-agent has the following
advantages:

v Ethernet cables do not need to be run to the controllers.

v A DHCP/BOOTP server is not needed to connect the storage subsystems to the
network.

v The controller network configuration tasks that are described in Chapter 2,
“Preparing for installation” on page 21, do not need to be performed.

Chapter 1. Introduction 5



v A host name or IP address must only be specified for the host instead of for the
individual controllers in a storage subsystem. Storage subsystems that are
attached to the host are automatically discovered.

Managing storage subsystems through the host-agent has the following
disadvantages:

v The host-agent requires a special logical drive, called an access logical drive, to
communicate with the controllers in the storage subsystem. Therefore, you are
limited to configuring one less logical drive than the maximum number that is
allowed by the operating system and the host adapter that you are using.

v If the connection through the fibre channel is lost between the host and the
subsystem, the subsystem cannot be managed or monitored.

Note: The access logical drive is also referred to as the Universal Xport Device.

Important: If your host already has the maximum number of logical drives
configured, either use the direct management method or give up a logical drive for
use as the access logical drive. For more information, see “Number of supported
logical drives” on page 19.

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Network

Storage subsystems

Running the
host-agent software

Note: The host can
act as a management
station also.

Figure 1. Host-agent-managed (in-band) storage subsystems
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Direct-managed (out-of-band) method
When you use the direct (out-of-band) management method, you manage storage
subsystems directly over the network through a TCP/IP Ethernet connection to each
controller. To manage the storage subsystem through the Ethernet connections, you
must define the IP address and host name for each controller. The controller must
be attached and a cable must be attached to the Ethernet connectors on each of
the storage subsystem controllers, as shown in Figure 2 on page 8.

Managing storage subsystems using the direct (out-of-band) management method
has the following advantages:

v The Ethernet connections to the controllers enable a management station
running SMclient to manage storage subsystems that are connected to a host
running any of the operating systems that are supported by Storage Manager
8.21.

v An access logical drive is not needed to communicate with the controllers. You
can configure the maximum number of logical drives that are supported by the
operating system and the host adapter that you are using.

v There is a constant management connection to the subsystem

Managing storage subsystems using the direct (out-of-band) management method
has the following disadvantages:

v You need two Ethernet cables to connect the storage subsystem controllers to a
network.

v When adding devices, you must specify an IP address or host name for each
controller.

v You might need a DHCP/BOOTP server and network preparation tasks are
required. For a summary of the preparation tasks, see “Preparing a network
installation” on page 23.

You can avoid DHCP/BOOTP server and network tasks by assigning static IP
addresses to the controller, or by using a default IP address.

v To assign a static IP addresses, see the IBM support Web site for Retain Tip
#H171389 Unable To Setup Networking Without DHCP/BOOTP.

v If the storage subsystem controllers have firmware version 05.00.xx. or later, they
have the following default settings:

Controller IP address Subnet mask

A 192.168.128.101 255.255.255.0

B 192.168.128.102 255.255.255.0
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Figure 2 shows a system in which storage subsystems are managed using the
direct (out-of-band) management method.

Ethernet

Host computer

Fibre Channel
I/O path

Management station
(one or more)

Controller

Controller

Controller

Controller

Storage subsystems

Figure 2. Direct-managed (out-of-band) storage subsystems
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Where to install the software components
How you manage the storage subsystems determines where you must install the
various software components.

Management stations
You must install the following software components on each management station:

v Storage Manager 8.21 Client (SMclient)

v Microsoft Virtual Machine (for Windows NT only)

Host computers
You must install the following software components on each host computer:

v Redundant Disk Array Controller (RDAC)

v Storage Manager 8.21 Utility (SMutil)

Depending on how you intend to manage the storage subsystems, you might need
to install the following software components:

v Storage Manager 8.21 Agent (SMagent)

v Storage Manager 8.21 Client (SMclient)

The SMagent must be installed on a host computer if you intend to manage the
storage subsystems using the host-agent management method.

The SMclient must be installed on a host computer if you intend the host computer
to act as a management station. If the host computer is not connected to a network,
it must have TCP/IP software installed, and be assigned an IP address.

Configuration types
You can install Storage Manager 8.21 in one of two configurations:

v Standard (noncluster) configuration

v Cluster server configuration
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Standard (noncluster) configuration
Figure 3 shows a sample standard (noncluster) configuration.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station

RDAC, SMutil,
SMagent

The SMclient software
can also be installed

on the host computer.
Storage subsystems

SMclient

Figure 3. Sample standard (noncluster) configuration
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Cluster server configuration
Figure 4 shows a sample cluster configuration.

Ethernet

Fibre Channel
I/O path

Management station
(one or more)

Cluster server
node A

Cluster server
node B

RDAC, SMutil,
SMagent

Controller

Controller

Storage subsystem

Managed hub or
switch

The SMclient software
can also be installed on
the cluster nodes.

SMclient

Installation types
You can install the storage-management software in two types of hardware
environments:

v New storage subsystem environment. You are installing the IBM TotalStorage
FAStT Fibre Channel Storage Server using firmware 05.2x.xx.xx and you will
manage storage subsystems using Storage Manager 8.21.

v Existing storage subsystem environment. You are installing the
storage-management software in an environment with existing storage
subsystems. See Table 3 on page 12 for your installation options in an
environment with existing storage subsystems.

Note: When instructed to uninstall Storage Manager software in the following table,
be sure to uninstall the management software on all management systems
or hosts that have access to the storage subsystem that has firmware
5.2x.xx.xx The Storage Manager 8.21 RDAC has new functionality and
features and it is compatible with older versions of firmware. To ensure the

Figure 4. Sample cluster server configuration
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highest level of compatibility and error-free operation, the Storage Manager
8.21 RDAC must be installed on all host computers that have firmware level
5.2x.xx.xx.

Table 3. Configurations for existing storage subsystems

Current environment Planned environment Action

(Machine type 3552)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
04.01.xx.xx

Upgrade firmware to
version 05.2x.xx.xx

Manage all storage
subsystems using
Storage Manager 8.21.

1. Purchase an upgrade option. Contact
your IBM service representative for
more information.

2. Uninstall Storage Manager version
7.x. Refer to “Uninstalling
storage-management software
components” on page 80 for more
information.

3. Install Storage Manager 8.21. Refer
to “New installation process” on
page 41 for more information.

4. Discover the storage subsystems.
Refer to “Performing an initial
automatic discovery of storage
subsystems” on page 67 for more
information.

5. Download firmware and NVSRAM
version 5.2x.xx.xx. Refer to
“Downloading firmware and
NVSRAM” on page 71 for more
information.

(Machine types 3526,
3542, 3552) Existing
storage subsystems
with controllers that
have firmware versions
04.00.02.xx through
04.01.xx.xx

Retain existing firmware
versions.

Manage all storage
subsystems using
Storage Manager 8.21.

1. Uninstall Storage Manager version
7.x. Refer to “Uninstalling
storage-management software
components” on page 80 for more
information.

2. Install Storage Manager 8.21. Refer
to “New installation process” on
page 41 for more information.

3. Discover the storage subsystems.
Refer to “Performing an initial
automatic discovery of storage
subsystems” on page 67 for more
information.
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Table 3. Configurations for existing storage subsystems (continued)

Current environment Planned environment Action

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
04.00.01.xx

Upgrade firmware to
version 04.00.02.xx or
higher.

Manage all storage
subsystems using
Storage Manager 8.21.

1. Uninstall Storage Manager version
7.x. Refer to “Uninstalling
storage-management software
components” on page 80 for more
information.

2. Install Storage Manager 8.21. Refer
to “New installation process” on
page 41 for more information.

3. Discover the storage subsystems.
Refer to “Performing an initial
automatic discovery of storage
subsystems” on page 67 for more
information.

4. Upgrade the firmware to version
4.00.02.xx or higher. Go to the IBM
Web site; download the firmware and
matching NVSRAM.

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
4.00.01.xx

Retain existing firmware
versions.

Manage existing
storage subsystems
using Storage Manager
7.01.

Set up a separate management station
with Storage Manager 7.01 installed to
manage the storage subsystems with
controllers that have back-level firmware.

(Machine types 1742,
3552) Existing storage
subsystems with
controllers that have
firmware versions
05.00.xx.xx or
05.20.xx.xx

Upgrade firmware to
version 5.2x.xx.xx

Manage all storage
subsystems using
Storage Manager 8.21.

1. Uninstall Storage Manager 8.0. See
“Uninstalling storage-management
software components” on page 80 for
more information.

2. Install Storage Manager 8.21. See
“New installation process” on page 41
for more information.

3. Discover the storage subsystems.
See “Performing an initial automatic
discovery of storage subsystems” on
page 67 for more information.

4. Download firmware and NVSRAM
version 5.2x.xx.xx. See “Downloading
firmware and NVSRAM” on page 71
for more information.
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Table 3. Configurations for existing storage subsystems (continued)

Current environment Planned environment Action

(Machine type 3542)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.02.xx through
04.01.xx.xx

Upgrade the firmware to
version 5.2x.xx.xx.

Manage all storage
subsystems using
Storage Manager 8.21.

1. Purchase the upgrade option.
Contact IBM for more information.

2. Uninstall Storage Manager 7.0. See
“Uninstalling storage-management
software components” on page 80 for
more information.

3. Install Storage Manager 8.21. See
“New installation process” on page 41
for more information.

4. Discover the storage subsystems.
See “Performing an initial automatic
discovery of storage subsystems” on
page 67 for more information. Go to
the IBM Web site to download the
04.01.02.26 or higher firmware and
matching NVSRAM. Important: The
storage subsystem controllers must
be at firmware level 04.01.02.26 or
higher before downloading firmware
level 05.2x.xx.xx and NVSRAM to the
controllers.

5. Download firmware level 04.01.02.26
or higher and its associated
NVSRAM. See “Downloading
firmware and NVSRAM” on page 71
for more information.

6. Download firmware and NVSRAM
version 5.2x.xx.xx. See “Downloading
firmware and NVSRAM” on page 71
for more information.

Managing coexisting storage subsystems
Storage subsystems are coexisting storage subsystems when the following
conditions are met:

v There are multiple storage subsystems with controllers running different versions
of firmware.

v These storage subsystems are attached to the same host.

For example, a coexisting situation exists when you have a new storage subsystem
with controllers running firmware version 05.2x.xx.xx, and it is attached to the same
host as one or more of the following configurations:

v A storage subsystem with controllers running firmware versions 04.00.xx.xx
through 04.00.01.xx, which is managed by a separate management station with
Storage Manager 7.01.

v A storage subsystem with controllers running firmware versions 04.00.02.xx
through 04.01.xx.xx, which is managed with Storage Manager 8.21.

Important: The common host must have the latest level (8.21) of RDAC and
Storage Manager Agent installed.
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Figure 5 shows an example of an environment that includes coexisting storage
subsystems.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station

Management station

Host-agent

Client software
Storage subsystems

Version 7.01 of the storage-management
software must be installed on a
management station.

Firmware version
4.x (minimum)

Firmware version 5.x

Version 8.21 of the
storage-management
software must be installed on either
a management station or host.

Important: In a
co-existing situation,
the common host
must have Storage Manager
Version 8.21 RDAC and SMagent
installed.

System requirements
This section provides detailed information about the hardware, software, and
operating system requirements for Storage Manager 8.21.

Figure 5. Sample coexistence installation

Chapter 1. Introduction 15



Hardware requirements
Table 4 lists the hardware required for installing Storage Manager 8.21.

Table 4. Hardware requirements for Storage Manager 8.21 software

Hardware component Requirements

A DHCP/BOOTP server (only
for directly managed storage
subsystems)
Note: If the controllers static
IP addresses or default IP
addresses are used, you do
not need to setup the
DHCP/BOOTP server.

One of the following BOOTP or BOOTP-compatible servers:

v Microsoft BOOTP-compatible DHCP server for Windows NT

v Microsoft BOOTP-compatible DHCP server for Windows
2000

v UNIX BOOTP server

v NetWare DHCP server

Storage subsystems (one or
more)

Storage subsystems with controllers running firmware version
04.00.02.xx through 05.21.xx.xx.

Fibre Channel (FC) host
adapters

The following Fibre Channel host adapters were tested with
the storage-management software:

v IBM FAStT host adapter (part number: 00N6881)

v IBM FAStT FC-2 host bus adapter (part number: 19K1246)

v IBM TotalStorage FAStT FC2-133 host bus adapter (part
number: 24P0960)

For information on specific host adapter requirements:

v Refer to the README file in the \Host_Adapter directory on
the installation CD.

v Read the host adapter documentation.

v Go to the http://www.ibm.com/pc/support Web site.

Fibre Channel (FC) fabric
switches (if needed for the
desired configuration)

The following Fibre Channel fabric switches were tested with
the storage-management software:

v IBM 8-port Fibre Channel switch (machine type: 2109-S08)

v IBM 16-port Fibre Channel switch (machine type:
2109-S16)

v IBM 16-port 2 Gbps Fibre Channel switch (machine type:
2019-F16)

v IBM 8-port 2 Gbps Fibre Channel switch (machine type:
3534-F08)

For specific Fibre Channel switch setup requirements:

v Read the switch documentation.

v Go to the http://www.ibm.com/storage/fcswitch Web site.

Fibre Channel (FC) managed
hub (if needed for the
desired configuration)

The IBM Fibre Channel managed hub (machine type: 3534)
was tested with the storage management software.

For specific Fibre Channel managed hub setup requirements:

v Read the managed hub documentation.

v Go to the http://www.ibm.com/storage/fchub Web site.
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Table 4. Hardware requirements for Storage Manager 8.21 software (continued)

Hardware component Requirements

Management station (for
client software)

Your management station computer will require:

v Intel® Pentium® or Pentium-equivalent microprocessor (450
MHz or faster)

v CD-ROM drive

v Mouse or similar pointing device

v System memory:

– For Windows NT 4.0: A minimum of 64 MB (128 MB
recommended)

– For Windows 2000: A minimum of 128 MB (256 MB
recommended)

v Ethernet network interface adapter

v AGP or PCI video adapter (AGP preferred), ISA adapters
are not supported

v Monitor setting of 1024 x 768 pixels with 64,000 colors. The
minimum display setting that is allowed is 800 x 600 pixels
with 256 colors.

v Hardware-based Windows acceleration: Desktop computers
that use system memory for video memory are not
preferred for use with the storage-management software.

Important: Many PC-based servers are not designed to run
graphic-intensive software. If your server has difficulty running
the storage-management software smoothly without video
artifacts, you might need to upgrade the server video adapter.

Note: For more information about host adapters, fabric switches, and managed
hubs, go to the ServerProven™ Web site at
http://www.ibm.com/pc/us/compat/.

Firmware requirements
To utilize all of the features of Storage Manager 8.21, your storage subsystem must
contain controllers with firmware version 05.21.xx.xx for machine types 1742 and
3552 or firmware version 05.20.08.xx for machine type 3542. To manage storage
subsystems with Storage Manager 8.21, your storage subsystems must contain
controllers with firmware versions 04.00.02.xx or higher.

To upgrade your firmware from version 04.00.xx.xx to 05.2x.xx.xx for machine type
3552 or to firmware version 05.20.xx.xx for machine type 3542, you must purchase
a firmware upgrade option. For more information, contact your IBM reseller or IBM
marketing representative.

Storage Manager 8.21 also supports two premium feature options: FlashCopy and
Remote Mirroring. For more information about these premium features, contact your
IBM reseller or IBM marketing representative.
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Software requirements
Table 5 lists the disk space and administrator privileges required to install version
8.21 of the storage-management software.

Note: The disk space listed in table 5 is for the packages after the installation.
During the installation of each software package, you might need up to 120M
of free disk space.

Table 5. Installation requirements by software package

Package Disk space requirement
(Windows NT / Windows 2000)

Administrator privilege
(Windows NT / Windows 2000)

Microsoft Virtual
Machine

1 MB / NA Required / NA

Storage Manager 8.21
Client (SMclient)

40 MB Not required / Not Required

Redundant Disk Array
Controller (RDAC)

1 MB / 1 MB Required

Storage Manager 8.21
Agent (SMagent)

1 MB / 1 MB Required

Storage Manager 8.21
Utility (SMutil)

4 MB / 4 MB Required

Operating system requirements
Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations. Install one of the following operating systems:

v Windows NT 4.0 Server with Service Pack 6a

v Windows NT 4.0 Enterprise Edition with Service Pack 6a

v Windows NT 4.0 Workstation with Service Pack 6a

v Windows 2000 Server with Service Pack 2

v Windows 2000 Professional with Service Pack 2

v Windows 2000 Advanced Server with Service Pack 2

Host computers. Install one of the following operating systems:

v Windows NT 4.0 Server with Service Pack 6a

v Windows NT 4.0 Enterprise Edition with Service Pack 6a

v Windows NT 4.0 Workstation with Service Pack 6a

v Windows 2000 Server with Service Pack 2

v Windows 2000 Professional with Service Pack 2

v Windows 2000 Advanced Server with Service Pack 2

Cluster nodes. Install one of the following operating systems:

v Windows NT 4.0 Enterprise Edition with Service Pack 6a

v Windows 2000 Advanced Server with Service Pack 2
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Number of supported logical drives
Supported logical drive limits for Windows NT 4.0 and Windows 2000 are as
follows:

v Windows NT 4.0 with Service Pack 6a supports up to 32 logical drives per
storage subsystem (LUNs 0-31) when using IBM-approved FAStT adapters and
their supported device drivers.

v Windows 2000 supports up to 32 logical drives per storage subsystem (LUNs
0-31) when using IBM-approved FAStT adapters and their supported device
drivers.

v The maximum number of logical drives that a FAStT storage subsystem supports
with firmware version 05.2x.xx.xx depends on the model of the FAStT storage
subsystem.

Table 6. Logical drives without the remote mirror option enabled

Model
Type

Maximum logical drives Maximum logical drives
per storage unit partition

Maximum flashcopy
logical drives

3542 5121 325 2562

3552 5121 325 2562

1742 20481 325 10242

Table 7. Logical drives using the remote mirror option

Model Type Maximum logical
drives

Maximum logical drives
per storage unit
partition

Maximum flashcopy
logical drives

3542 N / A N / A N / A

3552 1283,6 325 642

1742 2561,4,6 325 1282

Note: The access logical drive is also referred to as the Universal Xport Device.

1.When using firmware version 5.xx.xx.xx, the firmware reserves one logical drive
for use by the system.

2. Maximum of four Flashcopy logical drives for each standard logical drive

3. Maximum of eight remote mirror pairs

4. Maximum of 16 remote mirror pairs

5.The host-agent management method uses a special logical drive, called an access
logical drive, to communicate with the controllers on the storage subsystem. The
access logical drive uses one of the available LUNs. Therefore, managing storage
subsystems with the host-agent software limits you to one fewer LUN than the
maximum number supported by the operating system and the host adapter.

6.For firmware version 05.2x.xx.xx, the maximum number of logical drives includes
the flashcopy repository logical drives and the remote mirror logical drives in
addition to the standard data logical drives. If the remote mirror option is enabled,
two logical drives are reserved for use by the system.
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Chapter 2. Preparing for installation

This chapter provides information to help you plan the installation of the
storage-management software.

Table 8 contains information about where the Storage Manager software
components need to be installed.

Table 8. Software component installation in a Windows environment

System type Software installation sequence

Management station 1. Microsoft Virtual Machine (for Windows NT only)

v Optional package

v Necessary if you plan to install the Event Monitor option of the
SMclient

2. Storage Manager 8.21 Client (SMclient)

Host computer /
cluster node

1. Microsoft Virtual Machine (for Windows NT only)

v Optional package

v Necessary if you plan to install the Event Monitor option of the
SMclient.

2. Storage Manager 8.21 Client (SMclient)

v Optional component

v Necessary if you intend to manage the storage subsystem from
the host computer

3. Redundant Disk Array Controller (RDAC)

v Required component

v On Windows NT, you must assign static drive letters to existing
local drives before installing RDAC. This process requires a
minimum of two disk partitions (the BOOT partition and one
other partition).

4. Storage Manager 8.21 Agent (SMagent)

v Optional component

v Necessary if you intend to use the host-agent management
method.

5. Storage Manager 8.21 Utility (SMutil)

v Required component

v Contains the Hot Add, SMdevices, and SMflashcopyassist
utilities

Storage-subsystem management methods
If you have not already done so, see Chapter 1, “Introduction” on page 1 for
information about the following two methods for managing storage subsystems:

v Direct (out-of band) management: The storage subsystems are managed
through a TCP/IP Ethernet connection to each controller on the storage
subsystem.

v Host-agent (in-band) management: The storage subsystems are managed
through host-agent software that is installed on a host computer connected
through the fibre channel connection to the storage subsystem.
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You can use one or both methods. However, because many of the preparation
tasks for installation depend on which method you use, decide how you want to
manage the storage subsystems on your network before you begin.

Reviewing a sample network
Figure 6 on page 23 shows an example of a network containing both a
directly-managed storage subsystem (Network A) and a host-agent-managed
storage subsystem (Network B).

Directly-managed storage subsystem: Network A is a directly-managed storage
subsystem. Network A contains the following components:

v DHCP/BOOTP server

v Network Management Station (NMS) for Simple Network Management Protocol
(SNMP) traps

v Host that is connected to a storage subsystem through a Fibre Channel I/O path

v Management station connected by Ethernet cable to the storage subsystem
controllers

v If the controllers static IP addresses or default IP addresses are used, you do not
need to setup the DHCP/BOOTP server.

Host-agent-managed storage subsystem: Network B is a a host-agent-managed
storage subsystem. Network B contains the following components:

v Host that is connected to a storage subsystem through a Fibre Channel I/O path

v Management station connected by Ethernet cable to the host computer
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Preparing a network installation
To begin installing the storage-management software, ensure that the network
components are set up and operating properly, and that you have all the host and
controller information needed for the software to operate correctly.

The following list provides an overview of the tasks involved in setting up a network
installation.

1. Install all hardware components (host computers, storage subsystems, and
cables) that you want to connect to the network. You might need to refer to the
installation guides specific to the hardware components.

2. Establish a naming convention for the storage subsystems connected to the
network. Refer to “Naming the storage subsystems” on page 25 for more
information.

3. Record the storage subsystem names and management types in Table 13 on
page 89. An example of a completed information record is shown in Table 9 on
page 25.

Note: Throughout the remaining steps, you will need to return to Table 13 on
page 89 to record information such as hardware Ethernet addresses and
IP addresses.

Controller

Controller

Controller

Controller

Storage
subsystem

finance

Storage
subsystem
engineering

Fibre Channel
I/O path

Fibre Channel
I/O path

Network A
TCP/IP

Network B
TCP/IP

Ethernet

Router

Network
management

station
(for SNMP traps)

Management
station

(one or more)

Management
station

(one or more)

Host computer
Denver

(IP address
192.168.1.12)

Host computer
Atlanta

(IP address
)192.168.2.22

DHCP/BOOTP server

Host name: Denver_a
(IP address )

hardware address 00.a0.b8.02.04.20
192.168.128.101

Host name: Denver_b
(IP address )

hardware address 00.a0.b8.00.00.d8
192.168.128.102

Ethernet

Figure 6. Sample network using direct-managed and host-agent managed storage
subsystems
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4. (For a direct-managed system only) Determine the hardware Ethernet address
for each controller in storage subsystems connected to the network. Refer to
“Identifying the hardware Ethernet MAC address for each controller” on page 25
for more information.

5. (For a Direct managed system only) If you are using a default controller IP
addresses, go to step 7 Otherwise, Obtain the TCP/IP address and host name
for each of the controllers in the storage subsystems on the network from the
network administrator. Refer to “Assigning IP addresses to hosts and
controllers” on page 27.

(For a host-managed system only) Obtain the The IP address and host name of
the host computer on which the host-agent software will run from the network
administrator. Refer to “Assigning IP addresses to hosts and controllers” on
page 27.

6. (For a direct-managed system only) Set up the DHCP/BOOTP server to provide
network configuration information for a specific controller, however, if you are
using a controller static IP addresses, skip this step.

7. Verify that the TCP/IP software is installed. For more information, see “Verifying
the TCP/IP protocol and setting up the host or DNS table” on page 38.

8. (For a direct-managed system only) Set up the host or Domain Name Server
(DNS) table. For more information, see “Verifying the TCP/IP protocol and
setting up the host or DNS table” on page 38.

9. Power on the devices connected to the network.

Table 9 on page 25 shows a sample information record for the network shown in
Figure 6 on page 23. This network contains storage subsystems managed using
both the direct-management and host-agent-management method.
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Table 9. Sample information record

Storage
subsystem name

Management
type

Controllers—Ethernet and IP
addresses, and host name

Host—IP
address and
host nameController A Controller B

Finance Direct Hardware
Ethernet address
= 00a0b8020420

Hardware
Ethernet address
= 00a0b80000d8

IP address =
192.168.128.101

IP address =
192.168.128.102

Host = Denver_a Host = Denver_b

Engineering Host-agent IP address =
192.168.2.22

Host = Atlanta

Naming the storage subsystems
As you set up your network, decide on a naming convention for the storage
subsystems. When you install the storage-management software and start it for the
first time, all storage subsystems in the management domain are displayed as
<unnamed>. Use the Subsystem Management window to rename the individual
storage subsystems.

Consider the following when naming storage subsystems:

v There is a 30-character limit. All leading and trailing spaces are deleted from the
name.

v Use a unique, meaningful naming scheme that is easy to understand and
remember.

v Avoid arbitrary names or names that might quickly lose their meaning.

v The software displays storage-subsystem names with the prefix Storage
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is
displayed as:
Storage Subsystem Engineering

After you decide on a naming scheme, record the storage subsystem names in the
information record (Table 13 on page 89).

If you plan to manage your storage subsystem using the direct-management
method, go to “Identifying the hardware Ethernet MAC address for each controller”.
If you plan to manage your storage subsystem using the host-agent management
method, go to “Assigning IP addresses to hosts and controllers” on page 27.

Identifying the hardware Ethernet MAC address for each controller
To manage your storage subsystem using the direct-management method, you
need to identify the hardware Ethernet MAC address for each controller.

To identify the hardware Ethernet MAC address for machine type 3542, do the
following:

1. Locate the Ethernet MAC address at the back of the unit, under the controller
Gigabit Interface Converter (GBIC) ports, as shown in Figure 7 on page 26. The
number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.20.00.d8).
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2. Record each Ethernet address in the information record (Table 13 on page 89).

To identify the hardware Ethernet MAC address for machine types 3552 and 1742,
do the following:

1. Remove the front bezel from the storage subsystem, as shown in Figure 8.
Carefully pull the bottom of the bezel out �1�to release the pins; then, slide the
bezel down �2�.

2. On the front of each controller, look for a label with the hardware Ethernet MAC
address. The number will be in the form xx.xx.xx.xx.xx.xx (for example,
00.a0.b8.20.00.d8).

3. Record each Ethernet address in the information record (Table 13 on page 89).

Hardware Ethernet
address label

Figure 7. Locating the Ethernet MAC address for machine type 3542

Figure 8. Removing the controller-unit bezel (machine types 3552 and 1742)
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4. To replace the bezel, slide the top edge under the lip on the chassis �1�; then,
push the bezel bottom until the pins snap into the mounting holes �2�, as shown
in Figure 9.

5. Continue with “Assigning IP addresses to hosts and controllers”.

Assigning IP addresses to hosts and controllers
If you plan to manage your storage subsystem using the direct-management
method, assign a unique IP address for every controller in all storage subsystems
on the network. Record the IP address for each controller in the information record
(Table 13 on page 89). Then, go to “Setting up the DHCP or BOOTP-compatible
server”.

Note: If you want to assign static IP addresses for the controllers, refer to the IBM
support Web site for Retain Tip #H171389 Unable to setup networking
without DHCP/BOOTP. Then, go to “Verifying the TCP/IP protocol and
setting up the host or DNS table” on page 38.

If you plan to manage your storage subsystem using the host-agent management
method, assign an IP address for each host on which you will install the host-agent
software. Record the IP address for each host in the information record (Table 13
on page 89). Then, go to “Verifying the TCP/IP protocol and setting up the host or
DNS table” on page 38.

Setting up the DHCP or BOOTP-compatible server
To directly manage storage subsystems through the Ethernet connection to each
controller, you will need to set up a DHCP or BOOTP-compatible server and
configure the following options:

v Router/Gateway

Figure 9. Replacing the controller-unit bezel (machine types 3552 and 1742)
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v DNS Server

v Hostname

v DNS Domain Name

This section provides instructions for setting up a DHCP server on Windows NT,
Windows 2000, and Novell NetWare, as well as instructions for setting up a UNIX
BOOT server.

Note: The remote management station (RMS) and network management station
(NMS) entries used in previous versions of the storage-management
software are not required when using Storage Manager 8.21.

Setting up a Windows NT DHCP server
You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to “Setting up a DHCP server”. If a DHCP Manager is
not installed, use the following installation procedure to install one.

Installing the DHCP Manager
Use the following procedure to install the DHCP Manager:

1. Click Start → Settings → Control Panel. A Control Panel window opens.

2. Double-click Network. The Network window opens.

3. Click Services.

4. From the Services tab, click Add.

5. Click Microsoft DHCP Server; then, click OK.

6. Specify the path to the Windows NT Install file; then, click Continue. A
dialogue windows opens, stating that a static IP address is required.

7. Click OK. The Network window opens.

8. Click Protocols.

9. Click TCP/IP Protocol; then, click Properties.

10. Verify that the IP address information is correct; then, click OK.

11. Continue to “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to its online help for
additional information.

Setting up a DHCP server
Use the following procedure, along with the information you recorded in Table 13 on
page 89, to set up a DHCP server.

1. Click Start → Programs → Administrative Tools → DHCP Manager. The DHCP
Manager window opens.

2. Create a scope. A scope defines a group of TCP/IP addresses that you want the
DHCP server to use to assign to the controllers.

a. Click Local Machine.

b. Click Scope → Create. The Create Scope - (Local) window opens.
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c. Type the starting and ending IP addresses of the controllers that you are
configuring for the network.

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet,
set the starting address to 153.79.144.1 and the ending address to
153.79.144.50.

Note: If each field does not contain at least three characters, press the
period (.) key to advance to the next field. If you have only one
controller, type its address for both the starting and ending address.

d. Type the subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection
permanent.

f. Type a scope name and comment.

g. Click OK.

h. When the scope successfully completes, click Yes to activate it. This returns
you to the DHCP Manager window.

3. Configure global scope options. Table 10 shows the global options that need to
be set.

Table 10. Global options for a Windows NT DHCP server

Number Description Notes

003 Router/Gateway

006 DNS Server

012 Host name Unique for each controller

Figure 10. Create Scope - (Local) window
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Table 10. Global options for a Windows NT DHCP server (continued)

Number Description Notes

015 DNS domain name For example, ibm.com

165 Network Management Station Defines where the controller should send
SNMP alerts

You can apply options to specific controllers later using step 5 on page 31.

a. Click DHCP Options → Global. The DHCP Options: Global window opens.

b. To make a global option active, select an item in the Unused Options list;
then, click Add to move it to the Active options list.

c. Click Value to assign a value to the active option.

If the Value field is not available, click Edit Array; the Edit Array Editor
window opens. Do one of the following:

v If you need to add an IP address, complete the following procedure:

1) Click Edit Array. The IP Address Array Editor window opens.

2) Type a unique IP address for the option that you added.

Figure 11. DHCP Options: Global window

Figure 12. IP Address Array Editor window
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3) Click Add to move the New IP Address to the IP Addresses list.

4) Click OK. This returns you to the DHCP Options: Global window.

v If you do not need to add an IP address, click Cancel. This returns you to
the DHCP Options: Global window.

d. Repeat step 3b through step 3c on page 30 until all global options are
added.

e. When you finish adding the Global Scope Options, click OK at the DHCP
Options: Global window.

4. Create a reservation for each controller. Use the information record (Table 13 on
page 89) to make sure that you include all of the controllers on the network.

a. Click Scope → Add Reservations.

b. In the IP Address field, type the IP address for the first controller on your
data sheet.

c. In the Unique Identifier field, type the controller hardware Ethernet address.
Do not type decimal points or spaces.

d. In the Client Name field, type the controller eight-character name.

e. Click Add.

f. Repeat step 4b on page 31 through step 4e on page 31 for each controller
that is listed on information record (Table 13 on page 89).

g. When you finish adding the information for all of the controllers, click Close.
This returns you to the DHCP Manager window.

5. Configure controller-specific options. By creating a controller-specific option, you
can associate a controller configuration entry with a specific controller.

Note: If you set an option as Global Scope, it applies to every controller in this
group and does not need to be added again.

a. Click Scope → Active Leases. The Active Leases window opens.

b. Select a controller in the list.

Figure 13. Active Leases window
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c. Click Properties. The Add Option Type window opens. The Unique Identifier
is the hardware Ethernet address from step 4c.

d. Click Options. The DHCP Options: Reservations window opens.

e. Select an option from the Unused Options list, and click Add to move it to
the Active Options list.

f. Click Value to assign a value to the active option.

g. Type the information for the value of the option. For example, type the host
name for the controller from your information record (Table 13 on page 89) in
the String field. Click Edit if the value that you need to add is an IP address
for a router.

h. Repeat step 5e through step 5g until you finish adding specific options for
this controller.

i. Click OK. This returns you to the Add Option Type window.

j. Click OK. This returns you to the Active Leases window.

k. Repeat step 5b on page 31 through step 5j until you finish adding
controller-specific options for every controller.

l. Click OK on the Active Leases window. This returns you to the DHCP
Manager window.

6. Continue with “Verifying the TCP/IP protocol and setting up the host or DNS
table” on page 38.

Setting up a Windows 2000 DHCP server
You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to “Setting up a DHCP server” on page 33.

Installing the DHCP Manager
To install the DHCP Manager, do the following:

1. Click Start → Administrative Tools → Configure Your Server. The Configure
Your Server window opens.

2. In the left pane, double-click Networking; then, click DHCP

3. In the right pane, click Start. The Windows Components Wizard starts.

4. In the Components field, select Networking Services; then, click Details.
The Networking Services window opens.

Figure 14. Add Option Type window
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Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

5. In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP).

6. Click OK; the Windows Components Wizard window opens.

7. Click Next to start the installation process.

8. If prompted, type the full path to the Windows 2000 distribution files and click
Continue.

9. When the installation has successfully completed, the Windows Components
Wizard window close, and the Configure Your Server Window opens.

10. Click Next.

11. Click Open the DHCP Manager. The DHCP window opens.

12. Continue with step 2 of “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to the DHCP Manager
online help for additional information.

Setting up a DHCP server
Use the following procedure to create a scope and to set up a DHCP server. A
scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. Refer to the information record (Table 13 on page 89). Before you
begin, read through the instructions to determine what information is required; then,
request the information from your network administrator.

1. Click Start → Programs → Administrative Tools → DHCP. The DHCP window
opens.

2. In the Console tree, right-click the server you want to configure; click New
Scope. The New Scope Wizard starts.

3. Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following:

a. Scope name and description

b. IP address range for the subnet mask, and the controllers you are
configuring.
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c. IP addresses that you want to exclude from the IP address range

d. IP address lease duration

e. Common DHCP options:

v IP address for a router

v Domain name and DNS servers

4. When you have defined the scope, click Yes, I want to activate this scope
now. The wizard ends, and the DHCP window appears.

5. In the Console tree, open the scope folder.

6. Right-click Reservations; then, select New Reservations. The New
Reservations window opens.

7. To define the IP address reservation, type the following information:

a. Reservation name

b. IP address

c. Ethernet hardware MAC address

d. Description

8. In the Supported Type field, select Both (DHCP and BOOTP).

9. Click Add.

10. Repeat steps 5 through 9 for each controller in the network.

11. Restart the DHCP server and then restart the storage subsystem so that all
modifications are applied.

12. Go to “Verifying the TCP/IP protocol and setting up the host or DNS table” on
page 38.

Figure 15. New Scope Wizard: IP Address Range window
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Setting up a NetWare DHCP server
A NetWare DHCP server automatically assigns IP addresses and other
configuration information to clients upon request or when the clients are restarted.

To set up a NetWare DHCP server, you must complete the following tasks:

1. Install DNS/DHCP Services, either during or after installing NetWare 5.

2. Install the DNS/DHCP Management Console.

3. Create the DHCP server object.

4. Create the subnet address.

5. Create the subnet address range.

6. Create the IP address object.

7. Start the DHCP server.

Installing NetWare 5.1 with DNS/DHCP Services
This section contains instructions for adding Novell DNS/DHCP services during and
after the NetWare 5.1 installation.

Adding Novell DNS/DHCP Services during the NetWare 5.1 installation: Do
the following to add Novell DNS/DHCP Services during the Netware 5.1 installation:

1. From the Installation Options window, select Custom.

2. From the Components window, select the Novell DNS/DHCP Services check
box.

3. Follow the on-screen instructions to complete the NetWare 5.1 installation.

Adding Novell DNS/DHCP Services after the NetWare 5.1 installation: Do the
following to add Novell DNS/DHCP Services after the Netware 5.1 installation:

1. Insert the NetWare 5.1 Installation CD into the CD-ROM drive; then, mount the
CD as a volume.

2. Load NWCONFIG and select Product Options.

3. Select Install a Product not Listed.

4. Press F3 and specify the volume name of the CD. The X Server-Graphical
Console window opens.

5. In the Additional Products and Services dialog box, select the Novell
DNS/DHCP Services check box.

6. Follow the on-screen instructions to complete installation.

Note: Installing the DNS/DHCP Service will extend the Novell Directory
Services (NDS) schema and create the following NDS objects:

v DNSDHCP-GROUP Group object

v DNS/DHCP Locator object

v RootServerInfo Zone object

Installing the DNS/DHCP Management Console
Do the following to install the DNS/DHCP Management Console and NetWare
Administrator snap-in files on the client workstation you will use to administer DNS
and DHCP:

1. If you have not done so, install the latest version of Novell Client 32 on your
workstation.

2. From the workstation, run the SYS:PUBLIC\DNSDHCP\SETUP.EXE program.

3. Install the DNS/DHCP Management Console on the local hard-disk drive.
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4. Install the NetWare Administrator snap-in files in the SYS:PUBLIC\WIN32
directory.

5. Restart the workstation.

6. To start the DNS/DHCP Management Console, double-click the shortcut icon on
the desktop, enter the NDS Tree NAME, and click Launch.

Note: You can install the DNS/DHCP Management Console on a workstation, or
you can access it from the Tools menu of the NetWare Administrator utility.

Creating the DHCP server object
Use the DHCP Management Console to create a DHCP server object. A DHCP
server object can be created under any of the following objects:

v Organization (O)

v Organization Unit (OU)

v Country (C)

v Locality (L)

Do the following to create a DHCP server object:

1. From the DHCP Management Console, click the DHCP Service tab.

2. In the left pane, select Our Network.

3. Click Create. The Create New DHCP Object window opens.

4. Select DHCP Server; then, click OK. The Create DHCP Server window opens.

5. Select a server; then, click Create. This creates the DHCP server object in
NDS, called DHCP_servername.

6. In the DHCP Management Console, locate the icon for the DHCP server object
at the bottom of the DHCP Service tab. The server object is displayed with a
red line through it. The red line indicates that DHCP server has not been
started.

7. Continue with “Creating a subnet object”.

Creating a subnet object
You must do the following to create a DHCP subnet object for each of the subnets
for which you want to assign addresses:

1. In the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select Our Network or the DHCP Server Object.

3. Click Create. The Create New DHCP Object window opens.

4. Select Subnet; then, click OK. The Create Subnet window opens.

5. For each subnet, type the following information:

v Subnet name

v NDS context

v Subnet address

v Subnet mask

v Default DHCP Server

6. Click Create. The DHCP subnet object is created and displayed in the
DNS/DHCP Management Console.

Creating subnet address ranges
Do the following to create a subnet address range object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.
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2. Select the subnet object under which you want to create the subnet address
range object; then, click Create. The Create New DHCP Record window opens.

3. Select Subnet Address Range; then, click OK. The Create New Subnet
Address Range window opens.

4. Type the following information for the subnet address range:

v Subnet address range name

v Starting address

v Ending address

5. Click Create.

6. Select the Define Additional Properties check box; then, set the Range Type
to Dynamic BOOTP and DHCP.

Creating IP address objects
Use the DNS/DHCP Management Console to create IP address objects. IP address
objects are used for the following purposes:

v To exclude an IP address from assignment

v To assign an IP address manually to a specific host

v To record dynamic IP address leases

Do the following to create an IP address object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select the subnet object of the target IP address; then, click Create.

3. Select IP Address; then, click OK. The Create IP Address window opens.

4. In the IP Address field, type the IP address for the first controller.

5. In the Assignment field, select Manual.

6. In the Client Identifier field, specify the MAC address.

7. In the MAC Address field, enter the hardware Ethernet MAC address for the
controller.

8. Select the Define Additional Properties check box.

9. In the Hostname field, type the eight-character name for the controller.

10. In the Usage field, select Permanent.

11. Repeat step 3 through step 10 for each controller.

Starting the DHCP server
To start the DHCP server, at the DHCP server console, type:
LOAD DHCPSRVR

The DHCP server can now respond to client requests and assign IP addresses.

Notes:

1. To load the DHCP server automatically each time the server starts, place the
DHCPSRVR command in the SYS:\SYSTEM\AUTOEXEC.NCF directory.

2. For additional information about setting up, configuring, or using Novell
DNS/DHCP Services, refer to the NetWare 5.1 documentation, located on the
Novell Documentation CD or go to http://www.novell.com/documentation.

Setting up a UNIX BOOTP server
To use a UNIX BOOTP server, you must set up a BOOTP table. Table 11 on
page 38 and the information record (Table 13 on page 89) provide the necessary
information.
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Table 11. Required entries for setting up the UNIX BOOTP server

Entry Description Sample format in
BOOTP server

Subnet mask Mask that is used to route packets to defined
subnets

dot notation
(sm=255.255.0.0)

Router IP address of the host computer that routes
packets to networks

dot notation
(gw=192.168.128.1)

Host name for the
controller

Host name that is associated with the controller
(refer to Table 13 on page 89)

host name (Denver_a)

IP address IP address of the controller (refer to Table 13 on
page 89)

dot notation
(ip=192.168.128.101)

Ethernet address The Ethernet address of the controller
hardware (refer to Table 13 on page 89)

hexadecimal notation
(ha=00a0b8020420)

To set up a UNIX BOOTP server, do the following:

1. Use a text editor to edit the bootptab file in the /etc directory.

The following is an example of the BOOTP table used to configure the Network
A server shown in Figure 6 on page 23:
s4.default:\ (common settings)

ht=ether:\

sm=255.255.255.0:\

gw=192.168.128.1:\

hn:

denver_a:\

tc=s4.default:\ (common settings)

ip=192.168.128.101:\

ha=00a0b8020420:

denver_b:\

tc=s4.default:\

ip=192.168.128.102:\

ha=00a0b80000d8:

where the s4.default:\ entry denotes settings that are common to all controllers,
and the tc=s4.default:\ entry associates this common setting group to a specific
controller.

2. If the storage subsystem is running, shut down and then restart the subsystem.
This will ensure that the parameters in the BOOTP table take effect.

3. Continue with “Verifying the TCP/IP protocol and setting up the host or DNS
table”.

Verifying the TCP/IP protocol and setting up the host or DNS table
Use the following procedure to verify that the TCP/IP protocol software is installed
on the management station and to set up the host or DNS table.

Note: Make sure that the host names for the controller match the IP addresses for
the controllers.

For Windows NT, do the following:

1. Right-click Network Neighborhood.
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2. Select Properties. The Network window opens.

3. Click the Protocols tab. If the TCP/IP protocol entry does not appear in the
Network Products box, click Add. The Select Network Protocol window opens.

4. In the Network Protocol field, select TCP/IP Protocol.

5. Click OK; then, follow the on-screen instructions to install the TCP/IP protocol.

6. Update the DNS table to specify a host name to associate with an IP address.

If you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following is an example of the
host tables for the controllers connected to Network A as shown in Figure 6 on
page 23.
# Copyright (c) 1993-1999 Microsoft Corp.

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should be placed
# in the first column followed by the corresponding host name. The IP address
# and the host name should be separated by at least one space.

# Additionally, comments (such as these) might be inserted on individual

# lines or following the machine name denoted by a ’#’ symbol.

# For example:

# 102.54.94.97 rhino.acme.com # source server

# 38.25.63.10 x.acme.com # x client host

127.0.0.1 local host

192.168.128.101 denver_a

192.168.128.102 denver_b

7. If you want to manage storage subsystems through a firewall, configure the
firewall to open port 2463 to TCP data.

For Windows 2000, do the following:

1. Right-click My Network Places.

2. Select Properties. The Network and Dial-up Connections window opens.

3. Right-click on a defined network connection.

4. Select Properties. Make sure that the Internet Protocol TCP/IP box under the
Components checked that are used by this connection is marked. If not, mark it,
click Install and follow the instructions that display.

5. Update the DNS table to specify a host name to associate with an IP address.

If you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following is an example of the
host tables for the controllers connected to Network A as shown in Figure 6 on
page 23.
# Copyright (c) 1993-1999 Microsoft Corp.

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should be placed
# in the first column followed by the corresponding host name. The IP address
# and the host name should be separated by at least one space.

# Additionally, comments (such as these) might be inserted on individual

# lines or following the machine name denoted by a’#’ symbol.

# For example:

# 102.54.94.97 rhino.acme.com # source server

# 38.25.63.10 x.acme.com # x client host

127.0.0.1 local host
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192.168.128.101 denver_a

192.168.128.102 denver_b

6. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.
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Chapter 3. Installing software in a standard configuration

This chapter describes how to install the storage-management software in a
standard (noncluster) configuration. If you intend to configure your system for
clustering, go to Chapter 4, “Installing software in a cluster server environment” on
page 49.

If you have existing storage systems, make sure you have read “Installation types”
on page 11 and “Managing coexisting storage subsystems” on page 14. Both
sections are located in Chapter 1, “Introduction” on page 1.

To ensure proper installation, make sure you have completed all preparation tasks
described in Chapter 2, “Preparing for installation” on page 21.

Important: Always check for a README file on any installation media. The
README file might contain important information that was not available when the
Installation and Support Guide was prepared.

New installation process
The Storage Manager 8.21 software components must be installed on both host
computers and management stations.

Management station: A management station is a system that is used to manage
the storage subsystem. It can be attached to the storage subsystem in the following
ways:

v Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

v Through a TCP/IP network connection to a host computer with host-agent
software installed on it, which in turn is directly attached to the storage
subsystem through the Fibre Channel input/output (I/O) path

You must install storage-management software on a management station in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.21 Client

Host computer: A host computer (or host) is a system that is directly attached to
the storage subsystem through a Fibre Channel I/O path.

Important: Before you begin the storage-manager software installation, you must
install the host-bus adapter and driver.

You must install storage management software on each host computer in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.21 Client

3. Redundant Disk Array Controller

4. Storage Manager 8.21 Agent

5. Storage Manager 8.21 Utility

If you are installing the Storage Manager software on a Windows NT platform, see
“Microsoft Virtual Machine” on page 42 to begin the installation.
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If you are installing the Storage Manager software on a Windows 2000 platform,
see “Storage Manager 8.21 Client” to begin the installation.

Microsoft Virtual Machine
On Windows NT, Microsoft Virtual Machine is required to support the following
components:

v Event Monitor option of Storage Manager 8.21 Client

v Storage Manager 8.21 Agent

To install Microsoft Virtual Machine on management stations and host computers
running Windows NT 4.0, do the following:

1. Close all programs.

2. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM
drive.

3. Click Start → Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\MSVM\NT folder; then, click Open.

7. Select the MSJavx86-3805.exe file; then, click Open, and follow the instructions
on the screen. The Setup Complete window opens.

8. Click No, do not restart the system at this time. Click Finish.

9. Continue with “Storage Manager 8.21 Client”.

Storage Manager 8.21 Client
This section provides instructions for installing Storage Manager 8.21 Client on
management stations and host computers.

Before you install the software, make sure that:

v The management station or host computer has at least 40 MB of available disk
space.

v (Windows NT only) Microsoft Virtual Machine software has been installed on the
device.

Important: When you install Storage Manager 8.21 Client on a stand-alone host
and manage storage subsystems through the Fibre Channel I/O path rather than
through the network, you must install the TCP/IP software on the host and assign
an IP address to the host.

Installing Storage Manager 8.21 Client
To install Storage Manager 8.21 Client, do the following:

1. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM
drive.

2. Click Start → Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the \Win32\SMclient folder; then, click Open.

6. Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens. The Welcome window opens.
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7. Click Next. The End User License Agreement (EULA) window opens.

Note: For Windows NT 4.0, ensure that the Microsoft Virtual Machine is
installed before you install the Event Monitor.

8. Read the license agreement and click Yes. The Event monitor window opens.

9. At the prompt, click Yes if you want to install the Event Monitor. The Choose
Destination Location window opens.

10. Click Browse to change the destination location.

11. Click Next to start the installation. When the installation is complete, the
Operation Complete window opens.

12. Click Finish.

13. Continue with “Verifying the Storage Manager 8.21 Client installation”.

Verifying the Storage Manager 8.21 Client installation
To verify that Storage Manager 8.21 Client is installed correctly, do the following:

1. Click Start → Programs.

2. Verify that IBM FAStT Storage Manager 8 Client appears in the Program list. If
the IBM FAStT Storage Manager 8 Client appears, go to step 3.

Otherwise, repeat “Installing Storage Manager 8.21 Client” on page 42. If the
IBM FAStT Storage Manager 8 Client still does not appear, a failure has
occurred. Contact your IBM technical-support representative.

3. If you installed the optional Event Monitor service, go to “Verifying the Event
Monitor installation”. Otherwise, continue to step 4.

4. If you are installing Storage Manager 8.21 Client on a host computer, go to
“Redundant Disk Array Controller” on page 44. Otherwise, go to Chapter 5,
“Completing the installation” on page 67.

Verifying the Event Monitor installation
This section provides instructions for verifying that the Event Monitor service has
been installed correctly on Windows NT and Windows 2000.

Windows NT 4.0
To verify that the Event Monitor service has been installed correctly, do the
following:

1. Click Start → Settings → Control Panel. The Control Panel window opens.

2. Double-click Services. The Services window opens.

3. Verify that the IBM FAStT Storage Manager 8 Event Monitor service is displayed
with the status Started. If it is not, click Start. If the service does not start,
reinstall the Storage Manager 8.21 Client. If the failure persists, call your IBM
technical-support representative.

4. If you are installing the storage-management software on a host computer, go to
“Redundant Disk Array Controller” on page 44. Otherwise, go to Chapter 5,
“Completing the installation” on page 67.

Windows 2000
To verify that the Event Monitor service has been installed correctly, do the
following:

1. Click Start → Programs → Administrative Tools → Services. The Services
window opens.
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2. Verify that the Storage Manager 8 Event Monitor service is displayed with the
startup type Automatic and status Started. If it is not, click Start. If it does not
start, reinstall the Storage Manager 8.21 Client. If the failure persists, call your
IBM technical-support representative.

3. If you are installing the storage-management software on a host computer, go to
“Redundant Disk Array Controller”. Otherwise, go to Chapter 5, “Completing the
installation” on page 67.

Redundant Disk Array Controller
RDAC must be installed on each host computer. RDAC contains the multipath
device driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:

v You have Administrator privileges on the host computer.

v The host computer has at least 1 MB of available disk space.

v All programs are closed.

v You have installed the host bus adapter and driver.

If you are installing RDAC on Windows NT 4.0, continue with “Assigning static drive
letters”.

If you are installing RDAC on Windows 2000, continue with “Installing the
Redundant Disk Array Controller” on page 45.

Assigning static drive letters

Important:

Before installing RDAC, you must assign static drive letters to existing local drives.
Otherwise, problems might occur during new installations and upgrades. When RDAC is
installed, the RDAC utility installs the RDAC device driver before the Windows NT class
driver. If static drive letters have not previously been assigned to local drives, the system
will detect storage subsystem arrays and assign them drive letters before detecting and
assigning drive letters to local drives. If you have software applications using
non-permanent drive letters that are assigned to local drives, and this occurs application
errors will result.

Use the following procedure to manually assign static drive letters on host
computers running Windows NT 4.0:

1. Determine how many partitions are on the system. Click Start → Programs →
Administrative Tools → Disk Administrator to view the disk configuration and
check the number of partitions.

2. Check that the following conditions are met:

v A boot partition exists.

v The last partition has been created with Disk Administrator or Disk
Management.

v The partition has an assigned drive letter with either an unknown status or a
status other than Unformatted.

If all conditions are met, go to “Installing the Redundant Disk Array Controller”
on page 45. Otherwise, continue to step 3.

3. Create a new partition on your local system or on a storage subsystem using
the following procedure:
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a. Select a drive with free space; then, click Partition → Create. The partition is
created with a status of Unformatted and a drive letter is assigned. You can
delete or change the logical drive at a later time without causing
reassignment of the boot partition.

b. Click Partition → Commit Changes Now. The partition status changes to
Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with “Installing the Redundant Disk Array Controller”.

Installing the Redundant Disk Array Controller
To install RDAC, do the following:

1. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM
drive.

2. Click Start → Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select one of the following directories:

For Windows NT 4.0 \Win32\SMrdac\NT

For Windows 2000 Server or Professional \Win32\SMrdac\W2K

6. Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens. The Welcome window opens. Click Next. The End User License
Agreement (EULA) window opens.

7. Click Yes to start the installation. After installing RDAC, the InstallShield Wizard
Complete window opens.

8. Select Yes I want to restart my computer now; then, click Finish.

9. Continue with “Verifying the RDAC installation”.

Verifying the Redundant Disk Array Controller installation
This section provides instructions for verifying that RDAC has been installed
correctly on a Windows NT 4.0 and a Windows 2000 operating system.

Windows NT 4.0
To verify that RDAC has been installed correctly, do the following:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start → Settings → Control Panel. The Control Panel window opens.

2. Double-click Devices. The Devices window opens.

3. Scroll to symarray.

v If symarray appears with a device status of Started, go to step 4.

v If symarray does not appear, an error might have occurred. Repeat the
procedure outlined in “Installing the Redundant Disk Array Controller”. If the
failure persists, call your IBM technical-support representative. Otherwise, go
to step 4.

4. Do one of the following:

v If you are managing the storage subsystems using the host-agent method,
continue with “Storage Manager 8.21 Agent” on page 46.

v If you are managing your storage subsystems directly, go to “Storage
Manager 8.21 Utility” on page 48.
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Windows 2000
To verify that RDAC has been installed correctly, do the following:

1. Right-click My Computer.

2. Click Start → Programs → Administrative Tools → Computer Management.
The Computer Management window opens. Go to the \System Tools\Software
Information\Software environment\drives directory.

3. Scroll through the list of device drivers until you find rdacfltr.

4. Verify that rdacfltr is displayed with the state type Running and status OK. If it is
not, repeat the procedure outlined in “Installing the Redundant Disk Array
Controller” on page 45. If the failure persists, call your IBM technical-support
representative. Otherwise,

v If you are managing the storage subsystems using the host-agent method,
continue with “Storage Manager 8.21 Agent”.

v If you are managing your storage subsystems using the direct-management
method, go to “Storage Manager 8.21 Utility” on page 48.

Storage Manager 8.21 Agent
The Storage Manager 8.21 Agent software must be installed if you want to manage
the storage subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:

v You have Administrator privileges on the host computer.

v The host computer has at least 1 MB of available disk space.

v RDAC is installed on each host computer. If not, refer to “Redundant Disk Array
Controller” on page 44.

v (For Windows NT 4.0) Microsoft Virtual Machine is installed (refer to “Microsoft
Virtual Machine” on page 42).

v All storage subsystems are connected to the host computer and are powered on.

Installing Storage Manager 8.21 Agent
To install Storage Management 8.21 Agent, do the following:

1. Close all programs.

2. Insert the IBM FAStT Storage Manager Version 8.21 CD in the CD-ROM drive.

3. Click Start → Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\SMagent folder; then, click Open.

7. Select the setup.exe file; then, click Open. The InstallShield window opens,
showing the status the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement (EULA) window opens.

9. Read the license and click Yes to begin the installation. The software
installation ends, and the Operation Complete window opens.

10. Click Finish.

11. Continue with“Verifying the Storage Manager 8.21 Agent installation”

Verifying the Storage Manager 8.21 Agent installation
This section provides instructions for verifying that Storage Manager 8.21 Agent has
been installed correctly on Windows NT 4.0 and Windows 2000.
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Windows NT 4.0
To verify that Storage Manager 8.21 Agent has been installed correctly, do the
following:

1. Click Start → Settings → Control Panel. The Control Panel window opens.

2. Double-click Services. The Services window opens.

3. Scroll through the list of services until you find IBM FAStT Storage Manager 8
Agent.

v If IBM FAStT Storage Manager 8 Agent appears with a startup type of
Started, close the Services window and continue to step 4.

v If IBM FAStT Storage Manager 8 Agent does not appear with a startup type
of Started, click Start. If the status changes to Started, go to step 4. If not,
refer to Table 12 on page 83 for a possible cause. Otherwise, reinstall IBM
FAStT Storage Manager 8.21 Agent. If the problem persists, contact your IBM
technical-support representative.

4. Do one of the following:

v If you plan to use the host-agent software to manage one or more storage
subsystems, go to “Storage Manager 8.21 Utility” on page 48.

v If you do not plan to use the host-agent software to manage one or more
storage subsystems, do the following to disable the host-agent service:

a. Click Start → Settings → Control Panel. The Control Panel window opens.

b. Double-click Services. The Services window opens.

c. From the list of displayed services, right-click IBM FAStT Storage Manager
8 Agent.

d. Click Properties → Startup Type → Manual.

e. Click OK.

5. Continue with “Storage Manager 8.21 Utility” on page 48.

Windows 2000
To verify that Storage Manager 8.21 Agent has been installed correctly, do the
following:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start → Programs → Administrative Tools → Services. The Services
window opens.

2. Scroll through the list of services until you find IBM FAStT Storage Manager 8
Agent.

3. If IBM FAStT Storage Manager 8 Agent does not appear with a startup type of
Started, click Start. If the status changes to Started, go to step 4. If not, refer to
Table 12 on page 83 for a possible cause. Otherwise, reinstall IBM FAStT
Storage Manager 8.21 Agent. If the problem persists, contact your IBM
technical-support representative.

4. Do one of the following:

v If you plan to use the host-agent software to manage one or more storage
subsystems, go to “Storage Manager 8.21 Utility” on page 48.

v If you do not plan to use the host-agent software to manage one or more
storage subsystems, do the following to disable the host-agent service:

a. Click Start → Programs → Administrative Tools → Computer
Management. The Computer Management window opens.

b. Click Services.
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c. From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Click Properties → Startup Type → Manual.

e. Click OK.

5. Continue with “Storage Manager 8.21 Utility”.

Storage Manager 8.21 Utility
This section provides instructions for installing Storage Manager 8.21 Utility on host
computers. This component contains utilities that will register and map new logical
drives to the operating systems.

Installing Storage Manager 8.21 Utility
To install Storage Manager 8.21 Utility, do the following:

1. Close all programs and insert the IBM FAStT Storage Manager Version 8.21
installation CD in the CD-ROM drive.

2. Click Start → Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the \Win32\SMutil folder; then, click Open.

6. Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next.

8. The End User License Agreement (EULA) window opens. Click Yes to begin
the installation. After the installation is complete, the Operation Complete
window opens.

9. Click Finish.

10. Continue with “Verifying the Storage Manager 8.21 Utility installation”.

Verifying the Storage Manager 8.21 Utility installation
To verify that Storage Manager 8.21 Utility has been installed correctly, do the
following:

1. Go to the following directory:

installation_directory\IBM_FAStT\Util

where installation_directory is the directory where you installed the Storage
Manager 8.21 Utility.

2. Verify that the directory contains the following files:

v hot_add.exe

v SMdevices.bat

v SMflashcopyassist.exe

If it does not, reinstall the Storage Manager 8.21 Utility using the procedure
outlined in “Installing Storage Manager 8.21 Utility”. If the problem persists
contact your IBM technical-support representative.

3. Go to Chapter 5, “Completing the installation” on page 67.
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Chapter 4. Installing software in a cluster server environment

This chapter describes how to install the storage-management software in a cluster
server environment.

The installation process you will use depends on your storage subsystem
environment. If you have existing storage systems, read “Installation types” on
page 11 and “Managing coexisting storage subsystems” on page 14.

To ensure proper installation, complete all preparation tasks described in Chapter 2,
“Preparing for installation” on page 21.

If upgrading from a previous version of IBM FAStT Storage Manager on a existing
cluster, go to “Upgrading from a previous version of the storage-management
software” on page 60.

Important: Always check for a README file on any installation media. A README
file might contain important information that was not available when the Installation
and Support Guide was prepared.

Installing the hardware
The hardware installation involves installing host adapters and storage subsystems.
Before you begin the installation of Storage Manager 8.21, make sure that all
hardware components are installed correctly for the cluster server configuration.

Configuration options
You can connect the storage subsystem to the cluster nodes either directly or
through Fibre Channel switches. Both configurations offer full redundancy. The
following figure illustrates both configurations.
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Host adapters
Refer to the appropriate host-adapter documentation for specific installation
requirements and procedures. The following considerations apply:

v To use the dual-path configuration, do the following:

– Install two host adapters in each node.

– Run two fibre channel cables from each node to the storage subsystem.

Node A

Host adapters

Node A

Host adapters

Node B

Host adapters

Node B

Host adapters

Switch Switch

Storage
subsystem
controllers

Storage
subsystem
controllers

Storage subsystem

Storage subsystem

Interlink

Interlink

Fibre Channel
connection
(direct)

Fibre Channel
connection
(Fibre Channel switch)

Mini hub
1

Mini hub
1

Mini hub
2

Mini hub
2

Figure 16. Installing the storage subsystem on a Fibre Channel network
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v If the storage subsystem is connected through a Fibre Channel Arbitrated Loop
(FC-AL), ensure that every adapter on the loop has been assigned a unique hard
ID. For instructions about changing hard IDs, refer to the documentation provided
with your host adapters.

v The correct device driver is installed for the host adapter. Refer to the README
file in the \Host_Adapter directory on the IBM FAStT Storage Manager Version
8.21 CD for information on supported host adapters and device drivers.

Storage subsystems
Refer to the appropriate hardware documentation for specific installation
requirements and procedures. If you are managing storage subsystems directly, you
must connect Ethernet cables to both controllers in each storage subsystem.

Installing Storage Manager in a cluster environment
Do the following to install the storage-management and cluster service software:

1. Be sure that the host bus adapter and driver is installed in each cluster node.

2. Power down node B. Start node A.

3. Install the storage-management software on node A. Refer to “Installing the
storage-management software” on page 52 for instructions.

4. Complete the procedures detailed in Chapter 5, “Completing the installation” on
page 67.

5. Run the Hot Add utility on node A. Refer to “Using the Hot Add utility” on
page 78 for instructions.

Note: You may have to restart node A in order to see the newly-added logical
drives.

6. Format all shared logical drives as NTFS (NT File System), assign volume
labels, and specify a drive letter for each.

Important: You must assign a permanent (sticky) drive letter to the shared
logical drive on both cluster nodes. The two nodes must have the same drive
letters on each shared drive. If you do not assign permanent drive letters,
Windows might assign different drive letters on each node. Assigning a
permanent drive letter ensures that Windows assigns the same drive letter to
the partition on both cluster nodes.

7. Shut down node A. Start node B.

8. Install the storage-management software on node B. Refer to “Installing the
storage-management software” on page 52 for instructions.

9. To verify the drive letters for the cluster configuration, do one of the following:

v For Windows NT, click Start → Programs → Administrative Tools → Disk
Administrator.

v For Windows 2000, do the following:

a. Click Start → Programs → Administrative Tools → Computer
Management. The Computer Management window opens.

b. Click Storage → Disk Management.

10. Verify that the following conditions are met:

v The same logical drives appear on each cluster node.

v Each cluster node has the same number of partitions defined on the logical
drives.

v Drive letters are assigned to the configured logical drives.
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v The drive letters on the partitions are the same on both cluster nodes.

11. Shut down node B.

12. Install the cluster server software. Refer to “Installing the cluster server
software” on page 59 for instructions.

13. Go to Chapter 5, “Completing the installation” on page 67.

Installing the storage-management software
Before you begin an installation with existing storage subsystems, refer to your
hardware installation documentation for the specific configuration. A specific
configuration might be required for your hardware to support the
storage-management software in a cluster configuration.

The Storage Manager 8.21 software components must be installed on both
management stations and cluster nodes.

Management station: A management station is a system that is used to manage
the storage subsystem. It can be attached to the storage subsystem in the following
ways:

v Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

v Through a TCP/IP network connection to a cluster node with the host-agent
software installed

You must install storage-management software on a management station in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.21 Client

Cluster node: The cluster nodes are directly attached to the storage subsystem
through a Fibre Channel I/O path.

You must install storage management software on each cluster node in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.21 Client

3. Redundant Disk Array Controller

4. Storage Manager 8.21 Agent

5. Storage Manager 8.21 Utility

If you are installing the Storage Manager software on a Windows NT platform, see
“Installing the Microsoft Virtual Machine” to begin the installation.

If you are installing the Storage Manager software on a Windows 2000 platform,
see “Storage Manager 8.21 Client” on page 53 to begin the installation.

Installing the Microsoft Virtual Machine
On Windows NT, Microsoft Virtual Machine is required to support the following
components:

v Event Monitor option of Storage Manager 8.21 Client

v Storage Manager 8.21 Agent
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To install Microsoft Virtual Machine on management stations or cluster nodes, do
the following:

1. Close all programs.

2. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM
drive.

3. Click Start → Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\MSVM\NT folder; then, click Open.

7. Select the MSJavx86-3805.exe file; then, click Open.

8. Click Finish and follow the instructions on the screen. When the software is
installed, the Setup Complete window opens.

9. Click No, do not restart the system at this time.

10. Continue with “Storage Manager 8.21 Client”.

Storage Manager 8.21 Client
This section provides instructions for installing Storage Manager 8.21 Client on
management stations and cluster nodes.

Before you install the software, make sure that:

v The management station or host computer has at least 40 MB of available disk
space.

v All programs are closed.

v For Windows NT systems, that the Microsoft Virtual Machine software has been
installed on the device. Refer to “Installing the Microsoft Virtual Machine” on
page 52.

Important: When you install Storage Manager Client on a stand-alone host and
manage storage subsystems through the Fibre Channel I/O path rather than
through the network, you must install the TCP/IP software on the host and assign
an IP address to the host.

Installing Storage Manager 8.21 Client
To install Storage Manager 8.21 Client, do the following:

1. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM
drive.

2. Click Start → Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the \Win32\SMclient folder; then, click Open.

6. Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens. The Welcome window opens.

7. Click Next. The End User License Agreement (EULA) window opens.

Note: For Windows NT 4.0, ensure that the Microsoft Virtual Machine is
installed before you install the Event Monitor.

8. Read the license agreement and click Yes. The Event monitor window opens.

9. At the prompt, click Yes if you want to install the Event Monitor. The Choose
Destination Location window opens.

10. Click Browse to change the destination location.
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11. Click Next to start the installation. When the installation is complete, the
Operation Complete window opens.

12. Click Finish.

13. Continue with “Verifying the Storage Manager 8.21 Client”.

Verifying the Storage Manager 8.21 Client
This section provides instructions for verifying that Storage Manager 8.21 Client has
been installed correctly.

Do the following to verify that the Storage Manager 8.21 Client software is installed
correctly:

1. Click Start → Programs.

2. Verify that IBM FAStT Storage Manager 8 Client appears in the Program list. If
the IBM FAStT Storage Manager 8 Client appears, go to step 3.

Otherwise, repeat “Installing Storage Manager 8.21 Client” on page 53. If the
IBM FAStT Storage Manager 8 Client still does not appear, a failure has
occurred. Contact your IBM technical-support representative.

3. If you installed the optional Event Monitor service, go to “Verifying the Event
Monitor installation”. Otherwise, continue to step 4.

4. If you are installing Storage Manager 8.21 Client on a host computer, go to
“Redundant Disk Array Controller” on page 55. Otherwise, go to Chapter 5,
“Completing the installation” on page 67.

Verifying the Event Monitor installation
This section provides instructions for verifying that the IBM FAStT Event Monitor
service has been installed correctly on the following operating systems:

v Windows NT 4.0

v Windows 2000

Windows NT 4.0: To verify that the IBM FAStT Event Monitor service has been
installed correctly, do the following:

1. Click Start → Settings → Control Panel. The Control Panel window opens.

2. Double-click Services. The Services window opens.

3. Verify that IBM FAStT Storage Manager 8 Event Monitor service is displayed
with the status Started. If it is not, click Start. If the service does not start,
reinstall the Storage Manager 8.21 Client. If the failure persists, call your IBM
technical-support representative.

4. If you are installing the storage-management software on a cluster node, go to
“Redundant Disk Array Controller” on page 55. Otherwise, go to Chapter 5,
“Completing the installation” on page 67.

Windows 2000: To verify that the IBM FAStT Storage Manager 8 Event Monitor
service has been installed correctly, do the following:

1. Click Start → Programs → Administrative Tools → Services. The Services
window opens.

2. Verify that the IBM FAStT Storage Manager 8 Event Monitor service is displayed
with the startup type Automatic and status Started. If it is not, click Start. If the
service does not start, reinstall the Storage Manager 8.21 Client. If the failure
persists, call your IBM technical-support representative.

3. If you are installing the storage-management software on a host computer, go to
“Redundant Disk Array Controller” on page 55. Otherwise, go to Chapter 5,
“Completing the installation” on page 67.
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Redundant Disk Array Controller
RDAC must be installed on each cluster node. RDAC contains the multipath device
driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:

v You have Administrator privileges on the cluster nodes.

v Each cluster node has at least 1 MB of available disk space.

v You close all programs.

v The appropriate host bus adapter driver is installed.

If you are installing RDAC on Windows NT 4.0, continue with “Assigning static drive
letters”.

If you are installing RDAC on Windows 2000, continue with “Installing the
Redundant Disk Array Controller”.

Assigning static drive letters

Important:

Before installing RDAC, you must assign static drive letters to existing local drives.
Otherwise, problems might occur during new installations and upgrades. When RDAC is
installed, the RDAC utility installs the RDAC device driver before the Windows NT class
driver. If static drive letters have not previously been assigned to local drives, the system
will detect storage subsystem arrays and assign them drive letters before detecting and
assigning drive letters to local drives. If this occurs and you have software applications
using non-permanent drive letters that are assigned to local drives, application errors will
result.

Use the following procedure to manually assign drive letters on cluster nodes
running Windows NT 4.0:

1. Click Start → Programs → Administrative Tools → Disk Administrator to view
the disk configuration and check the number of partitions.

2. Check that the following conditions are met:

v A boot partition exists.

v The last partition has been created with Disk Administrator or Disk
Management.

v The partition has an assigned drive letter and either an unknown status or a
status other than Unformatted.

If all conditions are met, go to “Installing the Redundant Disk Array Controller”.
Otherwise, continue to step 3.

3. Create a new partition on your local system or on a storage subsystem using
the following procedure:

a. Select a drive with free space; then, click Partition → Create. The partition is
created with a status of Unformatted and a drive letter is assigned. You can
delete or change the logical drive at a later time without causing
reassignment of the boot partition.

b. Click Partition → Commit Changes Now. The partition status changes to
Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with “Installing the Redundant Disk Array Controller”.

Installing the Redundant Disk Array Controller
To install RDAC, do the following:
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1. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM
drive.

2. Click Start → Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select one of the following directories:

For Windows NT 4.0 Enterprise Edition \Win32\SMrdac\NT

Windows 2000 Advanced Server \Win32\SMrdac\W2K

6. Select the setup.exe file; then, click Open. The InstallShield window opens,
showing the file unpacking. The Welcome window opens.

7. Click Next to begin the installation. After installing RDAC, the InstallShield
Wizard window opens.

8. Click Yes to restart your computer.

9. Continue with “Verifying the RDAC installation”.

Verifying the Redundant Disk Array Controller installation
This section provides instructions for verifying that the Redundant Disk Array
Controller has been installed correctly on the following operating systems:

v Windows NT 4.0

v Windows 2000

Windows NT 4.0: To verify that RDAC has been installed correctly, do the
following:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start → Settings → Control Panel. A Control Panel window opens,
double-click Devices.

2. When the Devices window opens, scroll to symarray.

v If symarray appears with a device status of Started, go to step 3.

v If symarray does not appear, an error might have occurred. Repeat the
procedure outlined in “Installing the Redundant Disk Array Controller” on
page 55. If the failure persists, call your IBM technical-support representative.
Otherwise, go to step 3.

3. Do one of the following:

v If you are managing the storage subsystems using the host-agent method,
continue with “Storage Manager 8.21 Agent” on page 57.

v If you are managing your storage subsystems directly, go to “Storage
Manager 8.21 Utility” on page 59.

Windows 2000: To verify that the Redundant Disk Array Controller has been
installed correctly, do the following:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Right-click My Computer.

2. Click Start → Programs → Administrative Tools → Computer Management.
The Computer Management window opens. Go to the \System Tools\System
Information\Software environment\Drivers directory.
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3. Scroll through the list of device drivers until you find rdacfltr.

4. Verify that rdacfltr is displayed with the state type Running and status OK. If it is
not, repeat the procedure outlined in “Installing the Redundant Disk Array
Controller” on page 55. If the failure persists, call your IBM technical-support
representative. Otherwise, go to step 5.

5. Do one of the following:

v If you are managing the storage subsystems using the host-agent method,
continue with “Storage Manager 8.21 Agent”.

v If you are managing your storage subsystems directly, go to “Storage
Manager 8.21 Utility” on page 59.

Storage Manager 8.21 Agent
The Storage Manager 8.21 Agent software must be installed if you want to manage
the storage subsystem using the host-agent method.

Before you install the software, ensure that the following conditions are met:

v You have Administrator privileges on the cluster nodes.

v Each cluster node has at least 1 MB of available disk space.

v You have installed RDAC on each cluster node. If you have not done so, refer to
“Redundant Disk Array Controller” on page 55.

v (For Windows NT 4.0) You have installed Microsoft Virtual Machine (refer to
“Installing the Microsoft Virtual Machine” on page 52).

Installing Storage Manager 8.21 Agent
To install Storage Management 8.21 Agent, do the following:

1. Close all programs.

2. Insert the IBM FAStT Storage Manager Version 8.21 CD in the CD-ROM drive.

3. Click Start → Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\SMagent folder; then, click Open.

7. Select the setup.exe file; then, click Open. The InstallShield window opens,
showing the status the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement (EULA) window opens.

9. Read the license and click Yes to begin the installation. The software
installation ends, and the Operation Complete window opens.

10. Click Finish.

11. Continue with“Verifying the Storage Manager 8.21 Agent”.

Verifying the Storage Manager 8.21 Agent
This section provides instructions for verifying that Storage Management 8.21 Agent
has been installed correctly on the following operating systems:

v Windows NT 4.0

v Windows 2000

Windows NT 4.0: To verify that Storage Manager 8.21 Agent has been installed
correctly, do the following:

1. Click Start → Settings → Control Panel. The Control Panel window opens.

2. Double-click Services. The Services window opens.
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3. Scroll through the list of services until you find IBM FAStT Storage Manager 8
Agent.

v If IBM FAStT Storage Manager 8 Agent appears with a startup type of
Started, close the Services window, and continue to step 4.

v If IBM FAStT Storage Manager 8 Agent does not appear with a startup type
of Started, click Start. If the status changes to Started, go to step 4 on
page 47. If not, refer to Table 12 on page 83 for a possible cause. Otherwise,
reinstall IBM FAStT Storage Manager 8.21 Agent. If the problem persists,
contact your IBM technical-support representative.

4. Do one of the following:

v If you plan to use the host-agent software to manage one or more storage
subsystems, go to “Storage Manager 8.21 Utility” on page 59.

v If you do not plan to use the host-agent software to manage one or more
storage subsystems, do the following to disable the host-agent service:

a. Click Start → Programs → Administrative Tools → Manage. The
Computer Management window opens.

b. Click Services.

c. From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Click Properties → Startup Type → Manual.

e. Click OK.

5. Continue with “Storage Manager 8.21 Utility” on page 59.

Windows 2000: To verify that Storage Manager 8.21 Agent has been installed
correctly, do the following:

1. Click Start → Programs → Administrative Tools → Services. The Services
window opens.

2. Scroll through the list of services until you find IBM FAStT Storage Manager 8
Agent.

3. Verify that IBM FAStT Storage Manager Agent is displayed with the startup type
Automatic and status Started. If IBM FAStT Storage Manager 8 Agent does not
appear with a startup type of Started, click Start. If the status changes to
Started, go to step 4 on page 47. If not, refer to Table 12 on page 83 for a
possible cause. Otherwise, reinstall IBM FAStT Storage Manager 8.21 Agent. If
the problem persists, contact your IBM technical-support representative.

4. Do one of the following:

v If you plan to use the host-agent software to manage one or more storage
subsystems, go to “Storage Manager 8.21 Utility” on page 59.

v If you do not plan to use the host-agent software to manage one or more
storage subsystems, do the following to disable the host-agent service:

a. Click Start → Programs → Administrative Tools → Computer
Management. The Computer Management window opens.

b. Click Services.

c. From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Click Properties → Startup Type → Manual.

e. Click OK.

5. Continue with “Storage Manager 8.21 Utility” on page 59.
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Storage Manager 8.21 Utility
This section provides instructions for installing the Storage Manager 8.21 Utility
software on cluster nodes. This component contains utilities that will register and
map new logical drives to the operating systems.

Installing Storage Manager 8.21 Utility
To install Storage Manager 8.21 Utility, do the following:

1. Close all programs and insert the IBM FAStT Storage Manager Version 8.21
installation CD in the CD-ROM drive.

2. Click Start → Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the \Win32\SMutil folder; then, click Open.

6. Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next.

8. The End User License Agreement (EULA) window opens. Click Yes to begin
the installation. After the installation is complete, the Operation Complete
window opens.

9. Click Finish.

10. Continue with “Verifying the Storage Manager 8.21 Utility installation” on
page 48.

Verifying the Storage Manager 8.21 Utility installation
To verify that Storage Manager 8.21 Utility has been installed correctly, do the
following:

1. Go to the following directory:

installation_directory\IBM_FAStT\Util

where installation_directory is the directory where you installed the Storage
Manager 8.21 Utility.

2. Verify that the directory contains the following files:

v hot_add.exe

v SMdevices.bat

v SMflashcopyassist.exe

If it does not, reinstall the Storage Manager 8.21 Utility using the procedure
outlined in “Installing Storage Manager 8.21 Utility” on page 48. If the problem
persists, contact your IBM technical-support representative.

3. Go to “Installing Storage Manager in a cluster environment” on page 51.

Installing the cluster server software

Important:

Do not perform this procedure unless you have installed the necessary
storage-management software components on both cluster nodes.

To install the cluster server software on Nodes A and B, do the following:
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1. Install the cluster server software on Node A, as follows:

a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for
the correct procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.

b. After the system restarts, leave Node A running.

2. Install the cluster server software on Node B, as follows:

a. Refer to the appropriate MSCS documentation for the correct procedure to
install the Cluster Server software.

Note: During installation, specify that you want to join the existing cluster.

b. After the system restarts, leave Node B running.

3. After installing MSCS, do one of the following:

v For systems running Windows NT, reinstall Service Pack 6a.

v For systems running Windows 2000, reinstall Service Pack 2.

Note: Refer to Microsoft knowledge base article Q174799 for more information
about installing a service pack in a cluster environment.

4. Verify the software installation, as follows:

a. On either node A or node B, click Start → Programs → Administrative Tools
→ Cluster Administration.

b. In the Cluster or Server Name field, type either the name of the cluster or
the name or IP address of one of the nodes.

If the installation is successful, the computer names of both nodes appear
on the left side of the Cluster Administrator window.

c. Make sure that the cluster disk groups can be moved between cluster
nodes.

5. If both node names do not appear on the left side of the Cluster Administrator
window, reinstall the cluster server software. If the problem persists, contact
your IBM technical-support representative.

Upgrading from a previous version of the storage-management
software

Be sure that you are familiar with the steps required in a new installation before you
continue with the following upgrade procedure.

Choose one of the following two procedures:

v Performing a scheduled upgrade: A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and
storage-management software. The services and resources offered by the cluster
are not available during the upgrade.

Note: The scheduled upgrade is the preferred procedure for upgrading a cluster
server configuration.

v Performing a rolling upgrade: A rolling upgrade requires upgrading the
storage-management software first in node A and then in node B, so that the
services and resources offered by the cluster are always available.

Important: Do not upgrade your storage subsystem firmware until you have
upgraded the storage-management software on all cluster nodes and management
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stations. If you upgrade your storage subsystem controller firmware to version
05.2x.xx.xx, you will not be able to communicate with the controller until you have
upgraded to Storage Manager 8.21 software on your management station and
cluster nodes. Previously installed versions of Storage Manager will not recognize
controllers running version 05.2x.xx.xx firmware.

Performing a scheduled upgrade
To perform a scheduled upgrade from Storage Manager version 7.0, 7.01, 7.02,
7.10, 8.0 to Storage Manager 8.21, do the following:

1. Before installing the storage-management software, do the following:

a. Click Start → Programs → Administrative Tools → Services. The Services
window opens.

b. From the list of displayed services, right-click the cluster server. Then, click
Manual.

c. Stop the cluster server on all nodes in the cluster configuration.

2. Shut down node B.

3. From node A, uninstall the components from the previous version of the
storage-management software. To uninstall the storage-management software
for Storage Manager Version 7.x, or 8.0 see “Uninstalling storage-management
software components” on page 80.

Note: Uninstall the storage-management components in the following order:

a. Storage Manager Agent

b. Storage Manager Utility

c. Redundant Disk Array Controller

d. Storage Manager Client

4. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the README file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

5. Install the Storage Manager 8.21 Client on node A. Refer to “Storage Manager
8.21 Client” on page 53 for instructions.

6. Install the Redundant Disk Array Controller on node A. Refer to “Redundant
Disk Array Controller” on page 55 for instructions.

7. Install the Storage Manager 8.21 Agent on node A. Refer to “Storage Manager
8.21 Agent” on page 57 for instructions.

8. Install the Storage Manager 8.21 Utility on node A. Refer to “Storage Manager
8.21 Utility” on page 59 for instructions.

9. Shut down node A.

10. Restart node B.

11. From node B, uninstall the components from the previous version of the
storage-management software. To uninstall the storage-management software
for Storage Manager Version 7.x and 8.0, refer to “Uninstalling
storage-management software components” on page 80.

12. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the README file located in the \Host_Adapter directory on
the installation CD and upgrade the device driver versions before continuing.

13. Install the Storage Manager 8.21 Client on node B. Refer to “Storage Manager
8.21 Client” on page 53 for instructions.

14. Install the Redundant Disk Array Controller on node B. Refer to “Redundant
Disk Array Controller” on page 55 for instructions.
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15. Install the Storage Manager 8.21 Agent on node B. Refer to “Storage Manager
8.21 Agent” on page 57 for instructions.

16. Install the Storage Manager 8.21 Utility on node B. Refer to “Storage Manager
8.21 Utility” on page 59 for instructions.

17. Shut down node B.

18. Start up one node at a time and complete the following procedure:

a. Click Start → Programs→ Administrative Tools → Services. The Services
window opens.

b. From the list of displayed services, right-click the cluster server. Click
Automatic to change the cluster server startup option.

c. Start the cluster server service on node B.

19. Go to Chapter 5, “Completing the installation” on page 67.

Performing a rolling upgrade

Important:

If you have applications installed in the cluster server environment that do not support a
rolling upgrade, you must do one of the following:

v Put those resources offline before the upgrade; then, put them back online after the
upgrade.

v Perform a scheduled upgrade. A scheduled upgrade requires scheduling downtime on
your cluster server to upgrade the controller firmware and storage-management software.

To perform a rolling upgrade from Storage Manager version 7.0, 7.01, 7.02, or 7.10
to Storage Manager 8.21, do the following:

1. From node A, open Cluster Administrator.

2. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

3. Select each group listed, and move them to node B.

4. Select node A; then, click File → Pause Node to pause cluster service in node
A.

5. From node A, uninstall the components from the previous version of the
storage-management software. To uninstall the storage-management software
for Storage Manager Version 7.x or 8.10 refer to “Uninstalling
storage-management software components” on page 80.

Note: Uninstall the storage-management components in the following order:

a. Storage Manager Agent

b. Storage Manager Utility

c. Redundant Disk Array Controller

d. Storage Manager Client

6. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the README file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

7. Install the Storage Manager 8.21 Client on node A. Refer to “Storage Manager
8.21 Client” on page 53 for instructions.

8. Install the Redundant Disk Array Controller on node A. Refer to “Redundant
Disk Array Controller” on page 55 for instructions.
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9. Install the Storage Manager 8.21 Agent on node A. Refer to “Storage Manager
8.21 Agent” on page 57 for instructions.

10. Install the Storage Manager 8.21 Utility on node A. Refer to “Storage Manager
8.21 Utility” on page 59 for instructions.

11. Run Cluster Administrator; then, click File → Resume Node to resume cluster
service in node A.

12. From node B, open Cluster Administrator.

13. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

14. Select each group listed, and move them to node A.

15. Select node B; then, click File → Pause Node to pause cluster service in node
B.

16. From node B, uninstall the components from the previous version of the
storage-management software. To uninstall the storage-management software
for Storage Manager Version 7.x or 8.10, refer to “Uninstalling
storage-management software components” on page 80.

17. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the README file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

18. Install the Storage Manager 8.21 Client on node B. Refer to “Storage Manager
8.21 Client” on page 53 for instructions.

19. Install the Redundant Disk Array Controller on node B. Refer to “Redundant
Disk Array Controller” on page 55 for instructions.

20. Install the Storage Manager 8.21 Agent on node B. Refer to “Storage Manager
8.21 Agent” on page 57 for instructions.

21. Install the Storage Manager 8.21 Utility on node B. Refer to “Storage Manager
8.21 Utility” on page 59 for instructions.

22. Run Cluster Administrator; then, click File → Resume Node to resume cluster
service in node B.

23. Go to Chapter 5, “Completing the installation” on page 67.

Upgrading from Windows NT 4.0 to Windows 2000 in a cluster
configuration

To ensure that the services and resources offered by the cluster are always
available, you must perform a rolling upgrade. A rolling upgrade requires upgrading
the controller firmware, storage-management software, and operating system first in
node A and then in node B.

Important:

If you have applications installed in the cluster server environment that do not support a
rolling upgrade, you must do one of the following:

v Put those resources offline before the upgrade; then, put them back online after the
upgrade.

v Perform a scheduled upgrade. A scheduled upgrade requires scheduling downtime on
your cluster server to upgrade the controller firmware and storage-management software.

To upgrade from Windows NT 4.0 Enterprise Edition to Windows 2000 Advanced
Server, do the following:

1. On node A, open Cluster Administrator.
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2. Double-click on the Active Groups folder in the right pane of Cluster
Administrator.

3. Make sure that all of the groups failover to node B successfully.

4. Select node A; then, click File → Pause Node to pause cluster service in node
A.

5. From node A, uninstall all storage-management software components. To
uninstall the storage-management software, refer to “Uninstalling
storage-management software components” on page 80. The
storage-management components should be uninstalled in the following order:

a. Storage Manager 8.21 Agent

b. Storage Manager 8.21 Utility

c. Storage Manager 8.21 Redundant Disk Array Controller

d. Storage Manager 8.21 Client

6. Follow the instructions from Microsoft to upgrade node A from Windows NT
Enterprise Edition to Windows 2000 Advanced Server.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node A will rejoin the cluster and remain
paused.

7. Verify that the host bus adapter (HBA) device driver versions are correct. If
they are not the certified versions, refer to the README file in the
\Host_Adapter directory on the installation CD and upgrade the device driver
versions before continuing.

8. Verify that node A was successfully upgraded to Windows 2000 Advanced
Server.

9. Install the Storage Manager 8.21 Client on node A. Refer to “Storage Manager
8.21 Client” on page 53 for instructions.

10. Install the Redundant Disk Array Controller on node A. Refer to “Redundant
Disk Array Controller” on page 55 for instructions.

11. Install the Storage Manager 8.21 Agent on node A. Refer to “Storage Manager
8.21 Agent” on page 57 for instructions.

12. Install the Storage Manager 8.21 Utility on node A. Refer to “Storage Manager
8.21 Utility” on page 59 for instructions.

13. Run Cluster Administrator; then, click File → Resume Node to resume cluster
service in node A.

14. On node B, open Cluster Administrator.

15. Double-click on the Active Groups folder in the right pane of Cluster
Administrator.

16. Make sure that all of the groups failover to node A successfully.

17. Select node B; then, click File → Pause Node to pause cluster service in node
B.

18. From node B, uninstall all storage-management software components. To
uninstall the storage-management software, refer to “Uninstalling
storage-management software components” on page 80. The
storage-management components should be uninstalled in the following order:

a. Storage Manager Agent

b. Storage Manager Utility

c. Redundant Disk Array Controller

d. Storage Manager Client
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19. Follow the instructions from Microsoft to upgrade node B from Windows NT
Enterprise Edition to Windows 2000 Advanced Server.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node B will rejoin the cluster and remain
paused.

20. Verify that the host bus adapter (HBA) device driver versions are correct. If
they are not the certified versions, refer to the README file in the
\Host_Adapter directory on the installation CD and upgrade the device driver
versions before continuing.

21. Verify that node B was successfully upgraded to Windows 2000 Advanced
Server.

22. Install the Storage Manager 8.21 Client on node B. Refer to “Storage Manager
8.21 Client” on page 53 for instructions.

23. Install the Redundant Disk Array Controller on node B. Refer to “Redundant
Disk Array Controller” on page 55 for instructions.

24. Install the Storage Manager 8.21 Agent on node B. Refer to “Storage Manager
8.21 Agent” on page 57 for instructions.

25. Install the Storage Manager 8.21 Utility on node B. Refer to “Storage Manager
8.21 Utility” on page 59 for instructions.

26. Run Cluster Administrator; then, click File → Resume Node to resume cluster
service in node B.

27. Go to Chapter 5, “Completing the installation” on page 67.
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Chapter 5. Completing the installation

This chapter contains procedures for using Enterprise Management and Subsystem
Management to complete the following installation tasks:

1. Perform an initial automatic discovery of storage subsystems.

2. Add devices, if necessary.

3. Set up alert notifications, if you want.

4. Name the storage subsystems.

5. Download firmware and NVSRAM.

6. Create arrays and logical drives.

7. Define the default host type.

8. Configure the heterogeneous hosts.

9. Perform other storage subsystem tasks.

The Enterprise Management window opens when you start IBM FAStT Storage
Manager. Use the Enterprise Management window to:

v Add and discover the storage subsystems

v View all storage subsystems in your management domain

v Perform batch storage subsystem management tasks using the Script Editor

Performing an initial automatic discovery of storage subsystems
To perform an initial automatic discovery of storage subsystems, do the following:

1. Click Start → Programs.

2. Click IBM FAStT Storage Manager 8 Client. The client software starts,
displaying the Enterprise Management window and the Confirm Initial Automatic
Discovery window.
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Note: The Enterprise Management window might take several minutes to open.
No wait cursor (such as an hourglass) is displayed.

3. Click Yes to begin an initial automatic discovery of hosts and storage
subsystems attached to the local subnetwork.

After the initial automatic discovery is complete, the Enterprise Management
window displays all hosts and storage subsystems attached to the local
subnetwork.

Note: The Enterprise Management window might take up to a minute to refresh
after an initial automatic discovery.

Figure 17. Confirm Initial Automatic Discovery window
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4. Verify that each host and storage subsystem is displayed in the Enterprise
Manager window.

If a hosts or storage subsystem is not displayed, do the following:

v Check the hardware and connections for possible problems (refer to the
hardware documentation for specific procedures).

v Refer to the Enterprise Management online help for additional information
about discovering storage subsystems.

v If using the direct-management method, verify that all hosts and storage
subsystems are connected to the same subnet network. If using the
host-agent method, ensure that the fibre channel connection between the
host and storage subsystems is made.

v Make sure that all of the preparation steps for setting up the storage
subsystem for a direct-managed system in Chapter 2 are completed. If they
are, use the Add Device option to add the IP addresses of the Storage
subsystem. You add both IP addresses of the controller. Otherwise, you will
get a ″partially-managed device″ error message when you try to manage the
storage subsystem.

v If using the host-agent management method, make sure that the Storage
Manager 8.21 Agent is installed in the host. Then, verify that you have a fibre
channel connection from the storage subsystems to the host that has the
Storage Manager 8.21 Agent installed. Then, verify that all of the preparation
steps outlined in Chapter 2 have been completed. If they have, run the Hot
Add Utility. Then, restart the Storage Manager 8.21 Agent using the
information in “Stopping and restarting the host-agent software” on page 80.
Click Tools → Rescan in the Enterprise management window.

Note: In certain situations, a storage subsystem might be duplicated in the
device tree after an automatic discovery. You can remove a duplicate

Figure 18. Enterprise Management window
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storage-management icon from the device tree using the Remove Device
option in the Enterprise Management window.

5. Verify that the status of each storage subsystem is Optimal. If a device shows a
status of Unresponsive, right-click the device and select Remove Device to
delete it from the management domain; then, use the Add Device option to add
it to the management domain again. Refer to the Enterprise Management
window online help for instructions on removing and adding devices.

6. Continue with “Adding devices”.

Adding devices
You can manually add more hosts or storage subsystems. You can use this option
to selectively manage a group of storage subsystems from a Storage Manager 8
Client. You can also use this option to add additional devices to be managed that
were not discover during the Storage Manager 8 Client initial discovery. For more
information about this option, refer to the Enterprise Management window online
help.

Important:

v When you add new storage subsystems to the existing storage subsystems in a
Storage Area Network (SAN) that are managed through the host-agent software,
you must stop and restart the host-agent service. When the host-agent service
restarts, the new storage subsystem is detected. For more information, refer to
“Stopping and restarting the host-agent software” on page 80. Then, go to the
Enterprise Management window and click Tools → Rescan to add the new
storage subsystems to the management domain.

v When you add new storage subsystems to existing storage subsystems that are
managed using the direct-management method, be sure and specify the IP
addresses for both controllers.

Continue with “Setting up alert notifications”.

Setting up alert notifications
After you add devices to the management domain, you can set up alert notification
to report critical events on the storage subsystems. The following alert-notification
options are available:

v Notification to a designated network management station (NMS) using Simple
Network Management Protocol (SNMP) traps

v Notification to designated e-mail addresses

v Notification to designated alphanumeric pagers (requires separately supplied
software to convert e-mail messages)

Note: You can only monitor storage subsystems within the management domain. If
you do not install Event Monitor service, the Enterprise Management window
must remain open. If you close the window, you will not receive any alert
notifications from the managed storage subsystems. Refer to the Enterprise
Management window online help for additional information.

To set up alert notification to a NMS using SNMP traps, do the following:

1. Insert the IBM FAStT Storage Manager Version 8.21 CD into the CD-ROM drive
on a network management station (NMS). You need to set up the designated
management station only once.

2. Copy the SM820.MIB file from the SM820.mib directory to the NMS.
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3. Follow the steps required by your NMS to compile the management information
base (MIB) file. (For details, contact your network administrator or see the
documentation specific to the storage management product you are using.)

4. Continue with “Naming storage subsystems”.

Naming storage subsystems
To name your storage subsystem, do the following:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens, as
shown in Figure 19.

3. Click Storage Subsystem → Rename. The Rename Storage Subsystem
window opens.

4. Type the name of the storage subsystem (refer to Table 13 on page 89); then,
click OK.

5. Repeat for each unnamed storage subsystem. For more information, refer to the
topic on renaming storage subsystems in the Subsystem Management window
online help.

6. Continue with “Downloading firmware and NVSRAM”.

Downloading firmware and NVSRAM
This section provides instructions for downloading firmware and NVSRAM. You
must download firmware version 05.2x.xx before you download NVSRAM.

Downloading firmware
To download firmware version 05.2x.xx, do the following:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens.

Figure 19. Subsystem Management window
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3. Click Storage Subsystem → Download → Firmware. Follow the instructions that
display.

4. Continue with “Downloading NVSRAM”.

Downloading NVSRAM
To download NVSRAM, do the following:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem→ Download → NVSRAM. Follow the instructions that
display.

4. Continue with “Creating arrays and logical drives”.

Creating arrays and logical drives
A logical drive is the basic structure you create to store data on the storage
subsystem. The operating system recognizes a logical drive as a single drive.
Choose a RAID level to meet application needs for data availability and maximize
Fibre Channel I/O performance.

To create arrays and logical drives, do the following:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens.

3. Click the Logical/Physical View tab.

4. Click Logical Drive → Create. The Logical Drive Create wizard starts. Follow
the online instructions to create arrays and logical drives.

5. Continue with “Verifying and defining the default host type”.

Note: (For cluster configurations) If you add or delete logical drives, you must
make them known to both node A and node B.

Verifying and defining the default host type
Before using the logical drives in a host computer, you must specify the host type.
The host type determines how the storage subsystem controllers will work with
each particular operating system on the hosts to which it is connected. If all of the
host computers connected to the same storage subsystem are running the same
operating system, and you do not want to define partitioning, you can define a
default host type.

To verify the current default host type, do the following:

1. In the Subsystem Management window, click View → Storage subsystem
profile. A Storage Subsystem Profile window opens.

2. Click the Mappings folder tab, and scroll down to NVSRAM Host Type Internal
Definitions. The host type name of the index that has the word DEFAULT next
to it is the default host type.

3. Click Close.

To define a default host type, do the following:

1. Click Storage subsystem → Change → Default host-type. The Default
Host-type window opens.

2. From the pull-down list, select the host type.

72 IBM FAStT Storage Manager Version 8.21: Installation and Support Guide for Microsoft Windows NT and Windows 2000



3. Click OK.

If you have hosts with different operating systems or if you want to define partitions
for the hosts, continue with “Configuring heterogeneous hosts”.

Configuring heterogeneous hosts
The heterogeneous hosts feature enables hosts running different operating systems
to access a single storage subsystem. Previous releases of IBM FAStT Storage
Manager (versions 7.02 or earlier) required that hosts run the same operating
system in order to access a single storage subsystem.

Host computers can run completely different operating systems (for example,
Solaris and Windows NT) or variants of the same operating system (for example,
Windows NT running in a cluster environment or Windows NT running in a
noncluster environment). When a host type is specified in the Define New Host Port
window, the heterogeneous hosts feature enables the controllers in the storage
subsystem to tailor their behavior (such as LUN reporting) to the needs of the host.

Important: To use the heterogeneous host feature, the following conditions must be
met:

v Storage partitioning must be enabled.

v During host-port definition, you must set each host type to the appropriate
operating system so that the firmware on each controller can respond correctly to
the host.

To start the heterogeneous host configuration, do the following:

1. From the Subsystem Management window, click Mappings View.

2. Follow the on-screen instructions.

3. Continue with “Performing other storage-subsystem management tasks”.

Note: Partitioning is a premium feature. If you disable partitioning, you must
contact your IBM technical-support representative to obtain a key to reenable
partitioning.

Performing other storage-subsystem management tasks
Other storage subsystem management tasks you can perform include the following:

v Locating a storage subsystem

v Viewing a storage subsystem profile or event log

v Entering or changing a storage subsystem password

v Creating and managing logical drives and arrays

v Using the Performance Monitor

v Creating storage partitions (if applicable) and heterogeneous hosts

Note: To create storage partitions, you must obtain the worldwide or port of each
host adapter in every host connected to the storage subsystem.

For more information about these and other storage subsystem management tasks,
refer to the appropriate topics in the Subsystem Management online help.

After installing IBM FAStT Storage Manager Version 8.21, consider installing the
FAStT Management Suite Java (FAStT-MSJ) diagnostic program. You can use this
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program to verify the status of the fiber channel connections before using the
storage subsystem. The program and the IBM FAStT MSJ User’s Guide are located
on the IBM FAStT Storage Manager Version 8.21 CD.
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Chapter 6. Using the storage-management software

This chapter provides information about adding or deleting logical drives, creating
FlashCopy logical drives, using the Hot Add and SMdevices utilities, starting and
stopping the host-agent software, and uninstalling Storage Manager components.

Adding or deleting logical drives
Use the following instructions to add or delete logical drives in a standard
(noncluster) configuration.

Standard (noncluster) configuration for Windows NT

Creating logical drives
When you create logical drives with the storage-management software, you must
add the new logical drives to Windows NT. Refer to the Windows NT documentation
for details about adding a drive. Each logical drive (not array) is recognized by
Windows NT as a single drive.

After creating logical drives, run the Hot Add and SMdevices utilities that are
provided with the storage-management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For information
about using these utilities, see “Using the Hot Add utility” on page 78 and “Using the
SMdevices utility” on page 78.

Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click Configure
→ Reset Configure. This will reset the controller unit and delete all previously-configured
logical drives.

Before deleting logical drives with the storage-management software or using
Configure → Reset Configuration, use Cluster Administrator to delete the cluster
physical disk resources that owns the logical drives that will be deleted. Then, use
Disk Administrator to delete any partitions and to unassign drive letters that are
associated with the logical drives. Restart the system to remove the configuration
information.

Attention: You must use Cluster Administrator and Disk Administrator to delete the
cluster physical disk resources, OS partitions, and unassigned drive letters before
deleting logical drives or resetting the configuration in Storage Manager. This will
avoid damage to your registry information.

Cluster server configuration for Windows NT
To add logical drives in a Windows NT 4.0 cluster server environment, do the
following:

1. Using the IBM FAStT Storage Manager 8.21 Client, create arrays and assign
them to the appropriate host group by using storage partitioning.

2. Stop the cluster server service in node A. Make sure that all of the cluster
groups and resources failover to node B.

3. Disable cluster server service and the cluster disk device in node A by doing
the following:

a. Click Start → Settings → Control Panel. The Control Panel window opens.
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b. Click Services. The Services window opens.

c. Select Cluster Server, and click Startup. The Service window opens.

d. Change the Startup Type Setting to Disabled; then, click OK.

e. Close the Services window.

f. Click Start → Settings → Control Panel. The Control Panel window opens

g. Click Devices. The Device window opens.

h. Select Cluster Disk; then, click Startup. The Devices window opens.

i. Select Disabled; then, click OK.

j. Close the Devices window.

4. Restart node A.

5. Use Disk Administrator to create and format your operating system partitions.

6. Enable cluster server service and the cluster disk device in node A. Make sure
that the start-up type is set to System for cluster disk device and Automatic for
cluster server service.

7. Restart node A; then, make sure that the cluster server service has started and
that the cluster groups and resources have failed back correctly.

8. Stop the cluster server service in node B.

9. Using the procedure outlined in step 3 on page 75, disable cluster server
service and the cluster disk device in node B.

10. Restart node B.

11. Use Disk Administrator to reassign the drive letters to match the ones that
were assigned to a given disk in node A.

12. Enable cluster server service and the cluster disk device in node B. Make sure
that the start-up type is set to System for cluster disk device and Automatic for
cluster server service.

13. Restart node B; then, make sure that the cluster server service started and the
cluster groups and resources failed back correctly.

14. Stop the cluster server service in node A.

15. Restart node A.

16. After cluster server service has started, use Cluster Administrator to create
your physical disk resources.

17. Verify that the physical disk resources can be brought online in both nodes.

Standard (noncluster) configuration for Windows 2000
Use the following instructions to add or delete logical drives in a cluster server
environment.

Creating logical drives
When you create logical drives with the storage-management software, you must
add the new logical drives to the Windows 2000 operating system. Each logical
drive (not array) is recognized by Windows 2000 as a single drive.

After creating logical drives, run the HotAdd and SMdevices utilities that are
provided with the storage-management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For more
information about using these utilities, see “Using the Hot Add utility” on page 78or
“Using the SMdevices utility” on page 78.
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Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click Configure
→ Reset Configure. This will reset the controller unit and delete all previously-configured
logical drives.

Before deleting logical drives with the storage-management software or using
Configure → Reset Configuration, use Cluster Administrator to delete the cluster
physical disk resources that owns the logical drives that will be deleted. Then, use
Disk Administrator to delete any partitions and to unassign drive letters that are
associated with the logical drives. Restart the system to remove the configuration
information.

Attention: You must use Cluster Administrator and Disk Administrator to delete the
cluster physical disk resources, OS partitions, and unassigned drive letters before
deleting logical drives or resetting the configuration in Storage Manager. This will
avoid damage to your registry information.

Cluster server configuration for Windows 2000
To add logical drives in a Windows 2000 cluster server environment, do the
following:

1. Using the IBM FAStT Storage Manager 8.21 Client, create arrays and assign
them to the appropriate host group by using storage partitioning.

2. Use the Hot Add utility to add the new logical drives to node A.

3. Using the Disk Administrator, create, format, and assign drive letters to the disk
partitions on the new logical drives.

4. Use the Hot Add utility to add the new logical drives to node B.

5. Using the Disk Administrator, ensure that the drive letters assigned to the disk
partitions on the logical drives are the same on both node A and node B.

6. Restart node A; then, use the Cluster Administrator to create cluster physical
disk resources using the new disk partitions on the new logical drives.

7. Bring the cluster resources online in node A.

8. Use cluster administrator to move the cluster physical disk resources to node B.

9. Verify that the resources come online on node B.

Creating a FlashCopy logical drive
A FlashCopy logical drive is a logical point-in-time image of a logical drive, called a
base logical drive. A FlashCopy logical drive has the following features:

v It is created quickly and requires less disk space than an actual logical drive.

v It can be assigned to a host address, so that you can perform backups using the
FlashCopy logical drive while the base logical drive is online and accessible.

v You can use the FlashCopy logical drive to perform application testing or
scenario development and analysis. This does not effect the actual production
environment.

v The maximum number of FlashCopy logical drives allowed is one half of the total
logical drives supported by your controller model.

For additional information about the FlashCopy feature and how to manage Flash
Copy logical drives, refer to the Storage Manager Subsystem Management online
help.
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Note: FlashCopy is a purchased premium feature. Contact your IBM reseller or
IBM marketing representative for more information.

To create a FlashCopy logical drive, do the following:

1. To ensure that you have the accurate point-in-time image of the base logical
drive, stop applications and flush cache I/O to the base logical drive. For
instructions, see “Using the SMflashcopyassist utility” on page 79.

2. Open the Subsystem Management window. From the Logical View, right-click
the base logical drive.

3. Select Create FlashCopy Logical Drive. The Create FlashCopy Logical Drive
Wizard starts.

4. Follow the on-screen instructions.

5. Refer to the Subsystem Management online help for instructions on how to add
the FlashCopy logical drive to the host.

Using the Remote Mirror feature
The Remote Mirror feature is a purchased premium feature. The Remote Mirror
Option is used for online, real-time replication of data between storage subsystems
over a remote distance. In the event of a disaster or unrecoverable error at one
storage subsystem, you can promote a second storage subsystem to take over
responsibility for normal I/O operations. Consult the IBM FAStT Remote Mirror
Option Installation and User’s Guide, or contact your IBM reseller or IBM marketing
representative for more information.

Using the Hot Add utility
The Hot Add utility enables to add new logical drives without restarting the system.
The utility registers the new logical drives with the operating system so that you can
use Disk Administrator to create partitions, add device names, and so on. The Hot
Add utility is part of the Storage Manager 8.21 Utility software package. If you run
the program twice and the new logical drives are not displayed in the Disk
Administrator window, you must either run Fibre Channel diagnostics, or restart
(reboot) the host.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem, and perform the following steps to
use the hot add utility:

1. From a DOS or command prompt, change to the
installation_directory\IBM_FAStT\Util where installation_directory is the directory
where you installed the Storage Manager 8.21 Utility.

2. From a DOS or command prompt, type the following:
hot_add

3. Press Enter. The new logical drives are available through the Disk Administrator.

Using the SMdevices utility
The Storage Manager 8.21 Utility software includes a utility called SMdevices that
you can use to view the storage subsystem logical drive that is associated with a
particular operating-system device name. This utility is helpful when you want to
create drive letters or partitions using Disk Administrator.
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When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:

1. From a DOS or command prompt, change to the
installation_directory\IBM_FAStT\Util where installation_directory is the directory
where you installed the Storage Manager 8.21 Utility.

2. Type:
SMdevices

3. Press Enter. The software displays device identification information. For
example, you might see the following:
\\.\PHYSICALDRIVEx [Storage Subsystem Finance, Logical Drive DEBIT, LUN xx,

WWN <worldwide_name>]

where

v x is the Disk number that displays in Disk Administrator

v Finance is the name of the storage subsystem

v DEBIT is the name of the logical drive

v xx is the LUN number associated with the logical drive

v worldwide_name is the worldwide name for the logical drive

Using the SMflashcopyassist utility

Note: This utility requires that the FlashCopy feature be enabled.

You can use SMflashassist utility to do the following:

v Flush cached data for a logical drive

v Resolve duplicate logical drive signatures between the base logical drives and
the FlashCopy logical drives

To flush cached data in a logical drive, do the following:

1. From a DOS or command prompt, change to the
installation_directory\IBM_FAStT\Util where installation_directory is the directory
where you installed the Storage Manager 8.21 Utility.

2. Type the following:
smflashcopyassist -f logical_drive_letter:

where logical_drive_letter is the operating-system drive letter that was assigned
to the disk partition created on the logical drive

3. Press Enter.

After creating a FlashCopy logical drive and mapping it to the same host as the
base logical drive, (for Windows NT only) to resolve duplicate logical drive
signatures:

1. Type smflashcopyassist -r

2. Press Enter.
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Stopping and restarting the host-agent software
You must stop and restart the host-agent software if you add additional storage
subsystems to the management domain of the host-agent software. When you
restart the service, the host-agent software discovers the new storage subsystems
and adds them to the management domain.

Note: If none of the access logical drives are detected after a restart, the
host-agent software automatically stops running. Make sure that there is a
good fibre channel connection from the host to the Storage Area Network
that the storage subsystem is connected to; then, restart the host or cluster
node so that new host-agent-managed storage subsystems can be
discovered.

Windows NT
To stop and restart the host-agent software, do the following:

1. Click Start → Settings → Control Panel. The Control Panel window opens.

2. Double-click Services. The Services window opens.

3. Click IBM FAStT Storage Manager 8 Agent; then, click Stop. The Confirmation
window opens.

4. Click Yes.

5. Click Start. The Storage Agent Manager starts.

6. Close the Services window.

Windows 2000
To stop and restart the host-agent software, do the following:

1. Click Start → Programs → Administrative Tools → Services. The Services
window opens.

2. Right-click IBM FAStT Storage Manager 8 Agent.

3. Click Restart. The IBM FAStT Storage Manager 8 Agent stops and then starts
again.

4. Close the Services window.

Uninstalling storage-management software components
Use the following procedure to uninstall one or more of the components of Storage
Manager 8.21. If you are uninstalling components released with an earlier version of
the storage-management software, use the procedure that came with the version of
the storage-management software that you are currently running.

Important: Do not uninstall the Redundant Disk Array Controller unless instructed
by an IBM technical-support representative. The host-agent package requires
RDAC to function properly. If you uninstall RDAC in a coexistence environment, you
will lose Fibre Channel I/O path failover support for both the version 7.xx and
version 8.xx of Storage Manager.

1. Click Start → Settings → Control Panel. The Control Panel window opens.
Select Add/Remove programs. The Add/Remove Programs Properties window
opens.

Note: Uninstall the Storage Manager components in the following order:

a. Storage Manager 8.21 Agent

b. Storage Manager 8.21 Utility
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c. Storage Manager 8.21 Redundant Disk Array Controller

d. Storage Manager 8.21 Client

2. Select the component you want to uninstall from the list of programs (for
example, IBM FAStT Storage Manager 8.21 Client).

3. Click Add/Remove. The Confirm File Deletion window opens.

4. Click Yes to start the uninstallation process.

5. When the uninstallation is complete, click OK.
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Chapter 7. Operating-system support

This chapter contains information related to operating the storage-management
software in a Windows NT or Windows 2000 environment.

Windows NT and Windows 2000 limitations
Important: Always check for a README file. A README file might contain
important information that was not available when this Installation and Support
Guide was prepared.

Table 12 explains limitations that apply when you use the IBM FAStT Storage
Manager Version 8.21 with Windows NT and Windows 2000.

Table 12. Windows NT and Windows 2000 limitations

Limitation Workaround

Clicking a vertical scroll arrow (either up
or down) causes the scroll box to move
all the way to the opposite end of the
scroll bar.

This is a known defect in the Java Runtime
Environment. Click the scroll box and slide it until
you reach the position that you want in the Help
window.

Data or configuration loss might occur
during a logical drive migration (removing
configured physical drives from one
storage subsystem and inserting them
into another storage subsystem).

Contact an IBM technical-support representative
for assistance in performing this procedure.

Array migration is not supported because
it could cause loss of configuration and
data. Array migration consists of removing
a set of drives configured with arrays from
one storage subsystem and inserting
them into another storage subsystem.

Contact an IBM technical-support representative.

If you manage storage subsystems
through the host-agent software and use
the storage management software to
download controller firmware, the
download process can take up to 10
minutes to complete.

None.

When you configure a new storage
subsystem with a single controller, you
must place the controller in slot A. The
controller firmware cannot recognize or
communicate with a single controller until
slot A is populated. This restriction does
not apply to storage subsystems that
were originally configured with two
controllers.

None.

The following loop configuration is not
supported: IBM Fibre Channel Hub
(machine type 3523) in conjunction with
the IBM Fibre Channel Switch (machine
types 2109-S16 and 2109-S8) or the IBM
Fibre Channel Switch (machine types
3534-F08 and 2109- F16.

None.
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Table 12. Windows NT and Windows 2000 limitations (continued)

Limitation Workaround

A controller failover occurs in an
active/active controller pair, and
ownership of arrays transfers from the
failed preferred owner to the other
controller of the repair. The failed
controller is replaced and brought online.
the array ownership is not automatically
transferred back to the preferred controller
owner.

Immediately after replacing the controller, click
Storage subsystem → Redistribute Arrays in
the Subsystem Management window to
redistribute arrays back to their preferred
controller owners. For more information, refer to
the online help.

When using 73.4 GB drives, the
maximum number of physical drives that
can be configured in a single logical drive
group is 29.

None.

After adding a host device to the
management domain of more than five
clients, the host-agent managed storage
subsystems attached to that host become
unresponsive.

A single instance of the host-agent software can
communicate with no more than five clients.

When you connect an IBM TotalStorage
FAStT EXP700 Storage Expansion Unit to
a FAStT200, the drive speed must be set
to 1 GB per second.

None.
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Table 12. Windows NT and Windows 2000 limitations (continued)

Limitation Workaround

After installing the host-agent software,
the error message:

Service Error 100

is displayed on the host.

The cause includes:

v The host-agent software does not find any
controllers with firmware version 04.00.02.00
or later. Upgrade the firmware to the latest FW
level from the IBM support Web site. For more
information, see the “Direct-management
method work around”.

v The access logical drive has been removed
from NVSRAM or the storage partition defined
for the host. Do one of the following:

– Manage the storage subsystem using the
direct-management method. See
“Direct-management method work around”.

– Define the access logical drive for the host;
restart SMagent. See the “SMAgent work
around for defining additional Access LUN
mapping” on page 86.

v The NVSRAM on the controllers in a storage
subsystem that you want to manage contains
an access logical drive LUN that is in use by
another logical drive. OR The NVSRAM on the
controllers in a storage subsystem that you
want to manage contains an access logical
drive LUN that is in use by another logical
drive, or is not supported by the operating
system or installed patches. For example, the
access logical drive is configured at LUN 31,
and the operating system and service packs
support only eight LUNs. Do one of the
following:

– Manage the storage subsystem using the
direct-management method. See the
“Direct-management method work around”.

– Change the LUN mapping for the host
access logical drive to a LUN that is not in
use and is supported by the operating
system either from a different computer that
has management access to the storage
subsystem, or establish a direct
management connection to the storage
subsystem from the current host. For more
information, see the SMAgent work around
for changing existing Access LUN mapping.

Direct-management method work around
Use these instructions for the direct managed method work around.

1. Connect the two controller Ethernet ports to the network.

2. Follow the direct-management setup instructions in Chapter 2, “Preparing for
installation” on page 21 to manage the subsystem directly.

3. Open the Storage Manager 8 Enterprise Management window. Click Edit →Add
device.

4. Enter the IP address for the first controller, and click Add.
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5. Repeat to add the IP address of the additional controllers.

6. Click Close.

7. Right-click the newly added storage subsystem and select Manage Device.The
Subsystem Management window for the storage subsystem opens. Proceed
with the storage subsystem management tasks.

SMAgent work around for defining additional Access LUN mapping
Use these instructions for Storage Manager 8.21 Agent.

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 8.21 Client and open the Subsystem
Management window for the storage subsystem.

3. Click the Mappings View tab.

4. Right-click the Default Group and select Define Additional mappings.

5. Select Access.

6. From the LUN drop-down menu, select Logical Unit Number (LUN) 31.

7. Click Add to define the access LUN.

8. Click Close. In the Define Mapping pane, a LUN with the Access name is
displayed.

9. Close the window and restart the host. When the host restarts, the SMagent
service starts.

SMAgent work around for changing existing Access LUN mapping
Use these instructions for Storage Manager 8.21 Agent.

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 8.21 Client and open the Subsystem
Management window for the storage subsystem.

3. Click the Mappings View tab.

4. From the topology pane, select the Default Group or the corresponding host
partition.

5. Right-click on Access, and select Change Mapping. A Change Mapping
window opens.

6. From the LUN drop-down menu, select the Logical Unit Number (LUN) that is
supported by your operating system. If it is not available, you must remove one
of the existing storage partitioning mappings.

7. Click OK.

8. Close the window, and restart the host. When the host restarts, the SMagent
service starts.

Upgrading from Windows NT 4.0 to Windows 2000
If you have an existing storage subsystem running Windows NT 4.0, you can
upgrade to Windows 2000 if the following conditions apply:

v Your storage subsystem is not the startup (boot) device.

v Your controllers are running firmware versions 04.00.00.00 or later.
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Attention: To avoid possible data loss, you must uninstall any previous versions of
the storage-management software (refer to “Uninstalling storage-management
software components” on page 80) before upgrading your operating system. All
storage-management configuration information is deleted during the uninstallation
process. A complete reinstallation of the storage-management software is required.

To upgrade from Windows NT 4.0 to Windows 2000, do the following:

1. Verify that the storage subsystem contains no system-dependent files or
directories, such as paging files.

2. Uninstall Storage Manager. Refer to “Uninstalling storage-management software
components” on page 80. The Storage Manager components should be
uninstalled in the following order:

a. Storage Manager Agent

b. Storage Manager Utility

c. Redundant Disk Array Controller

d. Storage Manager Client

3. Use the instructions from Microsoft to upgrade to Windows 2000.

4. Reinstall Storage Manager. Either refer to the instructions in “Installing Storage
Manager 8.21 Client” on page 42 or to the procedure that came with the version
of the storage-management software you are currently running.
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Appendix A. Storage subsystem and controller information

Table 13 provides a data sheet for recording storage subsystem names,
management types, hardware Ethernet addresses, and IP addresses. Make a copy
of this table and complete the information for your storage subsystems and
controllers. Use the information to set up the BOOTP table for the network server
and the host or Domain Name System (DNS) table. The information will also be
helpful if you add storage subsystems after initial installation. The column headings
show a page reference for detailed instructions about obtaining the information. For
a sample information record, refer to Table 9 on page 25.

Table 13. Storage subsystem information record and controller information record

Storage
subsystem name

(page 25)

Management
type (page 21)

Controllers—Ethernet and IP
addresses, and host name

(pages 25 and 27)

Host—IP
address and

host name
(page 27)
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Appendix B. Getting information, help, and service

If you need help, service, or technical assistance or just want more information
about IBM® products, you will find a wide variety of sources available from IBM to
assist you. This appendix contains information about where to go for additional
information about IBM and IBM products, what to do if you experience a problem
with your xSeries™ or IntelliStation® system, and whom to call for service, if it is
necessary.

Before you call
Before you call, make sure that you have taken these steps to try to solve the
problem yourself:

v Check all cables to make sure that they are connected.

v Check the power switches to make sure that the system is turned on.

v Use the troubleshooting information in your system documentation, and use the
diagnostic tools that come with your system.

v Go to the IBM Support Web site at http://www.ibm.com/pc/support/ to check for
technical information, hints, tips, and new device drivers.

v Use an IBM discussion forum on the IBM Web site to ask questions.

You can solve many problems without outside assistance by following the
troubleshooting procedures that IBM provides in the online help or in the
publications that are provided with your system and software. The information that
comes with your system also describes the diagnostic tests that you can perform.
Most xSeries and IntelliStation systems, operating systems, and programs come
with information that contains troubleshooting procedures and explanations of error
messages and error codes. If you suspect a software problem, see the information
for the operating system or program.

Using the documentation
Information about your IBM xSeries or IntelliStation system and preinstalled
software, if any, is available in the documentation that comes with your system.
That documentation includes printed books, online books, README files, and help
files. See the troubleshooting information in your system documentation for
instructions for using the diagnostic programs. The troubleshooting information or
the diagnostic programs might tell you that you need additional or updated device
drivers or other software. IBM maintains pages on the World Wide Web where you
can get the latest technical information and download device drivers and updates.
To access these pages, go to http://www.ibm.com/pc/support/ and follow the
instructions. Also, you can order publications through the IBM Publications Ordering
System at
http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgi.

Getting help and information from the World Wide Web
On the World Wide Web, the IBM Web site has up-to-date information about IBM
xSeries and IntelliStation products, services, and support. The address for IBM
xSeries information is http://www.ibm.com/eserver/xseries/. The address for IBM
IntelliStation information is http://www.ibm.com/pc/intellistation/.
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You can find service information for your IBM products, including supported options,
at http://www.ibm.com/pc/support/. If you click Profile from the support page, you
can create a customized support page. The support page has many sources of
information and ways for you to solve problems, including:

v Diagnosing problems, using the IBM Online Assistant

v Downloading the latest device drivers and updates for your products

v Viewing Frequently Asked Questions (FAQ)

v Viewing hints and tips to help you solve problems

v Participating in IBM discussion forums

v Setting up e-mail notification of technical updates about your products

Software service and support
Through IBM Support Line, you can get telephone assistance, for a fee, with usage,
configuration, and software problems with xSeries servers, IntelliStation
workstations, and appliances. For information about which products are supported
by Support Line in your country or region, go to
http://www.ibm.com/services/sl/products/.

For more information about Support Line and other IBM services, go to
http://www.ibm.com/services/, or go to http://www.ibm.com/planetwide/ for support
telephone numbers.

Hardware service and support
You can receive hardware service through IBM Integrated Technology Services or
through your IBM reseller, if your reseller is authorized by IBM to provide warranty
service. Go to http://www.ibm.com/planetwide/ for support telephone numbers.

In the U.S. and Canada, hardware service and support is available 24 hours a day,
7 days a week. In the U.K., these services are available Monday through Friday,
from 9 a.m. to 6 p.m.
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Appendix C. Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may be
used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply to
you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements and/or
changes in the product(s) and/or the program(s) described in this publication at any
time without notice.

Any references in this publication to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for this
IBM product, and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes
appropriate without incurring any obligation to you.

Edition notice
© COPYRIGHT INTERNATIONAL BUSINESS MACHINES CORPORATION, 2002.
All rights reserved.

Note to U.S. Government Users — Documentation related to restricted rights —
Use, duplication or disclosure is subject to restrictions set forth in GSA ADP
Schedule Contract with IBM Corp.
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Trademarks
The following terms are trademarks of International Business Machines Corporation
in the United States, other countries, or both:

Active PCI Predictive Failure
Analysis

e-business logo Redbooks
FlashCopy ServeRAID
IBM ServerProven
IntelliStation TotalStorage
Netfinity xSeries

Lotus, Lotus Notes, and Domino are trademarks of Lotus Development Corporation
and/or IBM Corporation in the United States, other countries, or both.

Intel, Celeron, MMX, LANDesk, Pentium, Pentium II Xeon, Pentium III Xeon, and
Xeon are trademarks of Intel Corporation in the United States, other countries, or
both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Linux is a registered trademark of Linus Torvalds.

Other company, product, or service names may be the trademarks or service marks
of others.

Important notes
Processor speeds indicate the internal clock speed of the microprocessor; other
factors also affect application performance.

CD-ROM drive speeds list the variable read rate. Actual speeds vary and are often
less than the maximum possible.

When referring to processor storage, real and virtual storage, or channel volume,
KB stands for approximately 1000 bytes, MB stands for approximately 1 000 000
bytes, and GB stands for approximately 1 000 000 000 bytes.

When referring to hard disk drive capacity or communications volume, MB stands
for 1 000 000 bytes, and GB stands for 1 000 000 000 bytes. Total user-accessible
capacity may vary depending on operating environments.

Maximum internal hard disk drive capacities assume the replacement of any
standard hard disk drives and population of all hard disk drive bays with the largest
currently supported drives available from IBM.

94 IBM FAStT Storage Manager Version 8.21: Installation and Support Guide for Microsoft Windows NT and Windows 2000



Maximum memory may require replacement of the standard memory with an
optional memory module.

IBM makes no representation or warranties regarding non-IBM products and
services that are ServerProven®, including but not limited to the implied warranties
of merchantability and fitness for a particular purpose. These products are offered
and warranted solely by third parties.

IBM makes no representations or warranties with respect to non-IBM products.
Support (if any) for the non-IBM products is provided by the third party, not IBM.

Some software may differ from its retail version (if available), and may not include
user manuals or all program functionality.
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