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About this document

Throughout this document, Storage Manager Version 9 refers to all version 9.1
software release levels. References to other Storage Manager versions refer
exclusively to those releases.

This document provides information about how to plan, install, configure, and work
with IBM® TotalStorage® FAStT Storage Manager Version 9.1 in each of the
following Intel® processor-based operating systems:

Windows® 2000
Windows Server 2003
Novell NetWare 6.0 and 6.5

Red Hat Enterprise Linux Advanced Server 2.1 (formerly Red Hat Linux
Advanced Server 2.1)

United Linux 1.0 IA-64

United Linux 1.0

— SuSE Linux Enterprise Server 8 (SLES 8)

— Turbolinux Enterprise Server 8 (TLES 8)

— Conectiva Linux Enterprise Edition Powered by United Linux
VMware ESX Server 2.1

Use this document to perform the following tasks:

Determine the hardware and software that you will require to install the storage
management software.

Integrate the necessary hardware components into your network.

Install the FASIT Storage Manager software.

Upgrade controller firmware, if necessary.

Identify storage management features that are unique to your installation.

Notes:

1.

© Copyright IBM Corp. 2004

The controller firmware version 06.10.xx.xx and NVSRAM that ship with the IBM
FASIT Storage Manager Version 9.1 support only the following FAStT storage
servers:

* FAStT600 Turbo Option; Machine Type 1722; Model Number 60U
* FAStT600 Turbo Option; Machine Type 1722; Model Number 60X
* FAStT700; Machine Type 1742; Model Number 1RU
* FAStT700; Machine Type 1742; Model Number 1RX
* FAStT900; Machine Type 1742; Model Number 90U
* FAStT900; Machine Type 1742; Model Number 90X

There is no controller firmware version 6.10.xx for the following FAStT storage
servers:

* FAStT100 — all models

* FAStT600 — base and SCU models
» FAStT200

* FAStT500

Please contact your IBM reseller or representative regarding any future
availability of 6.10.x controller firmware for these FAStT storage servers.

Xi



Who should read this document

This document is intended for system and storage administrators who are
responsible for installing software. Readers should have knowledge of Redundant
Array of Independent Disks (RAID), Small Computer System Interface (SCSI), and
Fibre Channel technology, They should also have working knowledge of the
applicable operating systems that are used with the management software.

FASLT installation process overview

gives an overview of the FAStT hardware and the FAStT Storage Manager
software installation process. Lined arrows in the flow chart indicate consecutive
hardware and software installation process steps. Labeled arrows indicate which
document provides detailed information about a step.

Install Process Documentation

* FC Planning and
Plan installation Integration: User's Guide

Connect Power and FASLT Storage Sever

and Svc Info g Start Server Installation Guide
¥ FAStT Storage Manager Fibre Channel
Concepts Guide v Hardware Maintenance
Install Storage VT e and Problem
Server/RAID Controller FASIT Storage Svr 1 Determination Guide
Enclosure(s) in Rack Installation Guide operation w/ LEDs
FAStT RAID Controller
Enclosure Unit Install A 4
Install Storage L__and Users Guide Prepare for
Expansion Unit(s) . Installation of
FASLT Storage I'Exp Units SM Software FASIT Storage
Install and User's Guides Manager Installation
and support
Make FC Connections — Vd i OS Guides
nstall an erl
FASIT Storage Manager
SM SW on Host and Copy Services
SET Link Speed Workstation User's Guide
(1GB or 2GB) FASIT and HBA Install

A\ 4
Complete SM SW
Installation

and User's Guides

Determine
Management
Method

FASLT Fibre Channel
Storage Server
Installation Guides

Out-of-Band

Fibre Channel Cabling Configure Storage Online Help

Install Network Instructions Hardware
Hardware; Prep are
Network Connection
| > Configure Storage

Subsystems on Host

For pSeries Server and 6227 or 6228 HBA use only

Figure 1. Installation process flow by current publications

FAStT Storage Manager Version 9 library

[Table 1 on page xiiil presents an overview of FAStT Storage Manager product library
documents by the common tasks that they address. Click on active links in the
tables to access those documents currently available on the Internet. You can
access documentation for the other FASIT products at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|
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Table 1. TotalStorage FASIT Storage Manager Version 9.1 titles by user tasks

Title

User tasks

Planning

Hardware
installation

Software
installation

Configuration

Operation and | Diagnosis and
administration | maintenance

IBM TotalStoragg
FASLT Storag
Manager Version 4
Installation and|
Support Guide forl
Intel-based
Operating System|

Environments,)
GC26-764

IBM TotalStoragé
FASLtT Storag
Manager Version 4
Installation and|
Support Guide forl
AIX, UNIX, Solaris
and Linux on Power)

GC26-7644

IBM TotalStora
FASLT Storag
Manager Version 9
Copy Service
User’s Guide,
GC26-766

IBM TotalStora
FASIT Storag
Manager Version 9

Concepts Guide,
GC26-7661

About this document
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How this document is organized

[Chapter 1, “Introduction,” on page 1|provides an overview of IBM FAStT Storage
Manager Version 9.1 and describes storage subsystem management methods,
configuration types, types of installations, and installation requirements.

|Chapter 2, “Preparing for installation,” on page 33|discusses preparing for a network
installation, including setting up a Dynamic Host Configuration Protocol/Boot
Protocol (DHCP/BOQOTP) server on Windows 2000, Windows Server 2003,
NetWare, Linux, and UNIX® platforms. It also describes other setup tasks.

Chapter 3, “Installing Storage Manager software in a standard Windows|
configuration,” on page 53 provides installation instructions for Windows 2000, and
Windows 2000 Server software components in a standard (noncluster) environment.

Chapter 4, “Installing Storage Manager software in a Windows cluster server|
environment,” on page 61| provides installation instructions for Windows 2000, and
Windows 2000 Server software in a cluster server environment.

Chapter 5, “Installing Storage Manager software in a standard NetWare|
configuration,” on page 81| provides installation instructions for the storage
management software in standard (noncluster) and cluster server configurations in
the NetWare operating system environment.

Chapter 6, “Installing Storage Manager software in a Linux configuration,” on page]
87| provides installation instructions for the storage management software in a Linux
operating system environment.

Chapter 7, “Installing Storage Manager software in a VMware ESX Server
configuration,” on page 95| provides installation instructions for the storage
management software in a VMware ESX Server operating system environment.

[Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97 discusses
completion of Storage Manager software on Windows 2000, Windows 2000 Server,
NetWare, and Linux platforms. It provides details on starting the Enterprise
Management window, performing an automatic discovery of storage subsystems,
adding devices, setting up alert notifications, downloading firmware and nonvolatile
storage random access memory (NVSRAM), creating arrays and logical drives, and
other storage subsystem management tasks.

Chapter 9, “Using the storage management software for Windows and NetWare,” on|
page 11§| provides information about adding and deleting logical drives, using the
hot_add and SMdevices utilities, starting and stopping the host-agent software, and
uninstalling Storage Manager components in Windows 2000, Windows 2000 Server,
and NetWare operating system environments.

IAppendix A, “Windows operating system limitations,” on page 123| discusses
Windows 2000, and Windows Server 2003 operating system limitations and other
operating system issues.

|Appendix B, “NetWare operating system limitations,” on page 131| discusses
NetWare operating system limitations and other related operating system issues.

|Appendix C, “Linux operating system limitations,” on page 133| discusses Linux
operating system limitations and other related operating system issues.
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lAppendix D, “VMware ESX Server operating system limitations,” on page 135|
discusses VMware ESX Server operating system limitations and other related
operating system issues.

lAppendix E, “Storage subsystem and controller information record,” on page 137
provides a data sheet template that you can use to create a controller information
record.

|Appendix F, “Additional FAStT documentation,” on page 139|provides an overview
of the FAStT900, FAStT700, and FAStT600 Fibre Channel Storage Server product
libraries, as well as other related documents.

Notices that this document uses

This document contains the following notices designed to highlight key information:
* Notes: These notices provide important tips, guidance, or advice.

» Important: These notices provide information that might help you avoid
inconvenient or problem situations.

» Attention: These notices indicate possible damage to programs, devices, or
data. An attention notice is placed just before the instruction or situation in which
damage could occur.

Getting information, help, and service

If you need help, service, or technical assistance or just want more information
about IBM and IBM products, you will find a wide variety of sources available from
IBM to assist you. This section contains information about where to go for additional
information, what to do if you experience a problem with your IBM @server
xSeries® or IntelliStation® system, and whom to call for service, if it is necessary.

Before you call

Before you call, make sure that you take these steps to try to solve the problem
yourself:

» Check all cables to make sure that they are connected.
» Check the power switches to make sure that the system is turned on.

* Use the troubleshooting information in your system documentation, and use the
diagnostic tools that come with your system.

* Go to the IBM Support Web site at:

[www.ibm.com/pc/support/|

to check for technical information, hints, tips, and new device drivers.
Use an IBM discussion forum on the IBM Web site to ask questions.

You can solve many problems without outside assistance by following the
troubleshooting procedures that IBM provides in the online help or in the
publications that are provided with your system and software. The information that
comes with your system also describes the diagnostic tests that you can perform.
Most xSeries and IntelliStation systems, operating systems, and programs come
with information that contains troubleshooting procedures and explanations of error
messages and error codes. If you suspect a software problem, see the information
for the operating system or program.

About this document XV
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Using the documentation

Web sites

Information about your IBM @server xSeries or IntelliStation system and
preinstalled software, if any, is available in the documentation that comes with your
system. That documentation includes printed documents, online documents, readme
files, and help files. See the troubleshooting information in your system
documentation for instructions for using the diagnostic programs. The
troubleshooting information or the diagnostic programs might tell you that you need
additional or updated device drivers or other software. IBM® maintains pages on the
World Wide Web where you can get the latest technical information and download
device drivers and updates. To access these pages, go to the Web site at:

www.ibm.com/pc/support/

and follow the instructions. Also, to order publications through the IBM Publications
Ordering System, go to the Web site at:

www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgil

Locate up-to-date information about FAStT Fibre Channel Storage Servers and
FASIT Storage Manager 9.1, including documentation and the most recent software,
firmware, and NVSRAM downloads at the following Web sites.

IBM xSeries servers
For IBM xSeries information, go to the Web site at:

www.ibm.com/eserver/xseries/

IBM IntelliStation
For IBM IntelliStation information, go to the Web site at:

www.ibm.com/pc/intellistation/]

FAStT Fibre Channel Storage Servers
Find the latest information about all of the IBM FAStT Fibre Channel
Storage Servers at:

www.ibm.com/storage/disk/fastt/

IBM TotalStorage products
Find information about all IBM TotalStorage products at:

www.ibm.com/storage]

TotalStorage FAStT interoperability matrix
Find the latest information about operating system and host bus adapter
(HBA) support, clustering support, storage area network (SAN) fabric
support, and Storage Manager feature support at:

|www.ibm.com/storage/disk/fastt/supserver.htm/1

IBM Service
For service information for your IBM products, including supported options,
go to the Web site at:

www.ibm.com/pc/support/
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FASIT technical support
Find FASIT software downloads, hints and tips, documentation, parts
information, HBA and fibre channel support at:

www-1.ibm.com/servers/storage/support/fastt/index.html|

If you click Profile from the support page, you can create a customized
support page. The support page has many sources of information and ways
for you to solve problems, including how to:

» Diagnose problems, using the IBM Online Assistant.

* Download the latest device drivers and updates for your products.

* View Frequently Asked Questions (FAQ).

* View hints and tips to help you solve problems.

» Participate in IBM discussion forums.

» Set up e-mail notification of technical updates about your products.
Premium feature activation

Enable a premium feature on a FAStT600 or FAStT900 by using the online
tool at:

www.storage.ibm.com/pfeatures.html|

IBM Publications Center
Order IBM publications at:

www.ibm.com/shop/publications/order/|

Software service and support

Through the IBM Support Line, for a fee, you can get telephone assistance with
usage, configuration, and software problems with xSeries servers, IntelliStation
workstations and appliances. For information about which products are supported
by Support Line in your country or region, go to the Web site at:

www.ibm.com/services/sl/products/|

For more information about Support Line and other IBM services, go to the Web
site at:

www.ibm.com/services/

or, for support telephone numbers, go to the Web site at:

www.ibm.com/planetwide]

Hardware service and support

You can receive hardware service through IBM Integrated Technology Services or
through your IBM reseller, if your reseller is authorized by IBM to provide warranty
service. For support telephone numbers, go to the Web site at:

www.ibm.com/planetwide/|

In the U.S. and Canada, hardware service and support are available 24 hours a
day, 7 days a week. In the U.K., service and support are available Monday through
Friday, from 9 a.m. to 6 p.m.
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How to send your comments

Your feedback is important to help us provide the highest quality of information. If
you have any comments about this document, please either fill out the Readers’
comments form (RCF) at the back of this document and give it to an IBM
representative, or submit it in one of the following ways:

e E-mail

Submit your comments over the Internet to:

[starpubs @ us.ibm.com|
— Submit your comments over IBMLink™ from the U.S.A. to:

STARPUBS at SUIEVM5
— Submit your comments over IBMLink from Canada to:

STARPUBS at TORIBM
— Submit your comments over IBM Mail Exchange to:

USIB3WD at IBMMAIL

Be sure to include the name and order number of the document and, if
applicable, the specific location of the text that you are commenting on, such as
a page or table number.

*  Mail
Complete the readers’ comments form (RCF) at the back of this document and

return it by mail. If the RCF Business Reply Mailer has been removed, you may
address your comments to:

International Business Machines Corporation
Information Development

Dept. GZW

9000 South Rita Road

Tucson, Arizona 85744-0001

U.S.A.
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Chapter 1. Introduction

IBM FAStT Storage Manager version 9.1x host software supports new features
incorporated into the latest release of controller firmware version 06.10.xx.xx. This
version of FAStT Storage Manager also manages FAStT Storage Servers with all
general released firmware versions from 04.01.xx.xx through 05.4x.xx.xx. See
for information on latest supported controller firmware code levels available
for all FAStT Storage Server models. New features associated with the 06.10.xx.xx
controller firmware are listed in [‘'New features” on page 2] All of the controller
firmware versions listed below are available free-of-charge. However, you must
purchase an EXP100 Expansion Enclosure or FAStT100 Storage Server to obtain
controller firmware code versions 05.41.xx.xx or 05.42.xx.xx, respectively.

Table 2. Current firmware versions by server and environment

Latest controller |Latest controller
firmware version |firmware version
Storage server Machine | Model for fibre channel |for SATA
name type number environment environment
IBM Netfinity Fibre 3526 1RU 04.01.xx.xx N/A
Channel RAID 1RX
Controller Unit
FAStT100 1724 100 N/A 05.42.xx.xX
FAStT200 High 3542 2RU 05.30.XX.XX N/A
Availability (HA) 2RX
FAStT200 1RU
1RX
FAStT500 3552 1RU
1RX
FAStT600 Base 1722 6LU 05.34.xx.Xx 05.41.xx.xx
FAStT600 Single 6LX N/A
Controller Unit (SCU)
FAStT600 Turbo 60X 06.10.xx.xx 06.10.xx.xx
Option 60U
FAStT700 1742 1RU 06.10.XX.XX
1RX
FAStT900 90U 06.10.xx.xx
90X

This document provides information on how to prepare, install, configure, and start
IBM TotalStorage FASIT Storage Manager Version 9.1 in the following operating
system environments:

* Windows 2000

* Windows Server 2003

* Novell NetWare

* Linux

* VMware ESX Server 2.1

Note: For analogous information regarding other operating systems, see the IBM

TotalStorage FASIT Storage Manager 9 Installation and Support Guide for
AIX, UNIX, Solaris and Linux on Power.
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Consult your IBM service representative for any future support of additional
operating system environments.

Before you begin the installation of this product, consult the following
documentation:
* readme.txt file

Read this document first. It supplies information associated with operating
systems on which you can install Storage Manager software. A readme file is
located in the root directory of each of four installation CDs associated with
supported operating systems. For the latest installation and user information,
refer to the following IBM Web site:

[www-1.ibm.com/servers/storage/support/fastt/index.html|
* IBM TotalStorage FAStT Storage Manager Concepts Guide

Use this document to become familiar with terminology and features of the IBM
TotalStorage FASIT Storage Manager software. To download this book, go to the
Web site at:

[www-1.ibm.com/servers/storage/support/fastt/index.html|

When you finish the installation process, refer to the following online help systems:
* Enterprise Management window help

Use this online help system to learn more about working with the entire
management domain.

» Subsystem Management window help

Use this online help system to learn more about managing individual storage
subsystems.

You can access these help systems from within the Storage Manager 9.1 Client.
From either an Enterprise Management or Subsystem Management window, click
Help or press F1.

After you install IBM FAStT Storage Manager Version 9.1, consider installing the
FASIT Management Suite Java (FAStT-MSJ) diagnostic program. You can use
these programs to verify the status of the fibre channel connections before you use
the storage subsystem.

The IBM FASIT MSJ User’s Guide and the FAStT-MSJ program are located on the
IBM FASET Storage Manager Version 9.1 CD where associated with your particular
operating system.

Note: If your FASIT Storage Server is connected to a fibre channel host bus
adapter (HBA) in the host server in a SAN environment, consider purchase
one of the following software applications helpful for SAN management and
troubleshooting.

* |IBM Tivoli SAN Manager

e McData SANavigator

New features

This section describes the standard features that are part of the Storage Manager
version 9.1 software. Your storage subsystem firmware must be version 6.10.xx.xx if
you plan to use any of the features listed in this section. Exceptions associated with
the EXP100 Expansion Enclosure and FAStT100 Storage Server are listed in

[Table 2 on page 1}
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The following new features and support have been added to the Storage Manager
version 9.1 software:

» Enhanced Remote Mirror functionality

Besides Metro Mirroring, IBM FAStT Storage Manager now supports Global
Mirroring and Global Copy. For details, see the IBM TotalStorage FAStT Storage
Manager Version 9 Copy Services User's Guide. More detailed information is
also available in .

+ Staged controller firmware download
See online help to learn more about this feature.

Note: The option to activate firmware at a later time is not supported on the
FAStT700.

» Parallel drive firmware download
See online help to learn more about this feature.
* Mixed drive types and improved configuration
See online help to learn more about this feature.
* Linux MPP-based multipath support
See the Linux RDAC Failover readme to learn more about this feature.
* Full command line SMcli support
See online help to learn more about this feature.

Premium features

— FAStT100 and FAStT600

» The Enhanced Remote Mirroring feature is not currently supported on either
the FAStT100 or FAStT600 Base or Single Controller Unit models.
FAStT600 Turbo Option Fibre Channel Storage Servers do support the
Remote Mirror feature.

» Storage Partitioning is not a standard feature on the FAStT100 or
FAStT600.

Four premium features can be enabled on all FAStT subsystems by purchasing a
premium feature key. These include FlashCopy, Remote Mirror option, VolumeCopy,
and Storage Partitioning (standard on all but the FAStT600 and FAStT600 Turbo
Option). Each of these features is described in the following section.

FlashCopy
This feature supports the creation and management of FlashCopy logical
drives. A FlashCopy logical drive is a logical point-in-time image of another
logical drive, called a base logical drive, that is in the storage subsystem. A
FlashCopy is the logical equivalent of a complete physical copy, but you
create it much more quickly and it requires less disk space. Because a
FlashCopy is a host addressable logical drive, you can perform backups
using the FlashCopy while the base logical drive remains online and
user-accessible. In addition, you can write to the FlashCopy logical drive to
perform application testing or scenario development and analysis. The
maximum number of FlashCopy logical drives allowed is one half of the
total number of logical drives supported by your controller model.

Enhanced Remote Mirror Option
The Enhanced Remote Mirror option is used for online, real-time replication
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of data between storage subsystems over a remote distance. In the event
of a disaster or unrecoverable error on one storage subsystem, the Remote
Mirror Option enables you to promote a second storage subsystem to take
over responsibility for normal input/output (1/0) operations.

Enhancements to the Remote Mirror feature for Storage Manager version
9.1 software include:

Delta Logging

Synchronization previously required a complete recopy of the
primary Remote Mirror volume. It now only requires updates to
the LBAs that were changed.

A repository volume is now used to store a queue of outstanding
write operations for the secondary Remote Mirror.

Updates to the secondary Remote Mirror are now a background
operation once the connection is restored.

Suspend/Resume

Uses the delta-logging facility to manage the suspension and
resumption of I/0O activity with the secondary Remote Mirror.

Based on the delta logging functionality of outstanding 1/0
requests.

Allows suspension and later resumption of asynchronous
operation with the secondary Remote Mirror.

A suspend command stops I/O writes to secondary Remote
Mirror.

A resume command initiates a partial re-synchronous
accumulation of log entries and continues primary write
synchronization.

Global Copy and Global Mirroring (Asynchronous Write Mode)

Allows host acknowledgement of a write operation before data is
successfully written to the secondary Remote Mirror.

Uses a repository volume to hold write data until an
acknowledgment is received from the secondary Remote Mirror.

Write Order Consistency allows for write order preservation to the
secondary Remote Mirror under asynchronous writes.

Write order consistency is maintained across all of the volumes
configured for this mode of operation.

Ensures that the write order to a secondary Remote Mirror is the
same as the acknowledged order to a host.

Asynchronous Write Mode without write order consistency is
referred to as Global Copy.

Asynchronous Write Mode with write order consistency is
referred to as Global Mirroring.

Read access to secondary Remote Mirror

Allows direct host Read access to a secondary Remote Mirror.

Allows for creation of FlashCopy volume of the secondary
Remote Mirror volume.

Allows Read and Write access to the FlashCopy volume of the
secondary mirror volume.

Inter-array Communication Diagnostics
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* Improves return status for failed Remote Mirror creation
requests as follows:

— Array to fabric connection
— Array to array communication
— Array to volume on remote system

» Allows the user to test connectivity between mirrors after Remote
Mirror relationships are established.

Increased number of Remote Mirror relationships
The number of Remote Mirror relationships now supported is 64.

Note: The terms Remote Mirror and Enhanced Remote Mirror are
used interchangeably throughout this document, the FAStT
Storage Manager client program GUI and online help.

Increased maximum distance between nodes
The maximum distance between nodes in Metro Mirroring
(synchronous write mode) configurations is increased with this
update.

VolumeCopy
The VolumeCopy feature is a firmware-based mechanism for
replicating logical drive data within a storage array. This feature is
designed as a system management tool for tasks such as
relocating data to other drives for hardware upgrades or
performance management, data backup, or restoring FlashCopy
logical drive data. Users submit VolumeCopy requests by specifying
two compatible drives. One drive is designated as the Source and
the other as the Target. The VolumeCopy request is persistent so
that any relevant result of the copy process can be communicated
to the user.

Note: The terms VolumeCopy and Logical Drive Copy are used
interchangeably throughout this document, the FAStT
Storage Manager client program GUI, and online help.

Storage Partitioning

Storage Partitioning allows the user to present all storage volumes
to a SAN through several different partitions by mapping storage
volumes to a LUN number, each partition presenting LUNs 0 - 255.
This volume/LUN mapping applies only to the host port or ports that
have been configured to access that LUN. A given storage volume
can have only one Host/LUN mapping. This feature allows the total
number of configurable storage volumes supported by the array to
be much greater than the number of addressable storage devices.

This feature also allows the support of multiple hosts using different
operating systems and their own unique disk storage subsystem
settings to be connected to the same FASIT Storage Server at the
same time (heterogeneous host environment).

Storage Manager 9.1 limitations

Because there is no Storage Manager 9.1-level controller firmware version
06.10.xx.xx and NVSRAM for FAStT100 (1724-100), FAStT200 (3542, all models),
FAStT500 (3552, all models), FAStT600 (1722-60U and -60X), or FAStT600 Single
Controller Unit (1722-6LU and -6LX), Storage Manager 9.1 features are unavailable
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for these products. However, IBM recommends that you use Storage Manager 9.1
host software to manage these Storage Manager servers, provided the installed
controller firmware in these models is version 04.10.xx.xx or higher. See

Supported machine types

provides a list of FAStT machine types, their all inclusive supported storage
management host software and compatible FAStT Storage Server controller
firmware versions.

Table 3. Machine types and supported storage management software

Supported Storage

Machine Firmware |Manager software
Product name type Model |version version
IBM Netfinity® Fibre Channel 3526 1RU 4.x 7.0,7.01,7.02, 7.10,
RAID Controller Unit 1RX 8.0, 8.2, 8.21, 8.3,
8.41,8.42, 9.1
IBM TotalStorage FAStT100 1724 100 5.42.xx.xx [8.42, 9.1
Storage Server (supports
FAStT100
only)
IBM FAStT200 Storage Server 3542 1RU 4.x, 7.02,7.10, 8.0, 8.2,
1RX 5.20.xx.xx |8.21, 8.3, 8.41, 8.42,
5.30.xx.xx |9.1
IBM FAStT200 High Availability 3542 2RU 4.x, 7.02,7.10, 8.0, 8.2,
(HA) Storage Server 2RX 5.20.xx.xx |8.21, 8.3, 8.41, 8.42,
5.30.xx.xx |9.1
IBM Netfinity FAStT500 RAID 3552 1RU 4.x, 7.0,7.01,7.02, 7.10,
Controller Enclosure Unit 1RX 5.00.xx.xx |8.0, 8.2, 8.21, 8.3,
(no longer available for purchase) 5.20.xx.xx |8.41, 8.42, 9.1
5.21.xx.xx
5.30.xx.xx
IBM TotalStorage FAStT600 Fibre | 1722 6LU 5.34.xx.xx |8.41.xx.03 or later,
Channel Storage Server 6LX 8.42, 9.1

60U 5.38.xx.xx [8.3, 8.4, 8.41, 8.42, 9.1
60X 5.34.xx.xx
(Base |5.40.xx.xx
Model) | (Turbo
Model
only)

60U
60X 5.41.XX.XX
(Turbo | (supports
Model) |EXP100
only)

IBM TotalStorage FAStT700 Fibre | 1742 1RU 5.00.xx.xx |8.0, 8.2, 8.21, 8.3,
Channel Storage Server 1RX 5.20.xx.xx |8.41, 8.42, 9.1

5.21.xX.Xx
5.30.xx.xx
5.40.xx.Xx

06.10.xx.xx
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Table 3. Machine types and supported storage management software (continued)

Supported Storage
Machine Firmware |Manager software
Product name type Model |version version

IBM TotalStorage FAStT900 Fibre | 1742 90X 5.30.xx.xx [8.3, 8.4, 8.41, 8.42, 9.1
Channel Storage Server 90U 5.40.xx.xx

5.41.xX.XX
(supports
EXP100
only)

06.10.xx.xx

Notes:

1. Firmware level 05.41.xx.xx provides EXP100 expansion enclosure support only
for FAStT600 Base models.

2. Firmware level 5.40.xx.xx and earlier provide support for EXP500 and EXP700
expansion enclosures only.

Note: Firmware version 6.10.xx.xx provides support for both fibre channel and
SATA expansion enclosures, as long as they are not intermixed in the
same FAStT Storage Server configuration.

3. Controller firmware versions regulate the function of any given Storage Manager
client code version release. You might need to purchase the appropriate
firmware upgrade or hardware option to enable the function of your particular
Storage Manager client code version release. Storage subsystem firmware must
be at version 04.00.02.xx or higher to be managed with Storage Manager
versions 8.0, 8.2, 8.21, 8.3, 8.4, 8.41, 8.42, or 9.1.

4. This table associates all compatible controller firmware and management
software versions for the various FAStT Storage Server products. To ensure the
highest level of compatibility and error-free operation, the controller firmware for
all FAStT Storage Server products should be 05.3x.xx.xx-level (except for
machine type 3526, for which the latest available firmware level is 04.01.xx.xx.)
and the management software version should be 08.4x.xx.xx-level or higher.

Terms to know

If you are upgrading from a previous version of Storage Manager software, some of
the terms you are familiar with have changed. It is important that you familiarize
yourself with the new terminology. provides a list of some of the changed
terms. For further information on terminology, see the Help section of the Storage
Manager Enterprise Management window, the Storage Subsystem Management

window, or the glossary on page

Table 4. New terminology

Term used in previous versions New term

RAID module Storage subsystem
Drive group Array

Volume Logical drive

It is important to understand the distinction between the following two terms when
you read this document.
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Management station
A management station is a system that is used to manage the storage
subsystem. You can attach it to the storage subsystem in either of the
following ways:

* Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

» Through a TCP/IP connection to the host-agent software that is installed
on a host computer, which in turn is directly attached to the storage
subsystem through the fibre-channel input/output (1/O) path

Host computer
A host computer is a system that is directly attached to the storage
subsystem through a fibre-channel 1/O path. This system is used to perform
the following tasks:

« Serve data (typically in the form of files) from the storage subsystem

» Function as a connection point to the storage subsystem for a
remote-management station

Notes:

1. The terms host and host computer are used interchangeably throughout
this document.

2. A host computer can also function as a management station.

IBM FAStT Storage Manager Version 9.1 software for Windows
Storage Manager Version 9.1 contains the following software components for
Windows 2000 and Windows Server 2003:
* The following component installs on both the host and management station:
— Storage Manager 9.1 Client (SMclient)
* The following components install only on the host:
— Redundant Disk Array Controller (RDAC)
— Storage Manager 9.1 Agent (SMagent)
— Storage Manager 9.1 Utility (SMutil)

Storage Manager 9.1 Client

The Storage Manager 9.1 Client (SMclient) component provides the graphical user
interface (GUI) for managing storage subsystems. The SMclient contains two main
components:

« Enterprise Management. You can use the Enterprise Management component
to add, remove, and monitor storage subsystems within the management
domain.

* Subsystem Management. You can use the Subsystem Management component
to manage the components of an individual storage subsystem.

The Event Monitor is a separate program that is bundled with the SMclient. If
installed, it monitors storage subsystems whenever the Enterprise Management
window is closed. It runs continuously in the background and can send alert
notifications in the event of a critical problem.

Redundant disk array controller

The redundant disk array controller (RDAC) contains the multi-path device driver
that is necessary to provide controller failover support when a component on the
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fibre-channel 1/0 path fails. For RDAC in Storage Manager 9 and higher, a
maximum of four end-to-end fibre-channel paths from the host to the storage
subsystems are supported.

Storage Manager 9.1 Agent

The Storage Manager Agent (SMagent) provides a management conduit for the
SMclient to configure and monitor the subsystem through the fibre-channel I/O path.
The agent also provides local or remote access to the SMclient depending on
whether the client is installed on the host or in a network management station over
the TCP/IP network.

Storage Manager 9.1 Utility

The Storage Manager 9.1 Utility (SMutil) dynamically defines and maps new logical
drives to the operating system. This software package contains the following
components:

* hot_add utility. The hot_add utility enables you to register newly created logical
drives with the operating system. For more information, see [Using the hot_add|
[utility” on page 116

» SMdevices utility. The SMdevices utility enables you to associate storage
subsystem logical drives with operating-system device names. For more
information, see [‘Using the SMdevices utility” on page 116/

* SMrepassist utility. The SMrepassist utility enables you to perform the following
tasks:

— Flush cached data before creating a FlashCopy or VolumeCopy.

— This is a Windows-only utility. Unmount the file system when using other
operating systems.

For more information, see[‘Using the SMrepassist utility” on page 117

IBM FAStT Storage Manager Version 9.1 software for NetWare
Storage Manager Version 9.1 contains the following software components for
NetWare:
* The following components install on both the host and management station:
— Storage Manager 9.1 Client (SMclient)
» The following components install only on the host:
— LSIMPE.CDM

Versions of this component appear on the latest IBM fibre channel HBA
device driver for NetWare, on Novell NetWare Support Packs and on the
Novell web site. Always select the latest version of this component for use.
Download this software component from the following Web site:

lsupport.novell.com|

IBM FAStT Storage Manager Version 9.1 software for Linux

Storage Manager Version 9.1 contains the following software components for Linux:
» The following components install on both the host and management station:
— Storage Manager 9.1 Runtime (SMruntime)
This component contains the Java JRE for other software packages.
— Storage Manager 9.1 Client (SMclient)
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This component is necessary if you intend to manage the storage subsystem
from a host computer or a management station.

* If you choose Linux as the failover multipath driver, the following components
install only on the host:

— Storage Manager 9.1 Utility (SMutil)

This component packaged with the SMclient package contains the hot_add
and SMdevices utilities.

— Storage Manager 9.1 RDAC (SMRDAC)
This component provides multipath failover/failback capability.
— Storage Manager 9.1 Agent (SMagent)

This component is necessary if you intend to use the host-agent (in band)
management method. It requires that you first install RDAC.
 If you choose the QLogic HBA failover driver as the multipath failover/failback

driver, the following components install only on the host:

— Storage Manager 9.1 Utility (SMutil)

— FAStT Management Suite Java" (FAStT MSJ)
This component is optional if you installed RDAC to provide FC HBA
diagnostic functions. It is required if you did not install RDAC. It is necessary

to configure the LUN failover/failback path information for the Linux fibre
channel Host Bus Adapter failover device drivers.

— IBM FAStT-MSJ QLremote agent

Storage subsystem management methods
Storage Manager software provides the following two methods for managing
storage subsystems:
* The host-agent management method
* The direct management method

— Note:

* You must make direct (out-of-band) connection to the FAStT Storage Server
in order to obtain the correct host type. The correct host type will allow the
FAStT Storage Server to configure itself properly for the operating system of
the host server. After you do so, and depending on your particular site
requirements, you can use either or both management methods. The
management methods you select will determine where you will need to
install the software components.

» To optimize FAStT Storage Server management availability and access,
IBM recommends that you configure both in-band and out-of-band
management connections. In such an arrangement, should either
connection type fail, you should still able to manage your storage server
using the other connection.

* If you establish management connections from multiple management
stations or hosts to the same FAStT Storage Servers, it is best practice to
have only one active management connection to the FAStT Storage Server
at a time, even though IBM supports up to eight simultaneous active
management sessions to a given FAStT Storage Server.

« Storage Manager 9.1 supports only the out-of-band management method
for use with the Linux operating system when no Linux RDAC is used.
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Host-agent (in-band) management method
When you use the host-agent (in-band) management method, you manage the
storage subsystems through the fibre-channel 1/0 path to the host. The

management information can either be processed in the host or passed to the
management station through the network connection, as shown in |Figure 2.0n page|

Managing storage subsystems through the host-agent has the following
advantages:

e Ethernet cables do not need to be run to the controllers.

* A Dynamic Host Configuration Protocol/Bootstrap Protocol (DHCP/BOOTP)
server is not needed to connect the storage subsystems to the network.

» The controller network configuration tasks that are described in [Chapter 2,
[‘Preparing for installation,” on page 33, do not need to be performed.

* A host name or IP address must only be specified for the host instead of for the
individual controllers in a storage subsystem. Storage subsystems that are
attached to the host are automatically discovered.

Managing storage subsystems through the host-agent has the following
disadvantages:

* The host-agent requires a special logical drive, called an access logical drive, to
communicate with the controllers in the storage subsystem. Therefore, you are
limited to configuring one less logical drive than the maximum number that is
allowed by the operating system and the host adapter that you are using.

 If the connection through the fibre channel is lost between the host and the
subsystem, the subsystem cannot be managed or monitored.

Note: The access logical drive is also referred to as the Universal Xport Device.

Important: If your host already has the maximum number of logical drives
configured, either use the direct-management method or give up a logical drive for
use as the access logical drive. For more information, see [‘Number of supported|
logical drives” on page 31
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Running the
host-agent software
’ Controller ‘ ffffff ;
’ Controller ‘
Host computer
Fibre Channel
47 /0 path
’ Controller ‘ Network—»
’ Controller ‘

Storage subsystems

Note: The host can
act as a management
station also.

Management station
(one or more) $J000879

Figure 2. Host-agent (in-band) managed storage subsystems

Direct-management (out-of-band) method

When you use the direct-management (out-of-band) method, you manage storage
subsystems directly over the network through a TCP/IP Ethernet connection to each
controller. To manage the storage subsystem through the Ethernet connections, you
must define the IP address and host nhame for each controller. Each of the storage
subsystem controllers must be connected, through a cable connected to the RJ-45
connector, to an Ethernet network, as shown in|Figure 3 on page 14{

Managing storage subsystems using the direct-management (out-of-band) method

has the following advantages:

* The Ethernet connections to the controllers enable a management station
running SMclient to manage storage subsystems that are connected to a host
running any of the operating systems that Storage Manager 9.1 supports.

* An access logical drive is not needed to communicate with the controllers. You
can configure the maximum number of logical drives that are supported by the
operating system and the host adapter that you are using.

* You can manage and troubleshoot the storage subsystem when there are
problems with the fibre-channel links.

Managing storage subsystems using the direct-management (out-of-band) method
has the following disadvantages:
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* You need two Ethernet cables to connect the storage subsystem controllers to a
network.

* When adding devices, you must specify an IP address or host name for each
controller.

* Network preparation tasks are required and you might need a DHCP/BOOTP
server. For a summary of the preparation tasks, see|Chapter 2, “Preparing for|
[installation,” on page 33.|

You can avoid DHCP/BOOTP server and network tasks by assigning static IP
addresses to the controller, or by using a default IP address.

» To assign a static IP address, see the IBM support Web site at:
[www.ibm.com/pc/support/]

Refer to Retain Tip *H171389 Unable To Setup Networking Without
DHCP/BOQOTP.

» Storage subsystem controllers with firmware version 05.00.xx.xx or higher have
the following default settings.

Controller IP address Subnet mask

A 192.168.128.101 255.255.255.0

B 192.168.128.102 255.255.255.0
Notes:

1. If the storage subsystem controllers have firmware version 05.4x.xx.xx or
higher, use the Storage Manager Client Program to change the default IP
address.

2. You must make a direct management connection to the storage server using
the default IP addresses before you can change them.

[Figure 3 on page 14|shows a system in which storage subsystems are managed by
using the direct-management (out-of-band) method.
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’ Controller ‘ ***** !

’ Controller ‘
Host computer
| Fibre Channel
I/O path

’ Controller ‘

’ Controller ‘

Storage subsystems

<+— Ethernet

Management station
(one or more) ;500864

Figure 3. Direct-management (out-of-band) storage subsystems

Reviewing a sample network

[Figure 4 on page 15|shows an example of a network that contains both a
directly-managed storage subsystem (Network A) and a host-agent-managed
storage subsystem (Network B).

Directly-managed storage subsystem: Network A is a directly-managed storage
subsystem. Network A contains the following components:

e A DHCP/BOOTP server

* A network management station (NMS) for Simple Network Management Protocol
(SNMP) traps

* A host that is connected to a storage subsystem through a fibre-channel I/O path

* A management station that is connected by an Ethernet cable to the storage
subsystem controllers

Note: If the controllers, static IP addresses, or default IP addresses are used, you
do not need to setup the DHCP/BOOTP server.

Host-agent-managed storage subsystem: Network B is a host-agent-managed
storage subsystem. Network B contains the following components:

* A host that is connected to a storage subsystem through a fibre-channel I/O path
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* A management station that is connected by an Ethernet cable to the host

computer
Network A Fibre Channel
TCP/IP I/O path Ethernet
Storage
subsystem

’ ‘ ’ ‘ - finance

Network Host computer ', Controller || Management DHCP/BOOTP server

management Denver | Control station

station (IP address 7] ontroerji—" (one or more)

(for SNMP traps)192.168.128.112) Host name: Denver._a
(IP address 192.168.128.101)

hardware address 00.a0.b8.02.04.20
Host name: Denver_b

Router (IP address 192.168.128.102)
hardware address 00.a0.b8.00.00.d8

Network B Fibre Channel
TCP/IP I/0 path Ethernet
Storage
subsystem

Host computer | | Management
Atlanta ! Controlier station

(IP address ~ ‘——1|_Controller (one or more)

192.168.2.22) $J000882

Figure 4. Sample network using directly-managed and host-agent managed storage
subsystems

Where to install software components

How you manage the storage subsystems determines where you must install the
various software components.

Management stations
You must install the following software components on each management station:
» SMclient
* SMruntime (for Linux only)

Host computers
You must install the following software components on each host computer:
* RDAC (for Linux, Windows 2000, and Windows Server 2003 only)
*  SMutil (for NetWare, Linux, Windows 2000, and Windows Server 2003 only)
* LSIMPE.com (for NetWare only)

* IBM FAStT MSJ and QLRemote agent (for Linux only, if Linux RDAC is not
installed)
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Note: See the Linux RDAC README in the IBM FAStT Storage Manager for x86
Linux software package for detailed Linux RDAC installation instructions.

Depending on how you intend to manage the storage subsystems, you might need
to install the following additional host software components:

* SMruntime (for Linux only)
* SMclient
* SMagent (for Linux, Windows 2000, Windows Server 2003, and NetWare only)

Note: Install the SMagent on a host computer if you intend to manage the storage
subsystems using the host-agent management method.

You must install the SMclient on a host computer if you intend the host computer to
act as a management station. If the host computer is not connected to a network,
you must install TCP/IP software and assign an IP address.

Configuration types

You can install Storage Manager 9.1 in either of the two following configurations:
» Standard (noncluster) configuration
+ Cluster server configuration

— Although there is currently no support for Linux cluster server configurations,
you can contact IBM for updates regarding availability of such support in the
future.

— lllustrations of cluster server configurations that follow do not pertain to
NetWare or Linux.
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Standard (non-cluster) configuration
shows a sample standard (non-cluster) configuration.

Controller ‘
| RDAC, SMutil,
Controller ‘ SMagent
Host computer
“«———Fibre Channel
| I/O path
’ Controller ‘ ****** i
The SMclient software
’ Controller ‘ fffffff can also be installed
on the host computer.
Storage subsystems
SMclient
<+— Ethernet
Management station $J000869

Figure 5. Sample standard (non-cluster) configuration
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Cluster server configuration for Windows and NetWare

Figure 6[ shows a sample cluster server configuration.

RDAC, SMutil,
SMagent

Ethernet—»

SMclient

Management station
(one or more)

| &~

|

Cluster server
node A

The SMclient software
can also be installed on
the cluster nodes.

Storage subsystem

Figure 6. Sample cluster server configuration

/" Cluster server
node B

N
\
\

1
'

Managed hub or
switch

’ Controller ‘

’ Controller ‘

$J000870

Installation types

You can install Storage Manager software in either of the following types of

hardware environments:

* New storage subsystem environment. Use this hardware environment if you
are installing the IBM TotalStorage FASIT Fibre Channel Storage Server using
firmware 06.10.xx.xx and you will manage storage subsystems using Storage

Manager 9.1.

« Existing storage subsystem environment. If you are installing Storage
Manager software in an environment with existing storage subsystems, see

[Table 5 on page 19|for your installation options.

Notes:

1. Where you are instructed in the following table to uninstall Storage Manager
software, be sure to uninstall the management software on all management
systems or hosts that have access to the storage subsystem that has firmware
06.10.xx.xx. The Storage Manager 9.1 RDAC has new functionality and features
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and it is compatible with older versions of firmware. To ensure the highest level
of compatibility and error-free operation, install the Storage Manager 9.1 RDAC
on all host computers that have disks defined on storage subsystems that have
firmware level 06.10.xx.xx.

2. Because uninstallation and installation of RDAC in Windows operating systems
requires system reboot, it is possible to install all other components of Storage
Manager 9.1, except RDAC, so that you can download the new firmware
version (06.10.xx.xx) to the storage subsystem and manage it. Schedule an
RDAC installation as soon as possible to ensure error-free operation and the
highest level of compatibility.

3. Controller firmware version 05.42.xx.xx is associated only with the IBM
TotalStorage FAStT100 Storage Server. Do not load this controller firmware
version on any other FAStT Storage Server.

Table 5. Configurations for existing storage subsystems

Current environment

Planned environment

Action

(Machine type 1742)
Existing storage
subsystems with
controllers that have
firmware versions
05.00.xx.xx, 05.2X.XX.XX
or 05.3x.xx.xx

(Machine type 1722 —
Turbo Option model
only) Existing storage
subsystems with
controllers that have
firmware version
05.4%.XX.XX

Firmware version 1.

06.10.xx.xx

Storage Manager 9.1.
Note: Firmware version

06.10.XX.XX Supports 2.

both fibre channel
expansion enclosures

(EXP500 and EXP700) |3.

and SATA expansion
enclosures (EXP100) as
long as the fibre

channel and SATA 4.

expansion enclosures
are not intermixed.

Uninstall Storage Manager 8.4x. See
‘Uninstalling storage management
software components” on page 118
for more information.

Install Storage Manager 9.1. See
['New installation process” on page 53
for more information.

Discover the storage subsystems.
See [‘Performing an initial automatic|
discovery of storage subsystems” on|
page 97| for more information.
Download firmware and NVSRAM
version 06.10.xx.xx. See
‘Downloading controller and
NVSRAM ESM firmware” on page)
102| for more information.

Note: To incorporate SATA hardware in
an existing FAStT600 Turbo, FAStT700,
or FAStT900 storage subsystem, use the
the upgrade instructions in the EXP100
Installation and User’s Guide. Instead of
using the version 05.41.xx.xx firmware
indicated in that document, however, use
the version 06.10.xx.xx firmware.

19

Chapter 1. Introduction



Table 5. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 1722 —
Base Option model
only) Existing storage
subsystems with
controllers that have
firmware version
05.4%.XX.XX

Firmware version
5.41.xXX.XX

Storage Manager 9.1.

Notes:

1. Perform upgrade of
machine types 1742
and 1722 to
firmware level
05.41.xx.xx only
when you no longer
plan to use these
storage servers to
manage EXP500
and EXP700
storage expansion
enclosures equipped
with fibre-channel
drives. Perform this
upgrade only when
you plan to use
these FAStT
Storage Servers
only to manage
EXP100 expansion
enclosures.

2. Firmware version
05.41.xx.xx supports
EXP100 expansion
enclosures only.

1.

This firmware ships as part of the
FAStT Storage Manager 8.41 Support
for FAStT EXP100 SATA Storage
Expansion Unit CD.

Uninstall Storage Manager 8.4x. See
"TUninstaIIing storage management
software components” on page 118|
for more information.

Install Storage Manager 9.1. See
FNew installation process” on page 53
for more information.

Follow the instructions to upgrade the
controller firmware in the IBM
TotalStorage FAStT EXP100
Installation and User’s Guide..

Note: Upgrade the controller firmware
using the version supplied on the FAStT
Storage Manager 8.41 Support for FAStT
EXP100 SATA Storage Expansion Unit
CD before downloading controller
firmware from the Web.

Only after you have done so, access the
Web to download controller firmware
version 5.41.xx.xx.
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Table 5. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 3552)
Existing storage
subsystems with
controllers that have
firmware version levels
04.00.xx.xx through
05.3X.XX.XX

Firmware version level
05.3X.XX.XX

Storage Manager 9.1.
Note: Firmware version
level 05.4x.xx.xx does
not support machine
type 3552.

1.

Uninstall previous Storage Manager
version. See [‘Uninstalling storage
management software components’|

on page 118| for more information.

Install Storage Manager 9.1. See
[‘New installation process” on page 53
for more information.

Discover the storage subsystems.
See fPerforming an initial automatid
discovery of storage subsystems” on|
page 97|for more information. If the
current controller firmware version
number starts with “4.”, go to the
FAStT technical support Web site
listed on page to download
firmware level 04.01.02.30 or higher
and its matching NVSRAM.

Important: The storage subsystem
controllers must be at firmware level
04.01.02.30 or higher before you
download firmware level 05.3x.xx.xx
and NVSRAM to the controllers.

If the current controller firmware
version number starts with "4.”,
download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See f‘DownIoadina
controller and NVSRAM ESM
firmware” on page 102|for more
information.

Download the latest firmware and
NVSRAM version 5.3x.xx.xx from the
IBM Web site. See |“Down|oadina
controller and NVSRAM ESM|
firmware” on page 102|for more
information.
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Table 5. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 3542)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.02.xx through
05.3X.XX.XX

Firmware version
5.3X.XX.XX

Storage Manager 9.1.
Note: Firmware version
05.4x.xx.xx does not
support machine type
3542.

1.

Uninstall the previous Storage
Manager software. See f‘UninstaIIingl
storage management software|
components” on page 118|for more
information.

Install Storage Manager 9.1. See
FNew installation process” on page|

B3
Discover storage subsystems. See
fPerforming an initial automatid]
discovery of storage subsystems” o
age 97|for more information. If the
current controller firmware version
number starts with “4.” , go to the
FASHT technical support Web site
listed on page to download the
level 04.01.02.30 or higher firmware
and matching NVSRAM.

Important: The storage subsystem
controllers must be at firmware level
04.01.02.30 or higher before you
download firmware level 05.3x.xX.xx
and NVSRAM to the controllers.

Download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See [‘Downloadin
controller and NVSRAM ESM
firmware” on page 102|for more
information.

Download firmware and NVSRAM

version 5.3x.xx.xx. See |“Downloadin§]

controller and NVSRAM ESM|
firmware” on page 102|for more
information.

(Machine type 1724)
Existing storage
subsystems with
controllers that have
firmware version
05.42.xx.xXx

Firmware version
5.42.xx.xx

Storage Manager 9.1.
Note: Firmware version
06.10.xx.xx does not
support Machine type
1724.

Uninstall Storage Manager 8.4x. See
‘Uninstalling storage management
software components” on page 118
for more information.

Install Storage Manager 9.1. See
['New installation process” on page 53
for more information.

Discover the storage subsystems.
See [‘Performing an initial automatic|
discovery of storage subsystems” on|
page 97| for more information.
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Table 5. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions

Firmware version
04.01.xx.xx for machine
type 3526

Firmware version

1.

Uninstall Storage Manager Version
7.x. See [‘Uninstalling storage}
management software components’|

on page 118| for more information.

04.00.xx.xx through 05.3x.xx.xx for machine |2- I‘nstaII_Storagg Manager 91 See
04.00.01.xx type 3552 [New installation process” on page 53
for more information.
Storage Manager 9.1 3. Discover the storage subsystems.
Note: Firmware version See fPerforming an initial automatid
05.3x.xx.xx does not discovery of storage subsystems” or]
support machine type page 97[for more information. If the
3526. Firmware version current controller firmware version
05.4x.xx.xx does not number starts with "4.”, go to the
support machine type FASLT technical support Web site
3552. listed on page fviilto download the
level 04.01.02.30 or higher firmware
and matching NVSRAM.
Important: The storage subsystem
controllers must be at firmware level
04.01.02.30 or higher before you
download firmware level 05.3x.xx.xx
and NVSRAM to the controllers.
4. If the current controller firmware
version number starts with "4.”,
download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See f‘DownIoadina
controller and NVSRAM ESM
firmware” on page 102|for more
information.
(Machine types 1722, | Remain at existing 1. Uninstall older versions of Storage
1742, 35.52., 3542 and | firmware version. Manager. See |—qq“Uninstalling storag
3526) Existing storage management software components’|
subsystems with Storage Manager 9.1 on page 118[for more information.
controllers that have Note: Storage Manager
firmware versions 9.1 can only manage I‘nstaII_Storagt_e Manager 91 See
04.01.xx.xx through FASIT Storage Servers [New installation process” on page 53
05.4X.XX.XX with controller firmware for more information.
versions 04.01.xx.xx or |3. Discover the storage subsystems.

higher.

See [‘Performing an initial automatic|
discovery of storage subsystems” on|
page 97| for more information.

(Machine types 3526,
3542, 3552) Existing
storage subsystems
with controllers that
have firmware versions
04.00.02.xx upto but not
including 04.01.xx.xx

Existing firmware
versions

Storage Manager 8.4x

Set up a separate management station
with Storage Manager 8.4x installed to
manage the storage subsystems with
controllers that have back-level firmware.
Note: The minimum controller firmware
level required for management by
Storage Manager 9.1 is 04.01.xx.xx or
higher.
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Table 5. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have

Existing firmware
versions

Storage Manager 7.10

Set up a separate management station
with Storage Manager 7.10 installed to
manage the storage subsystems with
controllers that have back-level firmware.

firmware versions
04.00.xx.xx through
4.00.01.xx

Managing coexisting storage subsystems

Storage subsystems are coexisting storage subsystems when the following
conditions are met:

* Multiple storage subsystems with controllers are running different versions of
firmware.

* These storage subsystems are attached to the same host.

For example, a coexisting situation exists when you have a new storage subsystem
with controllers running firmware version level 06.10.xx.xx, and it is attached to the
same host as one or more of the following configurations:

* A storage subsystem with controllers running firmware version levels 04.00.xx.xx
through 04.00.01.xx, which is managed by a separate management station with
Storage Manager 7.10.

» A storage subsystem with controllers running firmware version levels 04.00.02.xx
through 05.3x.xx.xx, which is managed with Storage Manager 8.4x.

Important: The common host must have the latest level (9.1) of RDAC and
SMagent installed. Upgrade all storage subsystems running firmware at or below
level 05.2x.xx.xx to the current code level. The latest 05.3x.xx.xx firmware for
FAStT200, FAStT500, FAStT600 Base and 06.10.xx.xx for FAStT600 Turbo,
FAStT700, and FAStTO00 is available free of charge for download with all fixes and
software patches from the following IBM support Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|
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Figure 7| shows an example of a Windows environment that includes coexisting

storage subsystems.

Version 8.4 of the
storage-management

software must be installed on either

a management station or host.

Important: In a

co-existing situation,

the common host

must have Storage Manager
Version 8.4 RDAC and SMagent

installed./

Management station

Firmware version
4.x (minimum)

’ Controller ‘

’ Controller ‘

Firmware
version 5.x

’ Controller ‘ ffffff !

Host-agent

Host computer

<+— Fibre Channel

I/O path

Ethernet ——»|

’ Controller ‘ 777777 i

Storage subsystems

Version 7.10 of the storage-management

software must be installed on a
management station.*

*Only to manage existing
storage subsystems with firmware
version 4.00.xx.xx to 4.00.01.xx.

Client software

Management station $J001058

Figure 7. Sample coexisting storage subsystems

System requirements

This section provides detailed information about the hardware, software, and
operating system requirements for Storage Manager 9.1.
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Hardware requirements
lists the hardware required for installing Storage Manager 9.1.

Table 6. Hardware requirements for Storage Manager 9.1 software

Hardware
component Requirements Software tested

A DHCP/BOOTP | One of the following BOOTP or
server (only for | BOOTP-compatible servers:

directly managed |. Microsoft BOOTP-compatible
storage DHCP server for Windows 2000

subsystems) * Microsoft BOOTP-compatible

Note: If the )
controllers static g(l)ﬂoCc))’P server for Windows Server

IP addresses or
default IP ¢ UNIX BOOTP server
addresses are |+ NetWare DHCP server
used, you do not
need to set up
the
DHCP/BOOTP
server.

Storage Storage subsystems with controllers
subsystems (one | running firmware version levels
or more) 04.00.02.xx through 05.4x.XX.XX

Fibre Channel The following fibre-channel host
host adapters adapters were tested with the
storage management software:

* IBM FAStT host adapter (part
number: OON6881)

* An IBM FASLtT FC2 Host Bus
Adapter (part number 19K1246)
or IBM FASHT single port
FC2-133 Host Bus Adapter (part
number 24P0960)

For information about specific host
adapter requirements:

* Refer to the readme file in the
\Host_Adapter directory on the
installation CD.

* Read the host adapter
documentation.

* Go to the Web site at:
[www.ibm.com/pc/support]
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Table 6. Hardware requirements for Storage Manager 9.1 software (continued)

Hardware
component

Requirements

Software tested

Fibre Channel
fabric switches
(if needed for the
desired
configuration)

The following fibre-channel fabric
switches were tested with the
storage management software:

* |BM 8-port fibre-channel switch
(machine type 2109 S08)

* IBM 16-port fibre-channel switch
(machine type 2109 S16)

* IBM 16-port 2 Gbps fibre-channel
switch (machine type 2019 F16)

* IBM 8-port 2 Gbps fibre-channel
switch (machine type 3534 F08)

e IBM 32-port 2 Gbps fibre-channel
switch (machine type 2109 F32)

* |BM TotalStorage SAN Switch
HO8 (machine type 2005-H08)

* |BM TotalStorage SAN Switch
H16 (machine type 2005-H16)

* INRANGE IN-VSN FC/9000 2
Gbps fibre-channel directors
(machine types 2042-01 and
2042-128)

* McDATA 4500 Sphereon 2 Gbps
16-, 24-, and 32-port
fibre-channel switch (machine
types 2031-216, 2031-224, and
2032-232)

* McDATA Intrepid 6140 2 Gbps
directors (machine type
2032-140)

» CISCO MDS 9209 2 Gbps
multilayer director (machine types
2062-D07 and 2062-T07)

» CISCO MDS 9216 2 Gbps
multilayer fabric switch (machine
type 2062-D01)

For specific fibre-channel switch
setup requirements:

* Read the switch documentation.
* Go to the Web site at:
[www.ibm.com/storage/fcswitch/|
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Table 6. Hardware requirements for Storage Manager 9.1 software (continued)

Hardware

component Requirements Software tested
Management Your management station computer

station (for client |requires:

software) * Intel Pentium® or

Pentium-equivalent
microprocessor (450 MHz or
faster)

* CD-ROM drive
* Mouse or similar pointing device
* System memory:

— For Windows 2000: A
minimum of 128 MB (256 MB
recommended)

— For Windows Server 2003,
NetWare, and Linux: A
minimum of 256 MB (512 MB
recommended)

« Ethernet network interface
adapter

e AGP or PCI video adapter (AGP
preferred); ISA adapters are not
supported

* Monitor setting of 1024 x 768
pixels with 64 000 colors. The
minimum display setting that is
allowed is 800 x 600 pixels with
256 colors.

* Hardware-based Windows
acceleration. Desktop computers
that use system memory for video
memory are not preferred for use
with the storage management
software.

Important: Many PC-based servers
are not designed to run
graphic-intensive software. If your
server has difficulty running the
storage management software
smoothly without video artifacts, you
might need to upgrade the server
video adapter.

Note: For more information about host adapters, fabric switches, and managed
hubs, go to the following ServerProven™ Web sites at:

www.ibm.com/pc/us/compat/]

www.ibm.com/storage/disk/fastt/supserver.htm|

Firmware requirements

To use all of the features of Storage Manager 9.1, your storage subsystem must
contain controllers with firmware version 06.10.xx.xx for machine types 1722 (Turbo

28 1BM TotalStorage FAStT Storage Manager Version 9 Installation and Support Guide for Intel-based Operating System

Environments


http://www.ibm.com/pc/us/compat
http://www.storage.ibm.com/disk/fastt/supserver.htm

Option model only) and 1742 (all models). To manage storage subsystems with
Storage Manager 9.1, your storage subsystems must contain controllers with
firmware versions 04.01.xx.xx or higher.

lists firmware upgrades that are not currently possible.

Table 7. Firmware upgrades that are not possible

Machine type

Impossible firmware version upgrade

3552 and 3542

04.xx.xx.xx through 5.3x.xx.xx to 06.10.xx.Xx

1722 (Base and Single
Controller Unit models)

05.3x.xx.xx to 06.10.xx.xx

1724

05.42.xx.xx to 06.10.xx.xx

For more information on this subject, contact your IBM reseller or IBM marketing

representative.

Storage Manager 9.1 also supports four premium feature options:
» Storage Partitioning

* FlashCopy
* VolumeCopy
* Remote Mirror

Windows software requirements

lists the disk space and administrator privileges that are required to install
version 9.1 of the storage management software in a Windows environment.

Note: The disk space listed in Table 5 is for the packages after the installation.
During the installation of each software package, you might need up to 140
MB of free disk space.

Table 8. Installation requirements for Windows by software package

Disk space requirement Administrator privilege
Package (Windows 2000) (Windows 2000)
SMclient 80 MB Not required / Not required
RDAC 2MB/2MB Required
SMagent 1 MB /1 MB if SMclient is Required

installed.

40 MB / 40 MB if SMclient is not

installed.
SMutil 2MB/2 MB Required

Windows operating system requirements

Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations

* Windows 2000 Server with Service Pack 4

* Windows 2000 Professional with Service Pack 4

* Windows 2000 Advanced Server with Service Pack 4
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* Windows XP, Professional Edition

* Windows Server 2003, Web Edition

* Windows Server 2003, Standard Edition
* Windows Server 2003, Enterprise Edition

Host computers

* Windows 2000 Server with Service Pack 4

* Windows 2000 Professional with Service Pack 4

* Windows 2000 Advanced Server with Service Pack 4
* Windows Server 2003, Web Edition

» Windows Server 2003, Standard Edition

* Windows Server 2003, Enterprise Edition

Cluster nodes

* Windows 2000 Advanced Server with Service Pack 4
* Windows 2000 Datacenter

* Windows Server 2003, Enterprise Edition

NetWare software requirements

lists the disk space that is required for installing the Storage Manager 9.1
software in a NetWare environment. During the installation of each software
package, you may need up to 120 MB of free disk space.

Table 9. Installation requirements for NetWare by software package

Package Disk space requirement
Storage Manager 9.1 Client (SMclient) 50 MB

LSIMPE.CDM driver 2 MB

IBM FAStT Management Suite Java (FAStT-MSJ) |2 MB

IBM HA device driver 2 MB

NetWare operating system requirements

Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations

* Windows 2000 Server with Service Pack 4

* Windows 2000 Professional with Service Pack 4

* Windows 2000 Advanced Server with Service Pack 4
* Windows XP

* Windows Server 2003

Host computers
* Novell NetWare 6.0 with Service Pack 4
* Novell NetWare 6.5 with Service Pack 2

Cluster nodes
* Novell NetWare 6.0 with Service Pack 4 and NCS 1.6
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Novell NetWare 6.5 with Service Pack 2 and NCS 1.7

Linux software requirements

lists the disk space that is required for installing Storage Manager 9.1 in a
Linux environment.

Table 10. Installation requirements for Linux by software package

Package Disk space requirement
Storage Manager 9.1 Client (SMclient) 50 MB on /opt, 2 MB on /tmp
IBM FAStT Management Suite Java (FAStT-MSJ) 50 MB

Storage Manager 9.1 RDAC 2 MB

Storage Manager 9.1 Agent (SMagent) 2 MB

Storage Manager 9.1 Utility (SMutil) 7 MB on /opt

IBM Host Adapter device driver 1 MB

Storage Manager 9.1 run time (SMruntime) 70 MB on /opt, 1 MB on /var

Linux operating system requirements

able 11|lists the minimum operating system and kernel levels required by each
management station or host computer.

Table 11. Management station or host computer by minimum operating system and kernel

levels

Operating system Kernel

Red Hat Linux Advanced Server 2.1 2.4.9-e.43 or higher
Red Hat Enterprise Linux Advanced Server 3.0 2.4.21-9.0.3.el or higher
SuSE Linux Enterprise Server Version 8 (SLES 8) 2.4.21-215 or higher
Notes:

1.

Red Hat Enterprise Linux Advanced Server 2.1 supports a maximum of 128
logical drives per storage partition.

Red Hat Enterprise Linux Advanced Server 3.0 support 256 logical drives per
partition.

SuSE Linux Enterprise Server 8 supports a maximum of 256 logical drives per
storage partition.

Number of supported logical drives

With controller firmware 05.40.xx.xx and higher, the supported logical drive limits for
NetWare 6.0, Linux, Windows 2000, and Windows Server 2003 are as follows:

NetWare 6.0 with SP3 or higher and NetWare 6.5 with SP2 or higher, support up
to 256 logical drives per storage subsystem (LUNs 0-255) when you use
IBM-approved FASIT adapters and their supported device drivers.

Linux supports up to 256 logical drives per storage subsystem (LUNs 0 through
255) when you use IBM-approved FASIT adapters and their supported device
drivers.

Check your Linux kernel documentation for the maximum total number of logical
drives supported in the host sever and the maximum number of logical drives
that can be mapped from a storage subsystem.
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Windows 2000 supports up to 64 logical drives per storage subsystem (LUNs O
through 63) when you use IBM-approved FAStT adapters and their supported
device drivers.

Windows Server 2003 supports a maximum of 255 LUNs (LUNs 0 through 254)
when you use IBM-approved FASIT adapters and their supported device drivers.

The maximum number of logical drives that a FASIT storage subsystem supports
with firmware version 05.4x.xx.xx depends on the model of the FASIT storage

subsystem. See [Table 12

Table 12. Maximum number of logical drives per storage server

Model Maximum logical Maximum logical drives |Maximum FlashCopy
Type drives per storage unit partition | logical drives

1742 2048 (See notes[d and |256 (See notes[dand[e) | 1024 (See note[d)
1722 1024 (See notes and |256 (See noteslé—_'rlandEb 512 (See note@)

Environments

The access logical drive is also referred to as the Universal Xport Device.

Notes:

1.

When you use firmware version 5.xx.xx.xx or higher, the firmware reserves one
logical drive for use by the system.

Maximum of four FlashCopy logical drives for each standard logical drive.
Maximum of 64 Remote Mirror pairs.

The host-agent management method uses a special logical drive, called an
access logical drive, to communicate with the controllers on the storage
subsystem. The access logical drive uses one of the available LUNs. Therefore,
managing storage subsystems with the host-agent software limits you to one
fewer LUN than the maximum number supported by the operating system and
the host adapter.

For firmware version levels 05.2x.xx.xx and higher, the maximum number of
logical drives includes the FlashCopy repository logical drives and the Remote
Mirror logical drives in addition to the standard data logical drives. If the Remote
Mirror option is enabled, two logical drives are reserved for use by the system.

For firmware version level 05.4x.xx.xx and higher, the default host type limit is
the maximum LUN value allowed in the default partition. If the default host type
has the restriction option enabled, the default partition allows only 32 LUNS;
otherwise, it allows 256 LUNSs.

Important:

The FlashCopy drive can not be added or mapped to the same server that has
the base logical drive of the FlashCopy logical drive in a Windows 2000,
Windows Server 2003, or NetWare environment. You must map the FlashCopy
logical drive to another server.

For firmware version 05.3x.xx.xx and earlier, the maximum number of logical
drives that can be mapped to a host server from each storage subsystem is 32.
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Chapter 2. Preparing for installation

This chapter provides information to help you plan the installation of the storage
management software.

See the appropriate sections of this document to install either Storage Manager 9.1
host software for a particular operating system. When you have completed Storage
Manager 9.1 software component installation procedures, perform the procedures in
Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97| and

Chapter 9, “Using the storage management software for Windows and NetWare,” on|

page 113.|

See the FASIT Storage Manager 9.1 Support for FAStT EXP100 SATA Storage
Expansion Unit CD for additional information as well as firmware associated with
FAStT EXP100 Storage Expansion Unit.

Planning and preparing for Windows installation

contains information about where you need to install the Storage Manager
software components.

Table 13. Software component installation in a Windows environment

System type Software installation sequence

Management station | SMclient

Host computer and 1. SMclient

cluster node )

= Optional component

» Necessary if you intend to manage the storage subsystem from
the host computer.

- See[‘Storage Manager 9.1 Client” on page 54.|
2. RDAC

* Required component

« See[‘RDAC” on page 56
3. SMagent

» Optional component

* Necessary if you intend to use the host-agent management
method.

+ See(‘Storage Manager 9.1 Agent” on page 57|
4. SMutil
* Required component
» Contains the hot_add, SMdevices, and SMrepassist utilities
+ See|[‘Storage Manager 9.1 Utility” on page 59.|

Planning and preparing for NetWare installation

[Table 14 on page 34|shows the installation sequence for Storage Manager software
components and provides information to help you plan for the installation of the
storage management software.

Important:
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» If you are upgrading from Storage Manager version 8.x, remove the current
software before installing Storage Manager version 9.1.

* No reboot is required during the client software installation process. The event
monitor software is installed automatically during client software installation.

Table 14. Software component installation sequence in a Novell NetWare 6.0 environment

System type

Software installation sequence

Management station

Storage Manager 9.1 Client (SMclient).

Host computer and
cluster node

1.

Storage Manager 9.1 Client (SMclient)

This optional component is necessary if you intend to manage the
storage subsystem from a host computer.

See FStorage Manager 9.1 Client” on page 82.|
a. Storage Manager 9.1 Agent (SMagent)

This optional component packaged with the SMclient package
is necessary if you intend to use the a host-agent management
method.

b. Storage Manager 9.1 Utility (SMutil)

This required component packaged with the SMclient package
contains the hot_add, SMdevices, and SMrepassist utilities.

IBM Host Adapter device driver (QL2x00)
See [‘Installing the NetWare fibre channel HBA device driver” on|

|Qage 85.|

LSIMPE.CDM and Novell native multipath failover drivers.

See [‘Installing the LSIMPE driver and NetWare native failover
|device driver” on page 85.]

Planning and preparing for Linux installation

shows the installation sequence for Storage Manager software
components and provides information to help you plan for the installation of the
storage management software for Linux.

Table 15. Software component installation sequence in a Linux environment

System type

Software installation sequence

Management station
(and any host server
in use as a

management station)

—_

Storage Manager 9.1 runtime (SMruntime)
Storage Manager 9.1 Client (SMclient)
See [Installing the Storage Manager 9.1 Client (SMclient)” on page|
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Table 15. Software component installation sequence in a Linux environment (continued)

System type Software installation sequence

Host computer and | If you chose the Linux RDAC as the failover multipath, install the
cluster node following components:

1. IBM Linux fibre channel host bus adapter non-failover device
driver version of the fibre channel HBA (QLA2200.0 and QLA2300.0).

2. Storage Manager 9.1 RDAC (required)

This component provides failover/failback capability. See |'RDAC”
on page 56

3. Storage Manager 9.1 Agent (optional)
This component is necessary if you intend to use the host-agent

(in band) management method. It requires that you first install
RDAC. See step 2

S-ee [“Installing Storage Manager 9.1 Agent (SMagent)” on page

4. IBM FASIT Management Suite Java and QLRemote Agent
(optional, for diagnostics only)

These components are optional. Completed this step to provide
fibre channel host bus adapter diagnostic functions.

See [Installing IBM FAStT Management Suite Java” on page 93]

Install the following packages if you chose the IBM Linux Host Bus
Adapter failover driver as the multipath (non-RDAC) failover driver:

1. IBM Linux Host Adapter failover device driver version of the FC
HBA (QLA2200.0 and QLA2300.0).

These required components enable your computer to communicate
with the host adapter and to provide logical drive failover/failback
support.

See [‘Installing the IBM fibre-channel host bus adapter device|
[driver” on page 94,
2. IBM FASIT Management Suite Java and QLRemote (required)

This package is required if you did not install RDAC (step Eb It will
configure the LUN failover/failback path information for the Linux
FC Host Bus Adapter failover device drivers and also provide
diagnostic function. See the README file that ships with the
FAStT-MSJ package and the Linux FC HBA failover device driver
for information needed to set up the failover/failback path.

See [‘Installing IBM FAStT Management Suite Java” on page 93/

Preparing a network installation

To begin installing the storage management software, ensure that the network
components are set up and operating properly, and that you have all the host and
controller information needed for the software to operate correctly.

The following steps provide an overview of the tasks involved in setting up a
network installation:

1. Install all hardware components (host computers, storage subsystems, and
cables) that you want to connect to the network. You might need to refer to the
installation guides specific to the hardware components.

2. Establish a naming convention for the storage subsystems connected to the
network. See[“Step 1: Naming the storage subsystems” on page 36| for more
information.
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3. Record the storage subsystem names and management types in|Appendix E,|
[‘Storage subsystem and controller information record,” on page 137.|An
example of a completed information record is shown in[Table 16 on page 37}

Note: Throughout the remaining steps, you will need to return to|Appendix E,|
[‘Storage subsystem and controller information record,” on page 137[to
record information such as hardware Ethernet addresses and IP
addresses.

4. (For a directly-managed system only) Determine the hardware Ethernet address
for each controller in storage subsystems connected to the network. See |“Step
3: Identifying the hardware Ethernet MAC address for each controller” on page
3_7| for more information.

5. (For a directly-managed system only) If you are using a default controller IP
address, go to step|7] Otherwise, obtain the TCP/IP address and host name for
each of the controllers in the storage subsystems on the network from the
network administrator. See [‘Step 4: Assigning IP addresses to hosts and|
[controllers” on page 39|

(For a host-managed system only) Obtain the IP address and host name of the
host computer on which the host-agent software will run from the network
administrator. See [‘Step 4: Assigning IP addresses to hosts and controllers” on|

6. (For a directly-managed system only) Set up the DHCP/BOOTP server to
provide network configuration information for a specific controller. If you are
using a controller static IP addresses, skip this step.

7. Verify that the TCP/IP software is installed. For more information, see[‘Step 6]

(Windows): Verifying the TCP/IP protocol and setting up the host or DNS table’]

on page 47.|

8. (For a directly-managed system only) Set up the host or domain name server
(DNS) table. For more information, see [‘Step 6 (Windows): Verifying the TCP/IP|
[protocol and setting up the host or DNS table” on page 47

9. Power on the devices that are connected to the network.

Step 1: Naming the storage subsystems

As you set up your network, decide on a naming convention for the storage
subsystems. When you install the storage management software and start it for the
first time, all storage subsystems in the management domain display as <unnamed>.
Use the Subsystem Management window to rename the individual storage
subsystems.

Consider the following factors when you name storage subsystems:

* There is a 30-character limit. All leading and trailing spaces are deleted from the
name.

* Use a unique, meaningful naming scheme that is easy to understand and
remember.

» Avoid arbitrary names or names that might quickly lose their meaning.

» The software displays storage-subsystem names with the prefix Storage
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is
displayed as:

Storage Subsystem Engineering
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Step 2: Recording the subsystem names

After you decide on a naming scheme, record the storage subsystem names in the
blank information record form provided in|Appendix E, “Storage subsystem and|
icontroller information record,” on page 137).

Table 16/ shows a sample information record for the network shown in
ba i

ge 15| This network contains storage subsystems that are managed by using
both the direct-management and host-agent-management method.

Table 16. Sample information record

Storage Management | Controllers-Ethernet and IP Host-IP address

subsystem name | method addresses, and host name and host name
Controller A Controller B

Finance Direct Hardware Hardware

Ethernet address | Ethernet address
= 00a0b8020420 |= 00a0b80000d8

IP address = IP address =
192.168.128.101 |192.168.128.102

Host = Denver_a | Host = Denver_b

Engineering Host-agent IP address =
192.168.2.22

Host = Atlanta

If you plan to manage your storage subsystem using the direct-management
method, go to |“Step 3: Identifying the hardware Ethernet MAC address for eachl
|gontro||er.”| If you plan to manage your storage subsystem using the host-agent
management method, go to [‘Step 4: Assigning IP addresses to hosts and|
icontrollers” on page 39

Step 3: Identifying the hardware Ethernet MAC address for each

controller

To manage your storage subsystem using the direct-management method, you
need to identify the hardware Ethernet medium access control (MAC) address for
each controller.

To identify the hardware Ethernet MAC address for machine types 3542 and 1722,
perform the following steps:

1. Locate the Ethernet MAC address at the back of the unit, under the controller
fibre-channel host ports, as shown in [Figure 8 on page 38| The number will be
in the form xx.xx.xx.xx.xx.xx (for example, 00.a20.b8.20.00.d8).

2. Record each Ethernet address in the information record (Appendix E, “Storage]
[subsystem and controller information record,” on page 137).
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Hardware Ethernet
address label $J000866

Figure 8. Locating the Ethernet MAC address (machine types 3542, 1724, and 1722)

To identify the hardware Ethernet MAC address for machine types 3552, 1724, and
1742, perform the following steps:

1. Remove the front bezel from the storage subsystem, as shown in|Figure 9
Carefully pull the bottom of the bezel out [ to release the pins. Then slide the
bezel down H .

$J000865

Figure 9. Removing the controller-unit bezel (machine types 3552 and 1742)

2. On the front of each controller, look for a label with the hardware Ethernet MAC
address. The number will be in the form xx.xx.xx.xx.xx.xx (for example,
00.20.b8.20.00.d8).

3. Record each Ethernet address in the information record dAppendix E, “Storagel
[subsystem and controller information record,” on page 137).
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4. To replace the bezel, slide the top edge under the lip on the chassis . Then
push the bezel bottom until the pins snap into the mounting holes H, as shown

in|Figure 10,

NNNNNN
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NNNNNNANN
NNSENNAE

$J000867

Figure 10. Replacing the controller-unit bezel (machine types 3552 and 1742)

5. Continue with f‘Step 4: Assigning IP addresses to hosts and controllers.’1

Step 4: Assigning IP addresses to hosts and controllers

If you plan to manage your storage subsystem using the direct-management
method, assign a unique IP address for every controller in all storage subsystems
on the network. Record the IP address for each controller in the information record
(Appendix E, “Storage subsystem and controller information record,” on page 137).
Then, go to[“Step 5: Setting up the DHCP or BOOTP-compatible server’ on page

/]

Note: If you want to assign static IP addresses for the controllers, refer to Retain
Tip #H171389 Unable to setup networking without DHCP/BOOTP at the IBM
support Web site at:

www.ibm.com/support|

Then go to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up|
the host or DNS table” on page 47.|

For FASLT storage controllers with firmware versions 05.4x.xx.xx or higher, you can
establish the out-of-band management connection to the FASIT Storage Server by
using the default IP addresses of 192.168.128.101 and 192.168.128.102 for
controllers A and B, respectively. You can change the IP addresses by using the
Controller » Change » Network Configuration menu option in the Storage
Manager Client Subsystem Management window.

Chapter 2. Preparing for installaton 39


http://www.ibm.com/support

If you plan to manage your storage subsystem using the host-agent management
method, assign an IP address for each host on which you will install the host-agent
software. Record the IP address for each host in the information record

(Appendix E, “Storage subsystem and controller information record,” on page 137).
Then, go to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up the]
lhost or DNS table” on page 47

Step 5: Setting up the DHCP or BOOTP-compatible server

To directly manage storage subsystems through the Ethernet connection to each
controller, you will need to set up a DHCP or BOOTP-compatible server and
configure the following options:

* Router/Gateway

+ DNS Server

* Hostname

* DNS

This section provides instructions to set up a DHCP server on Windows 2000,
Windows Server 2003, and Novell NetWare, as well as instructions to set up a
UNIX BOOT server.

Note: The remote management station (RMS) and network management station
(NMS) entries used in previous versions of the storage management
software are not required for Storage Manager 9.1.

Setting up a Windows 2000 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to [‘Creating a scope and setting up a DHCP server” on|

Installing the DHCP Manager
To install the DHCP Manager, perform the following steps:

1. Click Start » Administrative Tools » Configure Your Server. The Configure
Your Server window opens.

2. In the left pane, double-click Networking. Click DHCP.
3. In the right pane, click Start. The Windows Components Wizard starts.

4. In the Components field, select Networking Services. Then click Details.
The Networking Services window opens.

Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

5. In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP).

6. Click OK. The Windows Components Wizard window opens.
7. Click Next to start the installation process.

8. If prompted, type the full path to the Windows 2000 distribution files and click
Continue.

9. When the installation has successfully completed, the Windows Components
Wizard window closes and the Configure Your Server Window opens.

10. Click Next.
11. Click Open the DHCP Manager. The DHCP window opens.
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12. Continue with stepof [‘Creating a scope and setting up a DHCP server.]

Note: After you install the DHCP Manager, you can refer to the DHCP Manager
online help for additional information.

Creating a scope and setting up a DHCP server
Use the following procedure to create a scope and to set up a DHCP server. A
scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. Refer to the information record {Appendix E, “Storage subsystem and|
lcontroller information record,” on page 137). Before you begin, read through the
instructions to determine what information is required. Then request the information
from your network administrator.

1. Click Start » Programs » Administrative Tools + DHCP. The DHCP window

opens.

2. In the Console tree, right-click the server you want to configure; click New
Scope. The New Scope Wizard starts, as shown in [Figure 11]
x|

IP Addrezs Hange —r
“'ou defing the scope address range by identifying a set of consecutive 1P

addreszes.

Enter the range of addrezses that the zcope distibutes.

Start |P address: |152.1EB. 1.1

End IP address; |192 168, 1 . A0

& subnet mazk defines how many bitz of an IP address o use for the network./zubnet
|De and how mary bitz bo uge for the host [0, You can zpecify the zubnet mazk by
length or as an [P address.

Length: 24 =i

Subnet mask: | 255,255 255 0

¢ Back I Meut I Cancel

$J000868

Figure 11. New Scope Wizard: IP Address Range window

3. Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following fields:

a. Scope name and description

b. IP address range for the subnet mask, and the controllers you are
configuring

c. IP addresses that you want to exclude from the IP address range
IP address lease duration
Common DHCP options:
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10.
11.

12.

* |P address for a router
e Domain name and DNS servers

When you have defined the scope, click Yes, | want to activate this scope
now. The wizard ends, and the DHCP window opens.

In the Console tree, open the scope folder.

Right-click Reservations. Then select New Reservations. The New
Reservations window opens.

To define the IP address reservation, type the following information:
a. Reservation name

b. IP address

c. Ethernet hardware MAC address

d. Description

In the Supported Type field, select Both (DHCP and BOOTP).
Click Add.

Repeat stepsthrough|§|for each controller in the network.

Restart the DHCP server and then restart the storage subsystem so that all
modifications are applied.

Proceed to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up thel
[host or DNS table” on page 47.|

Setting up a Windows Server 2003 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
already installed on the system, see[‘Creating a scope and setting up a DHCP|

lserver” on page 43|

Installing the DHCP Manager
To install the DHCP Manager, perform the following steps:

1.

Click Start » Control Panel » Add or Remove Programs. The Add or Remove
Programs window opens.

In the left pane, click Add/Remove Windows Components. The Windows
Components Wizard window opens.

In the Components field, select Networking Services. Then click Details. The
Networking Services window opens.

Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP). Click OK. The Networking Services window
closes.

In the Windows Components Wizard window, click Next to start the installation
process.

If prompted, type the full path to the Windows Server 2003 distribution files and
click Continue.

When the installation has successfully completed, the Windows Components
Wizard window opens. Click Finish to close the Windows Components Wizard
window.

Close the Add or Remove Programs window. You are now ready to perform the
tasks in [‘Creating a scope and setting up a DHCP server” on page 43
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After you install the DHCP Manager, you can refer to the DHCP Manager online
help for additional information.

Creating a scope and setting up a DHCP server

Perform the following steps to create a scope and to set up a DHCP server. A
scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. See |Appendix E, “Storage subsystem and controller information|
|record,” on page 137.[Before you begin, read through the instructions to determine
what information is required. Then request the information from your network
administrator.

1. Click Start » Administrative Tools » DHCP. The DHCP window opens.

2. In the Console tree, right-click the server you want to configure, then click New
Scope. The New Scope Wizard starts.

3. Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following fields:

* Scope name and description

» |P address range for the subnet mask, and the controllers that you are
configuring

» |P addresses that you want to exclude from the IP address range
* |P address lease duration
* Common DHCP options:

— |IP address for a router

— Domain name and DNS servers or Windows Internet Naming Service
(WINS) servers

4. When you have defined the scope, click Yes, | want to activate this scope
now. The New Scope Wizard window opens.

5. Click Finish. The New Scope Wizard window closes and the DHCP window
opens.

6. In the Console tree, expand the Scope folder.

7. Right-click Reservations. Then select New Reservations. The New
Reservations window opens.

8. To define the IP address reservation, type the following information:
* Reservation name
* |IP address
* Ethernet hardware MAC address
* Description
9. In the Supported Type field, select Both (DHCP and BOOTP).
10. Click Add.
11. Repeat steps Elthrough for each controller in the network.

12. Restart the DHCP server and then restart the storage subsystem so that all
the modifications are applied.

13. Proceed to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up the|
[host or DNS table” on page 47.]

Setting up a Novell NetWare DHCP server

A Novell NetWare DHCP server automatically assigns IP addresses and other
configuration information to clients upon request or when the clients are restarted.

Perform the following steps to set up a Novell NetWare DHCP server:
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Install DNS/DHCP Services, either during or after installing NetWare 6.
Install the DNS/DHCP Management Console.

Create the DHCP server object.

Create the DHCP subnet address.

Create the subnet address range.

Create the IP address object.

Start the DHCP server.

N o~ =

Each of these tasks is described in detail in the sections that follow.

Adding Novell DNS/DHCP Services during the NetWare 6.0
installation

Perform the following steps to add Novell DNS/DHCP Services during the NetWare
installation:

1. From the Installation Options window, select Custom.

2. From the Components window, select the Novell DNS/DHCP Services check
box.

3. Follow the on-screen instructions to complete the NetWare installation.

Adding Novell DNS/DHCP Services after the NetWare 6.0
installation

Perform the following steps to add Novell DNS/DHCP Services after the NetWare
installation:

1. Insert the NetWare 6.0 Installation CD into the CD-ROM drive. Then mount the
CD as a volume.

2. Load NWCONFIG and select Product Options.
3. Select Install a Product not Listed.

4. Press F3 and specify the volume name of the CD. The X Server-Graphical
Console window opens.

5. In the Additional Products and Services dialog box, select the Novell
DNS/DHCP Services check box.

6. Follow the on-screen instructions to complete installation.

Note: Installing the DNS/DHCP Service will extend the Novell Directory Services
(NDS) schema and create the following NDS objects:

* DNSDHCP-GROUP Group object
 DNS/DHCP Locator object
* RootServerinfo Zone object

Installing the DNS/DHCP Management Console

Perform the following steps to install the DNS/DHCP Management Console and
NetWare Administrator snap-in files on the client workstation you will use to
administer DNS and DHCP:

1. If you have not done so, install the latest version of Novell Client 32 on your
workstation.

From the workstation, run the SYS:PUBLIC\DNSDHCP\SETUP.EXE program.

Install the DNS/DHCP Management Console on the local hard-disk drive.

Install the NetWare Administrator snap-in files in the SYS:PUBLIC\WIN32 directory.
Restart the workstation.

To start the DNS/DHCP Management Console, double-click the shortcut icon on
the desktop, type the NDS tree name, and click Launch.

2B
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Note: You can install the DNS/DHCP Management Console on a workstation, or
you can access it from the Tools menu of the NetWare Administrator utility.

Creating the DHCP server object
Use the DHCP Management Console to create a DHCP server object. You can
create a DHCP server object under any of the following objects:

* Organization (O)

* Organization Unit (OU)
* Country (C)

* Locality (L)

Perform the following steps to create a DHCP server object:
1. From the DHCP Management Console, click the DHCP Service tab.

2. In the left pane, select Our Network.

3. Click Create. The Create New DHCP Object window opens.

4. Select DHCP Server. Click OK. The Create DHCP Server window opens.
5. Select a server. Click Create. This creates the DHCP server object, called

DHCP_servername, in NDS.

6. In the DHCP Management Console, locate the icon for the DHCP server object
at the bottom of the DHCP Service tab. The server object displays with a red
line through it, indicating that the DHCP server has not been started.

7. Continue with [‘Creating the DHCP subnet object.]

Creating the DHCP subnet object

Perform the following steps to create a DHCP subnet object for each of the subnets

for which you want to assign addresses:
1. In the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select Our Network or the DHCP Server Object.

3. Click Create. The Create New DHCP Object window opens.

4. Select Subnet. Then click OK. The Create Subnet window opens.
5. For each subnet, type the following information:

* Subnet name

* NDS context

e Subnet address

* Subnet mask

e Default DHCP Server

6. Click Create. The DHCP subnet object is created and displayed in the
DNS/DHCP Management Console.

Creating the subnet address range
Perform the following steps to create a subnet address range object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.
2. Select the subnet object under which you want to create the subnet address

range object. Then click Create. The Create New DHCP Record window opens.

3. Select Subnet Address Range. Then click OK. The Create New Subnet
Address Range window opens.

4. Type the following information for the subnet address range:
* Subnet address range name
» Starting address
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* Ending address
5. Click Create.

6. Select the Define Additional Properties check box. Then set the Range Type
to Dynamic BOOTP and DHCP.

Creating the IP address object
Use the DNS/DHCP Management Console to create IP address objects. You use IP
address objects for the following purposes:

* To exclude an IP address from assignment
» To assign an IP address manually to a specific host
» To record dynamic IP address leases

Perform the following steps to create an IP address object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.
Select the subnet object of the target IP address. Then click Create.
Select IP Address. Click OK. The Create IP Address window opens.

In the IP Address field, type the IP address for the first controller.
In the Assignment field, select Manual.
In the Client Identifier field, specify the MAC address.

In the MAC Address field, enter the hardware Ethernet MAC address for the
controller.

8. Select the Define Additional Properties check box.

9. In the Hostname field, type the eight-character name for the controller.
10. In the Usage field, select Permanent.
11. Repeat steps |3 through |10| for each controller.

Starting the DHCP server
To start the DHCP server, at the DHCP server console, type:

LOAD DHCPSRVR

No o kDD

The DHCP server can now respond to client requests and assign IP addresses.

Notes:

1. To load the DHCP server automatically each time the server starts, place the
DHCPSRVR command in the SYS:\SYSTEM\AUTOEXEC.NCF directory.

2. For additional information about setting up, configuring, or using Novell
DNS/DHCP Services, refer either to the Novell Documentation CD or to the
following Web site:

[www.novell.com/documentation/|

Setting up a UNIX BOOTP server

To use a UNIX BOOTP server, you must set up a BOOTP table. |Tab|e 17| and the
information record (A pendix E, “Storage subsystem and controller informatiod
|record,” on page 137) provide the necessary information.

Table 17. Required entries for setting up the UNIX BOOTP server

Sample format in
Entry Description BOOTP server
Subnet mask Mask that is used to route packets to defined dot notation
subnets (sm=255.255.0.0)
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Table 17. Required entries for setting up the UNIX BOOTP server (continued)

Sample format in

Entry Description BOOTP server
Router IP address of the host computer that routes dot notation

packets to networks (gw=192.168.128.1)
Host name for the | Host name that is associated with the controller | host name (Denver_a)
controller (see[Table 27 on page 137)
IP address IP address of the controller (see [Table 27 on dot notation

page 137) (1p=192.168.128.101)
Ethernet address | The Ethernet address of the controller hexadecimal notation

hardware (see[Table 27 on page 137) (ha=00a0b8020420)

Perform the following steps to set up a UNIX BOOTP server:
1. Use a text editor to edit the bootptab file in the /etc directory.

Use the following example of the BOOTP table to configure the Network A
server shown in [Figure 4 on page 15 where the s4.default:\ entry denotes
settings that are common to all controllers, and the tc=s4.default:\ entry
associates this common setting group to a specific controller.

s4.default:\ (common settings)
ht=ether:\

sm=255.255.255.0:\
gw=192.168.128.1:\

hn:

denver_a:\

tc=s4.default:\ (common settings)
ip=192.168.128.101:\
ha=00a0b8020420:

denver_b:\

tc=s4.default:\
ip=192.168.128.102:\
ha=00a0b80000d8:

2. If the storage subsystem is running, shut down and then restart the subsystem.
This ensures that the parameters in the BOOTP table take effect.

3. Continue with ['Step 6 (Windows): Verifying the TCP/IP protocol and setting up|
[the host or DNS table.”|

Step 6 (Windows): Verifying the TCP/IP protocol and setting up the
host or DNS table

Install the TCP/IP networking stack to enable SMclient functions. Perform the
following two tasks by using the procedure that follows them:

» Verify that the TCP/IP protocol software is installed on the management station or
the host server on which you will install and from which will run SMclient.

» Set up the host or DNS table.

Note: Make sure that the host names for the controllers match the IP addresses for
the controllers.
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Windows 2000

Perform the following steps for Windows 2000:

1. Right-click My Network Places.

2. Select Properties. The Network and Dial-up Connections window opens.
3. Right-click a defined network connection.
4

Select Properties. Make sure that the Internet Protocol TCP/IP box under the
Components checked that are used by this connection is marked. If not, mark it,
click Install, and follow the instructions that display.

5. Update the DNS table to specify a host name to associate with an IP address.

If you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following example shows the
host tables for the controllers that are connected to Network A as shown in
[Figure 4 on page 15
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#

127.0.0.1 local host
192.168.128.101  denver_a

192.168.128.102  denver_b

Copyright (c) 1993-1999 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual Tine. The IP address should be placed
in the first column followed by the corresponding host name. The IP address
and the host name should be separated by at least one space.

Additionally, comments (such as these) might be inserted on individual

lines or following the machine name denoted by a'#' symbol.

For example:
102.54.94.97  rhino.acme.com # source server
38.25.63.10  x.acme.com # x client host

6.

To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.

Windows Server 2003

Perform the following steps for Windows Server 2003:

1.
2.

3.

4.

Open the Windows Explorer window.

Right-click the My Network Places folder and select Properties from the
pull-down menu. The Network Connections window opens.

Right-click a defined network connection and select Properties from the
pull-down menu.

A network_name Properties window opens. Make sure that the Internet Protocol
TCP/IP box under “The Connection Uses The Following ltems” window pane is
selected. If not, select it and click OK to close the network_name Properties
window.

Update the DNS table to specify a host name to associate with an IP address. If
you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following example shows the
host tables for the controllers that are connected to Network A, as shown in
[Figure 4 on page 15
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# Copyright (c) 1993-1999 Microsoft Corp.

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

# This file contains the mappings of IP addresses to host names. Each

# entry should be kept on an individual line. The IP address should

# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.

# Additionally, comments (such as these) may be inserted on individual

# lines or following the machine name denoted by a '#' symbol.

# For example:

# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 X.acme.com # x client host
127.0.0.1 localhost

192.168.128.101 denver_a

192.168.128.102 denver_b

6. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.

Step 6 (NetWare): Verifying the TCP/IP protocol and setting up the host

or DNS table

The normal default installation process will install the TCP/IP software package.

Perform the following steps to set up the host or DNS table. Make sure that the

host names for the controller match the IP addresses for the controllers.

1. Update either the host table or the DNS table to specify a host name to
associate with an IP address. If you do not have a DNS table, edit the two host
tables that are found in the sys:etc\hosts directories. (Your directory will be
different if the operating system is not installed on the root.)

To set up the host tables for the controllers, open the hosts file that is located in
the \etc\ directory. Use a text editor to update the host file to create the
following IP address and controller name entries. For example:

Mappings of host names and host aliases to IP addresses

127.0.0.1  Toopback 1b Tocal host loopback address

Examples from a fictitious network:

129.47.4.2 ta tahiti ta.some.com Toghost
129.47.6.40 osd-frog

129.47.6.144 sj-in5 inb

197.67.172.71 sj-inl inl

2. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.
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Step 6 (Linux): Verifying the TCP/IP protocol and setting up the host or
DNS table

The normal default installation process will install the TCP/IP software package.

Perform the following steps to set up the host or DNS table. Make sure that the

host names for the controller match the IP addresses for the controllers.

1. Update either the host table or the DNS table to specify a host name to
associate with an IP address. If you do not have a DNS table, edit the host
table that is found in the /etc/hosts directory. Your directory might be different if
the operating system is not installed on the root.

2. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.

The following sample shows a Linux host file. Do not remove the following line, or
various programs that require network functionality will fail.

127.0.0.1 rh71_8500 localhost.localdomain
localhost 102.54.94.97 rhino.acme.com x.acme.com
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Chapter 3. Installing Storage Manager software in a standard
Windows configuration

This chapter describes how to install the storage management software for
Windows 2000, and Windows Server 2003 in a standard (noncluster) configuration.
Before you install the software, make sure that you have read the following
information:

- If you intend to configure your system for clustering, see [Chapter 4, “Installing
Storage Manager software in a Windows cluster server environment,” on page|
61.

« If you have existing storage systems, see [‘Installation types” on page 18/and
[‘Managing coexisting storage subsystems” on page 24.

» To ensure proper installation, make sure that you have completed all preparation
tasks described in|Chapter 2, “Preparing for installation,” on page 33.|

Important: Always check for a readme file on any installation media. The readme
file contains important information that was not available when the guide was
prepared.

New installation process

You can install the Storage Manager 9.1 software components on host computers
(only) or on both host computers and management stations. If you are running an
earlier version of Storage Manager software, you may need to uninstall it before
you are able to install Storage Manager Version 9.1 software components.

Management station: A management station is a system that you use to manage

the storage subsystem. You can attach it to the storage subsystem in the following

ways:

* Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

* Through a TCP/IP network connection to a host computer with host-agent
software installed on it, which in turn is directly attached to the storage
subsystem through the fibre-channel input/output (1/0) path

You must install the following storage management software on a management
station:

e SMclient

Host computer: A host computer (or host) is a system that is directly attached to
the storage subsystem through a fibre-channel 1/0 path.

Important: Be sure you install the host-bus adapter and driver before you install the
storage management software.

You must install storage management software on each host computer in the
following order:

1. SMclient
2. RDAC
3. SMagent
4. SMutil
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To beiin the installation on your management station, see|“Storage Manager 9.1|

To begin installation on a host, see [‘Installing the IBM fibre-channel host bus|
fadapter device driver.”|

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and an FASIT Storage Server. IBM FASLT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters that are
designed for high-end systems. These HBAs support all fibre-channel peripheral
devices that support private-loop direct-attach and fabric-loop attachment. The IBM
Host Adapter device driver enables your operating system to communicate with the
fibre-channel HBA. See the readme file included in the driver package for
installation instructions associated with your operating system.

Note: Read the device driver readme for any required modifications to the default
HBA BIOS and host operating system registry settings to ensure optimal
performance.

For more information, see the Installation and User’'s Guide for your particular
fibre-channel HBA model. The current readme file and latest multipath 1/0 device
driver are available at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Storage Manager 9.1 Client

This section describes how to install SMclient on management stations and host
computers that run Windows operating systems.

Before you install the software, make sure that the management station or host
computer has at least 80 MB of available disk space.

Important: When you install SMclient on a stand-alone host and manage storage
subsystems through the fibre-channel 1/0O path rather than through the network, you
must install the TCP/IP software on the host and assign an IP address to the host.

Installing SMclient

To install SMclient on Windows operating systems, perform the following steps:

1. Insert the IBM FAStT Storage Manager Version 9.1 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.

Operating System Folder

Windows 2000 or Advanced Server \Win32\SMclient

Windows Server 2003 (32 bit) \WS03_32bit\SMClient

Windows Server 2003 (64 bit) \WS03_64bit\SMClient

Click Open.
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6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens; then, the Prepare to Install window (showing the software unpacking
progress) opens, after which the Welcome window opens.

7. Click Next. The Controller Firmware Warning window opens. Read the
information and click OK. The Copyright window opens. Read the information
and click OK.The End User License Agreement window opens.

8. Perform the following procedures:

a. Read the license agreement and click Yes. The Choose Destination
Location window opens.

b. Click Browse to change the destination location. Click Next to continue with
the installation.

c. The Event monitor window opens. Click Yes if you want to install the Event
Monitor. Otherwise, click No.

d. The Setup Status window opens showing the installation progress. When
the installation is complete, the Operation Complete window opens.

e. Click Finish.
f. Continue with[“Verifying the SMclient installation.”]

Verifying the SMclient installation

To verify that you installed SMclient correctly on Windows operating systems,

perform the following steps:

1. Perform one of the following steps depending on your operating system:
* For Windows 2000, click Start » Programs.
* For Windows Server 2003, click Start » All Programs.

2. Verify that IBM FAStT Storage Manager 9 Client displays in the Program list. If
the appropriate software version displays, go to step

Otherwise, repeat [‘Installing SMclient” on page 54/ If the appropriate software
version associated with your operating system still does not display, a failure
has occurred. Contact your IBM technical support representative.

3. If you installed the optional Event Monitor service, go to [‘Verifying the Event|
[Monitor installation.”] Otherwise, continue to step [4}

4. If you are installing SMclient on a host computer, go to fRDAC” on page 56.|
Otherwise, go to[Chapter 8, “Completing Storage Manager 9.1 installation,” on|

Verifying the Event Monitor installation

This section describes how to verify that you installed the Event Monitor service
correctly on Windows operating systems.

Windows 2000

To verify that you installed the Event Monitor service correctly, perform the following

steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Verify that the IBM FAStT Storage Manager 9 Event Monitor service displays
with the startup type Automatic and status Started. If it does not display, click
Start. If it does not start, reinstall the SMclient. If the failure persists, call your
IBM technical support representative.

3. If you are installing the storage management software on a host computer, go to

“RDAC” on page 56, Otherwise, go to [Chapter 8, “Completing Storage Managet|

9.1 installation,” on page 97.|
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Windows Server 2003

To verify that you installed the Event Monitor service correctly, perform the following
steps:

1. Click Start » Administrative Tools » Services. The Services window opens.

2. Verify that the IBM FAStT Storage Manager 9 Event Monitor service displays
with the startup type Automatic and status Started. If it does not display, click
Start. If it displays but does not start, reinstall the SMclient. If the failure
persists, call your IBM technical support representative.

3. If you are installing the storage management software on a host computer, go to
“RDAC.”| Otherwise, go to |Chapter 8, “Completing Storage Manager 9.1|
installation,” on page 97.|

RDAC

This section describes how to install RDAC on Windows operating systems. You
must install RDAC on each host computer. RDAC contains the multipath device
driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the host computer.

* The host computer has at least 2 MB of available disk space.

* All programs are closed.

* You have installed the host bus adapter and driver.

If you are installing RDAC on Windows 2000 or Windows Server 2003, continue
with ['Installing the RDAC."|

Installing the RDAC

To install RDAC on Windows operating systems, perform the following steps:

1. Insert the IBM FASIT Storage Manager Version 9.1 CD into the CD-ROM
drive.

2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the directory that is associated with your operating system.
Operating System Directory
Windows 2000 Server or Advanced Server \Win32\SMrdac\W2K

Windows Server 2003 for 32-bit processors \WS03_32bit\SMrdac
Windows Server 2003 for 64-bit processors \WSO03_64bit\SMrdac

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens; then, the Welcome window opens.

7. Click Next. The End User License Agreement window opens.

8. Click Yes to start the installation. The Installation/Removal status window
opens displaying the RDAC installation progress. Continue with step El

9. After the installation is complete, the Operation Complete window opens.
10. Select Yes | want to restart my computer now. Click Finish.
11. Continue with [‘Verifying the RDAC installation” on page 57

56 IBM TotalStorage FASIT Storage Manager Version 9 Installation and Support Guide for Intel-based Operating System

Environments



Verifying the RDAC installation

This section describes how to verify that you installed RDAC correctly on Windows
operating systems.

Windows 2000
To verify that you installed RDAC correctly, perform the following steps:

1. Click Start » Programs » Administrative Tools »+ Computer Management.
The Computer Management window opens. Go to the \System Tools\System
Information\Software environment\drivers directory.

2. Scroll through the list and select one of the following device drivers:
* rdacbus
* rdacdisk
The rdacbus option always displays. The rdacdisk option displays only when
you have disks.

3. Verify that either rdacbus or rdacdisk displays with the state type Running and

status OK. If neither does, repeat the procedure in [Installing the RDAC” on page|

If the failure persists, call your IBM technical support representative.

Otherwise, continue as follows:

« If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 9.1 Agent.”|

» If you are managing your storage subsystems using the direct-management
method, go to[“Storage Manager 9.1 Utility” on page 59.|

Windows Server 2003
To verify that you installed RDAC correctly, perform the following steps:

1. Click Start » All Programs » Accessories » System Tools » System
information. The System Information window opens. Go to the \System
Summary\Software Environment\System Drivers list.

2. Scroll through the list and select one of the following device drivers:
* rdacbus
* rdacdisk

rdacbus is always shown. rdacdisk displays only when you have disks.

3. Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If it does not display, repeat the procedure in [Installing the RDAC” on|
If the failure persists, call your IBM technical support representative.
Otherwise, continue as follows:

« If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 9.1 Agent.”]

» |If you are managing your storage subsystems using the direct-management
method, go to[‘Storage Manager 9.1 Utility” on page 59|

Storage Manager 9.1 Agent

This section describes how to install SMagent software on Windows operating
systems. You must install the SMagent software if you want to manage the storage
subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:

* You have Administrator privileges on the host computer.

» The host computer has at least 1 MB of available disk space if the SMclient is
installed with the Event Monitoring service.

Chapter 3. Installing Storage Manager software in a standard Windows configuration 57



* The host computer has at least 40 MB of available disk space if the SMclient
program is not installed with the Event Monitoring service.

« RDAC is installed on each host computer. If not, see [‘RDAC” on page 56
» All storage subsystems are connected to the host computer and are powered on.

Installing SMagent
To install SMagent on Windows operating systems, perform the following steps:
1. Close all programs.

2. Insert the IBM FASIT Storage Manager Version 9.1 CD in the CD-ROM drive.
3. Click Start » Run. The Run window opens.
4. Click Browse. The Browse window opens.
5. Select the CD-ROM drive
6. Select the folder that is associated with your operating system.
Operating System Folder
Windows 2000 \Win32\SMagent
Windows Server 2003 (32 bit) \WS03_32bit\SMAgent
Windows Server 2003 (64 bit) \WS03_64bit\SMAgent

Then, click Open.

7. Select the displayed .exe file. Click Open. The InstallShield window opens,
showing the status of the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement window opens.

9. Read the license and click Yes to begin the installation. The software
installation ends, and the Operation Complete window opens.

10. Click Finish.
11. Continue with [‘Verifying the SMagent installation.”|

Verifying the SMagent installation

This section provides instructions on how to verify that you installed SMagent
correctly on Windows operating systems.

Windows 2000

To verify that you installed the SMagent correctly, perform the following steps:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Scroll through the list of services until you find IBM FAStT Storage Manager 9
Agent.

3. If IBM FASIT Storage Manager 9 Agent does not display with a startup type of
Started, click Start. If the status does not change to Started, see[Table 24 on
page 131|for a possible cause. Otherwise, reinstall SMagent. If the problem
persists, contact your IBM technical support representative.

4. Perform one of the following steps:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to f‘Storage Manager 9.1 Utility” on page 59.|
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5.

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following procedure to disable the
host-agent service:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 9 Agent.

d. Click Properties » Startup Type » Manual.
e. Click OK.
Continue with [‘Storage Manager 9.1 Utility.]

Windows Server 2003
To verify that you installed the SMagent correctly, perform the following steps.

Note: Make sure that all storage subsystems are connected to the host computer

1.
2.

5.

and are powered on.
Click Start » Administrative Tools » Services. The Services window opens.

Scroll through the list of services until you find IBM FAStT Storage Manager 9
Agent.

If IBM FASTIT Storage Manager 9 Agent does not display with a startup type of
Started, click Start. If the status changes to Started, go to step EI If not, see
[Table 24 on page 131|for a possible cause. Otherwise, reinstall IBM FAStT
Storage Manager 9 Agent. If the problem persists, contact your IBM technical
support representative.

Perform one of the following steps:

* If you plan to use the host-agent software to manage one or more storage
subsystems, see [‘'Storage Manager 9.1 Utility."|

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start » Administrative Tools »* Computer Management. The
Computer Management window opens.

Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 9 Agent.

d. Click Properties from the pull-down menu. The IBM FAStT Storage
Manager 9 Agent Properties window opens.

e. In the Startup Type list, select Manual. Click OK.
f. The IBM FASIT Storage Manager 9 Agent Properties window closes.
Continue with [‘Storage Manager 9.1 Utility.’]

Storage Manager 9.1 Utility

This section describes how to install SMutil on host computers that run both
Windows operating systems. This component contains utilities that will register and
map new logical drives to the operating systems.

Installing SMutil

To install SMutil on Windows operating systems, perform the following steps:
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1. Close all programs and insert the IBM FAStT Storage Manager Version 9.1
installation CD in the CD-ROM drive.

2. Click Start » Run. The Run window opens.
3. Click Browse. The Browse window opens.
4. Select the CD-ROM drive.
5. Select the folder that is associated with your operating system.
Operating System Folder
Windows 2000 Advanced Server \Win32\SMutil
Windows Server 2003 for 32-bit \WS03_32bit\SMUTil
processors
Windows Server 2003 for 64-bit \WS03_64bit\SMUTil
processors

Then click Open.

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next. The End User License Agreement window opens.

8. Click Yes to begin the installation. After the installation is complete, the
Operation Complete window opens.

9. Click Finish.
10. Continue with [‘Verifying the SMutil installation.’]

Verifying the SMutil installation

To verify that you installed the SMutil correctly on Windows operating systems,
perform the following steps:

1. Go to the <installation_directory>\Utildirectory.

...where installation_directory is the directory in which you installed the
SMutil.

The default directory is c:\Program Files\IBM_FAStT\Util.
2. Verify that the directory contains the following files:

* hot_add.exe

* SMdevices.bat

e SMrepassist.exe

If it does not, reinstall the SMutil by using the procedure in [‘Installing SMutil” on|

page 59.|If the problem persists, contact your IBM technical support
representative.

3. Go to [Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97|

Additional information

For additional information about installing and using Storage Manager 9.1 for
Windows 2000 and Windows Server 2003 in a standard (noncluster) configuration,
see|Appendix A, “Windows operating system limitations,” on page 123.|
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Chapter 4. Installing Storage Manager software in a Windows
cluster server environment

This chapter describes how to install the storage management software in a
Windows cluster server environment. Before you install the software, make sure
that you have read the following information:

« If you have existing storage systems, read [Installation types” on page 18 and
[‘Managing coexisting storage subsystems” on page 24|

 If you are upgrading from a previous version of Storage Manager on an existing
cluster, go to[‘Upgrading from a previous version of the storage management]
[software” on page 73

* To ensure proper installation, complete all preparation tasks described in
[Chapter 2, “Preparing for installation,” on page 33|

+ Review [Table 23 on page 123|for related information.

Important: Always check for a readme file on any installation media. A readme file
contains important information that was not available when this guide was prepared.

Preinstallation considerations

The hardware installation involves installing host adapters and storage subsystems.
Before you begin the installation of the software, make sure that all hardware
components are installed correctly for the cluster server configuration.

Configuration options

You can connect the storage subsystem to the cluster nodes either directly or
through fibre-channel switches. [Figure 12 on page 62| shows typical direct-attached
or fibre-channel switch connection configurations. Both configurations offer full
redundancy.
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Figure 12. Installing the storage subsystem on a fibre-channel network

Host adapters

Refer to the appropriate host-adapter documentation for specific installation
requirements and procedures. The following considerations apply:

* To use the dual-path configuration, perform the following tasks:
— Install two host adapters in each node.
— Run two fibre-channel cables from each node to the storage subsystem.
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» If you connect the storage subsystem through a Fibre Channel-Arbitrated Loop

(FC-AL), ensure that every adapter on the loop is assigned a unique hard ID. For
instructions about changing hard IDs, see the documentation provided with your
host adapters.

» The correct device driver is installed for the host adapter. See the readme file in
the \Host_Adapter directory on the IBM FAStT Storage Manager Version 9.1 CD
for information about supported host adapters and device drivers.

Storage subsystems

Refer to the appropriate hardware documentation for specific installation
requirements and procedures. If you are managing storage subsystems directly, you
must connect Ethernet cables to both controllers in each storage subsystem.

Installing the storage management software in a cluster environment

The following procedures describe how to install the storage management software
in a cluster environment.

Windows 2000

Perform the following steps to install the storage management and cluster service
software on Windows 2000:

1.

Be sure that the HBA and device driver are installed in each cluster node. For
information about HBA and device driver installation, see [‘Installing the IBM|
ffibre-channel host bus adapter device driver’ on page 65.

Power down node B. Start node A.

Install the storage management software on node A. See [‘Installing the

lstorage management software” on page 65| for instructions.

Complete the procedures in|Chapter 8, “Completing Storage Manager 9.1
installation,” on page 97|

Run the hot_add utility on node A. See [‘Using the hot_add utility” on page 116|
for instructions.

Note: You might have to restart node A in order to see the newly-added
logical drives.

Format all shared logical drives as NT File System (NTFS), assign volume

labels, and specify a drive letter for each.

Important: You must assign a permanent (sticky) drive letter to the shared

logical drive on both cluster nodes. The two nodes must have the same drive

letters on each shared drive. If you do not assign permanent drive letters,

Windows might assign different drive letters on each node. Assigning a

permanent drive letter ensures that Windows assigns the same drive letter to

the partition on both cluster nodes.

Shut down node A. Start node B.

Install the storage management software on node B. See[‘Installing the

lstorage management software” on page 65| for instructions.

To verify the drive letters for the cluster configuration, perform one of the
following procedures:

* For Windows 2000, perform the following steps:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

b. Click Storage » Disk Management.
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10.

11.
12.

13.

Verify that the following conditions are met:
* The same logical drives display on each cluster node.

« Each cluster node has the same number of partitions defined on the logical
drives.

» Drive letters are assigned to the configured logical drives.

* The drive letters on the partitions are the same on both cluster nodes.
Shut down node B.

Install the cluster server software. See [Installing the cluster server software’]

on page 72|for instructions.

Go to [Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97/

Windows Server 2003

Perform the following steps to install the storage management and cluster service
software on Windows Server 2003:

1.

10.
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Make sure that the HBA and device driver are installed in each cluster node.
For information about HBA and device driver installation, see |“Instal|ing th5|
[[BM fibre-channel host bus adapter device driver” on page 65

Install the storage management software on the host server that will be the
first node of the cluster. See [Installing the storage management software” on|

for instructions.

Complete the procedures in|Chapter 8, “Completing Storage Manager 9.1|
installation,” on page 97 | specifically to create LUNs that will be used as
cluster disks and to make sure that the host type of the host group or host
ports that these LUNs are mapped to were set to “Windows 2000/Server
2003..clustered” or “Windows 2000 clustered”.

Run the hot_add utility on the first node of the cluster. See[‘Using the hot_add|
[utility” on page 116|for instructions.

Note: You might have to restart the first node of the cluster in order to see the
newly-added logical drives (LUNSs).

Format all shared logical drives as NT File System (NTFS), assign volume
labels, and specify a drive letter for each.

Important: You must make sure that the permanent (sticky) drive letters that
are assigned to LUNSs in the first cluster node are available (not used) in the
rest of the cluster nodes. In another words, all of the nodes in the cluster must
have the same drive letters on each shared drive. If you do not assign
permanent drive letters, Windows might assign different drive letters on each
node, which will prevent the cluster disks from operating correctly. Assigning a
permanent drive letter ensures that Windows assigns the same drive letter to
the partition on all cluster nodes.

Install the storage management software on the second node of the cluster.

Note: You must install the RDAC and SMutil software packages. You do not
have to install all of the storage management software packages unless
you want to manage the storage subsystem from this cluster node.

Run the hot_add utility on the second node of the cluster.
Repeat step|§| and stepEIfor each additional node of the cluster.
Install the cluster server software. See [Installing the cluster server software’]

on page 72|for instructions.

Manually move the cluster disk groups from the first cluster node to each of
the nodes in the cluster, making sure that they can be brought online. If they
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can be brought online with no problems, you are ready to continue with your
application software installation. If you experience any problems, call IBM
support for assistance.

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and a FAStT Storage Server. IBM FASIT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters that are
designed for high-end systems. These HBAs support all fibre-channel peripheral
devices that support private-loop direct-attach and fabric-loop attachment. The IBM
Host Adapter device driver enables your operating system to communicate with the
fibre-channel HBA. See the readme file included in the driver package for
installation instructions associated with your operating system.

Note: Read the device driver readme for any required modifications to the default
HBA BIOS and host operating system registry settings to ensure optimal
performance.

For more information, see the Installation and User’s Guide for your particular
fibre-channel HBA model. The current readme file and latest multipath 1/0O device
driver are available at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Installing the storage management software

This section describes how to install the storage management software on Windows
operating systems. Before you begin an installation with existing storage
subsystems, refer to your hardware installation documentation for the specific
configuration. A specific configuration might be required for your hardware to
support the storage management software in a cluster configuration.

You can install the Storage Manager 9.1 software components on cluster nodes
only or cluster nodes and management stations.

Management station: A management station is a system that is used to manage
the storage subsystem. You can attach it to the storage subsystem in either of the
following ways:

» Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

» Through a TCP/IP network connection to a cluster node with the host-agent
software installed

You must install the following storage management software on a management

station:

» SMclient

Cluster node: The cluster nodes are directly attached to the storage subsystem
through a fibre-channel I/O path.

You must install storage management software on each cluster node in the
following order:

1. SMclient
2. RDAC
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3. SMagent
4. SMutil

See [Installing the SMclient’] to begin the installation.

Installing the SMclient

This section provides instructions on how to install SMclient on management
stations and cluster nodes that run on Windows operating systems.

Before you install the software, make sure that the following conditions are met:

* The management station or host computer has at least 80 MB of available disk
space.

* All programs are closed.

Important: When you install SMclient on a stand-alone host and manage storage
subsystems through the fibre-channel 1/O path rather than through the network, you
must install the TCP/IP software on the host and assign an IP address to the host.

Installing SMclient
To install SMclient on Windows operating systems, perform the following steps:

1. Insert the IBM FAStT Storage Manager Version 9.1 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.

Operating System Folder

Windows 2000 or Advanced Server \Win32\SMclient

Windows Server 2003 (32 bit) \WS03_32bit\SMClient

Windows Server 2003 (64 bit) \WS03_64bit\SMClient

Click Open.

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens; then, the Prepare to Install window (showing the software unpacking
progress) opens; then, the Welcome window opens.

7. Click Next. The Controller Firmware Warning window opens. Read the
information and click OK. The Copyright window opens. Read the information
and click OK. The End User License Agreement window opens.

8. Perform the following procedure:

a. Read the license agreement and click Yes. The Choose Destination
Location window opens.

b. Click Browse to change the destination location. Click Next to continue with
the installation.

c. The Event monitor window opens. Click Yes if you want to install the Event
Monitor. Otherwise, click No.

d. The Setup Status window opens showing the installation progress. When
the installation is complete, the Operation Complete window opens.

e. Click Finish.
f. Continue with |“Verifying the SMclient installation” on page 67.|
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RDAC

Verifying the SMclient installation
Perform the following steps to verify that the SMclient software is installed correctly
on Windows operating systems:

1. Perform one of the following steps, depending on your operating system:
* For Windows 2000, click Start » Programs.
* For Windows Server 2003, click Start » All Programs.

2. \Verify that IBM FAStT Storage Manager 9 Client displays in the Program list. If
the appropriate software version displays, go to step
Otherwise, repeat f‘lnstalling SMclient” on page 66.| If the appropriate software
version associated with your operating system still does not display, a failure
occurred. Contact your IBM technical support representative.

3. If you installed the optional Event Monitor service, go to [‘Verifying the Event]
[Monitor installation.” Otherwise, continue with step

4. If you are installing SMclient on a host computer, go to f‘RDAC.’1 Otherwise, go
to [Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97

Verifying the Event Monitor installation
This section describes how to verify that you installed the Event Monitor correctly
on Windows operating systems.

Windows 2000: To verify that you installed the Event Monitor service correctly on
Windows 2000, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Verify that the IBM FASIT Storage Manager 9 Event Monitor service displays
with the startup type Automatic and status Started. If it is not, click Start. If the
service does not start, reinstall the SMclient. If the failure persists, call your IBM
technical support representative.

3. If you are installing the storage management software on a host computer, go to
“RDAC.”| Otherwise, go to[Chapter 8, “Completing Storage Manager 9.1
installation,” on page 97.|

Windows Server 2003: To verify that you installed the Event Monitor service
correctly on Windows Server 2003, perform the following steps:

1. Click Start » Administrative Tools » Services. The Services window opens.

2. Verify that the IBM FASIT Storage Manager 9 Event Monitor service displays
with the startup type Automatic and status Started. If it is not, click Start. If it
does not start, reinstall the SMclient. If the failure persists, call your IBM
technical support representative.

3. If you are installing the storage management software on a host computer, see
“RDAC.”[ Otherwise, go to |Chapter 8, “Completing Storage Manager 9.1|
installation,” on page 97.

This section describes how to install RDAC on Windows operating systems. You
must install RDAC on each cluster node. RDAC contains the multipath device driver
that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the cluster nodes.

» Each cluster node has at least 2 MB of available disk space.

* You close all programs.

Chapter 4. Installing Storage Manager software in a Windows cluster server environment 67



* The appropriate HBA device driver is installed.

If you are installing RDAC on Windows 2000 or Windows Server 2003, continue
with Installing the RDAC."|

Installing the RDAC
To install RDAC on Windows operating systems, perform the following steps:

1. Insert the IBM FAStT Storage Manager Version 9.1 CD into the CD-ROM
drive.

2. Click Start » Run. The Run window opens.
3. Click Browse. The Browse window opens.
4. Select the CD-ROM drive.
5. Select the directory that is associated with your operating system.
Operating System Directory
Windows 2000 or Advanced Server \Win32\SMrdac\W2K
Windows Server 2003 for 32-bit \WS03_32bit\SMrdac
processors
Windows Server 2003 for 64-bit \WS03_64bit\SMrdac
processors

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens; then, the Welcome window opens.

7. Click Next. The End User License Agreement window opens.

8. Click Yes to start the installation. The Installation/Removal status window
opens displaying the RDAC installation progress. Continue with step El

9. After the installation is complete, the Operation Complete window opens.
10. Select Yes, | want to restart my computer now. Click Finish.
11. Continue with [‘Verifying the RDAC installation.]

Verifying the RDAC installation
The following section describes how to verify that you installed RDAC correctly on
Windows operating systems.

Windows 2000: To verify that you installed RDAC correctly on Windows 2000,
perform the following steps.

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Programs » Administrative Tools » Computer Management.
The Computer Management window opens. Go to the \System Tools\System
Information\Software environment\Drivers directory.

2. Scroll through the list and select one of the following device drivers:
* rdacbus
* rdacdisk
The rdacbus option always displays. The rdacdisk option displays only when
you have disks.

3. Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If neither does, repeat the procedure in ['Installing the RDAC.] If the

failure persists, call your IBM technical support representative. Otherwise,
procee to step -on page 69
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4.

Perform one of the following procedures:

» If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 9.1 Agent.”]

« If you are managing your storage subsystems directly, go to
[Manager 9.1 Utility” on page 71|

Windows Server 2003: To verify that you have installed RDAC correctly, perform
the following steps:

1.

Click Start » All Programs » Accessories » System Tools » System
information. The System Information window opens. Go to the \System
Summary\Software Environment\System Drivers list.

Scroll through the list and select one of the following device drivers:
* rdacbus
* rdacdisk

rdacbus is always shown. rdacdisk displays only when you have disks.

Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If it does not, repeat the procedure in[“Installing the RDAC” on page]
If the failure persists, call your IBM technical support representative.
Otherwise, continue as follows:

« If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 9.1 Agent.”|

* If you are managing your storage subsystems using the direct-management
method, go to[“Storage Manager 9.1 Utility” on page 71

Storage Manager 9.1 Agent

Th

e following section describes how to install the SMagent software on Windows

operating systems. You must install the SMagent software if you want to manage
the storage subsystem using the host-agent method.

Before you install the software on Windows operating systems, ensure that the
following conditions are met:

You have Administrator privileges on the cluster nodes.

Each cluster node will have at least 1 MB of available disk space if you install
SMclient with the Event Monitoring service.

The host computer will have at least 40 MB of available disk space if you do not
install the SMclient program with the Event Monitoring service.

You installed RDAC on each cluster node. If you have not done so, refer to

[‘RDAC” on page 67

Installing SMagent

To

1.

o0k~ w0

install SMagent on Windows operating systems, perform the following steps:
Close all programs.
Insert the IBM FASIT Storage Manager Version 9.1 CD in the CD-ROM drive.
Click Start » Run. The Run window opens.
Click Browse. The Browse window opens.
Select the CD-ROM drive.
Select the folder that is associated with your operating system.

Operating System Folder

Windows 2000 \Win32\SMagent
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Operating System Folder
Windows Server 2003 (32 bit) \WSO3_32bit\SMAgent
Windows Server 2003 (64 bit) \WS03_64bit\SMAgent
Click Open.
7. Select the displayed .exe file. Then click Open. The InstallShield window

10.
11.

opens, showing the status of the file unpacking. The Welcome window opens.
Click Next. The End User License Agreement window opens.

Read the license and click Yes to begin the installation. The software
installation ends, and the Operation Complete window opens.

Click Finish.
Continue with [*Verifying the SMagent installation.’]

Verifying the SMagent installation
The following section describes how to verify that you installed the SMagent
correctly on Windows operating systems.

Windows 2000: To verify that you installed the SMagent correctly on Windows
2000, perform the following steps:

1.

Click Start » Programs » Administrative Tools » Services. The Services
window opens.

Scroll through the list of services until you find Storage Manager 9 Agent.

Verify that Storage Manager 9 Agent is displayed with the startup type
Automatic and status Started. If Storage Manager 9 Agent does not display
with a startup type of Started, click Start. If the status does not change to
Started, see [Table 24 on page 131|for a possible cause. Otherwise, reinstall
SMagent. If the problem persists, contact your IBM technical support

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘Storage Manager 9.1 Utility” on page 71.

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following procedure to disable the

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

From the list of displayed services, right-click Storage Manager 9 Agent.
Click Properties » Startup Type » Manual.

2.
3.
representative.
4. Perform one of the following procedures:
host-agent service:
b. Click Services.
C.
d.
e. Click OK.
5.

Continue with [‘Storage Manager 9.1 Utility” on page 71

Windows Server 2003: To verify that you installed the SMagent correctly, perform
the following steps:

1.
2.

Click Start » Administrative Tools » Services. The Services window opens.
Scroll through the list of services until you find IBM FAStT Storage Manager 9
Agent.

If IBM FAStT Storage Manager 9 Agent does not display with a startup type of
Started, click Start. If the status changes to Started, go toE on Eaﬁe 71} If not,
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4.

5.

see|Table 24 on page 131|for a possible cause. Otherwise, reinstall SMagent. If
the problem persists, contact your IBM technical support representative.

Perform one of the following steps:

» If you plan to use the host-agent software to manage one or more storage
subsystems, see [‘Storage Manager 9.1 Utility.’]

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start » Administrative Tools »+ Computer Management. The
Computer Management window opens.

Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 9 Agent.

d. Select Properties from the pull-down menu. The IBM FASIT Storage
Manager 9 Agent Properties window opens.

e. In the Startup Type list, select Manual. Click OK.
f. The IBM FASLIT Storage Manager 9 Agent Properties window closes.
Continue with [‘Storage Manager 9.1 Utility.”]

Storage Manager 9.1 Utility

This section provides instructions regarding SMutil software installation on cluster
nodes that run Windows operating systems. This component contains utilities that
will register and map new logical drives to the operating systems.

Installing SMutil
To install SMutil on Windows operating systems, perform the following steps:

1.

Close all programs and insert the IBM Storage Manager Version 9.1
installation CD in the CD-ROM drive.

2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.

Operating System Folder
Windows 2000 Advanced Server \Win32\SMuti1
Windows Server 2003 for 32-bit \WS03_32bit\SMUti1
processors
Windows Server 2003 for 64-bit \WS03_64bit\SMUti1
processors

Click Open.

6. Select the setup.exe file, then click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next. The End User License Agreement window opens.

8. Click Yes to begin the installation. After the installation is complete, the
Operation Complete window opens.

9. Click Finish.

10. Continue with [‘Verifying the SMutil installation” on page 72
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Verifying the SMutil installation
To verify that you installed the SMutil correctly on Windows operating systems,
perform the following steps:

1. Go to the <installation_directory>\Utildirectory.

...where installation_directory is the directory in which you installed the
SMutil.

The default directory is c:\Program Files\IBM_FAStT\Util.
2. Verify that the directory contains the following files:

* hot_add.exe

* SMdevices.bat

e SMrepassist.exe

I it does not, reinstall the SMutil using the procedure in [‘Installing SMutil” on|
page 59.|If the problem persists, contact your IBM technical support
representative.

3. Go to [Installing the storage management software in a cluster environment” on|

|9age 63.|

Installing the cluster server software

Windows 2000

The following sections describe how to install the cluster server software on
Windows operating systems.

Important: Do not perform this procedure unless you installed the necessary
storage management software components on both cluster nodes.

To install the cluster server software on node A and node B, perform the following
steps:

1. Install the cluster server software on node A, as follows:

a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for
the correct procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.
b. After the system restarts, leave node A running.
2. Install the cluster server software on node B, as follows:

a. Refer to the appropriate MSCS documentation for the correct procedure to
install the Cluster Server software.

Note: During installation, specify that you want to join the existing cluster.
b. After the system restarts, leave node B running.
3. After you install MSCS, perform one of the following tasks:
* For systems running Windows 2000, reinstall Service Pack 4.

Note: Refer to Microsoft Knowledge Base article Q174799 for more information
regarding service pack installation in a cluster environment.

4. Verify the software installation as follows:

a. On either node A or node B, click Start » Programs » Administrative Tools
» Cluster Administration.

b. In the Cluster or Server Name field, type either the name of the cluster or
the name or IP address of one of the nodes.

72 1BM TotalStorage FAStT Storage Manager Version 9 Installation and Support Guide for Intel-based Operating System

Environments



If the installation is successful, the computer names of both nodes appear
on the left side of the Cluster Administrator window.

c. Make sure that the cluster disk groups can be moved between cluster
nodes.

5. If both node names do not display on the left side of the Cluster Administrator
window, reinstall the cluster server software. If the problem persists, contact
your IBM technical support representative.

Windows Server 2003

Important: Do not perform this procedure unless the necessary storage
management software components are installed on all cluster nodes.

Perform the following steps to install the cluster server software on cluster nodes:

1. Install the cluster server software on the first node of the cluster. Refer to the
appropriate Microsoft Cluster Server (MSCS) documentation for the correct
procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.

2. In the Cluster Administrator window, make sure that all of the cluster disk
groups can be varied online and offline with no problems.

3. Install the cluster server software on the second node of the cluster. Refer to
the appropriate MSCS documentation for the correct procedure to install
additional nodes in the cluster server.

Note: During installation, specify that you want to join the existing cluster. You
can add one cluster node at a time or all of the remaining cluster nodes
at the same time. You should add cluster nodes one at a time.

4. If all node names do not display on the left side of the Cluster Administrator
window, reinstall the cluster server software. If the problem persists, contact
your IBM technical support representative.

Upgrading from a previous version of the storage management
software

Be sure that you are familiar with the steps required in a new installation before you
continue with the following upgrade procedure.

Choose one of the following two procedures:

» Performing a scheduled upgrade: A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software. The services and resources offered by the cluster are not
available during the upgrade. If you choose this upgrade method, it is important
that you perform the upgrade during off-peak workload time.

Note: The scheduled upgrade is the preferred procedure for upgrading a cluster
server configuration.

* Performing a rolling upgrade: A rolling upgrade requires upgrading the storage
management software first in one of the cluster nodes and then in each of the
remaining cluster nodes, one cluster node a time, so that the services and
resources offered by the cluster are always available.

Important: Do not upgrade your storage subsystem firmware until you have
upgraded the storage management software on all cluster nodes and management
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stations. If you upgrade your storage subsystem controller firmware level to version
05.4x.xx.xx, you will not be able to communicate with the controller until you have
upgraded to Storage Manager 9.1 software on your management station and cluster
nodes. Previously installed versions of Storage Manager will not recognize
controllers running version 05.4x.xx.xx firmware.

Performing a scheduled upgrade

The following sections describe how to perform a scheduled upgrade on Windows
operating systems.

Windows 2000

To perform a scheduled upgrade from Storage Manager Version 7.xx, 8.0, 8.2x, or
8.4x to Storage Manager 9.1 on machines that are running Windows 2000, perform
the following procedure:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Shut down node B.

3. From node A, uninstall the components from the previous version of the
storage management software. To uninstall the storage management software
for Storage Manager Version 7.x, 8.0, 8.2x, or 8.4x see[‘Uninstalling storage]
[management software components” on page 118

Note: Uninstall the storage management components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

4. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

5. Install the SMclient on node A. See [‘Installing the SMclient” on page 66| for
instructions.

6. Install the RDAC on node A. See [‘RDAC” on page 67] for instructions.
7. Install the SMagent on node A. See [‘Storage Manager 9.1 Agent” on page 69
for instructions.
8. Install the SMutil on node A. See [‘Storage Manager 9.1 Utility” on page 71| for
instructions.
9. Shut down node A.
10. Restart node B.
11. From node B, uninstall the components from the previous version of the
storage management software. To uninstall the storage management software

for Storage Manager Version 7.x, 8.0, 8.2x, or 8.4x see r‘UninstaIIing storage|
[management software components” on page 118

12. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device driver versions before you continue.

13. Install the SMclient on node B. See [Installing the SMclient” on page 66| for
instructions.

14. Install the RDAC on node B. See ['/RDAC” on page 67| for instructions.

15. Install the SMagent on node B. See[“Storage Manager 9.1 Agent” on page 69|
for instructions.
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16. Install the SMutil on node B. See [‘Storage Manager 9.1 Utility” on page 71|for
instructions.

17. Shut down node B.
18. Start up one node at a time and complete the following procedure:

a. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

b. From the list of displayed services, right-click the cluster server. Click
Automatic to change the cluster server startup option.

c. Start the cluster server service on node B.
19. Goto |Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97]

Windows Server 2003
To perform a scheduled upgrade from Storage Manager Version 7.xx, 8.0, 8.2x, or
8.4x to Storage Manager 9.1 on machines that are running Windows Server 2003,
perform the following procedure:
1. Before you install the storage management software, perform the following
steps in each of the cluster nodes in the cluster:
a. Click Start » Administrative Tools » Services. The Services window
opens.
b. From the list of displayed services, right-click the cluster server. Then click
Manual.

c. Stop the cluster server on all nodes in the cluster configuration.

2. From each cluster node, uninstall the components from the previous version of
the storage management software. See[“Uninstalling storage management
[software components” on page 118 for instructions.

Note: Uninstall the storage management components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

3. Verify that the IBM host adapter device driver version in each cluster node is
current. If they are not current, refer to the readme file located in the
\Host_Adapter directory on the installation CD and upgrade the device drivers.

4. Install the new version of the Storage Manager software in each cluster node.
See [‘Installing the storage management software” on page 65| for instructions.

5. Start up one node at a time and complete the following steps for each node:

a. Click Start » Administrative Tools » Services. The Services window
opens.

b. From the list of displayed services, right-click the cluster server. Click
Automatic to change the cluster server startup option.

c. Manually start the cluster server service.

6. Open Cluster Administrator windows and verify that the cluster groups can be
brought online. If not, contact your IBM service representative for support.

Performing a rolling upgrade

This section describes how to perform a rolling upgrade on Windows operating
systems.
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Important: If you have applications installed in the cluster server environment that
do not support a rolling upgrade, perform one of the following tasks:

Put those resources offline before the upgrade; then, put them back online after
the upgrade.

Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

Windows 2000

To perform a rolling upgrade from Storage Manager Version 7.xx, 8.0, 8.2x, or 8.4x
to Storage Manager 9.1 on machines that are running Windows 2000, perform the
following steps:

1.
2.

10.

11.

12.
13.

14.
15.

16.

From node A, open Cluster Administrator.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Select each group listed and move them to node B.

Select node A. Then click File » Pause Node to pause cluster service in node
A

From node A, uninstall the components from the previous version of the
software. To uninstall the software for Storage Manager Version 7.x, 8.0, 8.2x,
or 8.4x see [‘Uninstalling storage management software components” on page|

fie)

Note: Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

Install the SMclient on node A. See [‘Installing the SMclient” on page 66| for
instructions.

Install the RDAC on node A. See['RDAC” on page 67| for instructions.

Install the SMagent on node A. See [‘Storage Manager 9.1 Agent” on page 69
for instructions.

Install the SMutil on node A. See [‘Storage Manager 9.1 Utility” on page 71| for
instructions.

Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node A.

From node B, open Cluster Administrator.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Select each group listed and move them to node A.
Select node B. Then click File » Pause Node to pause cluster service in node
B.

From node B, uninstall the components from the previous version of the

software. To uninstall the storage management software for Storage Manager
Version 7.x, 8.0, 8.2x, or 8.4x see[‘Uninstalling storage management software|
[components” on page 118
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17. Verify that the IBM HBA device driver versions are current. If they are not
current, see the readme file located in the \Host_Adapter directory on the
installation CD and upgrade the device drivers.

18. Install the SMclient on node B. See [Installing the SMclient” on page 66| for
instructions.

19. Install the RDAC on node B. See 'RDAC” on page 67| for instructions.

20. Install the SMagent on node B. See |“Storage Manager 9.1 Agent” on page 69|
for instructions.

21. Install the SMutil on node B. See [‘Storage Manager 9.1 Utility” on page 71|for
instructions.

22. Run Cluster Administrator. Then click File + Resume Node to resume cluster
service in node B.

23. Go to|Chapter 8, “Completing Storage Manager 9.1 installation,” on page 97/

Windows Server 2003

To perform a rolling upgrade from Storage Manager Version 7.xx, 8.0, 8.2x, or 8.4x
to Storage Manager 9.1 on machines that are running Windows Server 2003,
perform the following steps:

1. In the first node of the cluster, open the Cluster Administrator window.

2. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

3. Select each of the active groups listed in the first cluster node and move them
to other nodes in the cluster configuration. Make sure that the cluster groups
come online successfully.

4. Select the first node of the cluster in the Cluster Node Tree view and click File
» Pause Node to pause cluster service in that node.

5. From node A, uninstall the components from the previous version of the
software. To uninstall the previous version of Storage Manager software, see
[‘Uninstalling storage management software components” on page 118.|

Note: Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

6. Verify that the IBM HBA device driver versions in the cluster node are current.
If they are not current, refer to the readme file located in the \Host_Adapter
directory on the installation CD and upgrade the device drivers.

7. Install the new version of the Storage Manager software in the first cluster
node. See [Installing the storage management software” on page 65| for
instructions.

8. In the Cluster Administrator window, select the first node of the cluster and
click File » Resume Node to resume cluster service in first cluster node.

9. Move all cluster groups that were active in the first cluster node back to it.
Make sure that the cluster groups can be brought online in the first cluster
node with no problems.

10. Repeat stepsthrough|§|for each of the other nodes in the cluster
configuration. Perform all steps for each cluster node, one cluster node at a
time.
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Upgrading Windows operating systems

The following sections describe how to upgrade from one supported Windows
operating system to another.

Upgrading from Windows 2000 to Windows Server 2003 in a cluster
configuration

Note: Always perform a full system backup before you perform any upgrade
procedure.

Important: If you have applications that are installed in the cluster server

environment that do not support a rolling upgrade, perform one of the following

tasks:

» Put those applications offline before the upgrade. Then put them back online
after the upgrade.

» Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

To upgrade from Windows 2000 Advanced Server to Windows Server 2003
Enterprise Edition, perform the following steps:

1. On node A, open the Cluster Administrator window.
2. Double-click the Active Groups folder in the right pane of Cluster Administrator.

3. Move all active cluster groups in node A to node B. Make sure that the cluster
groups come online successfully in node B.

4. Select node A. Click File » Pause Node to pause cluster service in node A.

5. From node A, uninstall all software components. To uninstall the software, see
[‘Uninstalling storage management software components” on page 118.|
Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

6. Follow the instructions from Microsoft to upgrade node A from Windows 2000
Advanced Server to Windows Server 2003 Enterprise Edition.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node A rejoins the cluster and remain paused.

7. Verify that the HBA device driver versions are correct. If they are not the
certified versions, refer to the readme file in the \Host Adapter directory on the
installation CD and upgrade the device driver versions before you continue.

8. Verify that node A was successfully upgraded to Windows Server 2003

Enterprise Edition.

9. lInstall the Storage Management software in node A. See [‘Installing the storage]
|management software” on page 65.|

10. In the Cluster Administrator window, select node A and click File » Resume
Node to resume cluster service in node A.
11. Move the cluster groups that were active in node A back to node A.

12. On node B, open the Cluster Administrator window.
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13.
14.
15.
16.

17.

18.

19.

20.

21.

22.

23.

Double-click the Active Groups folder in the right pane of Cluster Administrator.
Make sure that all cluster groups failover to node A successfully.
Select node B. Click File » Pause Node to pause cluster service in node B.

From node B, uninstall all software components. To uninstall the software, see
I“Uninstalling storage management software components” on page 118.|
Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

Follow the instructions from Microsoft to upgrade node B from Windows 2000
Advanced Server to Windows Server 2003 Enterprise Edition.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node B rejoins the cluster and remain paused.

Verify that the HBA device driver versions are correct. If they are not the
certified versions, refer to the readme file in the \Host_Adapter directory on the
installation CD and upgrade the device driver versions before you continue.

Verify that node B was successfully upgraded to Windows Server 2003
Enterprise Edition.

Install the Storage Management software in node B. See [Installing the storage]
[nmanagement software” on page 65| for instructions.

In the Cluster Administrator window, select node B and click File » Resume
Node to resume cluster service in node B.

In the Cluster Administrator window, move the cluster groups that were active
in node B back to node B. Make sure that they come online with no problems.

If there are more than two nodes in a cluster, repeat steps{12 on page 78

through [22] for each of the remaining nodes in a cluster, one cluster node at a
time.

Additional information

For additional information about installing and using Storage Manager 9.1 in a
Windows cluster server configuration, see|Appendix A, “Windows operating system|

limitations,” on page 123.|
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Chapter 5. Installing Storage Manager software in a standard
NetWare configuration

This chapter describes how to install the storage management software in standard
(noncluster) and cluster server configurations in the NetWare 6.0 operating system
environment.

If you have existing storage systems, read [‘Installation types” on page 18 and
[‘Storage subsystem management methods” on page 10.

To ensure proper installation, complete all preparation tasks described in
fand preparing for NetWare installation” on page 33.|

Important: Always check for a readme file on any installation media. A readme file
might contain important information that was not available when this document was
prepared.

Installation overview

You must install Storage Manager 9.1 software components on both management
stations and host computers.

shows the installation sequence for Storage Manager software
components.

Table 18. Software component installation sequence in a Novell NetWare 6.0 environment

System type Software installation sequence

Management station | Storage Manager 9.1 Client (SMclient)

Host computer and | 1 storage Manager 9.1 Client (SMclient)

I ) .
cluster node The Storage Manager 9.1 Client software package also includes

the following host software components.

a. Storage Manager 9.1 Utility (SMutil)
This required component contains the hot_add and SMdevices
utilities.

b. Storage Manager 9.1 Agent (SMagent)

This optional component is necessary if you intend to use the
host-agent management method.

2. Fibre Channel Host Bus Adapter device driver
3. LSIMPE.cdm driver and NetWare native failover device driver

Important: Be sure to complete the folowing activities before you install Storage
Manager 9.1.

1. Uninstall Storage Manager 8.4x. See [‘Uninstalling Storage Management 8.4x|
[software components” on page 82

2. Install the host bus adapter.

To install the storage management software in a NetWare 6.0 operating system
environment, you must install the software on each host computer in the following
order:

1. Fibre Channel Host Bus Adapter device driver
2. LSIMPE.cdm driver and NetWare native failover device driver
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3. Storage Manager 9.1 Client

This requirement also includes the optional installation of the following Storage
Manager host software packages.

a. Storage Manager 9.1 Utility (SMutil)
b. Storage Manager 9.1 Agent (SMagent)
4. NetWare Agent component of IBM FAStT Management Suite Java (FAStT-MSJ)

Uninstalling Storage Management 8.4x software components

If you are upgrading from any Storage Manager version 8.4x , it will be necessary
for you to remove the current software before installing Storage Manager 9.1. No
reboot is required after removing a Storage Manager software package. Existing
storage array mappings and storage partition configurations are retained during
software removal ans wilkl be recognized by the new client software.

Use the following procedure to uninstall one or more of the components of Storage
Manager 8.4x. If you are uninstalling components released with an earlier version of
the storage management software, use the uninstall procedure that came with the
version of the storage management software that you are currently running.

1. From the Xserver Graphical Console, click Novell » Install.
The Installed Products window opens.

2. In the list of currently installed products, select the component you want to
remove from the list and click Delete.

The name of the Storage Manager packages are:
a. Storage Manager Agent

b. Storage Manager Utility

c. Storage Manager (this is the client)

3. Click OK in the Confirm Product Deletion window to proceed with the
uninstallation. Repeat stepto remove each Storage Manger component.

4. A Please Wait pop-up window displays while the package uninstalls.

5. The Installed Products window will display again when the uninstallation is
complete.

Storage Manager 9.1 Client

This section provides instructions for installing Storage Manager 9.1 Client on
management stations and host computers.

Before you install the software, make sure that:

* The management station or host computer has at least 140 MB of available disk
space.

» All programs are closed.
* The HBA and the driver are installed.

Important:

* When you install Storage Manager 9.1 Client on a stand-alone host and manage
storage subsystems through the fibre-channel I/O path rather than through the
network, you must install the TCP/IP software on the host and assign an IP
address to the host.

* Modify these instructions as required for your particular installation.
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Installing Storage Manager 9.1 Client (SMclient)

Perform the following steps to install SMclient:

1.
2.

10.
11.
12.
13.
14.

Insert the IBM FASLT Storage Manager installation CD into the CD-ROM drive.
Based on your version of Novell NetWare, perform one of the following actions:
* Novell Netware 6.0 with SP 4 or later, proceed with step
* Novell Netware 6.5 with SP 2 or later, proceed with step

To mount the installation CD, if needed, type the following command from the
System Console and press Enter.

load CDROM

To copy the zip file from the installation CD to the sys:\volume in the host
NetWare system, type the following command from the System Console and
press Enter.

copy cd<CDname>:\Netware\filename.zip SYS:\

...where filename.zip is the name of the zip file containing the IBM FASIT
Storage Manager host software for NetWare.

In the NetWare Console window, unzip the filename.zip file using the
following command:

unzip -o SYS:\filename.ZIP

The system extracts the install.ncf file and the instdata directory to the
temporary location specified.

...where SYS:\ is the zip file’s temporary location.

From the System Console window, type the following command, and press
Enter.

sys:/install

The Please Wait window displays while the software is loading. When the
software is loaded, the Introduction window displays.

Select Next.

The License Agreement window displays.

Read and select the option that accepts the terms of the License Agreement.
Select Next.

The Choose Install Folder window opens. Click the Choose button to select a
folder different than the default folder listed. The default folder name is
StorageManager.

Click Next to continue.

The 20-Second Delay dialog displays.

Select OK.

The Select Installation Type window displays.

Ensure that for the host, the Typical (Full Installation) installation type is
selected.

» The full installation type involves installation of the following components:
— SMclient
— SMagent
—  SMutil

e The custom installation type allows you to manually select the options for
installation.

* The management station only installation type involves installation of only
SMclient.
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The selected installation type is indicated in blue text.
15. Select Next.

If the software already exists, the Overwrite Warning dialog displays.
16. Select OK.

The Pre-Installation Summary window displays.
17. Select Install.

The Installing window displays while the software is loading. When the
software is loaded, the Install Complete window displays.

18. Select Done.
The Restart The GUI dialog displays.
19. Read and select OK.

Verifying the Storage Manager 9.1 Client installation

Perform the following steps to restart the GUI and to verify that the packages were

successfully installed:

1. From the Novell menu, select Close GUL....
The Close GUI dialog displays.

2. Select OK.

3. To restart the GUI, type the following command from the System Console, and
press Enter.
startx

4. Select Novell » Programs, and verify that the IBM FAStT Client program name
displays in the Programs list.

5. Open the file browser and select the install folder named: sys:\storagemanager.
You will see Client, Agent, and Util folders if you selected the Typical (Full
Installation) option during the installation procedure.

6. Verify that SMagent.ncf files reside in the SYS:\StorageManager\Agent directory.
See [‘Stopping and starting the host-agent software” on page 120.

7. Verify that the hot_add.ncf and SMdevices.ncf files reside in the folder that you
installed the NetWare Host software. Its default location is
SYS:\StorageManager\util.

8. Depending on success or failure of the installation, do one of the following:

If the IBM FASIT Storage Manager 9 Client Enterprise Management window
displays, the installation was successful. Perform activities detailed in
“Removing the temporary files’ and [Chapter 8, “Completing Storage Manager|
9.1 installation,” on page 97|

If the IBM FASET Storage Manager Client does not display, a failure has
occurred and the installation was unsuccessful. Repeat the steps detailed in
“Installing Storage Manager 9.1 Client (SMclient)” on page 83| andl“Verifying the|
Storage Manager 9.1 Client installation.’] If the failure persists, refer to Storage
Manager 9.1 Release Notes or contact your IBM technical support
representative.

Removing the temporary files

Use the following procedure to remove the temporary installation files from the
temporary directory.

1. Using the NetWare File Browser, select and delete the install.ncf file and the
InstData directory in the SYS:\ volume
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Note: This file and directory are in the root of the SYS:\ volume unless the user
placed them elsewhere. Delete them using the file browser delete
function.

2. Choose one of the following actions:

« Storage management software is required on other systems — For each

system that will be used as a storage management station or host, perform
the software removal and installation procedures described in |“Planning and|
preparing for NetWare installation” on page 33| and r‘lnstalling Storage|
Manager 9.1 Client (SMclient)” on page 83|

« Storage management software installation is complete is completed on
all systems — See |“Starting the host agent manually” on page 121 |

Installing the NetWare fibre channel HBA device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and a FAStT Storage Server. IBM FASLT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters that are
designed for high-end systems. These HBAs support all fibre-channel peripheral
devices that support private-loop direct-attach and fabric-loop attachment. The
Novell NetWare native failover device driver enables your operating system to
communicate with the fibre-channel HBA. See the readme file included in the driver
package for installation instructions associated with your operating system. For
more information, see the Installation and User’s Guide for your particular
fibre-channel HBA model. The current readme file and latest multipath 1/0O device
driver are available at the following Web site:

Note: Depending on your controller’s firmware version, change the LUNs per target
BIOS setting from the default value of 0 to 31 or 255 for IBM FASLT fibre
channel HBA. In addition, review the device driver readme for any other
required modifications to the default HBA BIOS and host operating system
registry settings to ensure optimal performance.

www-1.ibm.com/servers/storage/support/fastt/index.html|

Continue with ['Installing IBM FAStT Management Suite Java” on page 86.|

Installing the LSIMPE driver and NetWare native failover device driver

The NetWare native failover device driver is available in NW5.1 SP7 or later, NW6.0
SP3 or later, and in NW6.5 SP1a or later.

Note: Always use the Novell NetWare native failover device in the latest SP for a
particular NetWare operating system version. In addition, use the later
version of the LSIMPE.CDM file from either the latest Novell Support Pack or
the version that is included with the IBM Fibre Channel HBA device driver for
Netware which is available at the IBM FAStT support web site.

The LSIMPE.CDM driver is used in a Novell NetWare environment to enable the
Novell native multipath device driver to recognize the NetWare host-mapped logical
drives that were created on FASIT storage servers. The LSIMPE.CDM driver is a
custom driver module that is packaged with the IBM FAStT Host Adapter driver and
the Novell operating system distribution CD. In case of a failure along the I/O path,
the Novell native multipath device driver sends the I/O requests through the
alternate path and Auto-Volume Transfer (AVT) moves the logical drive within the
FAStIT Storage Server.
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See the current IBM Fibre Channel HBA device driver readme file for the current
LSIMPE.CDM driver, and the pointer to the Novell native multipath device driver
installation instructions.

www-1.ibm.com/servers/storage/support/fastt/index.htmi|

Continue with [‘Installing the NetWare fibre channel HBA device driver’ on page 85)

Installing IBM FASIT Management Suite Java

For information about installing and using this software, see the IBM FAStT MSJ
User’s Guide or online Help.

Additional information

For additional information about installing and using Storage Manager 9.1 in a
NetWare configuration, see|Appendix B, “NetWare operating system limitations,” on|
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Chapter 6. Installing Storage Manager software in a Linux
configuration

This chapter describes how to install the storage management software in a Linux
operating system environment.

If you have existing storage systems, make sure that you have read [Installation]
types” on page 18 and[‘Managing coexisting storage subsystems” on page 24

To ensure proper installation, make sure you have completed all preparation tasks
described in|Chapter 2, “Preparing for installation,” on page 33|

Important: Always check for a readme file on any installation media. This readme
file might contain important information made available only after completion of this
document.

Installation overview
Important: Be sure that you install the HBA and device driver before you install the
storage management software.

Linux software requirements

lists the disk space that is required for installing Storage Manager 9.1 in a
Linux environment.

Table 19. Installation requirements for Linux by software package

Package Disk space requirement
Storage Manager 9.1 Client (SMclient) 50 MB on /opt, 2 MB on /tmp
IBM FAStT Management Suite Java (FAStT MSJ) 50 MB

RDAC 2 MB

Storage Manager 9.1 Agent (SMagent) 2 MB

Storage Manager 9.1 Utility (SMutil) 7 MB on /opt

IBM Host Adapter device driver 1 MB

Storage Manager 9.1 runtime (SMruntime) 70 MB on /opt, 1 MB on /var

Linux operating system requirements

describes the minimum operating system and kernel level requirements for
each management station or host computer. See the readme file for the latest
information regarding supported kernel versions.

Table 20. Management station or host computer by minimum operating system and kernel

level

Operating system Kernel

Red Hat Enterprise Linux Advanced Server 2.1 2.4.9-e.43 or higher
SuSE Linux Enterprise Server Version 8 (SLES 8) 2.4.21-215 or higher
Red Hat Enterprise Linux Advanced Server 3.0 2.4.21-9.0.3.el or higher
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Note: Two Linux operating system packages are made available on the product CD
and Internet site. These packages are associated with either Intel
architecture 32-bit or 64-bit systems. Be certain to access the appropriate
package.

To begin installing the storage management software, ensure that the network
components are set up and operating properly, and that you have all the host and
controller information that you need for the software to operate.

When using Linux RDAC as the multipath failover/failback device driver, you must
install the software on each host computer in the following order:

1. Uninstall the earlier version Storage Manager.

Install Storage Manager 9.1 Runtime.

Install Storage Manager 9.1 Client.

Disable and enable the Event Monitor.

Install the IBM fibre channel HBA non-failover version device driver (for Linux
operating systems).

Install Linux RDAC.

Install Storage Manager 9.1 Agent (SMagent, optional)

Install Storage Manager 9.1 Utility.

Uninstall existing IBM FAStT Management Suite Java (use this procedure
when installing IBM FAStT-MSJ on an existing host/server).

10. Install IBM FAStT Management Suite Java and QLRemote Agent.

ok~ wDpd
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When not using RDAC as the multipath failover/failback device driver, and using the
IBM FASILT fibre channel HBA failover version of the device driver as the multipath
driver, you must install the software on each host computer in the following order:

1. Uninstall the earlier version Storage Manager.
Install Storage Manager 9.1 Runtime.

Install Storage Manager 9.1 Client.

Disable and enable the Event Monitor.

Install Storage Manager 9.1 Utility.

Uninstall existing IBM FAStT Management Suite Java (use this procedure when
installing Storage Manager 9.1 on an existing storage subsystem).

7. Install the IBM fibre channel Host Adapter (HA) failover version device driver for
Linux operating systems (q1a2200.0 or q1a2300.0).

8. Install IBM FAStT Management Suite Java and QLRemote Agent.

9. Configure path failover/failback. See the device driver readme file for
information.

o ok wD

Install the storage management software on a management station in the following
order:

1. Uninstall the earlier version Storage Manager.
2. Install Storage Manager 9.1 Runtime.
3. Install Storage Manager 9.1 Client.

In|“UninstaIIing Storage Manager” on page 89,| the package names SMutil,
SMclient, SMagent and SMruntime are the prefixes of the actual package names
that are either installed or to be installed. To determine the full names of the
installed Storage Manager software packages, at the command prompt, type rpm
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—qa | grep SM. The system will display the installed package file names. For the
new software package, use the 1s command to list the contents of the directory.

Uninstalling Storage Manager

This section contains procedures for uninstalling an earlier version of Storage
Manager software from one or more Linux management stations or hosts. Use the
following procedure to remove previous versions of the software before installing
Storage Manager version 9.1. The software removal procedures can also be
performed using an rpm-compatible, GUI-based package manager.

Perform the following steps to uninstall an earlier version of Storage Manager.

Note: You do not need to restart your host computer after removing a software
component. During the software removal process, the host keeps existing
storage subsystem mappings and storage partition configurations, which the
new client software will recognize.

1. Be sure that you have root privileges, which are required to uninstall Storage
Manager.

2. To remove previously installed software packages:

a. Type the appropriate uninstallation command at the command prompt in the
order listed in[Table 21| and press Enter.

Table 21. Software removal commands

Package Removal command
SMutil rpm -e SMutil
SMclient rpm -e SMclient
SMagent rpm -e SMagent
SMruntime rpm -e SMruntime

When the software has been removed, the system will return to the
command prompt.

b. At the command prompt, type the verification command for the selected
software package, and press Enter. See [Table 22

Table 22. Software removal verification commands

Package Removal command
SMutil rpm -qi SMutil
SMclient rpm -qi SMclient
SMagent rpm -qi SMagent
SMruntime rpm -qi SMruntime

The following message displays.
Package <packagename> is not installed.
¢. For information on uninstalingl Linux RDAC, see the Linux RDAC readme.

3. If you are installing a new version of the software, proceed to [‘Installing the

[Storage Manager 9.1 software” on page 90/ If you are not installing a new
version of the software, you have successfully completed this procedure.
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Installing the Storage Manager 9.1 software

Use the procedures in this section to install the applicable Storage Manager 9.1
software packages on a management station or host computer. These software
installation procedures can also be performed using an rpm-compatible, GUI-based
package manager.

Important: Before installing the client software, install the runtime software. A
system reboot is only required when installing the RDAC driver package. The event
monitor software is installed automatically during the client software installation.

1. Ensure that you have root priviledges, which are required to install the software.
2. Insert the installation CD and, if necessary, mount the CD-ROM drive.

Note: In the following procedure, the CD-ROM drive is mounted at /cdrom. You
must uncompressthe installation packages from the CD-ROM to an
existing folder on your hard drive. In the following procedure, this
temporary directory is designated as /tmp. You may choose to create a
different destination directory name.

Modify these instructions as required to meet your particular installation
requirements.

3. Use the following steps to review the End User License Agreement (EULA) and
to uncompress the packages to a temporary directory.

a. At the command prompt, type the following command and press Enter:
/cdrom/install/SM-tar.bin /tmp
The system will display the EULA and the following question.
Do you consent to the above terms [y or n]?

b. To confirm, type y and press Enter.

The system will extract the packages to the temporary location specified and
then display the folowing line.

Extraction to /tmp complete

c. To change the temporary directory, type the following command at the
command prompt and press Enter.

cd /tmp

Installing Storage Manager 9.1 Runtime (SMruntime)

Installation of the SMruntime package is necessary for both hosts and storage
management stations.

Note: The following steps direct you to enter commands necessary to install the
appropriate software packages. After you invoke each command, the
software installation begins. When the installation completes, a message
displays indicating that the installation was successful and returning the
system command prompt.

Perform the following steps to install SMruntime:
1. Type the following command at the command prompt and press Enter.
rpm -ivh SMruntime-LINUX<version number>.rpm

2. To verify the installation of the SMruntime package, type the following command
at the command prompt and press Enter.

rpm -ga SMruntime
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3. If the installation was successful, and no failure was reported, continue with
[Installing the Storage Manager 9.1 Client (SMclient).] If the installation was
unsuccessful, repeat steps [1 on page 90/and |2 on page 90} If the failure
persists, see the Storage Manager 9.1 Release Notes or contact your IBM
technical support representative.

Installing the Storage Manager 9.1 Client (SMclient)

Installation of the SMclient package is necessary only if the system is a storage
management station or if the system is a host acting as a storage management

station. If you are not installing SMclient, proceed to [Installing the RDAC package”|
on page 92,

Perform the following steps to install the SMclient:
1. Type the following command at the command prompt and press Enter.

rpm -ivh SMclient-LINUX<version number>.rpm

2. To verify the installation of the SMclient package, type the following command at
the command prompt and press Enter.
rpm -ga SMclient

3. If the installation was successful, and no failure was reported, continue with
[‘Installing the RDAC package” on page 92/ If the installation was unsuccessful,

repeat steps|1|and Ig] If the failure persists, see the Storage Manager 9.1
Release Notes or contact your IBM technical support representative.

Disabling and enabling the Event Monitor

The Event Monitor, which comes with the client software, installs automatically
during the client software installation. The Event Monitor handles storage
subsystem error notification through e-mail or SNMP traps when the storage
management software is not actively running on the management station or host
computer.

Important: If you installed the client software and configured alert notifications on
multiple hosts, you might receive duplicate error messages from the same storage
subsystem. To avoid receiving duplicate error messages, disable the Event Monitor
on all but one system. You must run the Event Monitor on one host that will run
continually.

You can disable and enable the event monitor while the event monitor is running. or
you can disable and enable the boot-time reloading of the event monitor. If you
disable the event monitor while it is running, it will start automatically at the next
reboot.

Disabling the event monitor while the software is running
Important: If you disable the event monitor while it is running, it will start
automatically at the next reboot.

At the command prompt, type the following command and press Enter:

SMmonitor stop

When the program shutdown is complete, the system displays the following
message.

Stopping Monitor process.
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Enabling the event monitor while the software is running
At the command prompt, type the following command and press Enter:

SMmonitor start
When the program startup begins, the system displays the following message.

SMmonitor started.

Disabling boot-time loading of the Event Monitor
At the command prompt, type the following command and press Enter:

mv /etc/rc2.d/S99SMmonitor /etc/rc2.d/disabledS99SMmonitor

You are returned to the command prompt.

Enabling boot-time loading of the Event Monitor
At the command prompt, type the following command and press Enter:

mv /etc/rc2.d/S99SMmonitor /etc/rc2.d/S99SMmonitor

You are returned to the command prompt.

Installing the RDAC package

This section describes how to install RDAC on the Linux operating system.
Installation of this package is necessary only if the system is a host. You must
install RDAC on each host computer. The RDAC package installs the multipath
device driver that is necessary for controller failover support. A system reboot is
required when installing the RDAC driver package. You must also need to install the
non-failover version of the fibre channel HBA device driver before installing RDAC.

Note: See the Storage Manager 9.1 Release Notes for information on supported
levels of HBA drivers.

1. To unpack the Linux RDAC source files from the /tmp directory, type the
following command at the command prompt, where <filename> is the name of
the Linux RDAC source file, and press Enter.

tar -zxvf <filename>.tar.gz
The source files will uncompress into the /tmp/1inuxrdac directory.

2. For detailed procedures on compiling and installing the driver modules, see the
README. txt file located in the Tinuxrdac directory.

3. If the installation was successful, and no failure was reported, continue with
|“Insta|ling the Storage Manager 9.1 Utility (SMutiI).”| If the installation was
unsuccessful, repeat steps |1| and Q If the failure persists, see the Storage
Manager 9.1 Release Notes or contact your IBM technical support
representative.

Installing the Storage Manager 9.1 Utility (SMutil)

Installing the SMutil package is necessary only if the system is a host. If you are

not installing SMutil, proceed to [Installing Storage Manager 9.1 Agent (SMagent)’|
on page 93,

Perform the following steps to install the SMutil:
1. Type the following command at the system prompt and press Enter.
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rpm -ivh SMutil-LINUX.rpm

2. To verify installation of the SMutil package, type the following command at the
system prompt and press Enter.
rpm -ga SMutil

3. If the installation was successful, and no failure was reported, continue with
[“Installing Storage Manager 9.1 Agent (SMagent).”| If the installation was
unsuccessful, repeat steps |1 on page 92| and |g| If the failure persists, see the

Storage Manager 9.1 Release Notes or contact your IBM technical support
representative.

Installing Storage Manager 9.1 Agent (SMagent)

Installation of the Storage Manager 9.1 Agent software is necessary only if the
system is a host and the storage array is to be managed using the in-band storage
array management method. In addition, RDAC must be installed. If you are not
installing SMagent, proceed to ['Removing the temporary Installation files.] To install
the SMagent package

1. Type the following command at the system prompt and press Enter.
rpm -ivh SMagent-LINUX.rpm

2. To verify installation of the SMagent package, type the following command at
the system prompt and press Enter.

rpm -ga SMagent

3. If the installation was successful, and no failure was reported, continue with
[‘Removing the temporary Installation files.”] If the installation was unsuccessful,
repeat stepsland @ If the failure persists, see the Storage Manager 9.1
Release Notes or contact your IBM technical support representative.

Removing the temporary Installation files

This section describes how to remove the temporary Installation files from the
temporary directory.

1. At the prompt, type the following command, and press Enter.
rm /install_dir/SM*-LINUX.rpm

...where /install_dir/ is the directory from which you will extract the
installation files.

2. To confirm, type y and press Enter.

Uninstalling IBM FAStT Management Suite Java

If you are installing Storage Manager 9.1 in an environment with existing storage
subsystems, you need to uninstall older versions of IBM FAStT Management Suite
Java (MSJ) and then install the version of IBM FAStT MSJ that came on the IBM
FAStT Storage Manager Version 9.1 CD.

Perform the following steps to uninstall FAStT MSJ:

1. From a system prompt, type the following command:
/usr/FAStT_MSJ_Uninstaller

2. Press Tab; then, press Enter.

Installing IBM FASIT Management Suite Java

The IBM FAStT MSJ software includes the FAStT GUI device driver that is required
for failover and diagnostic support. You can use the GUI to configure logical drives,
storage, and failover.
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Note: For additional information, see the online help.

Perform the following steps to install IBM FAStT MSJ:
1. Insert the IBM FASIT Storage Manager Version 9.1 CD into the CD-ROM drive.
2. From the X-windows GUI, open a command window.
3. Type the following command and press Enter:
cd /mnt/cdrom/FAStT_MSJ/1inux
4. To run the installer for FAStT MSJ, type the following command at a system
prompt:
sh FAStT
Press Tab; then, press Enter. The Introduction window opens.
Click Next.
Restart your Linux server.
Continue with ['Installing the IBM fibre-channel host bus adapter device driver.’|

© N o O

For additional configuration information, see the IBM FAStT MSJ User’s Guide.

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and a FAStT Storage Server. IBM FASLT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters designed for
high-end systems. These HBAs support all fibre-channel peripheral devices that
support private-loop direct-attach and fabric-loop attachment. The IBM Host Adapter
device driver enables your operating system to communicate with the fibre-channel
HBA. See the readme file included in the driver package for installation instructions
associated with your operating system. For more information, see the Installation
and User’s Guide for your particular fibre-channel HBA model. The current readme
file and latest multipath I/O device driver are available for download at the following
Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Note: Depending on your controller’s firmware version, change the LUNs per target
BIOS setting from the default value of 0 to 31 or 255 for IBM FASHT fibre
channel HBA.

Additional information

For additional information about installing and using Storage Manager 9.1 in a Linux
configuration, see IAppendix C, “Linux operating system limitations,” on page 133.|
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Chapter 7. Installing Storage Manager software in a VMware
ESX Server configuration

Install Storage Manager 9.1 on a management workstation separate from that
running VMware ESX Server 2.0, preferably on the workstation from which you
manage the VMware ESX Server 2.0 . Do not install Storage Manager 9.1 on a
server running VMware ESX Server 2.0. Your management station should be using
either a Windows or Linux operating system. For instructions associated with your
particular platform, see [Chapter 3, “Installing Storage Manager software in al
standard Windows configuration,” on page 53 or [Chapter 6, “Installing Storage
Manager software in a Linux configuration,” on page 87.|

shows a sample VMware ESX Server configuration.

Ethernet

Management station ESX server

<4——Fibre-channel
1/0 path

Ethernet —»

Controller

‘ Controller ‘

Storage subsystems

$J001150

Figure 13. Sample VMware ESX Server configuration

Software requirements
Software requirements for FAStT Storage Manager 9.1 running VMware ESX
Server 2.0 are detailed in this section.

Management station
The following software is required for the management station:
1. SM Runtime (Linux only)
2. SMclient

Note: The mapping storage partition host type for VMware is Linux.
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Host (ESX Server)

The following software is required for the ESX Server:

1. No Storage Manager software

2. VMware-supplied driver for the fibre-channel HBAs

3. QLogic driver failover setup (in VMware ESX Server 2.0)

Note: For the VMware ESX Server 2.0 Administration Guide and additional
related information, see the |VMware support Web site| at:

[www.vmware.com/support/esx2/

For more information about installing VMware ESX Server 2.0 on an IBM server,
see the IBM support Web site at:

www.ibm.com/pc/us/compat/nos/matrix.shtml|

Hardware requirements

For information about the hardware that is supported with VMware ESX Server 2.0,
see the IBM support Web site at:

www.ibm.com/storage/disk/fastt/supserver.htm|

Additional information

For additional information about installing and using Storage Manager 9.1 in a
VMware configuration, see |[Appendix D, “VMware ESX Server operating system|
limitations,” on page 135.|
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Chapter 8. Completing Storage Manager 9.1 installation

This chapter contains procedures on how to use Enterprise Management and
Subsystem Management to complete Storage Manager 9.1 installation tasks for
Windows, NetWare, and Linux operating system environments.

Completing the installation

To complete a Storage Manager 9.1 installation, perform the following tasks:
Perform an initial automatic discovery of storage subsystems.

Add devices, if necessary.

Set up alert notifications, if you want.

Name the storage subsystems.

Download firmware and NVSRAM.

Create arrays and logical drives.

Verify and define the default host type.

Configure the heterogeneous hosts.

Perform other storage subsystem tasks.

© © N oD~

Each of these steps is discussed in detail in the sections that follow.

The Enterprise Management window opens when you start the FAStT Storage
Manager. Use the Enterprise Management window to:

* Add and discover the storage subsystems.
* View all storage subsystems in your management domain.
+ Perform batch storage subsystem management tasks using the Script Editor.

Performing an initial automatic discovery of storage subsystems
To perform an initial automatic discovery of storage subsystems, perform the
following steps:

1. Click Start » Programs.

2. Click IBM FASIT Storage Manager 9 Client. The client software starts and
displays the Enterprise Management window and the Confirm Initial Automatic
Discovery window as illustrated in [Figure 14 on page 98|
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Initial Automatic Discovery

The Enterprize Management Windowe iz not configured to manitor
or manage any devices.

Zelect Yes to begin an automatic discovery on the local
EFS sub-netwark; thiz may take several minutes. Select Mo to bypazs
= the automsatic dizcovery process.
If wou zelect Mo, you can =till use the Edit==2dd Device option to
manually add the devices.,

Mo Help

dss00033

Figure 14. Confirm Initial Automatic Discovery window

Note: The Enterprise Management window can take several minutes to open.
No wait cursor (such as an hourglass) displays.

3. Click Yes to begin an initial automatic discovery of hosts and storage
subsystems attached to the local subnetwork.

After the initial automatic discovery is complete, the Enterprise Management
window displays all hosts and storage subsystems attached to the local
subnetwork.

Note: The Enterprise Management window can take up to a minute to refresh
after an initial automatic discovery.

il IBM FASLT Storage Manager 9 (Enterprise Management) = =10 x|
Edit  View Tools Help

4| @l Bl B :
Managemems‘taﬁon Mame | Type I Status Metwork Mahagetnent Type I Comtnent I

lj—"—%om-of-ﬁand Storage Subsysterms Urinatned @ © Optiral Out-of-Band

L Ste yatemn Unhamed
+ @\n-Band Storage Subsystems

dss00034

| @ lLaunched Subsystem Management Window for FASITEOD

Figure 15. Enterprise Management window

4. Verify that each host and storage subsystem displays in the Enterprise Manager
window.

If a host or storage subsystem is not displayed, perform the following tasks:

* Check the hardware and hardware connections for possible problems (refer
to the hardware documentation for specific procedures).
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6.

Adding devices

* Refer to the Enterprise Management online help for additional information
about discovering storage subsystems.

» If you are using the direct-management method, verify that all hosts and
storage subsystems are connected to the same subnet network. If you are
using the host-agent method, ensure that the fibre-channel connection
between the host and storage subsystems is made.

* Make sure that all of the preparation steps for setting up the storage
subsystem for a directly-managed system in |Chapter 2, “Preparing fod
|insta||ation,” on page 33| are completed. If they are, use the Add Device
option to add the IP addresses of the Storage subsystem. Add both IP
addresses of the controller. Otherwise, you will get a "partially-managed
device” error message when you try to manage the storage subsystem.

» If you are using the host-agent management method, perform the following
steps:
a. Make sure that the SMagent is installed in the host.
b. Verify that you have a fibre-channel connection from the storage
subsystems to the host that has the SMagent installed.

c. Verify that all of the preparation steps outlined in [Chapter 2, “Preparing for|
installation,” on page 33 are complete. If they are, perform the following
steps:

1) Run the hot_add utility.

2) Restart the SMagent using the information in [‘Stopping and restarting|
[the host-agent software” on page 117,

3) Right click on the host and click Tools » Rescan in the Enterprise
management window.

Note: In certain situations, a storage subsystem might be duplicated in the
device tree after an automatic discovery. You can remove a duplicate
storage management icon from the device tree by using the Remove
Device option in the Enterprise Management window.

Verify that the status of each storage subsystem is Optimal. If a device shows a
status of Unresponsive, right-click the device and select Remove Device to
delete it from the management domain. Then use the Add Device option to add
it to the management domain again. Refer to the Enterprise Management
window online help for instructions on removing and adding devices.

Continue with [‘Adding devices.’|

You can manually add more hosts or storage subsystems. You can use this option
to selectively manage a group of storage subsystems from an SMclient. You can
also use this option to add additional devices to be managed that were not
discovered during the SMclient initial discovery. For more information about this
option, see the Enterprise Management window online help.

Important:

When you add new storage subsystems to the existing storage subsystems in a
SAN that are managed through the host-agent software, you must stop and
restart the host-agent service. When the host-agent service restarts, the new
storage subsystem is detected. For more information, see
|restarting the host-agent software” on page 117.|Then, go to the Enterprise
Management window and click Tools » Rescan to add the new storage
subsystems to the management domain.
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* When you add new storage subsystems to existing storage subsystems that are
managed using the direct-management method, be sure to specify the IP
addresses for both controllers.

Continue with [‘Setting up alert notifications.”|

Setting up alert notifications

After you add devices to the management domain, you can set up alert notifications
to report critical events on the storage subsystems. The following alert-notification
options are available:

» Notification to a designated network management station (NMS) using Simple
Network Management Protocol (SNMP) traps

* Notification to designated e-mail addresses

* Notification to designated alphanumeric pagers (requires separately supplied
software to convert e-mail messages)

Note: You can only monitor storage subsystems within the management domain. If
you do not install the Event Monitor service, the Enterprise Management
window must remain open. If you close the window, you will not receive any
alert notifications from the managed storage subsystems. Refer to the
Enterprise Management window online help for additional information.

To set up alert notification to an NMS using SNMP traps, perform the following

steps:

1. Insert the IBM FASIT Storage Manager Version 9.1 CD into the CD-ROM drive
on an NMS. You need to set up the designated management station only once.

2. Copy the SM910.MIB file from the SM910.mib directory to the NMS.

3. Follow the steps required by your NMS to compile the management information
base (MIB) file. (For details, contact your network administrator or see the
documentation specific to your particular storage management product.)

4. Continue with ['Naming storage subsystems.’]

Naming storage subsystems
To name your storage subsystem, perform the following steps:
1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools » Manage Device. The Subsystem Management window opens, as
shown in [Figure 16 on page 101
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Figure 17.
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Figure 16. Subsystem Management window

3. Click Storage Subsystem » Rename. The Rename Storage Subsystem
window opens as shown in

% FASITH0D0 - Rename Storage Subsystem :

Changing the storage subsystem name can cause host

applications 1o loze access to the storage subsystem if the host
iz running certain path failover drivers.

update the storage subsystem name in your path failover driver's

2 If any of your hostz are running path failover drivers, please

configuration file before rebooting the host machine to enzure
uninterrupted access to this storage subsystem. Refer to your

path failover driver documentstion for more details.

Are you sure you vwant to continue?

X

Yes
4. Type the name of the storage subsystem (see [Table 27 on page 137). Then
click OK. Click Yes on the warning screen to continue.
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5. Repeat this procedure for each unnamed storage subsystem. For more
information, see the topic on renaming storage subsystems in the Subsystem
Management window online help.

6. Proceed to[‘Downloading controller and NVSRAM ESM firmware.”|

Downloading controller and NVSRAM ESM firmware

Note: Access the latest versions of FAStT Storage Server controller firmware and
NVSRAM and FASIT Storage Expansion Enclosure ESM firmware at the IBM
Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Important:

1. IBM supports firmware download with I/O, sometimes referred to as "concurrent
firmware download”. Before proceeding with concurrent firmware download,
check the readme file packaged with the firmware code or your particular
operating system’s FAStT Storage Manager host software for any restrictions to
this support .

2. Suspend all I/O activity while downloading firmware and NVSRAM to a FAStT
Storage Server with a single controller or you will not have redundant controller
connections between the host server and the FASIT Storage Server.

This section provides instructions for downloading FAStT storage server controller
firmware and NVSRAM and FAStT Storage Expansion Enclosure ESM firmware.

You must download FASTT storage server controller firmware version 06.10.xx.xx

before you download FASIT Storage Expansion Enclosure ESM firmware.

If your controller’s existing firmware is 06.10.xx.xx or later, you will have the option
to select the NVSRAM for download at the same time that you upgrade/download
the new controller firmware. Additionally, you will have the option to download the
firmware and NVSRAM immediately, but activate it later, when it may be more
appropriate. See the online help for more information.

Note: The option to activate firmware at a later time is not supported on the
FAStT700.

Downloading firmware
To download firmware version 06.10.xx.xx or NVSRAM, perform the following steps:

1. From the Enterprise Management window, select a storage subsystem.
2. Click Tools » Manage Device. The Subsystem Management window opens.

3. Click Advanced » Maintenance » Download » Controller firmware.... The
download firmware window opens as illustrated in [Figure 18 on page 103|

Note: FASIT Storage Server with controller firmware version 06.10.xx.xx and
higher supports the downloading of the NVSRAM file together with the
firmware file. Therefore, the following window will display only if your
exiting controller firmware is of version 06.10.xx.xx or higher. This
download feature is not supported in FAStT storage servers with
controller firmware 05.4x .xx.xx and earlier. If your exiting controller
firmware is of version 05.4x.xx.xx or lower, only a window for
downloading firmware will display.
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Figure 18. Download Firmware window

4. Click Browse next to the Selected firmware file: field to identify and select
the file with the new firmware.

5. Optionally:
» Select the Download NVSRAM file with firmware option and click Browse

next to the Selected NVSRAM file: field to identify and select the file and
identify and select the correct NVSRAM filename.

» If you choose to transfer and activate immediately, do not select Transfer
files but don’t activate them (activate later). Otherwise, click the box to
select Transfer files but don’t activate them (activate later). To activate
the firmware at a later time, in the Subsystem Management window, click
Advanced » Maintenance » Activate Controller Firmware.

Downloading ESM firmware

Perform the following steps to download the ESM firmware:

1. In the FASIT Storage Server Subsystem Management window, select
Advanced » Maintenance » Download » ESM firmware.... A Download
Environmental Card Firmware window opens.

2. Click Select All to direct the download to all enclosures. You can also select
one enclosure or combinations of enclosures by pressing the cnt1 key while
selecting the individual enclosures.

3. Click Browse to identify and select the filename of the ESM firmware file and
click Start to begin the ESM firmware download.

Chapter 8. Completing Storage Manager 9.1 installation 103



4. A Confirm Download window opens. Type Yes and click OK to start the
download process.

5. Click Cancel to close the window when the ESM firmware download to all
selected enclosures is complete.

Note: Suspend all I/O activity while ESM firmware downloads if you select
multiple enclosures for downloading ESM firmware. If you select only one
enclosure for download at a time, you can download ESM firmware while
the server conducts I/O activity. However, IBM recommends that you
suspend all 1/0 activity to perform firmware upgrades.

Creating arrays and logical drives

Important: You should create a storage subsystem profile and save it in a safe
place whenever you modify the arrays and logical drives in your storage server.
This profile contains detailed controller information including logical and physical
disk configuration information that you can use to help recover the configuration in
the event of a catastrophic failure. Do not save the profile in the logical drives that
are created in the FAStT Storage Server whose profile was collected and saved.

To create a storage subsystem profile, select Storage Subsystem » View Profile
in the Storage Subsystem Management window and click the Save As button when
the Storage Subsystem Profile window opens. In addition, using firmware version
06.10.xx.xx, you can also select Advanced » Troubleshooting » Collect All
Support Data as shown in[Figure 19 on page 105|to collect all the various types of
inventory, status, diagnostic and performance data from this storage subsystem and
save them to a single compressed file.
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Figure 19. Collect All Support Data window

If you have a storage server with firmware level 04.01.xx.xx or earlier, you must
also perform a controller state capture in addition to saving the storage subsystem
profile. To use the Capture State Information feature, you must upgrade the
controller to firmware level 04.01.02.34 or higher and install the FAStT Storage
Manager Field Tool Version 5.21 program. This program is available at the following
Web site:

www-1.ibm.com/servers/storage/support/fastt/index. html|

To create a storage subsystem profile using the Capture State Information feature,
perform the following steps:

1. Click Tools » Capture State Information. A State Capture window opens.

2. Click the Browse button to specify the file name for the state capture
information.

3. Click the Start button to start the capture process.

4. Click the Cancel button to close the State Capture window when the capturing
is completed.

An array is a set of fibre-channel hard drives that are logically grouped together to
form a RAID set. For firmware levels 05.3x.xx.xx and lower, the maximum number
of hard drives supported for each array is 30 if the hard drive capacities are 73.4
GB or less and 14 if the hard drive capacities are 146 GB. For firmware levels
5.4x.xx.xx and higher, however, the maximum number of drives supported in an
array is 30, regardless of the hard drive capacity. Each array can be divided into
from 1 to 256 logical drives. A logical drive is a logical structure, which is the basic
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structure that you create to store data on the storage subsystem. The operating
system recognizes a logical drive as a single drive. Choose a RAID level to meet
application needs for data availability and maximize fibre-channel 1/0 performance.

To create arrays and logical drives, perform the following steps:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools » Manage Device. The Subsystem Management window opens.
3. Click the Logical/Physical View tab.
4

Select Total Unconfigured Capacity or Free Capacity node. The Logical Drive
Create wizard starts. Follow the online instructions to create arrays and logical
drives. See also [‘Creating logical drives from free or unconfigured capacity.’|

5. Proceed to[*Verifying and defining the default host type” on page 108

Note: For cluster configurations, if you add or delete logical drives, you must make
them known to both nodes A and B.

Creating logical drives from free or unconfigured capacity

Perform the following steps to create logical drives from free or unconfigured
capacity nodes in the Subsystem Management window.

1. Select either Free Capacity node or Total Unconfigured Capacity node and
then click Logical Drive » Create.

The Introduction (Create Logical Drive) window opens.

Tests - FE00B4 - Create Logical Drive Wizard - Specify Array P. ‘ x|

Because you specified unconfigured capacity fram the previous screen, you must
indicate the RAID level and overall capacity ofthe new array. You specifythe exact
capacity for the individual logical drive on the next screen

 Create nev arra
RAID level

|RaiD 5 =l

Drive selection choices

£ Automatic - select from list of provided capacitiesidrives

" Manual - selectyour own drives o obtain capacity (minimurn 3 drives)

Array Capacity | Drives | Channel Protection |
o T — Bl
2,588.407 GB 20 Vv ves
2,724.639 GB 21 Vv ves
2,860.871 GB 22 Vv ves
2,887.103 GB 23 v Ves
3,133.334 GB 24 v ves
3,260 566 GA 25 v ves
3,405.798 GB 26 v ves
3,542.030 GB 7 Vv ves
3,676.262 GB 28 v Ves
3,814.494 GB 29 Vv ves
3,950.726 GB 30 v ves -

< Back | Mext= I Cancel | Help |

$J001129

Figure 20. Create Logical Drive window

2. The Introduction (Create Logical Drive) window indicates the amount of free or
unconfigured capacity available and provides a link to tips and examples on
allocating that additional capacity. Click Next to continue.

3. The Specify Array (Create Logical Drive) window opens to allow you to define
the parameters for an array that you will create for the logical drive. In this
window, specify the following array parameters:

* One of the following RAID levels:
— RAID-0
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4.

— RAID-1
— RAID-3
— RAID-5
* The array capacity.

Select the number of drives that will be used for this array. You can either
specify the number of drives in the array and let the storage subsystem
select which optimal hard drives in the storage subsystem to use
(Automatic_), or you can manually select which hard drives will form the
array (Manual_).

Note: In manual mode, to select multiple drives, you can press and hold
the Ctrl key and then use the mouse to select the desired hard drive
or drives in the available unconfigured optimal hard drive list.

Click Next to continue.

* When a box opens stating that you have successfully set the parameters for
creating an array, click OK to continue. The Specify Capacity/Name (Create
Logical Drive) window opens.

In the Specify Capacity/Name (Create Logical Drive) window, specify the
following logical drive parameters for the logical drive you want to create:

Logical drive capacity
The new logical drive capacity can either be the entire unconfigured
capacity in an array or a portion of the capacity.

Units You can choose GB, MB, or TB.

Logical drive name
This name must be unique in the storage subsystem.

Settings
You can create the logical drive either using the FAStT Storage Server
default settings or you can select your own customized 1/0
characteristics, controller ownership, and logical-drive-to-LUN mapping
settings.

If you choose to use the FASIT Storage Server default settings, click Next then
goto step|§| If you want to select your own customized settings, click Next
then go to step [

The Customize Advanced Logical Drive Parameters (Create Logical Drive)

window opens. In the Customize Advanced Logical Drive Parameters (Create

Logical Drive) window, specify the following settings:

* The appropriate 1/O characteristics (the I/O characteristics type, segment
size, and cache read-ahead multiplier)

The I/O characteristics settings can be manually specified or automatically
set based on the selection of one of the following expected logical drive
usages: file system, database, or multimedia.

Click Next. The Specify Logical Drive-to-LUN Mapping (Create Logical
Drive) window opens.

In the Specify Logical Drive-to-LUN Mapping (Create Logical Drive) window,

specify how you want the logical drive-to-LUN mapping to be mapped to the

individual logical drive.

The logical drive-to-LUN mapping preference can be one of the following two
settings:
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Default mapping
The Automatic setting specifies that a LUN is automatically assigned to
the logical drive using the next available LUN within the default host
group. This setting grants logical drive access to host groups or host
computers that have no specific logical drive-to-LUN mappings (those
that were designated by the default host group node in the Topology
view). If the Storage Partition feature is not enabled, you must specify
the Automatic setting. In addition, you can also change the host type to
match host’s operating system.

Map later using the Mappings View
This setting specifies that you are not going to assign a LUN to the
logical drive during creation. This setting enables you to define a
specific logical drive-to-LUN mapping and create storage partitions
using the Mappings Defined option. When you enable storage
partitioning, specify this setting.

7. Click Finish to create the logical drive. The Creation Successful (Create
Logical Drive) window opens and states that the logical drive was successfully
created.

8. Indicate in the Creation Successful (Create Logical Drive) window if you want
to create the logical drive from the same array, if there is free capacity, or from
a different array if there is no capacity in the array in which the logical drive
was just created. Click Yes and go to step E If you do not want to create
another logical drive, click No and continue with ste

9. The Allocate Capacity (Create Logical Drive) window opens. Select if you
want to create the new logical drive from free capacity on the same array, free

capacity on a different array, or from unconfigured capacity (create a new
array). Then continue with step |4 on page 107,
10. The Completed (Create Logical Drive) window opens. Click OK.

11. Reqgister the logical drive with the operating system.

After you create logical drives with automatic logical drive-to-LUN mappings,
follow the appropriate instructions in the Installation and Support Guide for your
operating system to enable the operating system to discover the new logical
drive.

Verifying and defining the default host type

Before you use the logical drives in a host computer, you must specify the correct
host type. For information on available host types, see[‘Host type options” on pagel
The host type determines how the storage subsystem controllers will work with
each particular operating system on the hosts to which it is connected. If all of the
host computers connected to the same storage subsystem are running the same
operating system, and you do not want to define partitioning, you can define a
default host type.

Note: Windows 2000 and Windows Server 2003 share the following host type
options:
* Windows 2000/Server 2003 non-clustered
* Windows 2000/Server 2003 clustered

If these host type entries do not display as options in your host type
pull-down menu, use either of the following host types instead:

¢ Windows 2000 non-clustered
¢ Windows 2000 clustered
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To verify the current default host type, perform the following steps:

1. In the Subsystem Management window, click Storage subsystem » View

profile. A Storage Subsystem Profile window opens.

2. Click the Mappings folder tab and scroll down to NVSRAM Host Type Index

Definitions. The host type name of the index that has the word DEFAULT next
to it is the default host type.

3. Click Close.

To define a default host type, perform the following steps:

1. Click Storage subsystem » Change » Default host-type. The Default
Host-type window opens.

2. From the pull-down list, select the host type.
3. Click OK.

If you have hosts with different operating systems or if you want to define partitions

for the hosts, continue with [‘Configuring heterogeneous hosts” on page 110

Host type options

The following host type options are available for specification.
1. Windows

Windows NT Non-clustered (SP5 or higher)
Windows NT Clustered (SP5 or higher)
Windows 2000/Server 2003 Non-clustered
Windows 2000/Server 2003 Clustered

Windows 2000/Server 2003 Non-clustered (Supports Veritas Dynamic
Multipathing [DMP])

Windows 2000/Server 2003 Clustered (Supports Veritas Dynamic
Multipathing [DMP])

2. Linux

Linux

This host type is intended for use with fibre channel HBA multipath
failover/failback device driver (non-RDAC).

LNXCL

This host type is intended for use with RDAC as the multipath
failover/failback device driver.

3. NetWare

NetWare-IBMSAN

This host type is intended for use with IBMSAN as multipath failover/failback

device driver.
NetWare Failover

This host type is intended for use with Novell native multipath failover/failback

device driver.

4. VVMware

ESX Server 2.0
Linux

ESX Server 2.1
LNXCL
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Configuring heterogeneous hosts

The heterogeneous hosts feature enables hosts running different operating systems
to access a single storage subsystem. Previous releases of FAStT Storage
Manager (versions 7.02 or earlier) required that hosts run the same operating
system in order to access a single storage subsystem.

Host computers can run completely different operating systems (for example,
Solaris) or variants of the same operating system. When a host type is specified in
the Define New Host Port window, the heterogeneous hosts feature enables the
controllers in the storage subsystem to tailor their behavior (such as LUN reporting)
to the needs of the host.

Important: To use the heterogeneous host feature, you must meet the following
conditions:

* You must enable storage partitioning.

» During host-port definition, you must set each host type to the appropriate
operating system so that the firmware on each controller can respond correctly to
the host.

To start the heterogeneous host configuration, perform the following steps:

1. From the Subsystem Management window, click the Mappings View tab.
2. Follow the on-screen instructions.

3. Continue with ['Performing other storage-subsystem management tasks” on|

|9age 111 |

Note: Partitioning is a premium feature. If you disable partitioning, you must
contact your IBM technical support representative to obtain a key to enable
partitioning again. This is not a standard feature with the FAStT600.

Creating a FlashCopy logical drive

A FlashCopy logical drive is a logical point-in-time image of a logical drive, called a
base logical drive. A FlashCopy logical drive has the following features:

» It is created quickly and requires less disk space than an actual logical drive.

» It can be assigned a host address, so that you can perform backups by using the
FlashCopy logical drive while the base logical drive is online and accessible.

* You can use the FlashCopy logical drive to perform application testing or both
scenario development and analysis. This does not effect the actual production
environment.

* The maximum number of FlashCopy logical drives allowed is one half of the total
logical drives supported by your controller model.

For additional information about the FlashCopy feature and how to manage Flash
Copy logical drives, refer to the Storage Manager Subsystem Management online
help.

Note: FlashCopy is a premium feature. Contact your IBM reseller or IBM marketing
representative for more information.

Important: The FlashCopy drive cannot be added or mapped to the same server
that has the base logical drive of the FlashCopy logical drive in a Windows 2000,
Windows Server 2003, or NetWare environment. You must map the FlashCopy
logical drive to another server.
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Perform the following steps to create a FlashCopy logical drive:

1. To ensure that you have the accurate point-in-time image of the base logical
drive, stop applications and flush cache 1/O to the base logical drive.

2. Open the Subsystem Management window. From the Logical View, right-click
the base logical drive.

3. Select Create FlashCopy Logical Drive. The Create FlashCopy Logical Drive
Wizard starts.

4. Follow the on-screen instructions.

5. Refer to the Subsystem Management online help for instructions on how to add
the FlashCopy logical drive to the host.

Using VolumeCopy

The VolumeCopy feature is a firmware-based mechanism for replicating logical
drive data within a storage array. This feature is designed as a system management
tool for tasks such as relocating data to other drives for hardware upgrades or
performance management, data backup, or restoring snapshot volume data. Users
submit VolumeCopy requests by specifying two compatible drives. One drive is
designated as the Source and the other as the Target. The VolumeCopy request is
persistent so that any relevant result of the copy process can be communicated to
the user. For more information about this feature, see the IBM TotalStorage FAStT
Storage Manager Copy Services User’s Guide, or contact your IBM reseller or
marketing representative.

Using the Remote Mirror option

The Remote Mirror option is a premium feature. It is used for online, real-time
replication of data between storage subsystems over a remote distance. In the
event of a disaster or unrecoverable error at one storage subsystem, the Remote
Mirror option enables you to promote a second storage subsystem to take over
responsibility for normal input/output (I/O) operations. For more information about
this feature, see the IBM FAStT Remote Mirror Option Installation and User’s Guide,
or contact your IBM reseller or marketing representative.

Performing other storage-subsystem management tasks

The following list includes other storage subsystem management tasks that you can
perform:

» Locating a storage subsystem

* Viewing a storage subsystem profile or event log

» Entering or changing a storage subsystem password

« Creating and managing logical drives and arrays

» Using the Performance Monitor

» Creating storage patrtitions (if applicable) and heterogeneous hosts
* Viewing or changing media scan settings

* Increasing capacity of an array or logical drive

» Changing RAID level for an array

* Monitoring read-link-status error counts

» Downloading ESM firmware or fibre-channel drive firmware

Note: To create storage partitions, you must obtain the worldwide name or port of
each host adapter in every host connected to the storage subsystem.
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For more information about these and other storage subsystem management tasks,
refer to the appropriate topics in the Subsystem Management online help.
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Chapter 9. Using the storage management software for
Windows and NetWare

This chapter provides information about how to add or delete logical drives, create
FlashCopy logical drives, use the hot_add and SMdevices utilities, start and stop
the host-agent software, and uninstall Storage Manager components in Windows
and NetWare operating system environments. Information regarding the Windows
operating system follows. See [‘Using the storage management software for
NetWare” on page 119|for analogous information about the NetWare operating
system environment.

Using the storage management software for Windows

This section provides information about how to add or delete logical drives, create
FlashCopy logical drives, use the hot_add and SMdevices utilities, start and stop
the host-agent software, and uninstall Storage Manager components in a Windows
operating system environment.

Adding or deleting logical drives

Use the following procedures to add or delete logical drives in a standard
(noncluster) and a cluster configuration.

Standard (noncluster) configuration for Windows 2000
Use the following procedures to create or delete logical drives in a standard server
environment for Windows 2000.

Creating logical drives: When you create logical drives with the storage
management software, you must add the new logical drives to Windows 2000. Each
logical drive (not array) is recognized by Windows 2000 as a single drive.

After creating logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The hot_add utility adds newly
created logical drives to the operating system without requiring a system restart.
The SMdevices utility identifies the logical drives by their associated operating
system device names. For more information, see [‘Using the hot_add utility” on page]
ﬁ%lorl“Using the SMdevices utility” on page 116

Deleting logical drives:

Attention: Do not click Configuration » Reset if you have data or logical drives
that you want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset, perform the following steps:

1. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

2. Restart the system to remove the configuration information.
Attention: You must use the Disk Administrator to delete OS partitions and

unassigned drive letters before you delete logical drives or reset the configuration in
Storage Manager. Take this action to avoid damage to your registry information.
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Cluster server configuration for Windows 2000
Use the following procedures to create or delete logical drives in a cluster server
environment for Windows 2000.

Creating logical drives: To add logical drives in a Windows 2000 cluster server
environment, perform the following steps:

1. Using the IBM FASIT Storage Manager Client, create arrays and assign them to
the appropriate host group by using storage partitioning.

2. Use the hot_add utility to add the new logical drives to node A.

3. Using the Disk Administrator, create, format, and assign drive letters to the disk
partitions on the new logical drives.

4. Use the hot_add utility to add the new logical drives to node B.

5. Using the Disk Administrator, ensure that the drive letters assigned to the disk
partitions on the logical drives are the same on both node A and node B.

6. Restart node A. Then use the Cluster Administrator to create cluster physical
disk resources using the new disk partitions on the new logical drives.

7. Bring the cluster resources online in node A.
8. Use cluster administrator to move the cluster physical disk resources to node B.
9. Verify that the resources come online in node B.

Deleting logical drives:

Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you
want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset in the Storage Manager Client Storage Subsystem
management window, perform the following steps:

1. Use the Cluster Administrator to delete the cluster physical disk resources that
own the logical drives that will be deleted.

2. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

3. Restart the system to remove the configuration information.

Attention: You must use the Cluster Administrator and Disk Administrator to
delete the cluster physical disk resources, delete OS partitions, and unassigned
drive letters before deleting logical drives or resetting the configuration in Storage
Manager. This avoids damage to your registry information.

Standard (non-clustered) configuration for Windows Server 2003
Use the following procedures to create or delete logical drives in a standard
environment.

Creating logical drives: When you create logical drives with the storage
management software, you must add the new logical drives to the Windows Server
2003 operating system. Each logical drive (not array) is recognized by Windows
Server 2003 as a single disk drive.

After creating logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The hot_add utility adds newly
created logical drives to the operating system without requiring a system restart.
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The SMdevices utility identifies logical drives by their associated operating system
device names. For more information, see [‘Using the hot_add utility” on page 116|or
[‘Using the SMdevices utility” on page 116.|

Deleting logical drives:

Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you
want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset in the Storage Manager Client Storage Subsystem
management window, perform the following steps:

1. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

2. If possible, restart the system to remove the configuration information.

Attention: You must use the Disk Administrator to delete the cluster physical disk
resources, delete OS partitions, and unassigned drive letters before you delete
logical drives or reset the configuration in Storage Manager. This action avoids
damage to your registry information.

Cluster server configuration for Windows Server 2003
Use the following procedures to create or delete logical drives in a cluster server
environment.

Creating logical drives: To add logical drives in a Windows Server 2003 cluster
server environment, perform the following steps:

1. Use the IBM FASIT Storage Manager Client program to create arrays and
logical drives and use storage partitioning to assign them to the appropriate
cluster host group.

2. Use the hot_add utility to add the new logical drives to the cluster node that is
currently owned by the cluster quorum resource.

3. Use the Disk Administrator program to create, format, and assign drive letters to
the disk partitions on the new logical drives.

4. In each of the rest of the cluster nodes in the cluster configuration, use the
hot_add utility to add the new logical drives to the cluster node.

5. In the first cluster node, use the Cluster Administrator program to create cluster
physical disk resources using the new disk partitions on the new logical drives.

Note: If the new disk does not show up in the available disk pull-down list when
you go through the Cluster Administrator program, you might have to
reboot the server.

6. Bring the cluster resources online in the first cluster node.

7. Use the Cluster Administrator to move the newly-created cluster physical disk
resources to other nodes in the cluster configuration.

8. Verify that the resources come online in other nodes in the cluster configuration.

Deleting logical drives:
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Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you
want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset in the Storage Manager Client Storage Subsystem
management window, perform the following steps:

1. Use the Cluster Administrator to delete the cluster physical disk resources that
own the logical drives that will be deleted.

2. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

3. If possible, restart the cluster nodes to remove the configuration information.

Attention: You must use the Cluster Administrator and Disk Administrator to
delete the cluster physical disk resources, delete OS partitions, and unassigned
drive letters before you delete logical drives or reset the configuration in Storage
Manager. This action avoids damage to your registry information.

Using the hot_add utility

The hot_add utility enables you to add new logical drives without restarting the
system. The utility registers the new logical drives with the operating system so that
you can use Disk Administrator to create partitions, add device names, and so on.
The hot_add utility is part of the SMutil software package. If you run the program
twice and the new logical drives are not displayed in the Disk Administrator window,
you must either run fibre-channel diagnostics or restart (reboot) the host.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem and perform the following steps to
use the hot_add utility:

1. From a DOS or command prompt, change to the directory
<installation_directory>\Util

...where installation_directory is the directory in which you installed the
SMutil.

The default directory is c:\Program Files\IBM_FAStT\Util.
2. From a DOS or command prompt, type the following command:
hot_add

3. Press Enter. The new logical drives are available through the Disk
Administrator.

Using the SMdevices utility
The SMutil software includes a utility called SMdevices that you can use to view the
storage subsystem logical drive that is associated with a particular operating system
device name. This utility is helpful when you want to create drive letters or partitions
by using Disk Administrator.

When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:

1. From a DOS or command prompt, change to the directory
<installation_directory>\Util
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...where installation_directory is the directory in which you installed the
SMutil.

The default directory is c:\Program Files\IBM_FAStT\Util.
2. Type:
SMdevices

3. Press Enter. The software displays device identification information. For
example, you might see the following information.

\\.\PHYSICALDRIVEx [Storage Subsystem Finance, Logical Drive DEBIT, LUN xx,

WWN <worldwide name>]

where:

* xis the Disk number that displays in Disk Administrator

* Finance is the name of the storage subsystem

« DEBIT is the name of the logical drive

* xx is the LUN associated with the logical drive

* worldwide_name is the worldwide name for the logical drive

Using the SMrepassist utility
You can use the SMrepassist utility to perform the following tasks:
* Flush cached data for a logical drive.

Important: The FlashCopy drive can not be added or mapped to the same server
that has the base logical drive of the FlashCopy logical drive in a Windows 2000,
Windows Server 2003, or NetWare environment. You must map the FlashCopy
logical drive to another server.

To flush cached data in a logical drive, perform the following steps:

1. From a DOS or command prompt, change to the directory
<installation_directory>\Util

...where installation_directory is the directory in which you installed the
SMutil.

The default directory is c:\Program Files\IBM FAStT\Util.
2. Type the following command:
smrepassist -f logical_drive_letter:

where logical_drive_letter is the operating system drive letter that was assigned
to the disk partition created on the logical drive.

3. Press Enter.

Stopping and restarting the host-agent software

You must stop and restart the host-agent software if you add additional storage
subsystems to the management domain of the host-agent software. When you
restart the service, the host-agent software discovers the new storage subsystems
and adds them to the management domain.

Note: If none of the access logical drives are detected after a restart, the
host-agent software automatically stops running. Make sure that there is a
good Fibre Channel connection from the host to the SAN to which the
storage subsystem is connected. Then restart the host or cluster node so
that new host-agent-managed storage subsystems can be discovered.
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Windows 2000
To stop and restart the host-agent software, perform the following steps:

1. Click Start —> Programs —> Administrative Tools —> Services. The Services
window opens.

2. Right-click IBM FAStT Storage Manager 8 Agent.

3. Click Restart. The IBM FAStT Storage Manager 8 Agent stops and then starts
again.
4. Close the Services window.

Windows Server 2003
To stop and restart the host-agent software, perform the following steps:

1. Click Start —> Administrative Tools —> Services. The Services window opens.
2. Right-click IBM FAStT Storage Manager 8 Agent.

3. Click Restart. The IBM FAStT Storage Manager 8 Agent stops and then starts
again.
4. Close the Services window.

Uninstalling storage management software components

If you are upgrading from any Storage Manager version 8.x , it will be necessary for
you to remove the current software before installing Storage Manager 9.1. No
reboot is required after removing a Storage Manager software package. Existing
storage array mappings and storage partition configurations are retained during
software removal ans will be recognized by the new client software.

Use the following procedure to uninstall one or more of the components of Storage
Manager 8.x. If you are uninstalling components released with an earlier version of
the storage management software, use the uninstall procedure that came with the
version of the storage management software that you are currently running.

Important: Do not uninstall the RDAC unless instructed by an IBM technical
support representative. The host-agent package requires RDAC to function properly.
If you uninstall RDAC in a coexistence environment, you will lose fibre-channel 1/0
path failover support for both the version 8.xx and version 9.xx of Storage Manager.

1. Click Start » Settings » Control Panel. The Control Panel window opens.
Select Add/Remove programs. The Add/Remove Programs Properties window
opens.

Note: Uninstall the Storage Manager components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

2. Select the component you want to uninstall from the list of programs (for
example, IBM FAStT Storage Manager Client).

3. Click Add/Remove. The Confirm File Deletion window opens.
4. Click Yes to start the uninstallation process.
5. When the uninstallation is complete, click OK.
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Using the storage management software for NetWare

This section provides information on how to add or delete logical drives using the
hot_add and SMdevices utilities, start and stop the host-agent software, and
uninstall Storage Manager components in a NetWare operating system
environment.

Adding or deleting logical drives

Use the following instructions to add or delete logical drives in a standard
(noncluster) configuration.

Creating logical drives

When you create new logical drives with the storage management software, you
must add the new logical drives to Novell NetWare. Refer to the Novell NetWare
documentation for details about adding a drive. Novell NetWare recognizes each
logical drive (not array) as a single drive.

After creating logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For information
about how to use these utilities, see [‘Using the hot_add utility’| and [‘Using the|
[SMdevices utility.”]

Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click
Configure » Reset Configure. This will reset the controller unit and delete all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configure » Reset Configuration, stop all input and output activity to the affected
storage subsystem. Then dismount any Novell NetWare volumes that are
associated with the logical drives.

Using the hot_add utility

The hot_add utility enables you to add new logical drives without restarting the
system. The utility registers the new logical drives with the operating system so that
you can use nwconfig to create partitions, add device names, and so on. The
hot_add utility is part of the Storage Manager 9.1 Utility package.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem, and perform the following steps to
use the hot_add utility:

1. From the Server Console, type:
InstalationFolder(ie. SYS:\StorageManger)\Util\hot add
2. Press Enter.
The new logical drives are available through the NetWare Disk Manager.

Using the SMdevices utility

The Storage Manager 9.1 Utility software package includes a utility called
SMdevices that you can use to view the storage subsystem logical drive that is
associated with a particular operating-system device name. This utility is helpful
when you want to create drives, volumes, or a combination of both for the logical
drive using the nwconfig program.
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When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:

1. From the Server Console type:
InstalationFolder(ie. SYS:\StorageManger)\Util\SMdevices
2. Press Enter.

The software displays device identification information. For example, you might
see the following:

Note: Note: IN NW6.5, the following information is displayed in the Logger
window instead of on the same NetWare Console window screen.

V596-A3-DO:0[Storage Subsystem MARKETING, Logical Drive DEBIT,
LUN 0, WWN <600a0b800007545c0000008d3a308b6e>]

V596-A3-DO:1 [Storage Subsystem MARKETING, Logical Drive DEBIT, LUN 1,
WWN <600a0b80000756ec000000a93a307d2a>]

V596-A3-D0:1F [Storage Subsystem MARKETING, Logical Drive Access volume,
LUN 31, WWN <600a0b800007545c0000009000000000>]

Where V596-A3-D0:0;

The numbers at the beginning of each line constitute the device name. The
device name identifies the adapter or device as follows:

Vendor number [V596]. A unique number specific to the device vendor.

Adapter number [A3]. The instance number of an adapter registered with
NWPA. In the example, A3 identifies the first instance of an adapter installed in
the server.

Device number [DO]. The number of the disk or other device.

Logical unit number [0,1,1F]. The LUN identifies individual devices when more
than one device is attached to one bus.

Storage Subsystem [x]. The storage subsystem name.

Logical Drive [x]. The logical drive name.

LUN [x]. The logical unit number associated with the logical drive.
WWN [x]. The worldwide name for the logical drive.

Stopping and starting the host-agent software
Use the procedures in the following sections to stop and start the host-agent
software installed on the host or cluster node.
Notes:

1. The smagent.nIm module will remain loaded after the agent java service ends
until you reboot the server.

2. If an access logical drive is not detected after a restart, the host-agent software
will automatically stop running. Restart the host or cluster node so that new
host-agent-managed storage subsystems will be discovered.

3. SMagent requires that JAVA version 1.4.2 or later be installed. Unpredictable
behavior may result if versions earlier than version 1.4.2 version are installed.
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Stopping the host-agent software

You must stop the host-agent software if you want to add storage subsystems.
When you restart the service, the host-agent software discovers the new storage
subsystems and adds them to the management domain.

Perform the following steps to stop the host-agent software:

1.
2.

4.

From the system console, press Ctrl+Esc, and then select System Console.
At the prompt, type:

java -show

Look for the following line:
"devmgr.versioned.agent.AgentServer............. QQQ"

where QQQ is the process ID.

At the prompt type the following:

java -ki11QQQ

where QQQ is the process ID from the java -show command.

Press Enter.

Starting the host agent manually
To add storage subsystems, start the host-agent software manually either when you
start the system or if it is already stopped.

Perform the following steps to start the host agent manually:

1.
2.

From the system console, press Ctrl+Esc, and then select System Console.
At the prompt, type:

smagent

Press Enter.

The agent will start and display the following message when UTM LUNS are
scanned:

Activating

Return to ConsoleOne. Press Ctrl+Esc, and then click Xserver » Graphical
Console.

Uninstalling Storage Management 9.1 software components

Use the following procedure to uninstall one or more of the components of Storage
Manager 9.1.

1.

From the Xserver Graphical Console, type the following command and press
Enter.

sys:\storage manager\suiteuninstall.ncf
The Uninstall window opens.

Select Next.

The Uninstall Options window opens.
Select the Complete Uninstall option.
Select Next.

When the software removal completes, the Uninstall Complete window opens.
Select Done.

The Restart the GUI dialog opens.

Select OK.

From the Novell Menu select Close GUI...
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The Close GUI dialog opens.
8. Select Yes.

9. To restart the GUI, from the System Console, type the following command, and
press Enter.

startx

10. Using the NetWare File Browser, select and delete the install.ncf file and
InstData directory in the SYS:\ volume. This file and the directory are in the
root of the SYS:\ volume, unless the user choose to place it elsewhere.

Note: Do not perform this step if you already deleted the files required for
installation when you installed the IBM FAStT Storage Manager host
software for NetWare.

11. Are you installing a new version of the software?

Yes. See|Chapter 5, “Installing Storage Manager software in a standard|
[NetWare configuration,” on page 81.]

No. You have completed this procedure.
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Appendix A. Windows operating system limitations

This appendix contains information about how to operate the storage management
software in a Windows 2000, or Windows Server 2003 environment.

Important: Always check for a readme file on any installation media. This readme
file might contain important information that was not available when this document

was prepared.

Limitations of Windows operating systems

explains limitations that apply when you use the IBM FAStT Storage
Manager Version 9.1 with Windows 2000 and Windows Server 2003.

Table 23. Windows operating system limitations and workarounds

Limitation

Workaround

If you click a vertical scroll arrow either up
or down, the scroll box will move all the
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime
Environment. Click the scroll box and slide it until
you reach the position that you want in the Help
window.

Data or configuration loss might occur
during a logical drive migration. Logical
drive migration consists of removing
configured physical drives from one
storage subsystem and inserting them
into another storage subsystem.

Contact an IBM technical support representative
for assistance in performing this procedure.

Array migration is not supported because
it could cause loss of configuration and
data. Array migration consists of removing
a set of drives configured with arrays from
one storage subsystem and inserting
them into another storage subsystem.

Contact an IBM technical support representative.

If you manage storage subsystems
through the host-agent software and use
the storage management software to
download controller firmware, the
download process can take up to 10
minutes to complete.

None.

When you configure a new storage
subsystem with a single controller, you
must place the controller in slot A. The
controller firmware cannot recognize or
communicate with a single controller until
slot A is populated. This restriction does
not apply to storage subsystems that
were originally configured with two
controllers.

None.

The following loop configuration is not
supported: IBM Fibre Channel Hub
(machine type 3523) in conjunction with
the IBM Fibre Channel Switch (machine
types 2109 S16 and 2109 S08) or the
IBM Fibre Channel Switch (machine types
3534 F08 and 2109 F16).

None.
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Table 23. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

A controller failover occurs in an
active/active controller pair, and
ownership of arrays transfers from the
failed preferred owner to the other
controller of the repair. The failed
controller is replaced and brought online.
The array ownership is not automatically
transferred back to the preferred controller
owner.

Immediately after you replace the controller, click
Storage subsystem » Redistribute Arrays in
the Subsystem Management window to
redistribute arrays back to their preferred
controller owners. For more information, refer to
the Enterprise Management online help.

After adding a host device to the
management domain of more than five
clients, the host-agent-managed storage
subsystems attached to that host become
unresponsive.

Make sure that a single instance of the
host-agent software communicates with no more
than five clients.

When you connect a FASTT EXP700
Storage Expansion Unit to a FAStT200,
you must set the drive speed to 1 Gbps.

None.
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Table 23. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

After you install the host-agent software,
the host displays the error message
Service Error 100.

The cause includes:

» The host-agent software does not find any
controllers with firmware version 04.00.02.00
or higher. Upgrade the firmware to the latest
firmware level from the IBM support Web site
at:

www.ibm.com/support/|

For more information, see [‘Direct-management|
[method workaround” on page 128

» The access logical drive has been removed
from NVSRAM or the storage partition defined
for the host. Perform one of the following
tasks:

— Manage the storage subsystem by using
the direct-management method. See
“Direct-management method workaround’]

on page 128.|

— Define the access logical drive for the host
and restart SMagent. Sed“SMagenﬂ
workaround for defining additional access]
LUN mapping” on page 128

* The NVSRAM on the controllers in a storage
subsystem that you want to manage contains
an access logical drive LUN that is in use by
another logical drive, or is not supported by
the operating system or installed patches. For
example, the access logical drive is configured
at LUN 31, and the operating system and
service packs support only eight LUNSs.
Perform one of the following tasks:

— Manage the storage subsystem by using
the direct-management method. See
“Direct-management method workaround’|

on page 128.|

— Change the LUN mapping for the
host-access logical drive to a LUN that is
not in use and is supported by the
operating system either from a different
computer that has management access to
the storage subsystem, or establish a direct
management connection to the storage
subsystem from the current host. For more
information, see [‘SMagent workaround for|
changing existing access LUN mapping” on|

page 129.|

Auto LUN/Array Transfer is not enabled. If
a controller fails over arrays to the
alternate controller and the failed
controller is replaced and brought back
online, the arrays will not automatically
transfer to the preferred controller.

Manually select the Redistribute Logical Drives
menu option in the IBM FASIT Storage Manager
client GUI.

A brownish hash pattern displays in the
dialog windows and in online help when
operating in 256-color mode.

Run the FAStT Storage Manager 9.1 application
in a higher display mode.

Appendix A. Windows operating system limitations 125


http://www.ibm.com/support

Table 23. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

The system might display the FAStT
Storage Manager dialog windows as
cropped without the vertical and horizontal
scroll bars.

Move the mouse pointer over the edge of the
window until the mouse pointer changes to a
window resize pointer. Left-click your mouse;
hold to grip the window’s edge and resize the
window.

The controller in the IBM FAStT Storage
Server with firmware 05.3x.xx.xx is
connected to a SAN with more than 64
host connections per controller port that
can log into the controllers, exceeding the
maximum number of host connections
that can be seen and log into the
controller.

Either use the switch zoning function or

rearrange the SAN connections so that only the

following maximum number of host connections

can be seen and log into the controller as

follows:

* The following FAStT storage subsystems have
two ports per controller — one per minihub slot.

— FAStT900, Machine Type 1742
— FAStT700, Machine Type 1742
— FAStT500, Machine Type 3552

» The FAStT600 (IBM machine type 1722) has
two ports per controller.

* The FAStT200 (IBM machine type 3542) has
only one port per controller.

It is possible to circumvent IBM FAStT
Storage Server hardware and software
designs for redundant pathways from the
host system. This is accomplished by
connecting a single host adapter from the
host system to one of the controller
minihubs, and then connecting this
minihub to the minihub of the other
controller, creating a Fibre
Channel-Arbitrated Loop (FC-AL) between
the host adapter and the two IBM FAStT
Storage Server controllers. This
configuration leaves no redundant path to
the host system.

When connecting two minihubs together, always
connect the IN port of one minihub to the OUT
port of the other minihub or vice versa. Do not
connect the IN port of one to the IN port of the
other minihub or the OUT port of one minihub to
the OUT port of the other minihub.

Nevertheless, this configuration is not supported
by IBM.

When you issue a Subsystem
Management command from the IBM
FAStT Storage Manager client, the
command may be cached. If so, the
system will issue the error: Error 21 -
The Operation cannot complete because
a... is in progress. The IBM FAStT
Storage Manager client will run such
cached commands as soon as the
controller resources become available.

Wait for at least ten minutes; then, check to see
if the IBM FASIT Storage Manager client has run
the command. If it has not, reissue the
command.

You must always uninstall IBM FAStT
Storage Manager RDAC before you
uninstall the host bus adapter driver.
Failure to do so may result in a hung
system or blue screen.

None.
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Table 23. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

When you upgrade the FASIT Storage
Subsystem controller firmware from any
version 05.00.xx.xx (or earlier) to version
05.2x.xx.xx (or later), the controller
returns the first four bytes of the firmware
revision to the Product Revision Field of
the SCSI LUN inquiry data. Windows
2000 uses this Product Revision data as
part of its LUN identification method. In
doing so, Windows 2000 incorrectly
interprets your upgrade of the firmware
revision level and subsequent Product
Revision data change to mean that you
have also removed LUNs with the original
Product Revision data from the server.

When the FAStT Storage Manager
hot_add utility later executes the scan for
hardware changes task, or when you
select the Scan For Hardware Changes
menu option of the Devices folder in the
Computer Management window, Windows
2000 displays the Unsafe Removal of
Devices dialogs for the original LUNs. The
devices cited in these dialogs are RDAC
Virtual Disks and xxxx SCSI devices,
where xxxx represents either 1722, 1742,
3552 or 3542, depending on the machine
type of the FASIT Storage Server from
which Windows 2000 had mapped the
original LUNs. Under these
circumstances, the Windows 2000 server
will lose connectivity to the LUNSs in the
FAStT Storage Subsystem whose
controller firmware you updated.

This problem will not occur when you
upgrade the FASIT Storage Subsystem
controller firmware from version
05.20.xx.xx to version 05.3x.xx.xx or later
because the Product Revision data field
was fixed at 0520.

After you apply the new FASIT Storage
Subsystem controller firmware and NVSRAM,
you must perform one of the following
procedures reconnect FAStT Storage Servers to
their logical drives:

* Re-scan the server for hardware changes.
» Add the logical drives back to the server.

* Reboot all of the Windows 2000 servers that
originally had LUNs mapped in the affected
FASLtT Storage Subsystem.
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Table 23. Windows operating system limitations and workarounds (continued)

Limitation Workaround

After using the Microsoft Cluster Complete the following procedure to change the
Administrator to configure a server cluster, | disk timeout value to the correct value after the
the disk timeout value in the system server cluster configuration is complete.

registry is changed to an incorrect value. |1 gelect Start + Run.

2. Type the following command and press
Enter:
regedit
The Registry Editor is displayed.

3. From the left pane of the Registry Editor,
navigate to the directory:

HKEY_LOCAL_MACHINE\System\
CurrentControlSet\Services\Disk

4. From the right pane of the Registry Editor,
double-click TimeOutValue.

The Edit DWORD Value dialog is displayed.

5. In the Value Data text area, type decimal 60
(or the value to which your system was
previously set), and press Enter.

6. Under Base, select Hexadecimal.
7. Select OK.

Direct-management method workaround
Perform the following steps for the direct-management method workaround:
1. Connect the two controller Ethernet ports to the network.

2. Follow the direct-management setup instructions in|Chapter 2, “Preparing for|
|insta||ation,” on page 33| to manage the subsystem directly.

3. Open the Storage Manager 9.1 Enterprise Management window. Click Edit »
Add device.

Type the IP address for the first controller and click Add.
Repeat to add the IP address of the additional controllers.
Click Close.

Right-click the newly added storage subsystem and select Manage Device. The
Subsystem Management window for the storage subsystem opens. Proceed
with the storage subsystem management tasks.

N oo~

SMagent workaround for defining additional access LUN mapping
Perform the following steps to define additional access LUN mapping for SMagent:

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 9.1 Client and open the Subsystem
Management window for the storage subsystem.

Click the Mappings View tab.

Right-click the Default Group and select Define Additional mappings.
Select Access.

From the LUN drop-down menu, select Logical Unit Number (LUN) 31.

ook~ w

128 1BM TotalStorage FASIT Storage Manager Version 9 Installation and Support Guide for Intel-based Operating System

Environments



7. Click Add to define the access LUN.
8. Click Close. In the Define Mapping pane, a LUN with the Access name
displays.

9. Close the window and restart the host. When the host restarts, the SMagent
service starts.

SMagent workaround for changing existing access LUN mapping
Perform the following steps to change existing access LUN mapping:

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 9.1 Client and open the Subsystem
Management window for the storage subsystem.

3. Click the Mappings View tab.

4. From the topology pane, select the Default Group or the corresponding host
partition.

5. Right-click Access and select Change Mapping. A Change Mapping window
opens.

6. From the LUN drop-down menu, select the LUN that your operating system
supports. If it is not available, you must remove one of the existing storage
partitioning mappings.

7. Click OK.

8. Close the window and restart the host. When the host restarts, the SMagent
service starts.

Appendix A. Windows operating system limitations 129



130 1BM TotalStorage FASIT Storage Manager Version 9 Installation and Support Guide for Intel-based Operating System

Environments



Appendix B. NetWare operating system limitations

This appendix contains information about how to operate the storage management

software in a NetWare environment.

Important: Always check for a readme file on any installation media. This readme
file might contain important information that was not available when this document

was prepared.

lists the limitations that apply when you use the IBM FAStT Storage

Manager Version 9.1 with Novell NetWare.

Table 24. Novell NetWare limitations and workarounds

Limitation

Workaround

If the SMagent is running on the NetWare
server and a fiber-optic cable is pulled or a
path failure occurs, the NetWare server might
end.

Stop the SMagent and manage the FAStT
using the direct (out-of-band) method of
management. See [‘Stopping the host-agent]
|software” on page 121[and use the procedure
for uninstalling the SMagent software.

Clicking a vertical scroll arrow (either up or
down) causes the scroll box to move all the
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime
Environment. Click the scroll box and slide it
until you reach the desired position in the
Help window.

Logical drive migration (removing a set of
drives that are configured with logical drives
from one storage subsystem for insertion into
another storage subsystem) is not supported
because it could cause loss of configuration.

Call for service.

When you manage storage subsystems
through the host-agent software and use the
storage management software to download
controller firmware, the download process
can take up to 10 minutes to complete.

None.

The controller firmware does not recognize or
communicate with a single controller until slot
A is populated. This limitation does not apply
to storage subsystems that were originally
configured with two controllers.

When you configure a new storage
subsystem with a single controller, you must
place the controller in slot A.

Public loop configurations (managed hubs
that are attached to switches) are not
supported.

None.

Multipath failover will work only if the storage
controllers are in active/active mode.

When you configure the storage subsystem,
change both controllers to active status.

When you remove a fan or power supply field
replaceable unit (FRU) from a storage
subsystem while the system is running, the
storage management software does not
report an error message, and the component
is not reported as missing.

Note: Fan and power supply FRU failures
are reported.

Replace the missing fan or power supply
FRUs immediately to ensure redundancy.
Make sure that the fan or power supply FRU
is properly seated in the controller unit.

Your windows and online Help displays a
brownish hash pattern when you run in
256-color mode.

Run the Storage Manager 8.4 application in a
higher display mode.
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Table 24. Novell NetWare limitations and workarounds (continued)

Limitation

Workaround

When performing a redundancy check (parity
scan) from the storage management
application, machine type 3542 can take
several minutes longer than machine type
3526 and 3552 controller platforms.

None.

When attempting to manage a storage
subsystem where the RAID controller unit
does not have access to logical drives,
Storage Manager prompts you for a
password. This occurs even if no password
has been set up. The automatic discovery
locates and identifies each storage
subsystem as two separate storage
subsystems.

Ensure that at least one IBM FAStT EXP700
Storage Expansion Unit with at least one
logical drive is properly attached to the IBM
FAStT700 RAID controller unit in each
storage subsystem being managed. The
RAID controller unit should not be powered
on until the expansion units are attached and
powered on. Power off the RAID controller
unit, properly attach all expansion units with
the drives installed to the RAID controller
unit, and power them on; then, power on the
RAID controller unit. At this point, the storage
subsystems can be rediscovered and
managed by using the FASIT Storage
Manager software.

You might not see the maximum number of
drives during Automatic Configuration if you
are using drives of different capacities.

Use Manual Configuration to select individual
drives and select the maximum number of
drives allowed.

When you connect an IBM TotalStorage
FAStT EXP700 Storage Expansion Unit to a
FAStT200, the drive speed must be set to 1
Gbps.

None.

When you issue a Subsystem Management
command from the IBM FAStT Storage
Manager client, the command may be
cached. If so, the system issues the error:
Error 21 - The Operation cannot complete
because a... is in progress. The IBM
FASIT Storage Manager client will run such
cached commands as soon as the controller
resources become available.

Wait for at least ten minutes; then, check to
see if the IBM FAStT Storage Manager client
has run the command. If it has not, reissue
the command.
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Appendix C. Linux operating system limitations

This appendix contains information that is specific to operating the storage
management software in a Linux environment.

Important: Always check for a readme file on any installation media. This readme
file contains information that was not available when this document was prepared.

lists the limitations that apply when you use the IBM FAStT Storage

Manager Version 9.1 with Linux.

Table 25. Linux limitations and workarounds

Limitations

Workaround

Vixel Rapport 2000 fibre-channel hubs using
controllers with firmware version 04.01.02
cause problems, including damage to data,
system instability, and disrupted loop activity.

Do not use Vixel Rapport 2000 fibre-channel
hubs when your system is operating in a
controller or an 1/O path fault-tolerant
environment.

The maximum number of physical drives
allowed in a single RAID 5 logical drive is 29.
The maximum number of physical drives
allowed in a single RAID 1 logical drive is 28.

None.

After removing all drives from a storage
subsystem, you are prompted for a password
at software startup or when you perform
protected operations, all passwords you enter
fail.

Add one of the drives to the storage
subsystem and attempt the operation again.

Removing a set of drives that are configured
with logical drives from one storage
subsystem for insertion into another storage
subsystem is not supported because it might
cause loss of configuration.

Contact an IBM technical support
representative for assistance.

A standard non-network configuration is not
supported when the Linux host does not have
the TCP/IP software installed.

Install the TCP/IP software on the Linux host
computer and assign the host a static IP
address.

Multipath failover will work only if the storage
controllers are in active/active mode.

When you configure the storage subsystem,
change both controllers to active status.

The controller firmware does not recognize or
communicate with a single controller until slot
A is populated. This restriction does not apply
to storage subsystems that were originally
configured with two controllers.

When you configure a new storage
subsystem with a single controller, you must
place the controller in slot A.

Your windows and online help display a
brownish hash pattern when you run in
256-color mode.

Run the Storage Manager 9.1 application in a
higher display mode.

When you perform a redundancy check
(parity scan) from the storage management
application, machine type 3542 can take
several minutes longer than machine type
1742 and 3552 controller platforms.

None.

You might not see the maximum number of
drives during Automatic Configuration if you
are using drives of different capacities.

Use Manual Configuration to select individual
drives and select the maximum number of
drives allowed.
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Table 25. Linux limitations and workarounds (continued)

Limitations

Workaround

When you connect an IBM TotalStorage
FASIT EXP700 Storage Expansion Unit to a
FAStT200, the drive speed must be set to 1
Gbps.

None.

When you issue a Subsystem Management
command from the IBM FAStT Storage
Manager client, the command may be

cached. If so, the system will issue the error:

Error 21 - The Operation cannot complete
because a... is in progress. The IBM
FASIT Storage Manager client will run such
cached commands as soon as the controller
resources become available.

Wait for at least ten minutes; then, check to
see if the IBM FAStT Storage Manager client
has run the command. If it has not, re-issue
the command.
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Appendix D. VMware ESX Server operating system limitations

This appendix contains information about how to operate the storage management
software in a VMware ESX Server environment.

Important: Always check for a readme file on any installation media. This readme
file might contain important information that was not available when this document

was prepared.

lists the limitations that apply when you use IBM FASLtT Storage Manager

Version 9.1 with VMware ESX Server.

Table 26. VMware ESX Server limitations and workarounds

Limitations

Workaround

VMware ESX 2.0 clustering function is not
supported. Clustering between guest
operating systems is not supported.

None.

For information about possible support in
future releases, contact your IBM service
representative or submit an RPQ.

The maximum number of guest operating
systems that are supported on each VMware
ESX 2.0 server is 16.

None.

For information about possible support in
future releases, contact your IBM service
representative or submit an RPQ.

New logical volumes cannot be successfully
created and assigned to a guest operating
system.

Although a guest operating system can scan
for new disk volumes dynamically, the guest
operating system must be powered off before
new logical volumes can be created within
VMware ESX Server and assigned to that
guest.

When you issue a Subsystem Management
command from the IBM FAStT Storage
Manager client, the command may be
cached. If so, the system will issue the error:
Error 21 - The Operation cannot complete
because a... is in progress. The IBM
FASIT Storage Manager client will run such
cached commands as soon as the controller
resources become available.

Wait for at least ten minutes; then, check to
see if the IBM FAStT Storage Manager client
has run the command. If it has not, reissue
the command.
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Appendix E. Storage subsystem and controller information

record

provides a data sheet for recording storage subsystem names,
management types, Ethernet hardware addresses, and IP addresses. Make a copy
of this table and complete the information for your storage subsystems and
controllers. Use the information to set up the BOOTP table for the network server
and the host or Domain Name System (DNS) table. The information is also helpful
if you add storage subsystems after initial installation. The column headings show a
page reference for detailed instructions about how to obtain the information. For a
sample information record, refer to[Table 16 on page 37,

Table 27. Storage subsystem and controller information record

Storage
subsystem
name (page

Management
method (page

Controllers-Ethernet and IP
addresses, and host name (pages

6] and B9)

Host-IP address
and host name

(page B9)
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Appendix F. Additional FASIT documentation

The following tables present an overview of the FAStT900, FAStT700, and
FAStT600 Fibre Channel Storage Server product libraries, as well as other related
documents. Each table lists documents that are included in the libraries and what
common tasks they address. Click on active links in the tables to access those
documents currently available on the Internet. You can access documentation for
the other FASIT products at the following Web site:

issddom02.storage.ibm.com/techsup/webnav.nsf/support/fastt/|

FAStT900 Fibre Channel Storage Server library

associates each document in the FAStT900 Fibre Channel Storage Server
library with its related common user tasks.

Table 28. TotalStorage FAStT900 Fibre Channel Storage Server document titles by user tasks

Title User Tasks

FAStTI90
Installation and| I I e
Support Guide,

GC26-7530]

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

IBM Tota/Storaga

FAStT900 Storage
Server User’s|
Guide, GC26-7534

IBM TotalStoraga

FAStT FC2-133 Dual
Port Host Bug
Adapter Installatior]
and User’s Guide,

GC26-7532f

IBM FASIT FC2-134
Host Bus Adaptel|

Installation an V I
User’s Guide,
48P9823
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http://ssddom02.storage.ibm.com/techsup/webnav.nsf/support/fastt
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/19k0900.pdf

Table 28. TotalStorage FAStT900 Fibre Channel Storage Server document titles by user tasks (continued)

Title User Tasks

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

IBM Fibre Channel
Planning anad|

Integration: User’
Guide and Service|

Information,
SC23-432

IBM FASHT]
Management Suit

Java User’s Guide,
32P0081

IBM TotalStora
FAStT Fibr
Channel Hardwarg o

Maintenanced
Manual,GC26-7640|

IBM TotalStoraaa
FASLT Fibr

Channel Problerm| -
Determination|

Guide, GC26-7642|
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http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf

FAStT700 Fibre Channel Storage Server library

associates each document in the FAStT700 Fibre Channel Storage Server
library with its related common user tasks.

Table 29. TotalStorage FAStT700 Fibre Channel Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM TotalStorage
FAStT700
Installation, User’s
and Maintenence
Guide, GC26-7647

IBM FAStT700 Fibre
Channel Cablin
Instructions,
32P0343

IBM FASIT FC2-139
Dual Port Host Bus|
Adapter Installatior]
and User’s Guide,

GC26-7532f

IBM TotalStoraga

FAStT FC2-133 Hosl{

IBM FAStil

Management Suit
Java User’s Guide,

32P0081|

IBM TotalStoraég
FASLT Fibr
Channel Hardware|
Maintenance

Manual,GC26-7640)|

IBM TotalStorag
FAStT Fibré
Channel Problem|
Determination|

Guide, GC26-7642|
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ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf

FAStT600 Fibre Channel Storage Server library

associates each document in the FAStT600 Fibre Channel Storage Server
library with its related common user tasks.

Table 30. TotalStorage FAStT600 Fibre Channel Storage Server document titles by user tasks
Title User Tasks

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

IBM TotalStorag
FAStT600 Fibr
Channel Storag
Server Installation
and User’s Guide,)

C26-7531|

G

IBM TotalStora
FAStT Fibr
Channel Hardwarg o

Maintenanced
Manual,GC26-7640|

I1BM TotalStoraaa
FASLT Fibr

Channel Problerm| -
Determination|

Guide, GC26-7642|

IBM TotalStoraga

FAStT FC2-133 Dual
Port Host Bug
|Adapter Installatior]
and User’s Guide,|

GC26-7532f
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ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600rack.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600rack.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600rack.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600rack.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600rack.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600cabling.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600cabling.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600cabling.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600cabling.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/600cabling.pdf

FAStT100 Fibre Channel Storage Server library

able 31| associates each document in the FAStT100 Fibre Channel Storage Server
library with its related common user tasks.

Table 31. TotalStorage FAStT100 Fibre Channel Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM TotalStorag
FAStT10
Installation, User’s|

and Maintenance
Guide, GC26-7641]

IBM TotalStoragé
FAStT Fibr
Channel Hardware|
Maintenanced

Manual,GC26-7640|

IBM TotalStoraéa
FASLT Fibr
Channel Problem|
Determination|

Guide, GC26-7642|

IBM Tota/Storaga

FAStT100 Cablin
Guide, 24P897
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ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/fas1uig0.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/fas1uig0.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/fas1uig0.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/fas1uig0.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/fas1uig0.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/GC26-7640-01.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/pdg00mst.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/100cable.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/100cable.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/100cable.pdf

FAStT-related documents

associates each of the following documents related to FAStT operations
with its related common user tasks.

Table 32. TotalStorage FAStT related document titles by user tasks

Title User Tasks

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

IBM Safety
Information, I
P48P9741

IBM TotalStoraqa
FASIT Quick Start] P P
Guide,, GC26-7662|

I1BM TotalStoralcE
FASIT EXP10

Storage Expansion| v v
Unit Release Notes,)

GC26-7619

IBM TotalStora
FAStT EXP10:
Storage Expansior]
Unit Installation and|
Users Guide,
GC26—7601

Fibre Channe
Solutions - IB
FASIT EXP500)
Installation and

User’s Guide,
59p5637
IBM TotalStoraga

FAStT Hard Drive

Migration Guide,
GC26-766

IBM Netfinity” Fibre]
Channel Cablin
Instructions,
19K0906

IBM Fibre Channel
SAN Configuration|

Setup Guide,
25P2509
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ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7662-00.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7662-00.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/gc26-7662-00.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp102rn.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp102rn.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp102rn.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp102rn.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp102rn.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp12mst_v2.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp12mst_v2.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp12mst_v2.pdf
ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers_pdf/exp12mst_v2.pdf
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Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Other company, product, or service names may be the trademarks or service marks
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Important notes

Processor speeds indicate the internal clock speed of the microprocessor; other
factors also affect application performance.

CD-ROM drive speeds list the variable read rate. Actual speeds vary and are often
less than the maximum possible.

When referring to processor storage, real and virtual storage, or channel volume,
KB stands for approximately 1000 bytes, MB stands for approximately 1 000 000
bytes, and GB stands for approximately 1 000 000 000 bytes.

When referring to hard disk drive capacity or communications volume, MB stands
for 1 000 000 bytes, and GB stands for 1 000 000 000 bytes. Total user-accessible
capacity may vary depending on operating environments.

Maximum internal hard disk drive capacities assume the replacement of any
standard hard disk drives and population of all hard disk drive bays with the largest
currently supported drives available from IBM.

Maximum memory may require replacement of the standard memory with an
optional memory module.

IBM makes no representation or warranties regarding non-IBM products and
services that are ServerProven®, including but not limited to the implied warranties
of merchantability and fitness for a particular purpose. These products are offered
and warranted solely by third parties.

IBM makes no representations or warranties with respect to non-IBM products.
Support (if any) for the non-IBM products is provided by the third party, not IBM.

Some software may differ from its retail version (if available), and may not include
user manuals or all program functionality.
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Glossary

This glossary provides definitions for the
terminology and abbreviations used in IBM
TotalStorage FASIT publications.

If you do not find the term you are looking for, see
the IBM Glossary of Computing Terms located at
the following Web site:

www.ibm.com/ibm/terminology|

This glossary also includes terms and definitions
from:

» Information Technology Viocabulary by
Subcommittee 1, Joint Technical Committee 1,
of the International Organization for
Standardization and the International
Electrotechnical Commission (ISO/IEC
JTC1/SC1). Definitions are identified by the
symbol (l) after the definition; definitions taken
from draft international standards, committee
drafts, and working papers by ISO/IEC
JTC1/SC1 are identified by the symbol (T) after
the definition, indicating that final agreement
has not yet been reached among the
participating National Bodies of SC1.

* IBM Glossary of Computing Terms. New York:
McGraw-Hill, 1994.

The following cross-reference conventions are
used in this glossary:

See  Refers you to (a) a term that is the
expanded form of an abbreviation or
acronym, or (b) a synonym or more
preferred term.

See also
Refers you to a related term.

Abstract Windowing Toolkit (AWT). A Java graphical
user interface (GUI).

accelerated graphics port (AGP). A bus specification
that gives low-cost 3D graphics cards faster access to
main memory on personal computers than the usual
peripheral component interconnect (PCI) bus. AGP
reduces the overall cost of creating high-end graphics
subsystems by using existing system memory.

access volume. A special logical drive that allows the
host-agent to communicate with the controllers in the
storage subsystem.

adapter. A printed circuit assembly that transmits user
data input/output (I/O) between the internal bus of the

© Copyright IBM Corp. 2004

host system and the external fibre-channel (FC) link and
vice versa. Also called an I/O adapter, host adapter, or
FC adapter.

advanced technology (AT) bus architecture. A bus
standard for IBM compatibles. It extends the XT bus
architecture to 16 bits and also allows for bus
mastering, although only the first 16 MB of main
memory are available for direct access.

agent. A server program that receives virtual
connections from the network manager (the client
program) in a Simple Network Management
Protocol-Transmission Control Protocol/Internet Protocol
(SNMP-TCP/IP) network-managing environment.

AGP. See accelerated graphics port.
AL_PA. See arbitrated loop physical address.

arbitrated loop. One of three existing fibre-channel
topologies, in which 2 - 126 ports are interconnected
serially in a single loop circuit. Access to the Fibre
Channel-Arbitrated Loop (FC-AL) is controlled by an
arbitration scheme. The FC-AL topology supports all
classes of service and guarantees in-order delivery of
FC frames when the originator and responder are on
the same FC-AL. The default topology for the disk array
is arbitrated loop. An arbitrated loop is sometimes
referred to as a Stealth Mode.

arbitrated loop physical address (AL_PA). An 8-bit
value that is used to uniquely identify an individual port
within a loop. A loop can have one or more AL_PAs.

array. A set of fibre-channel hard drives that are
logically grouped together to form a redundant array of
independent disks (RAID) set.

asynchronous write mode. In remote mirroring, an
option that allows the primary controller to return a write
1/0 request completion to the host server before data
has been successfully written by the secondary
controller. See also synchronous write mode, remote
mirroring, Global Copy,Global Mirroring.

AT. See advanced technology (AT) bus architecture.
ATA. See AT-attached.

AT-attached. Peripheral devices that are compatible
with the original IBM AT computer standard in which
signals on a 40-pin AT-attached (ATA) ribbon cable
followed the timings and constraints of the Industry
Standard Architecture (ISA) system bus on the IBM PC
AT computer. Equivalent to integrated drive electronics
(IDE).
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auto-volume transfer/auto-disk transfer (AVT/ADT).
A function that provides automatic failover in case of
controller failure on a storage subsystem.

AVT/ADT. See auto-volume transfer/auto-disk transfer.
AWT. See Abstract Windowing Toolkit.

basic input/output system (BIOS). The personal
computer code that controls basic hardware operations,
such as interactions with diskette drives, hard disk
drives, and the keyboard.

BIOS. See basic input/output system.
BOOTP. See bootstrap protocol.

bootstrap protocol (BOOTP). In Transmission Control
Protocol/Internet Protocol (TCP/IP) networking, an
alternative protocol by which a diskless machine can
obtain its Internet Protocol (IP) address and such
configuration information as IP addresses of various
servers from a BOOTP server.

bridge. A storage area network (SAN) device that
provides physical and transport conversion, such as
fibre channel to small computer system interface (SCSI)
bridge.

bridge group. A bridge and the collection of devices
connected to it.

broadcast. The simultaneous transmission of data to
more than one destination.

cathode ray tube (CRT). A display device in which
controlled electron beams are used to display
alphanumeric or graphical data on an
electroluminescent screen.

client. A computer system or process that requests a
service of another computer system or process that is
typically referred to as a server. Multiple clients can
share access to a common server.

command. A statement used to initiate an action or
start a service. A command consists of the command
name abbreviation, and its parameters and flags if
applicable. A command can be issued by typing it on a
command line or selecting it from a menu.

community string. The name of a community
contained in each Simple Network Management
Protocol (SNMP) message.

concurrent download. A method of downloading and
installing firmware that does not require the user to stop
I/O to the controllers during the process.

CRC. See cyclic redundancy check.
CRT. See cathode ray tube.

CRU. See customer replaceable unit.

customer replaceable unit (CRU). An assembly or
part that a customer can replace in its entirety when any
of its components fail. Contrast with field replaceable
unit (FRU).

cyclic redundancy check (CRC). (1) A redundancy
check in which the check key is generated by a cyclic
algorithm. (2) An error detection technique performed at
both the sending and receiving stations.

dac. See disk array controller.
dar. See disk array router.
DASD. See direct access storage device.

default host group. A logical collection of discovered
host ports, defined host computers, and defined host
groups in the storage-partition topology that fulfill the
following requirements:

» Are not involved in specific logical drive-to-LUN
mappings

» Share access to logical drives with default logical
drive-to-LUN mappings

device type. Identifier used to place devices in the
physical map, such as the switch, hub, or storage.

DHCP. See Dynamic Host Configuration Protocol.

direct access storage device (DASD). A device in
which access time is effectively independent of the
location of the data. Information is entered and retrieved
without reference to previously accessed data. (For
example, a disk drive is a DASD, in contrast with a tape
drive, which stores data as a linear sequence.) DASDs
include both fixed and removable storage devices.

direct memory access (DMA). The transfer of data
between memory and an input/output (I/O) device
without processor intervention.

disk array controller (dac). A disk array controller
device that represents the two controllers of an array.
See also disk array router.

disk array router (dar). A disk array router that
represents an entire array, including current and
deferred paths to all logical unit numbers (LUNs) (hdisks
on AlX). See also disk array controller.

DMA. See direct memory access.

domain. The most significant byte in the node port
(N_port) identifier for the fibre-channel (FC) device. It is
not used in the fibre channel-small computer system
interface (FC-SCSI) hardware path ID. It is required to
be the same for all SCSI targets logically connected to
an FC adapter.

DRAM. See dynamic random access memory.
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Dynamic Host Configuration Protocol (DHCP). A
protocol defined by the Internet Engineering Task Force
that is used for dynamically assigning Internet Protocol
(IP) addresses to computers in a network.

dynamic random access memory (DRAM). A
storage in which the cells require repetitive application
of control signals to retain stored data.

ECC. See error correction coding.

EEPROM. See electrically erasable programmable
read-only memory.

EISA. See Extended Industry Standard Architecture.

electrically erasable programmable read-only
memory (EEPROM). A type of memory chip which can
retain its contents without consistent electrical power.
Unlike the PROM which can be programmed only once,
the EEPROM can be erased electrically. Because it can
only be reprogrammed a limited number of times before
it wears out, it is appropriate for storing small amounts
of data that are changed infrequently.

electrostatic discharge (ESD). The flow of current
that results when objects that have a static charge
come into close enough proximity to discharge.

environmental services monitor (ESM) canister. A
component in a drive enclosure that monitors the
environmental condition of the components in that
enclosure. Not all storage subsystems have ESM
canisters.

E_port. See expansion port.

error correction coding (ECC). A method for
encoding data so that transmission errors can be
detected and corrected by examining the data on the
receiving end. Most ECCs are characterized by the
maximum number of errors they can detect and correct.

ESD. See electrostatic discharge.

ESM canister. See environmental services monitor
canister.

EXP. See expansion unit.

expansion port (E_port). A port that connects the
switches for two fabrics.

expansion unit (EXP). A feature that can be
connected to a system unit to provide additional storage
and processing capacity.

Extended Industry Standard Architecture (EISA). A
bus standard for IBM compatibles that extends the
Industry Standard Architecture (ISA) bus architecture to
32 bits and allows more than one central processing
unit (CPU) to share the bus. See also Industry Standard
Architecture.

fabric. A Fibre Channel entity which interconnects and
facilitates logins of N_ports attached to it. The fabric is
responsible for routing frames between source and
destination N_ports using address information in the
frame header. A fabric can be as simple as a
point-to-point channel between two N-ports, or as
complex as a frame-routing switch that provides multiple
and redundant internal pathways within the fabric
between F_ports.

fabric port (F_port). In a fabric, an access point for
connecting a user's N_port. An F_port facilitates N_port
logins to the fabric from nodes connected to the fabric.
An F_port is addressable by the N_port connected to it.
See also fabric.

FAStT MSJ. See FAS!T Management Suite Java.

FAStT Management Suite Java (FASIT MSJ). A
diagnostic and configuration utility that can be used on
Linux, Microsoft Windows, and Novell NetWare host
systems. In Linux, it is also used with the QLRemote
agent to define preferred and non-preferred paths for
logical drives.

FC. See fibre channel.
FC-AL. See arbitrated loop.

feature enable identifier. A unique identifier for the
storage subsystem, which is used in the process of
generating a premium feature key. See also premium
feature key.

fibre channel (FC). A set of standards for a serial
input/output (I/0O) bus capable of transferring data
between two ports at up to 100 Mbps, with standards
proposals to go to higher speeds. FC supports
point-to-point, arbitrated loop, and switched topologies.

Fibre Channel-Arbitrated Loop (FC-AL). See
arbitrated loop.

Fibre Channel Protocol (FCP) for small computer
system interface (SCSI). A high-level fibre-channel
mapping layer (FC-4) that uses lower-level fibre-channel
(FC-PH) services to transmit SCSI commands, data,
and status information between a SCSI initiator and a
SCSI target across the FC link by using FC frame and
sequence formats.

field replaceable unit (FRU). An assembly that is
replaced in its entirety when any one of its components
fails. In some cases, a field replaceable unit might
contain other field replaceable units. Contrast with
customer replaceable unit (CRU).

FlashCopy. A premium feature for FAStT that can
make an instantaneous copy of the data in a volume.

F_port. See fabric port.

FRU. See field replaceable unit.
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GBIC. See gigabit interface converter

gigabit interface converter (GBIC). A transceiver that
performs serial, optical-to-electrical, and
electrical-to-optical signal conversions for high-speed
networking. A GBIC can be hot swapped. See also
small form-factor pluggable.

Global Copy. Refers to a remote logical drive mirror
pair that is set up using asynchronous write mode
without the write consistency group option. This is also
referred to as "Asynchronous Mirroring without
Consistency Group.” Global Copy does not ensure that
write requests to multiple primary logical drives are
carried out in the same order on the secondary logical
drives as they are on the primary logical drives. If it is
critical that writes to the primary logical drives are
carried out in the same order in the appropriate
secondary logical drives, Global Mirroring should be
used instead of Global Copy. See also asynchronous
write mode, Global Mirroring, remote mirroring, Metro
Mirroring.

Global Mirroring. Refers to a remote logical drive
mirror pair that is set up using asynchronous write mode
with the write consistency group option. This is also
referred to as "Asynchronous Mirroring with Consistency
Group.” Global Mirroring ensures that write requests to
multiple primary logical drives are carried out in the
same order on the secondary logical drives as they are
on the primary logical drives, preventing data on the
secondary logical drives from becoming inconsistent
with the data on the primary logical drives. See also
asynchronous write mode, Global Copy, remote
mirroring, Metro Mirroring.

graphical user interface (GUI). A type of computer
interface that presents a visual metaphor of a real-world
scene, often of a desktop, by combining high-resolution
graphics, pointing devices, menu bars and other menus,
overlapping windows, icons, and the object-action
relationship.

GUI. See graphical user interface.
HBA. See host bus adapter.

hdisk. An AIX term representing a logical unit number
(LUN) on an array.

host. A system that is directly attached to the storage
subsystem through a fibre-channel input/output (1/0)
path. This system is used to serve data (typically in the
form of files) from the storage subsystem. A system can
be both a storage management station and a host
simultaneously.

host bus adapter (HBA). An interface between the
fibre-channel network and a workstation or server.

host computer. See host.

host group. An entity in the storage partition topology
that defines a logical collection of host computers that
require shared access to one or more logical drives.

host port. Ports that physically reside on the host
adapters and are automatically discovered by the FAStT
Storage Manager software. To give a host computer
access to a partition, its associated host ports must be
defined.

hot swap. To replace a hardware component without
turning off the system.

hub. In a network, a point at which circuits are either
connected or switched. For example, in a star network,
the hub is the central node; in a star/ring network, it is
the location of wiring concentrators.

IBMSAN driver. The device driver that is used in a
Novell NetWare environment to provide multipath
input/output (1/O) support to the storage controller.

IC. See integrated circuit.
IDE. See integrated drive electronics.

in-band. Transmission of management protocol over
the fibre-channel transport.

Industry Standard Architecture (ISA). Unofficial
name for the bus architecture of the IBM PC/XT
personal computer. This bus design included expansion
slots for plugging in various adapter boards. Early
versions had an 8-bit data path, later expanded to 16
bits. The "Extended Industry Standard Architecture”
(EISA) further expanded the data path to 32 bits. See
also Extended Industry Standard Architecture.

initial program load (IPL). The initialization procedure
that causes an operating system to commence
operation. Also referred to as a system restart, system
startup, and boot.

integrated circuit (IC). A microelectronic
semiconductor device that consists of many
interconnected transistors and other components. ICs
are constructed on a small rectangle cut from a silicon
crystal or other semiconductor material. The small size
of these circuits allows high speed, low power
dissipation, and reduced manufacturing cost compared
with board-level integration. Also known as a chip.

integrated drive electronics (IDE). A disk drive
interface based on the 16-bit IBM personal computer
Industry Standard Architecture (ISA) in which the
controller electronics reside on the drive itself,
eliminating the need for a separate adapter card. Also
known as an Advanced Technology Attachment
Interface (ATA).
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Internet Protocol (IP). A protocol that routes data
through a network or interconnected networks. IP acts
as an intermediary between the higher protocol layers
and the physical network.

Internet Protocol (IP) address. The unique 32-bit
address that specifies the location of each device or
workstation on the Internet. For example, 9.67.97.103 is
an IP address.

interrupt request (IRQ). A type of input found on
many processors that causes the processor to suspend
normal processing temporarily and start running an
interrupt handler routine. Some processors have several
interrupt request inputs that allow different priority
interrupts.

IP. See Internet Protocol.

IPL. See initial program load.

IRQ. See interrupt request.

ISA. See Industry Standard Architecture.

isolated group. A collection of isolated devices not
connected to the storage area network (SAN) but
discovered by the SANavigator tool. The isolated group
displays with a gray background near the bottom of the
Physical and Data Path maps.

Java Runtime Environment (JRE). A subset of the
Java Development Kit (JDK) for end users and
developers who want to redistribute the Java Runtime
Environment (JRE). The JRE consists of the Java virtual
machine, the Java Core Classes, and supporting files.

JRE. See Java Runtime Environment.

label. A discovered or user entered property value that
is displayed underneath each device in the Physical and
Data Path maps.

LAN. See local area network.
LBA. See logical block address.

local area network (LAN). A computer network
located on a user’'s premises within a limited geographic
area.

logical block address (LBA). The address of a logical
block. Logical block addresses are typically used in
hosts’ /0O commands. The SCSI disk command
protocol, for example, uses logical block addresses.

logical partition (LPAR). (1) A subset of a single
system that contains resources (processors, memory,
and input/output devices). A logical partition operates as
an independent system. If hardware requirements are
met, multiple logical partitions can exist within a system.
(2) A fixed-size portion of a logical volume. A logical
partition is the same size as the physical partitions in its
volume group. Unless the logical volume of which it is a

part is mirrored, each logical partition corresponds to,
and its contents are stored on, a single physical
partition. (3) One to three physical partitions (copies).
The number of logical partitions within a logical volume
is variable.

logical unit number (LUN). An identifier used on a
small computer system interface (SCSI) bus to
distinguish among up to eight devices (logical units) with
the same SCSI ID.

loop address. The unique ID of a node in
fibre-channel loop topology sometimes referred to as a
loop ID.

loop group. A collection of storage area network
(SAN) devices that are interconnected serially in a
single loop circuit. Loop groups are discovered by the
SANavigator tool and displayed with a gray background
on the Physical and Data Path maps.

loop port. A node port (N_port) or fabric port (F_port)
that supports arbitrated loop functions associated with
an arbitrated loop topology.

LPAR. See logical partition.
LUN. See logical unit number.
MAC. See medium access control.

management information base (MIB). The
information that is on an agent. It is an abstraction of
configuration and status information.

man pages. In UNIX-based operating systems, online
documentation for operating system commands,
subroutines, system calls, file formats, special files,
stand-alone utilities, and miscellaneous facilities.
Invoked by the man command.

MCA. See micro channel architecture.

media scan. A media scan is a background process
that runs on all logical drives in the storage subsystem
for which it has been enabled, providing error detection
on the drive media. The media scan process scans all
logical drive data to verify that it can be accessed, and
optionally scans the logical drive data also.

medium access control (MAC). In local area
networks (LANSs), the sublayer of the data link control
layer that supports medium-dependent functions and
uses the services of the physical layer to provide
services to the logical link control sublayer. The MAC
sublayer includes the method of determining when a
device has access to the transmission medium.

Metro Mirroring. This term is used to refer to a
remote logical drive mirror pair which is set up with
synchronous write mode. See also remote mirroring,
Global Mirroring.

MIB. See management information base.
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micro channel architecture (MCA). Hardware that is
used for PS/2 Model 50 computers and above to
provide better growth potential and performance
characteristics when compared with the original
personal computer design.

Microsoft Cluster Server (MSCS). MSCS, a feature
of Windows NT Server (Enterprise Edition), supports the
connection of two servers into a cluster for higher
availability and easier manageability. MSCS can
automatically detect and recover from server or
application failures. It can also be used to balance
server workload and provide for planned maintenance.

model. The model identification that is assigned to a
device by its manufacturer.

MSCS. See Microsoft Cluster Server.

network management station (NMS). In the Simple
Network Management Protocol (SNMP), a station that
runs management application programs that monitor
and control network elements.

NMI. See non-maskable interrupt.
NMS. See network management station.

non-maskable interrupt (NMI). A hardware interrupt
that another service request cannot overrule (mask). An
NMI bypasses and takes priority over interrupt requests
generated by software, the keyboard, and other such
devices and is issued to the microprocessor only in
disastrous circumstances, such as severe memory
errors or impending power failures.

node. A physical device that allows for the
transmission of data within a network.

node port (N_port). A fibre-channel defined hardware
entity that performs data communications over the
fibre-channel link. It is identifiable by a unique worldwide
name. It can act as an originator or a responder.

nonvolatile storage (NVS). A storage device whose
contents are not lost when power is cut off.

N_port. See node port.
NVS. See nonvolatile storage.

NVSRAM. Nonvolatile storage random access
memory. See nonvolatile storage.

Object Data Manager (ODM). An AIX proprietary
storage mechanism for ASCII stanza files that are
edited as part of configuring a drive into the kernel.

ODM. See Object Data Manager.

out-of-band. Transmission of management protocols
outside of the fibre-channel network, typically over
Ethernet.

partitioning. See storage partition.

PCI local bus. See peripheral component interconnect
local bus.

PDF. See portable document format.

performance events. Events related to thresholds set
on storage area network (SAN) performance.

peripheral component interconnect local bus (PCI
local bus). A local bus for PCs, from Intel, that
provides a high-speed data path between the CPU and
up to 10 peripherals (video, disk, network, and so on).
The PCI bus coexists in the PC with the Industry
Standard Architecture (ISA) or Extended Industry
Standard Architecture (EISA) bus. ISA and EISA boards
plug into an IA or EISA slot, while high-speed PCI
controllers plug into a PCI slot. See also Industry
Standard Architecture, Extended Industry Standard
Architecture.

polling delay. The time in seconds between
successive discovery processes during which discovery
is inactive.

port. A part of the system unit or remote controller to
which cables for external devices (such as display
stations, terminals, printers, switches, or external
storage units) are attached. The port is an access point
for data entry or exit. A device can contain one or more
ports.

portable document format (PDF). A standard
specified by Adobe Systems, Incorporated, for the
electronic distribution of documents. PDF files are
compact; can be distributed globally by e-mail, the Web,
intranets, or CD-ROM; and can be viewed with the
Acrobat Reader, which is software from Adobe Systems
that can be downloaded at no cost from the Adobe
Systems home page.

premium feature key. A file that the storage
subsystem controller uses to enable an authorized
premium feature. The file contains the feature enable
identifier of the storage subsystem for which the
premium feature is authorized, and data about the
premium feature. See also feature enable identifier.

private loop. A freestanding arbitrated loop with no
fabric attachment. See also arbitrated loop.

program temporary fix (PTF). A temporary solution or
bypass of a problem diagnosed by IBM in a current
unaltered release of the program.

PTF. See program temporary fix.
RAID. See redundant array of independent disks.

RAM. See random-access memory.
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random-access memory (RAM). A temporary storage
location in which the central processing unit (CPU)
stores and executes its processes. Contrast with DASD.

RDAC. See redundant disk array controller.

read-only memory (ROM). Memory in which stored
data cannot be changed by the user except under
special conditions.

recoverable virtual shared disk (RVSD). A virtual
shared disk on a server node configured to provide
continuous access to data and file systems in a cluster.

redundant array of independent disks (RAID). A
collection of disk drives that appears as a single volume
to the server and are fault tolerant through mirroring or
parity checking.

redundant disk array controller (RDAC). (1) In
hardware, a redundant set of controllers (either
active/passive or active/active). (2) In software, a layer
that manages the input/output (I/O) through the active
controller during normal operation and transparently
reroutes 1/Os to the other controller in the redundant set
if a controller or I/O path fails.

remote mirroring. Online, real-time replication of data
between storage subsystems that are maintained on
separate media. The Enhanced Remote Mirror Option is
a FAStT premium feature that provides support for
remote mirroring. See also Global Mirroring, Metro
Mirroring.

ROM. See read-only memory.

router. A computer that determines the path of
network traffic flow. The path selection is made from
several paths based on information obtained from
specific protocols, algorithms that attempt to identify the
shortest or best path, and other criteria such as metrics
or protocol-specific destination addresses.

RVSD. See recoverable virtual shared disk.
SAl. See Storage Array Ildentifier.

SA Identifier. See Storage Array Identifier.
SAN. See storage area network.

SATA. See serial ATA.

scope. Defines a group of controllers by their Internet
Protocol (IP) addresses. A scope must be created and
defined so that dynamic IP addresses can be assigned
to controllers on the network.

SCSIl. See small computer system interface.

segmented loop port (SL_port). A port that allows
division of a fibre-channel private loop into multiple
segments. Each segment can pass frames around as

an independent loop and can connect through the fabric
to other segments of the same loop.

sense data. (1) Data sent with a negative response,
indicating the reason for the response. (2) Data
describing an 1/O error. Sense data is presented to a
host system in response to a sense request command.

serial ATA. The standard for a high-speed alternative
to small computer system interface (SCSI) hard drives.
The SATA-1 standard is equivalent in performance to a
10 000 RPM SCSiI drive.

serial storage architecture (SSA). An interface
specification from IBM in which devices are arranged in
a ring topology. SSA, which is compatible with small
computer system interface (SCSI) devices, allows
full-duplex packet multiplexed serial data transfers at
rates of 20 Mbps in each direction.

server. A functional hardware and software unit that
delivers shared resources to workstation client units on
a computer network.

server/device events. Events that occur on the server
or a designated device that meet criteria that the user
sets.

SFP. See small form-factor pluggable.

Simple Network Management Protocol (SNMP). In
the Internet suite of protocols, a network management
protocol that is used to monitor routers and attached
networks. SNMP is an application layer protocol.
Information on devices managed is defined and stored
in the application’s Management Information Base
(MIB).

SL_port. See segmented loop port.

SMagent. The FAStT Storage Manager optional
Java-based host-agent software, which can be used on
Microsoft Windows, Novell NetWare, HP-UX, and
Solaris host systems to manage storage subsystems
through the host fibre-channel connection.

SMclient. The FAStT Storage Manager client software,
which is a Java-based graphical user interface (GUI)
that is used to configure, manage, and troubleshoot
storage servers and expansion units in a FAStT storage
subsystem. SMclient can be used on a host system or
on a storage management station.

SMruntime. A Java compiler for the SMclient.

SMutil. The FASIT Storage Manager utility software
that is used on Microsoft Windows, HP-UX, and Solaris
host systems to register and map new logical drives to
the operating system. In Microsoft Windows, it also
contains a utility to flush the cached data of the
operating system for a particular drive before creating a
FlashCopy.
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small computer system interface (SCSI). A standard
hardware interface that enables a variety of peripheral
devices to communicate with one another.

small form-factor pluggable (SFP). An optical
transceiver that is used to convert signals between
optical fiber cables and switches. An SFP is smaller
than a gigabit interface converter (GBIC). See also
gigabit interface converter.

SNMP. See Simple Network Management Protocol and
SNMPv1.

SNMP time-out. The maximum amount of time the
SANavigator tool will wait for a device to respond to a
request. The specified time applies to one retry only.

SNMP trap event. (1) (2) An event notification sent by
the SNMP agent that identifies conditions, such as
thresholds, that exceed a predetermined value. See
also Simple Network Management Protocol.

SNMPv1. The original standard for SNMP is now
referred to as SNMPv1, as opposed to SNMPv2, a
revision of SNMP. See also Simple Network
Management Protocol.

SRAM. See static random access memory.
SSA. See serial storage architecture.

static random access memory (SRAM). Random
access memory based on the logic circuit know as
flip-flop. It is called static because it retains a value as
long as power is supplied, unlike dynamic random
access memory (DRAM), which must be regularly
refreshed. It is however, still volatile, meaning that it can
lose its contents when the power is turned off.

storage area network (SAN). A dedicated storage
network tailored to a specific environment, combining
servers, storage products, networking products,
software, and services. See also fabric.

Storage Array ldentifier (SAl or SA Identifier). The
Storage Array Identifier is the identification value used
by the FASIT Storage Manager host software
(SMClient) to uniquely identify each managed storage
server. The FASIT Storage Manager SMClient program
maintains Storage Array Identifier records of
previously-discovered storage servers in the host
resident file, which allows it to retain discovery
information in a persistent fashion.

storage management station. A system that is used
to manage the storage subsystem. A storage
management station does not need to be attached to
the storage subsystem through the fibre-channel
input/output (I/O) path.

storage partition. Storage subsystem logical drives
that are visible to a host computer or are shared among
host computers that are part of a host group.

storage partition topology. In the FASIT Storage
Manager client, the Topology view of the Mappings
window displays the default host group, the defined host
group, the host computer, and host-port nodes. The
host port, host computer, and host group topological
elements must be defined to grant access to host
computers and host groups using logical drive-to-LUN
mappings.

subnet. An interconnected but independent segment
of a network that is identified by its Internet Protocol (IP)
address.

sweep method. A method of sending Simple Network
Management Protocol (SNMP) requests for information
to all the devices on a subnet by sending the request to
every device in the network.

switch. A fibre-channel device that provides full
bandwidth per port and high-speed routing of data by
using link-level addressing.

switch group. A switch and the collection of devices
connected to it that are not in other groups. Switch
groups are discovered by the SANavigator tool and
displayed with a gray background on the Physical and
Data Path maps.

synchronous write mode. In remote mirroring, an
option that requires the primary controller to wait for the
acknowledgment of a write operation from the
secondary controller before returning a write 1/0 request
completion to the host. See also asynchronous write
mode, remote mirroring, Metro Mirroring.

system name. Device name assigned by the vendor’s
third-party software.

TCP. See Transmission Control Protocol.

TCP/IP. See Transmission Control Protocol/Internet
Protocol.

terminate and stay resident program (TSR
program). A program that installs part of itself as an
extension of DOS when it is executed.

topology. The physical or logical arrangement of
devices on a network. The three fibre-channel
topologies are fabric, arbitrated loop, and point-to-point.
The default topology for the disk array is arbitrated loop.

TL_port. See translated loop port.

transceiver. A device that is used to transmit and
receive data. Transceiver is an abbreviation of
transmitter-receiver.

translated loop port (TL_port). A port that connects
to a private loop and allows connectivity between the
private loop devices and off loop devices (devices not
connected to that particular TL_port).
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Transmission Control Protocol (TCP). A
communication protocol used in the Internet and in any
network that follows the Internet Engineering Task Force
(IETF) standards for internetwork protocol. TCP
provides a reliable host-to-host protocol between hosts
in packed-switched communication networks and in
interconnected systems of such networks. It uses the
Internet Protocol (IP) as the underlying protocol.

Transmission Control Protocol/Internet Protocol
(TCP/IP). A set of communication protocols that
provide peer-to-peer connectivity functions for both local
and wide-area networks.

trap. In the Simple Network Management Protocol
(SNMP), a message sent by a managed node (agent
function) to a management station to report an
exception condition.

trap recipient. Receiver of a forwarded Simple
Network Management Protocol (SNMP) trap.
Specifically, a trap receiver is defined by an Internet
Protocol (IP) address and port to which traps are sent.
Presumably, the actual recipient is a software
application running at the IP address and listening to
the port.

TSR program. See terminate and stay resident
program.

uninterruptible power supply. A source of power
from a battery that is installed between a computer
system and its power source. The uninterruptible power
supply keeps the system running if a commercial power
failure occurs, until an orderly shutdown of the system
can be performed.

user action events. Actions that the user takes, such
as changes in the storage area network (SAN), changed
settings, and so on.

vendor. Property value that the SANavigator tool uses
to launch third-party software. Vendor property might be
discovered, but will always remain editable.

worldwide name (WWN). A unique identifier for a
switch on local and global networks.

WORM. See write-once read-many.

write-once read many (WORM). Any type of storage
medium to which data can be written only a single time,
but can be read from any number of times. After the
data is recorded, it cannot be altered.

WWN. See worldwide name.

zoning. A function that allows segmentation of nodes
by address, name, or physical port and is provided by
fabric switches or hubs.
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